21:00:02 <Hydroxide> #startmeeting
21:00:02 <MeetBot> Meeting started Wed Dec 16 21:00:02 2009 UTC.  The chair is Hydroxide. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:02 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:00:06 <Hydroxide> #chair MrBeige
21:00:06 <MeetBot> Current chairs: Hydroxide MrBeige
21:00:13 <Hydroxide> hi all. everyone ready?
21:00:16 <schultmc> yep
21:00:25 <AbsintheSyringe> aye :)
21:00:30 <Hydroxide> ok
21:00:35 <Hydroxide> #topic dc9: Final report
21:00:47 <Hydroxide> MrBeige has been doing a great job of spearheading this.
21:00:54 <Hydroxide> MrBeige: want to give an update in MeetBot friendly form?
21:01:34 <Hydroxide> hmmm... he was just here pre-meeting in /msg
21:01:38 <Hydroxide> let's do the other dc9 item first
21:01:49 <Hydroxide> #topic dc9: Finishing up last corporate sponsors
21:02:01 <Hydroxide> schultmc: can you summarize this? (make liberal use of #info)
21:02:10 <Hydroxide> (at least as isn't too private)
21:02:31 <schultmc> #info 4 sponsor payments still outstanding (down from 6 from last meeting)
21:02:58 <schultmc> #info anto, Sledge, h01ger and I are pinging sponsors as needed
21:03:08 <Hydroxide> great. any bottlenecks that are relevant to discuss now?
21:03:18 <schultmc> #info paperwork was snail mailed to one sponsor who required it
21:03:26 <schultmc> no bottlenecks that I'm aware of
21:03:31 <Hydroxide> ok
21:03:42 <Hydroxide> schultmc: anything else on this?
21:03:46 <schultmc> nope
21:03:49 <Hydroxide> ok
21:04:39 <Hydroxide> MrBeige has returned
21:04:45 <Hydroxide> so...
21:04:54 <Hydroxide> #topic dc9: Final report
21:05:04 <Hydroxide> MrBeige: status update / requests plz?
21:05:04 <MrBeige> ok
21:05:15 <MrBeige> so, most thinsg are done
21:05:48 <MrBeige> #info marga will assemble the report as soon as thinsg are all in
21:06:03 * h01ger waves - havent gone to sleep yet... instead maintaining piuparts :-) i'll look at the video report til (end of) the weekend
21:06:11 <MrBeige> #info see recent email for remaning articles
21:06:16 <Hydroxide> h01ger: cool :)
21:06:29 <MrBeige> I got marga to mail people about it since me mailing had become ineffective
21:06:47 <Hydroxide> MrBeige: that was only sent to individuals, not to the list, right?
21:07:37 <MrBeige> #info to do: video, sponsorship, fundraising, open day are big things left
21:08:30 <MrBeige> I've sort of let marga worry about it since she can get better results than me now
21:08:36 <Hydroxide> #action h01ger planning to look at the video report through the end of the weekend
21:08:44 <Hydroxide> (feel free to correct me if I misunderstood)
21:09:05 <MrBeige> there isn't much to add besides "those who have said they'll do something, work on it or get someone else to..."
21:09:17 <Ganneff> .
21:09:35 <Hydroxide> MrBeige: is it worth saying here who else is assigned to things, or no need?
21:09:38 <Hydroxide> Ganneff: hi
21:09:55 <MrBeige> i'm looking through mailboxes and lists for things
21:10:06 <Hydroxide> MrBeige: ok, should we move on to dc10 stuff then?
21:10:10 <Hydroxide> (it's :10 already)
21:10:24 <MrBeige> this would mostly be the same things we said last time
21:10:29 <Hydroxide> ok
21:10:32 <MrBeige> I can do it though:
21:11:02 <MrBeige> #info fundraising - Sledge ; video: h01ger, Womble2, marga ; networking - ???
21:11:48 <MrBeige> video is nearly done
21:11:57 <MrBeige> oh
21:12:00 <MrBeige> Open Day is improtant
21:12:23 <MrBeige> oh, I think marga emailed ana about it and didn't send it t ome
21:12:47 <Hydroxide> we need to move on ... already 12 minutes in. anything else important to mention on this topic?
21:12:52 <MrBeige> not really
21:13:01 <Hydroxide> (just trying to respect the europeans' sleep schedules)
21:13:02 <MrBeige> I can't push it anymore without being overly pushy
21:13:05 <Hydroxide> ok
21:13:09 <Hydroxide> thanks for your work
21:13:10 <Hydroxide> !
21:13:21 <MrBeige> also, most everything is revised at least once
21:13:25 <Hydroxide> #topic dc10 status reports: cletus aka pentatest.debconf.org
21:13:27 <Hydroxide> MrBeige: great
21:13:42 <Hydroxide> Ganneff: can you give an update on this to those who haven't been following our conversations?
21:13:46 <Ganneff> ok.
21:13:56 <Ganneff> pentatest is actually working. what needs to be done are two things
21:14:21 <Ganneff> a.) an anonymizer script, so the imported production database loses all the privat sensible data. talked about that with MrBeige/hydro yesterday
21:14:36 <Ganneff> b.) the vcs, we set on git.
21:14:50 <Ganneff> i expect it all done this week.
21:14:57 <Ganneff> (a meant i assume its outsourced)
21:14:57 <Hydroxide> great. thanks much.
21:15:05 <Hydroxide> yeah, we'll be responsible for a
21:15:15 <Ganneff> after a is done access to cletus is opened to whoever wants it, more or less
21:15:20 <Ganneff> (well, and is in debconf team)
21:15:23 <Hydroxide> #action MrBeige and Hydroxide create anonymizer script for cletus
21:15:41 <Hydroxide> #action Ganneff publishes penta code in git
21:15:51 <Hydroxide> #agreed both of these done by end of week(end)
21:15:56 <Ganneff> penta code and a little oc about it
21:15:59 <Ganneff> ie, our own schema and stuff
21:16:02 <Hydroxide> yeah
21:16:14 <Ganneff> take the admins now, then i can disappear again :)
21:16:17 <Hydroxide> #topic dc10 status reports: admin team membership change(s)
21:16:21 <Ganneff> ok. fine
21:16:22 <Hydroxide> Ganneff: go ahead :)
21:16:26 <Ganneff> there we added schultmc.
21:16:36 <Ganneff> noodles also agreed to get added, this will be done this week somewhere.
21:16:41 <Hydroxide> \o/
21:16:49 <Ganneff> be easy with em, they dont yet have anything like experience.
21:16:53 <Hydroxide> #info schultmc is now on debconf admin team
21:17:06 <Hydroxide> #action Ganneff to add Noodles by end of week(end)
21:17:18 <Hydroxide> #info be easy on schultmc and Noodles while they learn
21:17:21 <Hydroxide> Ganneff: thanks! :)
21:18:27 <Hydroxide> ok, next item
21:18:38 <Hydroxide> #topic dc10 status reports: corporate sponsorship levels
21:19:02 <Hydroxide> I have started following up with our biggest sponsor historically speaking, but nothing definite from them yet
21:19:48 <Hydroxide> so I'm just going to pick levels that are (1) what we decided last time we discussed it, for everything except platinum, and (2) $40k for platinum, which is one of the options we discussed before. this includes both cash and in-kind donations of course
21:20:13 <Hydroxide> anyone mind? we can also have an "in cooperation with" category for Columbia CS department if they decide they don't want to be called a sponsor
21:20:30 <MrBeige> Hydroxide: I can ask about that, yes
21:20:43 <Hydroxide> MrBeige: that can be decided later in their case. anyone mind about the rest of what I said?
21:20:58 <MrBeige> Hydroxide: perhaps I may wait for the next in-person meetings (probably this december or january), but no need to rushh...
21:21:02 <Hydroxide> MrBeige: right
21:21:22 <Hydroxide> #agreed sponsorship levels will be (1) what we decided last time we discussed it, for everything except platinum, and (2) $40k for platinum, which is one of the options we discussed before. this includes both cash and in-kind donations of course
21:21:32 <Hydroxide> #agreed we can also have an "in cooperation with" category for Columbia CS department if they decide they don't want to be called a sponsor
21:21:37 <Hydroxide> ok
21:21:38 <Hydroxide> next item
21:21:54 <Hydroxide> #topic dc10 status reports: potential sponsor brochure aka sponsor pack
21:22:38 <Hydroxide> #info I got contacted by pablo duboue and hans-christoph steiner who agreed in a previous meeting to work on this. I was slow about responding
21:23:04 <Hydroxide> #action Hydroxide will follow up with pablo and hans today - ETA for finished brochure is "in time to start soliciting sponsors in january"
21:23:22 <Hydroxide> is anyone besides MrBeige and me even paying attention? it's awfully quiet out there :)
21:23:25 * MrBeige will talk with pablo tonight about it
21:23:36 <Hydroxide> MrBeige: sounds good too
21:23:52 <Hydroxide> #action MrBeige will also follow up with pablo tonight
21:24:01 <MrBeige> most of this is relatively uncontroversial, it's just a matter of doing
21:24:16 * aba waits a bit
21:24:21 * Hydroxide requests that people other than MrBeige and me who are paying attention say so, just so it's clear this meeting is worth continuing :)
21:24:28 * AbsintheSyringe lurking ...
21:24:31 <Hydroxide> ok...
21:24:43 <dam> yo
21:24:48 * Sledge waves
21:24:55 <Hydroxide> #topic dc10 discussion item: frank's visa stuff, state department list of attendees
21:25:05 <Hydroxide> so, first a bit of nice process news
21:25:33 <Hydroxide> #topic dc10 visa invitation issuance mostly automated via python script being run by our lawyer, combining a template with Hydroxide's signature and the applicant's details
21:25:37 <Hydroxide> oops
21:25:42 <Hydroxide> #topic dc10 discussion item: frank's visa stuff, state department list of attendees
21:25:48 <Hydroxide> #info dc10 visa invitation issuance mostly automated via python script being run by our lawyer, combining a template with Hydroxide's signature and the applicant's details
21:25:51 <Hydroxide> :)
21:26:06 <Hydroxide> #info several requests received and several invitiations issued
21:26:27 <Hydroxide> MrBeige: do you want to speak about the list of attendees part? if not, I will
21:26:40 <dam> automation++
21:26:48 <MrBeige> so, DebConf is registered with the US state department
21:26:49 <Hydroxide> #info MrBeige wrote the python script
21:27:03 <MrBeige> they can recieve a list of attendees to use to cross-check things
21:27:12 <MrBeige> it's only a small help, but something
21:27:17 <Hydroxide> it's also not mandatory - important to note
21:27:28 <AbsintheSyringe> I think that's pretty good
21:27:37 <MrBeige> those attendees who a) get a visa invitation letter b) get notified that we'll do it and don't opt out  will be added
21:27:54 <MrBeige> but not visa waiver or other attendees
21:28:14 <Hydroxide> yes. and, as that implies, people will have a chance to tell the lawyer not to add their name to that list
21:28:24 <Hydroxide> sound good?
21:28:31 <AbsintheSyringe> yep
21:28:48 <AbsintheSyringe> I don't even know if I'll need one, but for all those who need visa like myself, that sounds great
21:29:10 <Hydroxide> #info attendees who get a visa invitation letter from dc10, are notified about the state department's list of conference attendees, and don't opt out will be added to state.gov's list to smooth the process
21:29:17 <Hydroxide> #info state.gov knows about DC10
21:29:18 <Hydroxide> ok
21:29:42 <Hydroxide> anything else on this topic? if not, we have a half-hour left for the rest, which is great
21:30:09 <Hydroxide> ok, moving on
21:30:18 <Hydroxide> #topic dc10 discussion item: registration timeline
21:30:46 <Hydroxide> ok, it looks to me like penta stuff is likely to be resolved and ready some time between now and the end of january
21:30:47 <MrBeige> <joke>I propose we open it when it's ready</joke>
21:30:52 * Hydroxide grins
21:31:09 <Hydroxide> when should we target for registration opening?
21:31:33 <MrBeige> as soon as those who are working on the reg system think it's ready to go ?
21:31:38 <dam> March?
21:31:54 <Hydroxide> dam: why so late? (unless we're not ready sooner)
21:32:06 <Hydroxide> *: speak up plz
21:32:13 <Clint> sooner the better
21:32:19 <Ganneff> feb sounds good to me.
21:32:20 <dam> it still gives three months to the conference. not enough?
21:32:38 <Ganneff> feb or earlier if the pentatest people say ready earlier
21:32:41 <Hydroxide> dam: not for airfare, travel sponsorship, etc. not really.
21:32:44 <Hydroxide> ok
21:32:44 <MrBeige> I propose: those who work on it decide when they've done all they can do, weighed against when it needed to happen
21:32:51 <AbsintheSyringe> I agree with Ganneff
21:33:02 <MrBeige> (does opening matter as much as closing?)
21:33:03 <Ganneff> make it feb as a must, everthing before as nice to have
21:33:09 <Hydroxide> #agreed we'll target registration to open in february, or earlier if penta is ready earlier
21:33:14 <Ganneff> MrBeige: yes, for sponsorship team and such
21:33:19 <Ganneff> the earlier they have data the better
21:33:20 * dam is afraid that penta won't be ready, remembering many issues with dc9
21:33:40 <Hydroxide> dam: well, while we're on this topic, what things do you want to fix? we're finally going to be able to have a place to make fixes again
21:33:47 <Ganneff> it has the same state as dc9. except, we now have a working test machine (modulu the small things said above)
21:34:20 <Hydroxide> I was mainly thinking of fixing terminology, adding/removing some fields, maybe some browser bugfixes, and ONLY if it's easy, upgrading to newer upstream penta
21:34:21 <dam> Hydroxide: can't tell off the top of my head. It is just an impression from dc9
21:34:40 <Hydroxide> dam: dc9 was a lot more last-minute than most years of debconf in many, many ways :) it's a bad example in terms of timeline
21:35:02 <dam> perhaps digging through the lists/IRC can produce a TODO list
21:35:34 <Hydroxide> dam: that and the penta RT queue, yeah. do you want to do that digging by, say, end of week 1 of 2010?
21:35:48 <dam> I am actually not against an early oopening, just wanted to give developers some space :)
21:35:59 * Hydroxide nods
21:36:13 <dam> Hydroxide: count me in
21:36:16 <Hydroxide> ok
21:36:39 <Hydroxide> #action dam will dig through lists, IRC, and penta RT queue to find penta fixes to make, and will report back by end of week 1 of 2010
21:36:42 <Hydroxide> thanks
21:36:51 <Hydroxide> next item
21:36:59 <Hydroxide> #topic dc10 discussion item: CfP timeline
21:37:16 <Hydroxide> MrBeige: do you want to take the lead on this discussion item, given that you had a sub-item?
21:37:27 <MrBeige> The summary of the sub-item is:
21:37:43 <MrBeige> from my work on past things (mainly final report), saying "we want to do blah" isn't very effective
21:38:11 <MrBeige> I tihnk it's more important to get new, enthuiastic(sp) who want to get it done in a timely manner
21:38:41 <MrBeige> rather than relying on our overworked debconf alumni
21:39:06 <Clint> someone fresh who cares about papers
21:39:06 <aba> MrBeige: if you find out how to do that, can we have the same for RC bug fixing?
21:39:09 * aba hides
21:39:13 <Hydroxide> haha :)
21:39:18 <MrBeige> which is why I thought it would be productive to poll Debian people to find people who want to help review talks
21:39:32 <MrBeige> aba: http://wiki.debian.org/BSP2010/NewYorkCity
21:39:33 <Hydroxide> aba: you do realize that MrBeige has organized some workshops about such topics in NYC and is working on organizing a BSP for January, right? :)
21:40:05 <MrBeige> aba: http://wiki.debian.org/DebianNYC/Workshops for recruiting new enthuiastic(sp) people
21:40:32 * aba is currently a bit busy with trying to not fall asleep :/
21:40:47 <Hydroxide> ok, great thing to mention, but let's get back to the topic
21:40:50 <MrBeige> anyway, I'm sure there are plenty of people who may be not have steam for RC bug fixing but would dedicate some hours to reviewing the talks
21:41:46 <MrBeige> and while "it's hard to find people" is true, relying on current people will cause more delays in the end, I think
21:42:06 <MrBeige> hm, so the point was:
21:42:15 <Ganneff> a cfp team is easy, thats a one time job :)
21:42:31 <MrBeige> oh, I was talking more about the talk reviewers
21:42:38 <Ganneff> thats the cfp team
21:42:44 <Hydroxide> yay terminology :)
21:42:45 <MrBeige> ok
21:43:07 <Ganneff> its actually easy work in pentabarf
21:43:18 <Hydroxide> ok
21:43:23 <Ganneff> much harder is schedule.
21:43:31 <MrBeige> anyway, when do we want it done by?
21:43:32 <Ganneff> similar easy but much more work is travelmoney.
21:43:41 <Hydroxide> can I try to refocus this a bit on the main topic then: let's figure out the deadline for talk reviewing
21:43:47 <Hydroxide> and/or submission
21:44:16 <dam> how was it done for dc9? was it right?
21:44:17 <MrBeige> how about "when it's ready" to take submissions
21:44:18 <Hydroxide> do people like the idea of having two rounds of it, or no?
21:44:21 <Ganneff> this paper review should have about 2 or 3 weeks for the work, so they can space it in their normal days. then one irc meeting. and you are basically settled.
21:44:35 <Ganneff> (thats after submission for "official/sponsored" talks closed
21:44:43 <Clint> how far in advance of debconf does it need to be done?
21:45:05 <Ganneff> in theory not that much. in practice people beg you for the schedule month in advance, so they can play their stay around it
21:45:16 <Hydroxide> Clint: I was hoping that some people would be able to use a partial list of talks to, yeah, plan their stay or get $employer to pay for it
21:45:48 <aba> ok, I'm off, way too tired. sorry.
21:45:56 <Hydroxide> aba: 'night! thanks for watching
21:46:02 <Clint> so at least a month beforehand
21:46:31 <Ganneff> yes, but the earlier the better for people.
21:47:03 <Hydroxide> do people like having May 15 as the submission deadline and June 1 as the announcement deadline?
21:47:18 <Ganneff> whens dc10 again?
21:47:25 <Clint> first week in august
21:47:27 <Hydroxide> that's what ana proposed
21:47:30 <Ganneff> Hydroxide: announcement deadline - is that schedule?
21:47:50 <Hydroxide> Ganneff: I meant list of talks, but good point to consider that too
21:48:03 <Hydroxide> Ganneff: maybe June 1 for list of talks, June 15 for schedule
21:48:06 <Ganneff> that leaves two weeks for the talk team only.
21:48:16 <Ganneff> oh, and two weeks for schedule is quite a hard task
21:48:29 <Hydroxide> that was based on ana's suggestion from November 12
21:48:37 <Ganneff> i would give them 3 weeks for the talk selection, if one can afford them
21:48:50 <Hydroxide> Ganneff: talk selection or talk schedule?
21:48:58 <Ganneff> selection
21:49:07 <MrBeige> this is why I said we should have an active selection team...
21:49:10 <Ganneff> schedule 3 weeks minimum, usually took 4 and more, i think
21:49:42 <MrBeige> (so there can be one week waiting and one week working instead of three weeks delaying and one week working...)
21:49:46 <Hydroxide> ok. how about April 30 for submission deadline, May 17 for list of talks announcement, June 21 for schedule announcement?
21:50:03 <Hydroxide> we don't want to get too close to the conference but that sounds sane
21:50:07 <Ganneff> MrBeige: you will have half a dozen or a dozen people reading through all of them. rating them. then one meeting to discuss things they didnt sort out easily in the rating. 2 weeks is doable, but harder on them.
21:50:30 <Ganneff> (obviously i actually dont care at all about the dates, just idle chatting) :)
21:50:40 <Hydroxide> Ganneff: haha :) does my last suggestion sound sane?
21:50:47 <Ganneff> yes
21:50:48 <Hydroxide> anyone else: ^^^
21:50:51 <Hydroxide> ok
21:50:52 <AbsintheSyringe> yes :)
21:50:57 <Sledge> ok
21:51:08 <dam> deal
21:51:29 <Hydroxide> #agreed CfP opens as soon as penta is ready; April 30 is submission deadline; May 17 is list of talks announcement deadline; June 21 is schedule announcement deadline
21:51:32 <Hydroxide> great
21:51:36 <Hydroxide> almost done ;)
21:51:50 <Hydroxide> #topic other: should we send a dc11 proposals reminder?
21:52:05 <Hydroxide> the topic is self-explanatory: dc11 proposals close in a couple of weeks at the end of 2009
21:52:12 <Hydroxide> should I send an email reminder?
21:52:25 <Hydroxide> we do have two good proposals, but for dc10 there were some last-minute bids
21:52:50 * Ganneff votes no
21:53:02 * MrBeige votes yes
21:53:03 <Ganneff> who still hasnt got it will have a hard time making it
21:53:08 <Ganneff> but somehow im biased
21:53:10 <MrBeige> (and not just to be contracidctory)
21:53:11 <Hydroxide> any other thoughts, ideally from people not from a host country? :)
21:53:30 <dam> it won't hurt
21:53:32 <schultmc> last year I think one of the last minute bids was technically late
21:53:33 * AbsintheSyringe votes no as wel, what for?
21:53:35 <MrBeige> limiting the number of bids was a problem, not selecting good bids
21:53:41 <AbsintheSyringe> waste of time imho
21:53:41 <schultmc> I suppose a reminder could help prevent that
21:54:12 <Hydroxide> Ganneff: if they haven't submitted it by December 31 that's of course going to be looked badly on, but I think they don't have to have a comprehensive thing by Dec 31, just the initial proposal...
21:54:37 <Ganneff> yeah well. it should be as far as remotely possible
21:54:38 <Hydroxide> it helps to be more prepared early of course, as I know from the NYC bid experience :)
21:54:45 <Ganneff> if you declare on 31st, thats not easy to achieve
21:55:42 <Hydroxide> so we seem pretty divided on this, but it's of course not hugely important in my opinion. anyone else want to speak?
21:55:43 <MrBeige> just do it
21:55:44 <Hydroxide> ok
21:55:49 <Ganneff> just dont do it
21:55:50 <Ganneff> :)
21:55:54 <Hydroxide> :)
21:55:56 <MrBeige> it'll remind people to fix up what they've got in prep for january
21:56:01 <Ganneff> oh hell, i dont care.
21:56:14 <Hydroxide> that's actually an even better excuse for a reminder: "germany and bosnia, fix up your wiki pages"
21:56:18 <Hydroxide> ok
21:56:19 <Hydroxide> moving on now
21:56:22 <MrBeige> the people doing proposals aren't our enemies
21:56:25 <Hydroxide> #topic next meeting
21:56:40 <AbsintheSyringe> I need to update the wiki page, but waiting for info
21:56:51 <AbsintheSyringe> will call regarding that tomorrow
21:56:54 <Hydroxide> the third-wednesday would be January 20, but if we want to open registration and CfP in jan/feb do people want to do it earlier? ("no" is ok)
21:57:54 <dam> a week earlier so that penta hackers can report?
21:58:01 <MrBeige> those who are doing work to make the opening  happen will talk before then, I'm sure
21:58:12 <Hydroxide> dam: unfortunately 2100 UTC a week earlier conflicts with an SPI meeting
21:58:23 <Hydroxide> if people can do a different day of week I can agree to that
21:59:17 <Hydroxide> ok... looks like by default it's Jan 20
21:59:36 <Hydroxide> #agreed next meeting is Jan 20, 2010, 21:00-22:00 UTC unless otherwise agreed later
21:59:38 <dam> yeah, 6th is too close to 1st :)
21:59:42 <Hydroxide> #endmeeting