19:15:23 <gwolf> #startmeeting Coordination team meeting
19:15:23 <MeetBot> Meeting started Tue Dec 16 19:15:23 2014 UTC.  The chair is gwolf. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:15:23 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:15:36 <gwolf> #topic Roll call
19:15:40 * madduck 
19:15:42 <gwolf> /me o/
19:16:05 <tiago> ~here
19:16:26 <rmayorga> I'll be mostly reading
19:16:28 <Tincho> madduck: gwolf: one thing I'd say about meetings, is that most people will not be more than one or two teams, so it is not that many meetings in the end
19:16:32 <cate> Ciao
19:16:43 <gwolf> (roll call about to be closed)
19:16:52 * bremner also reading somewhat
19:16:54 <Tincho> anyway, I need to leave
19:17:00 <gwolf> #topic DC16 decision timeline
19:17:19 <gwolf> OK... seems we will have a meeting with little attendance. So be it, lets make it swift :)
19:17:29 <gwolf> So... What do we currently know about DC16 bidders?
19:17:49 <gwolf> IIRC we have heard about South Africa and Montreal advancing, right? (no Paris?)
19:17:54 <madduck> capetown is well on the way
19:17:59 <madduck> and montreal too
19:18:12 <gwolf> Well, does not matter *that* much. We have to talk about the timeline more than the bidders, there's time for all that
19:18:14 <madduck> looks like we can keep the 31 january deadline for a decision
19:18:21 <madduck> marga sent an email
19:18:25 <gwolf> Yes, Jan31 looks completely viable to me
19:18:30 <madduck> asking for committee nominations by 5 january
19:18:43 <gwolf> #info Capetown and Montreal are on their way; no news from Paris or others?
19:18:48 <madduck> independently of that, I think we should schedule a decision meeting
19:19:06 <cate> Question only in mailinglist? Or do we make also a IRC meeting?
19:19:07 <gwolf> Well, that topic should have been covered before, but it sits at #3: how to establish the bid committee
19:19:13 <olasd> fwiw, Paris will regroup and do 2017
19:19:24 <olasd> (properly)
19:19:25 <madduck> cate: I think most should be done on the mailing list
19:19:29 <gwolf> cate: I'd say we should *now* do it on the lists so there's better follow-up
19:19:40 <madduck> and then the decision meeting should be basically just a committee vote
19:19:41 <gwolf> cate: and schedule for meeting in January
19:19:48 <madduck> maybe with each team presenting for 10 minutes or so
19:19:50 <cate> ok. I've several questions. I need only some time to prepare and send them
19:19:54 <gwolf> I don't expect much movement to happen in late December
19:19:59 <gwolf> cate: please do!
19:20:12 <gwolf> #info Questions and information exchange regarding the bids should be done on the list
19:20:21 <gwolf> #info We aim at a decision on Jan31
19:20:23 <madduck> i would suggest that we tell the teams that the decision meeting is on 29 January
19:20:26 <tiago> madduck, I agree, but it'd be nice to bring this on list
19:20:38 <madduck> tiago: bring what on list?
19:20:41 <tiago> I see some people are not agreeing with a decicision meeting
19:20:58 <madduck> i think the committee should decide the rules
19:20:59 <gwolf> So... Maybe we can move topic #3 to *now*, and discuss a bit on how to have a bid selection team
19:21:01 <gwolf> a committee
19:21:03 <tiago> madduck, a consensus on having a decision meeting
19:21:20 <gwolf> Should we re-ask the previous year's members? Or appoint them in some other way?
19:21:21 <tiago> madduck, commitee doesn't really exist I think
19:21:25 <tiago> for this year
19:21:27 <madduck> not yet, no
19:21:39 <gwolf> (wasn't there something on the Chairs' restructuring plan?)
19:21:41 <madduck> gwolf: as I said, marga has asked for nominations by 5 january
19:21:43 <tiago> anyways, just agreed about that
19:21:46 <gwolf> OK, sorry
19:21:50 <cate> chairs are recruiting the comitee
19:22:05 <madduck> so we won't have a committee until then
19:22:15 <madduck> i am still suggesting that we at least reserve 29 january for a possible meeting
19:22:16 <gwolf> #info Marga has asked for nominations for the Committee for January 5; Chairs are recruiting...
19:22:29 <madduck> better let it be known now to everyone and cancel than scramble to find a time that suits short-term
19:22:30 <gwolf> madduck: exact date should be decided by the committee members IMO
19:22:32 <tiago> ah, commitee email just arrived :)
19:22:47 <gwolf> Anyway, anything else to add to this DC16 topic?
19:22:59 <gwolf> No?
19:23:06 <gwolf> OK, lets move on to more pressing matters...
19:23:07 <madduck> gwolf: yes, you can expect the committee to set up a dudle a week after committee formation
19:23:21 <cate> committe and bit teams together
19:23:25 <madduck> and then you will have to pick a date knowing exactly who cannot make it
19:23:27 <Tincho> the committee still exists, and as per previous discussions, we are including representatives from the teams
19:23:30 <madduck> short term
19:23:32 <gwolf> Lets allow them to self-organize ;-)
19:23:33 <Tincho> this was also discussed with marga
19:23:48 <madduck> or you just set a date now and wait until people who have to attend step forward and say they cannot
19:23:52 <madduck> and then find an alternative
19:23:55 <gwolf> madduck: imposing now the meeting date shackles them...
19:24:02 <madduck> i am not imposing a meeting date
19:24:13 <madduck> i am suggesting we reserve one just in case and communicate it early
19:24:14 <gwolf> We are mentioning a (soft?) deadline of Jan31
19:24:18 <madduck> i.e. >30 days in advance
19:24:19 <tiago> Tincho, hey u not supposed to be here! :)
19:24:29 <Tincho> no, I am going to miss that train
19:24:30 <Tincho> damn
19:24:33 <tiago> ehh
19:24:36 <tiago> run run
19:24:40 <gwolf> Anyway... should we move on?
19:24:44 <gwolf> Tincho: Get a data plan!
19:24:45 <gwolf> :)
19:24:45 <tiago> gwolf, yes
19:24:48 <cate> BTW is this a -team meeting or the -coordination meeting?
19:24:50 <madduck> gwolf: allow committee to self-organise… 5 january deadline of nominations, so the committee will not be ready before mid-january
19:24:51 <gwolf> #topic DC15 timeline
19:25:10 <gwolf> cate: coord
19:25:11 <Tincho> gwolf: I have one, but I cannot leave if I am typing!
19:25:28 <gwolf> So... DC15 locals, please tell us!
19:25:38 <madduck> i believe azeem's email contains it all
19:25:51 <gwolf> madduck: (sorry... we can try to set the meeting time by mail and stuff)
19:26:09 <madduck> #link http://lists.debconf.org/lurker/message/20141204.100511.e4bada48.en.html
19:26:24 <madduck> gwolf: (I think it's asking for trouble, but you moved on…)
19:26:42 <madduck> basically, I think we all agree more or less on the dc15 timeline
19:26:47 <gwolf> :) The moment you joined #debconf-team you asked for trouble.
19:26:53 <madduck> about opening registrations early
19:27:02 <madduck> about committing sponsorship early
19:27:03 <madduck> etc.
19:27:09 <gwolf> right, I like the idea of early registration, and as early as possible bursaries.
19:27:11 <gwolf> OK.
19:27:18 <gwolf> Anything to add to azeem's mail?
19:27:20 <madduck> but the problem is that we are nowhere near registration ready
19:27:28 <madduck> there is no summit instance
19:27:38 <madduck> and the infrastructure team has not yet formed or started work, really.
19:27:38 <gwolf> Having a summit instance should not be *too* hard to get
19:27:50 <gwolf> does it involve... bugging vorlon?
19:27:58 <madduck> gwolf: no, except if you want to avoid all the problems from last year and avoid having to do the same hacks every year
19:27:59 <cate> right. I think summit can be set in few days
19:28:15 <madduck> there are todos that need to be fixed before we can go live
19:28:16 <gwolf> madduck: there will always be ad-hoc hacks needed
19:28:21 <gwolf> we have last year's changes
19:28:33 <gwolf> and of course, it'd be better to incorporate them during August-December
19:28:33 <madduck> last year's summit is not set up to handle this year
19:28:47 <madduck> so either you clone it and keep two summit instances
19:28:50 <madduck> and next year three
19:28:53 <cate> madduck: no, it is ready
19:28:57 <madduck> or you enable it to do multi-conference
19:28:58 <gwolf> but if that was not done, well... I think it's better to live hackish one more year than to delay starting
19:29:08 <cate> most of the table have a reference to the right conference
19:29:08 <madduck> gwolf: agreed
19:29:14 <gwolf> multi-conference would be best, of course
19:29:30 <gwolf> but, is it possible? cate?
19:29:34 <madduck> yes it is
19:29:37 <gwolf> (now?)
19:29:48 <gwolf> How long would it take to set it up?
19:29:56 <cate> Just like DC7 penta, some things are not in the right place (e.g. very few things are conference indipendent)
19:30:16 <madduck> what needs to happen so that we can start putting summit in place?
19:30:19 <madduck> for dc15?
19:30:32 <madduck> so that we can see if it works and still have enough time to fix things
19:30:51 <gwolf> #info Currently summit is not ready for multiconference, a DC15-specific instance should be set up
19:31:33 <gwolf> #info Installation and handling can be a bit hackish, but we should not delay registration for having a future-proof system set up
19:31:33 <cate> gwolf: I reapeat. The system is ready for multiconference
19:31:47 <gwolf> cate: OK. Who can set it up?
19:32:08 <cate> me, vorlon (and the admins)
19:32:16 <gwolf> cate: I understand you currently are familiar with summit's working, right? (and would just need admins to do their part?)
19:32:35 <gwolf> cate: How long would it take to have a functional bare one?
19:33:04 <cate> I think in this xmas holidays I can work on it.
19:33:20 <gwolf> So, can we volunteer you to have it for... Jan 5? :)
19:33:32 <cate> possibly with some help of vorlon, edrz, and few other dc14 people who worked with summit
19:34:06 <cate> gwolf: but this should be done with -infra. I really want that information flow will propagate
19:34:07 <gwolf> #action cate will coordinate with vorlon + admins, attempting to have a working Summit instance for Jan 5. Possibly even multi-conference!
19:34:18 <gwolf> cate: that's precisely the next point in the meeting
19:34:28 <gwolf> So... Anything else to say on DC15 timeline?
19:34:39 <madduck> is ana here?
19:34:55 <gwolf> If she is here, she's keeping it a secret
19:35:08 <gwolf> #topic  How will we manage communication across teams
19:35:22 <madduck> do we have any decisions about dc16 and dc15 timelines, gwolf?
19:35:23 <gwolf> OK. We have to grease the wheels to get the cart moving
19:35:37 <gwolf> But... where to start?
19:35:46 <cate> This was my question on marga
19:36:03 <madduck> . o O (this should have been done when designing the teams IMHO)
19:36:13 <gwolf> Again, I've been too disconnected, and don't really remember who's leading what :(
19:36:30 <madduck> I'd still love to see decisions about dc15/dc16 timelines, but I can also say something on teams and communication stuff
19:36:35 <cate> We (registration) have many information that should go to different teams. But.... we don't know what other team need, in what form, how to comunicate them
19:37:11 <madduck> cate: is there anything you need to push, or can you just wait until people pull/ask you?
19:37:16 <gwolf> So, maybe we could have mail aliases/lists for the different teams? Some kind of persisting+archived way to have communication?
19:37:23 <cate> [and probably we are not the only team who "originate" info]
19:37:42 <madduck> gwolf: we don't need a technical solution, I think; we need an organisational one.
19:37:46 <gwolf> cate: If you had anything to send to -infrastructure i.e., would it be enough to just cc:debconf-infrastructure?
19:37:56 <gwolf> madduck: right, but I think having a technical basis can help
19:38:02 <cate> madduck: I think knowing the info ASAP, it could help setting the system [summit]
19:38:11 <madduck> i think the technical basis needs to come from how we organise ourselves
19:38:14 <madduck> and we don't have that yet
19:38:40 <cate> last year the most caotic part was with you madduck ;-)  The flow of information of attendence fee, invoices, accountign was set up too late, and we were not able to track things
19:38:44 <gwolf> madduck: we can design many cat-chase-tail issues we are facing... Lets try to stop the tail from running away
19:38:51 <madduck> cate: but if the infra/summit team were ready to go, they'd also just ask you, right? Or do you have something you need to let people know now?
19:39:38 <madduck> cate: I was only doing accounting and I never got the information I needed; I still don't have it all.
19:39:55 <gwolf> (please, not finger-pointing...)
19:40:00 <cate> madduck: this is the problem. And asking info is not always enough
19:40:06 <gwolf> what kind of interactions we *want* to have?
19:40:12 <madduck> gwolf: come on, I am not suggesting tail chasing, I am saying that right now, we are all blind fish swimming in a pool of murky water and nobody knows how to work together
19:40:24 <gwolf> madduck: so lets design a plan
19:40:32 <madduck> i have a plan. do you want to hear it?
19:40:34 <cate> gwolf: it is not finger-pointing. I think we already discussed, but we need a global solution for similar problems
19:40:34 <gwolf> and if the teams don't work that way, we fix it
19:40:41 <tiago> (drama)
19:40:50 <gwolf> /me wants to read it
19:40:56 <gwolf> I don't like my computer making noises
19:41:02 <madduck> ;)
19:41:09 <tiago> (dark suspense music)
19:41:10 <tiago> :)
19:41:18 <madduck> it's actually really simople
19:41:20 <madduck> simple
19:41:33 <cate> [and it was not an error of madduck, just he was "choosen" too late, to be integrate on our information flow.
19:41:44 <cate> We need to setup this flow earlier
19:41:52 <madduck> cate: it's already set up for dc15 ;)
19:42:14 <gwolf> anyway... madduck, please share your ideas!
19:42:51 <Tincho> people need to talk to each other, and teams need to start working together, organising timelines, having meetings, etc
19:42:58 <Tincho> then it will not be so hard to organise
19:43:11 <cate> [debconf don't like ticket system, so we need a way to know if somebody will read and act infos]
19:43:12 <Tincho> you need something from infra, you mail them: an alias o r the lead or whatever
19:43:29 <madduck> I think we should make sure that each team has at least someone who knows DebConf, probably the leads; this is the baseline
19:43:39 <gwolf> Tincho: I was just suggesting the alias, or even better/simpler, a list...
19:43:53 <madduck> And then we define the set of decisions each team can make by themselves, and what sort of decisions need what sort of interaction
19:43:56 <gwolf> madduck: that's where we started off, yes
19:44:04 <cate> information will be lost  (too much stress near DebConf)
19:44:18 <madduck> And yes, I believe a ticket system would be really useful
19:44:23 <gwolf> umh... I think that delineating the specific responsabilities and reaches of each team will be too rigid
19:44:36 <cate> [Note: I don't have a solution, but I think every team should think about information flow]
19:44:46 <gwolf> It's much more useful to allow people to act. And to let them know easily how to reach out for others when they reach a wall
19:44:49 <madduck> gwolf: so make it less rigid, or revise it regularly
19:44:54 <gwolf> we are all acting for the same and in good faith
19:44:57 <Tincho> gwolf: I like that, but we have refrained from imposing how to do teams organisation
19:44:59 <gwolf> madduck: it's too much work!
19:45:14 <gwolf> Tincho: Teams should self-organize IMO
19:45:19 <gwolf> We need only points of contact
19:45:26 <gwolf> (and make sure they *do* self-organize
19:45:27 <gwolf> )
19:45:29 <Tincho> we have them already: leads
19:45:32 <madduck> it might be a lot of work to do now, but it'll be less work to do than bloody running after people and trying to figure out for every decision whether it needs to go to dc-team or whatever
19:45:54 <madduck> teams should self-organize *and* have very clear areas of competency
19:45:58 <gwolf> Tincho: I see leads as the people in charge of making sure the team works as a unit, but not necessarily the point of contact
19:46:04 <madduck> this already precludes a lot of communication
19:46:13 <Tincho> gwolf: it was in the original description of their duties
19:46:21 <madduck> and leaves whatever channel we create/have for the inter-disciplinary stuff
19:46:24 <gwolf> i.e. were a mail to be sent to -coordination, it's not only marga (or myself if she's not available) that will act. The team as a whole should get it
19:47:02 <gwolf> Tincho: A bit over-engineered then :) But anyway, that's my opinion. If it was debated at length, then I shut up
19:47:10 <cate> So it is a private things (between team). Coordination should not be involved?
19:47:15 <gwolf> ...But anyway, how should we then manage communication across teams?
19:47:17 <tiago> it's gonna be hard to define what teams can/can't decide
19:47:24 <Tincho> gwolf: I agree with most of that, but for now, I'd make everyone concentrate on getting to work. communication will be arranged as they see fit, IMHO
19:47:24 <gwolf> tiago++
19:47:25 <tiago> new issues come all the time
19:47:37 <tiago> they'll be exceptions then
19:47:47 <madduck> no
19:47:51 <madduck> you can cater for that
19:47:56 <madduck> it's not about defining decisions/issues
19:48:01 <madduck> it's about areas of competency
19:48:03 <tiago> we can make general rules, but still
19:48:11 <madduck> that would go a mighty long way
19:48:21 <Tincho> we have some rough definitions too
19:48:21 <tiago> misunderstood then, sorry
19:49:09 <tiago> regarding a ticket system, I'd say a reticent yes, I think it worths trying
19:49:13 <gwolf> /me feels we hit a bizantine wall
19:49:29 <Tincho> anyway, now I have to leave this train and cycle under the rain.
19:49:34 <gwolf> A ticket system is a PITA but helps organizationally IMO
19:49:40 <Tincho> we can discuss these tihngs on-list too
19:50:05 <madduck> i'd so much rather organise debconf than meta-discuss all the time :/
19:50:26 <Tincho> it would be great to have more on-list discussion, then meetings will be shorter :)
19:50:38 <gwolf> Tincho: This is an instance where "discuss on the list" might mean "leave things as they are"
19:50:38 <madduck> and decisions would take longer.
19:50:48 <tiago> madduck, could you propose a ticket system in the list?
19:50:54 <gwolf> a discussion that might just never happen
19:50:55 <madduck> exactly; if decisions could even be made.
19:50:56 <Tincho> bye now
19:51:06 <cate> bye Tincho
19:51:09 <gwolf> Tincho: o/
19:51:09 <tiago> Tincho, bye
19:51:30 <gwolf> Anyway, ticket system: Is it wanted? Should we have each team have a RT queue?
19:51:37 <madduck> tiago: uh, yes and no. We've done some research on this, but it really depends a lot on infra, and e.g. what happens with summit, Django in general, the CRM system etc.
19:51:41 <gwolf> [ ] Further discussion
19:52:00 <tiago> madduck, :\
19:52:24 <gwolf> Anyway... I don't think we are getting anywhere here. And we are not a representative group of DebConfTeam
19:52:37 <gwolf> So I'll do what I just said does not work :-/
19:52:43 <tiago> gwolf++
19:52:45 <madduck> tiago: also, honestly, and I know you'll hate this, I want someone to make a decision on one system, put it in place and get people to use it. I don't have the energy to "discuss" this.
19:52:52 <gwolf> #info Communication across teams should be discussed on the list.
19:53:04 <gwolf> #info Setting up RT tickets for teams should be discussed on the list.
19:53:12 * madduck dies a silent meta-death
19:53:21 <gwolf> #info Quoting Madduck, I'd so much rather ortganise DebConf than meta-discuss all the time
19:53:29 <tiago> madduck, I don't think it'll bring much discussion if someone propose as an experience, and *do* the setup job
19:53:41 <gwolf> madduck: we are not moving with this. Lets just push the topic to the wider audience.
19:53:44 <tiago> or even do the job and announce later for those who want to try
19:54:01 <gwolf> FWIW I'd have arranged items differently, but here we go
19:54:06 <gwolf> #topic  Status reports from the teams
19:54:27 <gwolf> So, anything to report we have not yet covered?
19:54:32 <madduck> gwolf: we are not moving because we are failing to make decisions and we are doing exactly the same mistakes we've done for 10 years, which is to broaden the audience if we fail to make decisions.
19:54:44 <madduck> we need to *enable* people to make decisions
19:54:52 <madduck> hence my suggestion to define areas of competencies
19:55:03 <gwolf> As for the Coordination team (and following on with meta-), we successfully held one meeting (which I missed), and have not yet successfully finished having our second meeting.
19:55:33 <tiago> madduck, write it down and propose in the channel you think is adequate
19:55:38 <gwolf> madduck: Yes. But it's not a consensus we will reach during a very little-attended meeting, without the titular team lead nor any of the Chairs online.
19:55:52 <cate> pa: nothing new. nattie keep singing (in december)
19:55:56 <tiago> madduck, we can't force people to follow closed decisions
19:56:28 <tiago> madduck, such areas of competence, needs some discussion, yes
19:56:41 <cate> [and BTW we are in a coordination meeting, to discuss what cannot be decided within a team]
19:56:45 <gwolf> ...Any team reports?
19:56:55 <tiago> gwolf, from content
19:56:56 <cate> gwolf: pa: nothing new. nattie keep singing (in december)
19:57:00 <tiago> nothing special
19:57:11 <gwolf> cate: PA means..?
19:57:13 <tiago> just a small thing, we're asked to consider a
19:57:24 <tiago> organizational psychologist for dc
19:57:34 <tiago> we've discussed a bit with no consensus
19:57:37 <cate> gwolf: I don't remember. something with Attendace  [the registration + bursaries]
19:57:51 <gwolf> #info no news from PA (Attendance)
19:57:51 <cate> Ah. nattie is forming the bursaries team
19:58:08 <gwolf> #info Content team is discussing an organizational psychologist for DebConf, but no consensus then
19:58:08 <tiago> but it seems people would not go against if it was a professional recommended by a trusted local
19:58:18 <bremner> participant assistance ?
19:58:28 <gwolf> #info nattie is forming the bursaries team (but she's mostly unavailable during December)
19:58:32 <madduck> what does an orga psych do?
19:58:35 <tiago> bremner, for a talk
19:58:37 <cate> bremner: right
19:58:44 <tiago> ops
19:59:14 <gwolf> And that seems to be it for status reports...
19:59:22 <gwolf> #topic Any other business?
19:59:34 <cate> what about facility team?
19:59:54 <cate> ah... no charis
20:00:03 <cate> so nothing more
20:00:09 <gwolf> .So... Should we consider this meeting closed?
20:00:22 <gwolf> Anything more to add? Or should we continue outside meeting-time?
20:00:52 <gwolf> OK... So being the case
20:00:56 <gwolf> #endmeeting