18:02:30 <edrz> #startmeeting
18:02:30 <MeetBot> Meeting started Wed Oct 7 18:02:30 2015 UTC. The chair is edrz. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:02:30 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:02:34 <indiebio> thanks
18:02:35 <edrz> #chair indiebio
18:02:35 <MeetBot> Current chairs: edrz indiebio
18:03:53 <indiebio> so I'm not the best person to run this, as my web knowledge is scant, but I'll do my best and then you can guide me where I lose the plit, ok?
18:03:57 <indiebio> s/plit/plot
18:04:03 <fil> hi
18:04:54 <larjona> hi! I'm multitasking here and kid's dinner, so mostly afk
18:04:59 <indiebio> The first topic is skills of the interested people, and my thinking there is just to figure out who is involved where. I don't know if this is required or useful for anyone else rather than me though...
18:05:23 <indiebio> So if you want, please put your skills down in the titanpad - https://titanpad.com/443gTylF6p
18:05:28 <edrz> #topic roll call/skills
18:05:36 <indiebio> Hodgestar: are you around?
18:05:37 * superfly is back for the moment
18:05:55 <superfly> 20:00 is SAST is an awkward time for me
18:06:42 <indiebio> sorry superfly, when is better? It's impossible to get these times right for everyone and no one gave suggestions for the website meeting...
18:07:13 <superfly> indiebio: 20:30 is fine. 20:00 is kid's bed time, so I can't always make it
18:07:26 <edrz> scheduling across several continents is always going to be a bit hard.
18:08:01 <superfly> indiebio: also, there's so much traffic on the -team list I find it difficult to keep track across all the political debates. And I don't have time when at work to follow the list.
18:08:07 <indiebio> I see. we can fuss around for a bit, and you can read the backlog when you're back? Are you also very into the wafer discussions, superfly?
18:08:38 <indiebio> I feel ya, superfly, hopefully those will quieten now...
18:08:43 <superfly> indiebio: not really. I'm happy to take the design into CSS and templates. wafer is a bit much right now
18:09:17 <indiebio> cool, so we can do wafer stuff with Hodgestar et al, and do Design when you're ready? (or next week even?) not sure when you want to do that...
18:10:31 <wendar> superfly: it's safe for you to ignore the political stuff, and just focus on the tech you're interested in :)
18:10:32 <highvoltage> Design needs a lot of help
18:10:45 <highvoltage> we need to spend some time with tammy to get all the elemetns and raw sources into git
18:11:05 <highvoltage> we can perhaps get some groundwork done for that on saturday
18:11:06 <indiebio> The next topic is the deadline for when we can evaluate a working system, but I don't see tumbleweed or Hodgestar around to give input here ...
18:11:17 <superfly> wendar: yeah, I've been doing that -_-
18:11:21 <tamo_> highvoltage: what do you mean?
18:11:22 * gwolf raises head and tries to follow
18:11:39 <wendar> superfly: it's also safe to just focus on the layout (css/html), we can translate that into the hosting system pretty easily
18:11:53 <superfly> wendar: that's kinda my intention
18:12:03 <highvoltage> tamo_: the git repository (unless I missed it) doesn't contain the vector graphics for most elements used in the designs
18:12:09 <indiebio> highvoltage, superfly, tamo_ do you need me to help with that? Or are you happier just carrying on on your own?
18:12:36 <tamo_> highvoltage: what do you mean by vector graphics?
18:12:37 <highvoltage> tamo_: so for example, when I needed to make a swirl favicon, I had to try to grab it from one of the PDFs
18:12:38 <superfly> indiebio: I can't speak for the others, but I'm happy carrying on on my own
18:13:13 <highvoltage> tamo_: you might call them 'open files', it's the source files that you work with
18:13:30 <tamo_> highvoltage: ah ok I see what you mean, let me know how you want them all saved so I can get that ready for Sat, ie: ping, pdf, jpg....
18:14:05 <tamo_> highvoltage: eps's and pings might work well for open source
18:14:06 <highvoltage> tamo_: that would be great, we can probably go through some of it on Saturday too? but if you could gather most of it up, it could give us some more time to socialise on saturday
18:14:50 <highvoltage> tamo_: yeah the .eps files currently in git are weird, they just open as small bitmaps for me, but we can look at exporting to .svg, that works everywhere
18:15:10 <superfly> highvoltage: what are you using to open the eps files?
18:15:13 <tamo_> highvoltage: sure, will sort out teh style guide too, just didn't ahve the energy to do it today, had to run around doing other stuff
18:15:53 <tamo_> highvoltage: ok well let me know which format works best
18:16:02 <highvoltage> indiebio: in short, the way I feel about it, if we can get all those source files into git, and get a styleguide going and lock down colours, etc, then it makes it really easy for anyone working on websites, pamphlets, interfaces, wikis, etc to make things that look and feel consistent and high quality
18:16:36 <indiebio> absolutely, agree highvoltage. I was wondering if I can help with that?
18:16:37 <tamo_> highvoltage: for sure!!
18:16:48 <indiebio> (I'd prefer not to, but happy to help where needed)
18:16:56 <tamo_> indiebio: nope no worries
18:17:03 <highvoltage> tamo_: great, you don't have to take that all on yourself though. both myself (and I'm sure) superfly would love to be involved with that
18:17:12 <larjona> tamo_ RGB notation of the colors would also help for the website
18:17:29 <superfly> tamo_: what highvoltage said :-)
18:17:31 <larjona> RGB or HTML, or whatever code
18:18:01 <tamo_> style guide has; RGB, WEB and CMYK colour guides, Images and styles used, fonts etc
18:18:06 <highvoltage> larjona: *nod*, once they're locked down, we can add them to https://wiki.debconf.org/wiki/DebConf16/Artwork
18:18:17 <indiebio> highvoltage, superfly, tamo: What date can I action when this will be ready for the rest of the team to look at? I don't think it's too urgent, but we have great momentum at the moment. Two weeks?
18:18:51 <tamo_> indiebio: style guide will take an hour max! not a big job
18:18:58 <highvoltage> indiebio: I think if we spend a little time on it on Saturday, we might be able to get it to 80% done by next week this time
18:19:07 <DLange> famous last words, tamo_ :)
18:19:08 <superfly> indiebio: I'm quite busy with the next major version of my open source project right now, releasing next sunday. I will try to work in some time.
18:19:20 <highvoltage> (I don't think we want to mark it quite as finished, because we'd want some wider input if possible)
18:19:28 <indiebio> Can I set the deadline for two weeks, and if we get it earlier, great?
18:19:40 <tamo_> highvoltage: how much is there to do? I thik I am not getting what you want to load etc?
18:19:49 <indiebio> sure highvoltage, I meant the deadline for wider input, yes
18:20:26 <edrz> what exactly will be possibly ready in 2 weeks?
18:20:29 <highvoltage> tamo_: we should have vector versions (resizable to any size) of all the images we'll use again that's in the current brochure and other PDFs (so that's all open files)
18:20:34 <edrz> an html/css mockup?
18:20:39 <highvoltage> tamo_: let's lable that artwork todo #1
18:20:46 <edrz> django templates for wafer?
18:20:51 <tamo_> highvoltage: it shouldn't take 2 weeks? Just an hour at teh most? Unless I am missing something
18:20:52 <superfly> edrz: html mockups
18:20:53 <edrz> a working wafer site/
18:21:13 <highvoltage> edrz: that's what superfly will work on (at least the basic elements) once the styles are available
18:21:36 <edrz> so #action html mockup of webdesign to present to debconf-team by Oct. 14th
18:21:39 <edrz> ?
18:21:54 <highvoltage> tamo_: it shouldn't. but I've been pestering for it for more than a month now, and we're just saying two weeks to make indiebio happy because she likes deadlines. we can have it ready tomorrow if you like :)
18:22:10 <tamo_> highvoltage: ok cool
18:22:13 <highvoltage> (and I know there's been many other things happening, I'm not complaining)
18:22:17 <superfly> highvoltage: I think it's a little longer than that.
18:22:25 <superfly> I'd much rather stick to the 2 weeks.
18:22:26 <tamo_> highvoltage: had other things on my plate sorry
18:22:35 <indiebio> edrz: no, the wafer site might take longer...
18:22:55 <indiebio> edrz: Two weeks for a design style guide, and all design elements documented in git and on the Artwork wiki page
18:23:09 <indiebio> thanks highvoltage :) (re deadlines)
18:23:16 <superfly> indiebio: I'm good with that
18:23:21 <tamo_> THE BIG QUESTION: did everyone see teh design proposal added last week? No feed back as of yet?
18:23:27 * superfly needs to duck out again
18:23:36 <highvoltage> superfly: well, besides source images and design elements, this is a good time to speak up for anything else needed
18:23:39 <indiebio> tamo_: I didn't, the file was too big and I didn't have time
18:23:53 <indiebio> oh, no, this is the website one...
18:24:12 <highvoltage> superfly: (typing for when you're back) I don't think it's optimal to obsess about page layout yet, but at least there are some ideas for that already
18:24:13 <indiebio> tamo_: can we bundle that with the two week deadline or would you want input sooner?
18:24:40 <highvoltage> (also, I'm sorry if I'm not making sense, been spending too much time in front of the screen today)
18:25:24 <tamo_> indiebio: sooner would be nicer it's been up for a week, but I'll leave it up to everyone to decide, what backend stuff is going to be worked on if no one has seen the website?
18:25:31 <indiebio> Ok ... so this basically took care of agenda point 3.1...
18:26:27 <indiebio> tamo_: I'll send an email for people to look at it if you like, but I think we're all wondering about wafer, so the focus is a bit diluted
18:27:01 <indiebio> #action indiebio to draft email with tamo about website visual design proposal to send to team
18:27:10 <indiebio> is that how one does the action thing?
18:27:16 <highvoltage> yup
18:27:17 <edrz> i think so.
18:27:59 <indiebio> great. I'm skipping over the second agenda point - the deadline for a 'demonstrable' wafer site as I don't see tumbleweed and Hodgestar here ...
18:28:50 <indiebio> Agenda point 3.2 Overall structure of website and 3.3. Content (pre-written and matrix) ... I don't know what is required here. Any ideas if this is required now and/or how to move ahead with this?
18:29:31 <indiebio> hmm. this needs superfly re content matrix.
18:29:38 <highvoltage> maybe it would be a good homework assignment for everyone interested in layout / content to go through the last few debconf sites and get aquanted with how they were done
18:29:41 <edrz> #topic 3.2 Overall structure of website and 3.3. Content
18:29:53 * edrz rusty at meetbot chairing ...
18:29:56 <indiebio> sorry edrz, I'm all over the place!
18:30:01 <edrz> no worries.
18:30:16 <tamo_> indiebio: cool
18:30:17 <indiebio> and the meetbot for today is just really to have a log
18:30:30 <edrz> i'm not sure what is meant by content matrix, specifically.
18:30:56 <indiebio> me neither. it's something superfly said, but he's ducked for father duties....
18:31:22 <indiebio> the next point was the static site, which is up and there's been edits, thanks highvoltage, larjona and probably others too!
18:31:27 <superfly> indiebio: I had a look at a couple of conference sites, like DebConf and PyCon, and they all seem to follow the same basic content layout
18:31:29 <indiebio> So we don't need much to say there, right?
18:31:32 <edrz> maybe he means something like a sitemap or perhaps the css grid for layout. i'm not sure.
18:31:41 <indiebio> ah, superfly's back!
18:31:42 <superfly> edrz: kinda like a site map
18:31:56 <indiebio> Ok, so what do you need from us, if anything?
18:32:10 <superfly> a content matrix is basically a way of organising your content so that it makes sense.
18:32:15 <gwolf> (and we have all of the historic DebConf sites to see how much each deviates from the others :) )
18:32:40 <edrz> probably looking back through what pages were used in past debconf's gives some idea of the information we typically need to make available.
18:32:50 <superfly> gwolf: they are all roughly the same from a content point of view
18:33:01 <superfly> edrz: yes, that's kinda what I did.
18:33:09 <indiebio> superfly: so what do you need from us, to help you, if anything?
18:33:10 <gwolf> superfly: right, I agree, I was basically summing up what has just been said
18:33:11 <superfly> tamo_ has some good ideas as well
18:33:12 * edrz nods
18:33:13 <edrz> ok
18:33:45 <edrz> iiuc, wafer stores the content as markdown in the db.
18:33:49 <superfly> indiebio: nothing right now. I need to take a look over tamo_'s design, and then back and the other sites. it won't take a long time. I think it's mostly there already.
18:33:53 <tamo_> indiebio: very confused are people dooing other sites?
18:34:06 <edrz> if possible many of us, i think, would like it to be in git.
18:34:07 <indiebio> superfly: excellent, can we bundle that in the two week deadline too?
18:34:17 <indiebio> tamo_: huh?
18:34:24 <superfly> indiebio: uh, my plate's already full without DebConf...
18:34:54 <indiebio> which is why I'm wondering if we can help, somehow, superfly
18:35:07 <indiebio> maybe a sprint at the braai?
18:35:14 <superfly> indiebio: the content matrix partially feeds into the design, but only after the style guide
18:35:15 <tamo_> everyone is talking about previous Debconf sites, site maps etc, I don't think I am understanding the full context of this all.
18:35:18 <indiebio> each take an old DebConf site and work on a titanpad?
18:35:29 <tumbleweed> indiebio: blergh, sorry. Not used to this time slot, yet
18:35:33 * fil notes that I rarely manage to find anything that I'm looking for on the somewhat disjointed debconf main site/year site/wiki that we normally have, without going round in circles a couple of times -- would be nice to make that better
18:35:45 <tamo_> once a design is decided on then you need a site map?
18:35:57 <highvoltage> tamo_: previous sites is mentioned for a guide on layout and content map. they've been pretty consistent (and good) and we can re-use good work done before
18:36:02 <superfly> indiebio: I've got some notes from when I looked at it last. I'll make those a little neater and put them somewhere, like git
18:36:07 <edrz> fil: yes. I think we can improve on that front.
18:36:20 <superfly> fil: I'd be keen to hear your input
18:36:35 <indiebio> fil: completely agree! I just have no idea how
18:36:38 <edrz> looking at the past is more to see what we've presented. we need to present it with better organisation and navigation.
18:36:39 <highvoltage> tamo_: in the context of other sites, there may be additional websites that won't be the main DC website. for example, this year there was a volunteer site, which had a different look and feel to the main one: https://summit.debconf.org/debconf15/volunteers/
18:36:58 <highvoltage> tamo_: but we'd like to make it easy for all debconf related sites to have a consistent look and feel for next year
18:37:23 <tamo_> highvoltage: ok explain that more to me on Sat, I think I am missing something
18:37:40 <tamo_> highvoltage: you mean in teh backend?
18:38:06 <edrz> highvoltage: i personally would like us to fins a way to apply consistent look and feel to our various pieces.
18:38:20 <highvoltage> tamo_: no. look at https://summit.debconf.org/debconf15/volunteers/ and look at http://debconf15.debconf.org/ - they look completely different but are both sites for DC15
18:38:32 <edrz> though stuff that is just for internal use, like volunteers, is of lower priority in that regard, imho.
18:38:46 <highvoltage> tamo_: for DC16, we'd like to make it easier for all related DC16 content to look like they belong together
18:38:53 <tamo_> highvoltage: aaah ok I am with you now thanks, was getting confused
18:39:01 <tamo_> highvoltage: agreed!
18:39:14 <highvoltage> tamo_: np
18:40:02 <tamo_> highvoltage: but why was it done that way? to have two different ones?
18:40:07 <edrz> volunteers is a seperate system from FOSDEM that cate managed to shoehorn into talking to summit, but didn't have time or inclination to make look nice.
18:40:35 <tamo_> edrz: ok I see
18:40:38 <highvoltage> tamo_: no idea, there could be a million different reasons. maybe the styles weren't ready yet when the volunteer site was made. maybe there just wasn't time to implement it, I have no idea
18:40:51 <highvoltage> tamo_: but getting them done early will make consistency drastically easier
18:41:09 <tamo_> highvoltage: def will.
18:41:44 <highvoltage> superfly: have you considered a workflow for that bootstrap html work? I was wondering if it would be worth while forking a DC16 bootstrap before going into further details. getting some good generic layouts based on tamo_'s designs and getting the colours right, etc
18:42:35 <superfly> highvoltage: I'd like to do that to. Glad to hear we're on the same page :-) I don't have a workflow yet, I'm open to suggestion.
18:42:40 <fil> superfly: ISTR failing to find a link for registration, for instance
18:42:41 <highvoltage> superfly: then if someone like the video team needs a page somewhere they could potentially recycle that whole DebConfinised bootstrap
18:42:58 <highvoltage> indiebio: with us?
18:43:04 <indiebio> tumbleweed, Hodgestar, side comment, do you want to talk wafer tonight?
18:43:17 <indiebio> highvoltage: not really, but I like where it's going :)
18:43:22 <indiebio> it sounds good
18:43:25 <superfly> highvoltage: ah. yes, yes, n b yes.
18:43:30 <indiebio> but I'm not sure if it's english
18:43:31 <edrz> highvoltage: i'm not sure I understand how that helps onece stuff is in django templates + markdown.
18:43:36 <tumbleweed> indiebio: I can
18:43:54 <highvoltage> edrz: ah, so...
18:44:17 <highvoltage> edrz: breaking down an html page that can be used in django is trivial
18:44:37 <indiebio> tumbleweed: do you think the deadline for a 'demonstrable wafer site' is still necessary nowthat we have decided it's the way we're going?
18:44:56 <tumbleweed> indiebio: we've had a demonstratable wafer site up for months
18:45:03 <tumbleweed> I don't know what you want a deadline for
18:45:09 <indiebio> I think it's good to give a date by which time we can see what is going to be issues. But this is more like a progress report, really
18:45:18 <DLange> one that looks DC16 and has contents would be nice
18:45:18 <indiebio> coz I like deadlines :)
18:45:19 <edrz> well, we still need to prove that wafer can meet DebConf's needs and that we're definitely not going to have to fallback to summit.
18:45:36 <edrz> unless everyone feels that is a foregone conclusion ...
18:45:39 <tumbleweed> indiebio: no, I mean, what you want to have *implemented* in wafer before the deadline
18:45:47 <indiebio> originally it was because we needed to give other systems a chance, but ok, I'm fine with if it's not needed. Can you give me that link again please?
18:45:59 <highvoltage> indiebio: it's generally the best approach to continuously look for blockers and then remove those
18:46:38 <indiebio> highvoltage: explain?
18:47:19 <indiebio> tumbleweed: I want to know how to move this forward, is DLange's idea of one that looks like DC16 and has content doable?
18:47:20 <highvoltage> indiebio: ok, over braai :)
18:47:47 <tumbleweed> indiebio: that's more up to the people doing design
18:47:48 <highvoltage> for the website, that's doable even without wafer.
18:48:00 <indiebio> you mean the other contenders, highvoltage? my conflicts are between getting things done and letting people feel they're heard. it's psychological
18:48:18 <indiebio> ok, so what are the next steps with wafer, tumbleweed?
18:48:24 <indiebio> is it something I need to prod?
18:48:25 <highvoltage> indiebio: I mean, showing content and lookin like another site doesn't even need an app or cms, that's just html/css
18:48:40 <indiebio> coz we need a site working by January.
18:48:40 <tumbleweed> indiebio: DLange is organising a VM, we'll get wafer up on it, and figure out how we're going to manage it
18:48:48 <tumbleweed> indiebio: I don' tthink there's anything to prod here, things are moving
18:48:58 <indiebio> great, thanks, that's what I needed to know
18:49:09 <indiebio> would progress reports help keeping people informed?
18:49:18 <highvoltage> which people?
18:49:25 <indiebio> (please bear in mind I don't know what's going on here)
18:49:29 <indiebio> the rest of the team, highvoltage
18:49:29 <tumbleweed> highvoltage, superfly: Have you guys looked at its templates, yet?
18:49:42 <superfly> tumbleweed: negative.
18:49:53 <tumbleweed> hrm, just got a google calendar reminder fro this meeting :(
18:50:04 <highvoltage> tumbleweed: is it different that usual django templates? I know it supports some markdown
18:50:17 <indiebio> #info website/wafer: DLange is organising a VM, we'll get wafer up on it, and figure out how we're going to manage it
18:50:18 <DLange> tumbleweed: timezones++
18:50:24 <tumbleweed> highvoltage: django is just a framework. Every django site is themed differently
18:50:43 <tamo_> indiebio: superfly and highvoltage have seen it before it was uploaded
18:51:01 <tumbleweed> DLange: didn't they used to happen at 19:00 UTC?
18:51:05 <tumbleweed> this was 18:00 UTC
18:51:08 * indiebio is wondering if it would be worth recording when people chat about this at the braai...
18:51:13 <edrz> tumbleweed: there was mail.
18:51:17 <highvoltage> tumbleweed: just looked at https://github.com/CTPUG/wafer/tree/master/wafer/templates/wafer
18:51:22 <indiebio> they did, but I moved it earlier. my bad.
18:51:34 <indiebio> #link https://github.com/CTPUG/wafer/tree/master/wafer/templates/wafer
18:51:34 <highvoltage> tumbleweed: that's the same way django sites typically worked at Praekelt, so yes I'm familiar with it
18:51:35 <tumbleweed> edrz: oh, I'm a few days behind on that
18:51:44 <tamo_> indiebio: just let me know when I need to step in the picture on all this with the Website and in good time please
18:52:06 <indiebio> tamo_: I'll try, TBH I don't know... 8|
18:52:18 <indiebio> I hope the braai will enlighten us...
18:52:33 <tamo_> indiebio: hmm me too! :)
18:53:04 <indiebio> I think I'll just randomly harass people until they give me something just to shut me up.
18:53:09 <indiebio> it seems to be working, generally
18:53:16 <tamo_> indiebio: hahha
18:53:39 <tumbleweed> edrz: at least I know why the meeting was unexpected, now :)
18:53:44 <highvoltage> tumbleweed: or is there something I'm missing or some complication/booby trap with templating?
18:53:47 <tumbleweed> I just thought I'd been forgetful
18:53:54 <DLange> tumbleweed: I tend to read the /topic so whoever sets that owns my agenda :)
18:53:55 <tamo_> indiebio: I think I am going to sign out am I still needed?
18:54:38 <indiebio> tamo_: only thing is to take note of the 'tiny brochure changes' titanpad. Not to worry about, we can meet and deal with it in a week or so? https://titanpad.com/DC16-sponsorship-brochure-tiny-issues
18:54:55 <tumbleweed> highvoltage: No, it should be fairly straightforward. But if we're able to keep mostly the existing HTML, the templating can be less invasive
18:54:58 <indiebio> and to say a HUGE thanks to tamo_ for the brochure!
18:55:13 <tumbleweed> highvoltage: it's mostly bootstrap primitives, so, fairly standard
18:55:22 <indiebio> edrz, I think we can change the topic to wafer now :)
18:55:30 <edrz> heh.
18:55:33 <indiebio> lol
18:55:50 <tamo_> indiebio: yup those can be done the sooner the better I would imagine I had suggested to MeetBotand DLange that if they need just pages inserted then that can be a quick job, but not sure how DLangeset it up
18:56:07 <tamo_> indiebio: PLEASURE :)
18:56:27 <indiebio> we could do it Saturday possibly...
18:56:37 <tamo_> Yup lets do it then
18:56:42 <indiebio> would be nice to have one printed copy there too, just to show it
18:56:45 <highvoltage> yes tamo_, great brochuring there :)
18:57:16 <tamo_> indiebio: sure will do
18:57:22 <indiebio> thanks
18:57:25 <tamo_> highvoltage: thanks highvoltage
18:57:50 <indiebio> so the wafer thing seems to have moved to #debconf-infra...
18:57:55 <highvoltage> so is the #topic on to wafer?
18:58:00 <tumbleweed> indiebio: no, it's parallel :)
18:58:04 <indiebio> Is there anything that still needs discussing here?
18:58:10 <tumbleweed> indiebio: this discussion has been theming, that has been deployment :P
18:58:17 <indiebio> oh my word, you guys are trying to confuse me on purpose :P
18:58:39 <indiebio> uh, yes highvoltage, I think...
18:58:43 <indiebio> #topic wafer
18:59:50 <edrz> indiebio: sorry ... i was just asking about some specifics of logistics.
18:59:53 <edrz> over there.
19:00:34 <indiebio> tumbleweed: so for the record, you're saying everything is all good, no action needed from anyone?? My neurotic worry is that the website lags and doesn't get done in time and ... nightmares! So what can I do to make that not happen.
19:00:57 <tumbleweed> people are currently active, so prodding now doesn't seem useful
19:01:06 <indiebio> but looks like other than the VM (virtual machine, right?) there's not much to do?
19:01:08 <tumbleweed> there are times of inactivity, this isn't one of them
19:01:13 <indiebio> good. :)
19:01:22 <tumbleweed> no, there's lots to do
19:01:29 <edrz> VM == virtual machine, yes.
19:01:33 <indiebio> Can I delegate official poker capacity on wafer to you, tumbleweed?
19:01:34 <tumbleweed> superfly and highvoltage were interested in the design, I think
19:01:41 <tumbleweed> so, we need to get them going on that
19:01:55 * madduck waves. I really thought it was 1900 UTC :/
19:02:04 <tumbleweed> madduck: it got me too
19:02:15 <tumbleweed> indiebio: time changes really need to be announced well in advance
19:02:18 <indiebio> it sortof was madduck, my fault. I just can't stay awake that long.
19:02:22 <indiebio> tumbleweed: I did.
19:02:25 <indiebio> last week already.
19:02:33 <tumbleweed> oh :(
19:02:35 <superfly> indiebio: website will be done by January. you're worrying too much.
19:02:38 <indiebio> but it's no trainsmash
19:02:45 <indiebio> I worry superfly, it's what I do :)
19:02:47 <tumbleweed> edrz, and cate (?) were interested in contribution to wafer, so we need to get them started
19:02:52 <indiebio> I worry so you don't have to
19:02:57 <tumbleweed> but I thinkt hat'll wait for a deployment of some sort
19:03:22 <edrz> cate was. his last mail seemed to indicate he needed at least a few weeks for non-DebConf life.
19:03:30 <indiebio> tumbleweed: can I action that you are poker (aka responsible) for wafer? That way I don't annoy you guys.
19:03:38 <edrz> oh, and, yes me, too.
19:03:39 <tumbleweed> indiebio: sure
19:03:40 <highvoltage> indiebio: best thing now is for all the basics to be taken care of. so that's the design elements tamo_, superfly and myself will look at so long (and hopefully some others), and then superfly can start working properly on those bootstrap templates for dc16
19:04:23 <DLange> we need to setup a workflow git -> dev, git -> int and deployment to prod
19:04:28 <tumbleweed> highvoltage: I'll see if I can get a basic setup together before the braai, then we can see that you have working local dev, on the weekend
19:04:34 <indiebio> perfect highvoltage, and you guys are on that, and where you need help, I'll be there. But you said you don't need help so I won't bug you for two weeks unless you ask me to.
19:04:35 * gwolf would like to dip my toes in wafer, but being honest I'm too time-constrained
19:04:37 <highvoltage> tumbleweed: great
19:04:43 <DLange> Ganneff wants to do prod on the current Summit VM
19:04:52 <gwolf> so if anything, I'll be a happy fallback person for it :)
19:04:53 <highvoltage> indiebio: deal
19:04:53 <indiebio> #action tumbleweed is taking care of pokering of wafer
19:04:56 <DLange> for dev + int we have "scratchy.dc.o"
19:05:21 <DLange> (Ganneffs naming choice, not mine :))
19:05:32 <tumbleweed> DLange: dev may not prove necessary, but that's useful, thanks
19:05:33 <edrz> DLange: can you explain what int means to you? (i can guess, but want to be sure)
19:05:54 <DLange> integration, just a normal staged deployment setup
19:06:00 <highvoltage> ooh, scratchy.debconf.org even resolves to something now
19:06:09 <DLange> as in: test before we deploy to end users
19:06:18 <edrz> scratchy's just a host name. we can have it be wafertest.dc.o or whatever as well.
19:06:34 <DLange> yes, CNAMES are free :)
19:06:46 <edrz> summittest -> milhouse.
19:06:58 <edrz> Ganneff just likes simpson's characters. *shrug*
19:07:34 <highvoltage> Ganneff has good taste.
19:08:19 <highvoltage> tumbleweed: so, I'm not sure if you read the discussion between me and superfly or if you joined after...
19:08:25 <edrz> DLange: so integration is what i've been calling testing and we mean the same thing. good good.
19:08:48 <highvoltage> tumbleweed: but the idea is to start with just bootstrap-based html for dc16, and then templatize that for wafer after
19:08:58 <tumbleweed> highvoltage: I skimmed
19:09:12 <tumbleweed> highvoltage: right, but there are multiple ways of using bootstrap, so if you use the same way, it'll be easiest :)
19:09:19 <tumbleweed> (and the same version of bootstrap)
19:09:21 <highvoltage> tumbleweed: it seems like the simplest process and might make the base easier to adapt if necessary for other sites
19:09:46 <highvoltage> tumbleweed: cool, ok so we'll match the bootstrap version. good tip.
19:10:17 <superfly> tumbleweed: how hard is it to upgrade bootstrap in wafer?
19:10:31 <tumbleweed> superfly: doable
19:10:45 <superfly> because if wafer has 2, then I'd say there's no question, it must be upgraded, but if it's 3.x, then that's OK
19:10:57 <tumbleweed> it has 3
19:11:06 <tumbleweed> I say doable because we did it once
19:11:07 <superfly> (keeping in mind that 4 is coming out "soon")
19:11:13 <tumbleweed> but it took the best part of a day
19:11:34 <superfly> (question for another day: why is bootstrap tied to wafer?)
19:11:51 <indiebio> highvoltage, tumbleweed: that sounds like something we can #action? bootstrap-based html for dc16, and then templatize that for wafer after, NB to match the bootstrap version
19:12:00 <tumbleweed> that's our primary site, so presumably that's what you're building the template for
19:12:03 <highvoltage> yep, that can happen out of meeting
19:12:19 <superfly> indiebio: yes, but after the style guide, etc
19:12:42 <indiebio> yes, I'm just trying to document what we're talking about (it's like minuting a legal meeting when you can only grunt)
19:12:53 <indiebio> #action bootstrap-based html for dc16, and then templatize that for wafer after, NB to match the bootstrap version
19:13:49 <edrz> tumbleweed: there was recently some work done on wafer at pycon.za? there was a whiteboard, iirc ...
19:13:56 <KGB-0> 03Jonathan Carter 05master 67aa22a 06debconf-data/dc16 10website/ 10css/bootstrap.css 03favicon.ico Unbreak bootstrap.css, add icon
19:13:57 <KGB-0> 03Jonathan Carter 05master 81359fe 06debconf-data/dc16 10website/index.html Unbreak index.html for now
19:14:08 <tumbleweed> edrz: yes, at the pycon.za sprints
19:14:14 <tumbleweed> edrz: but it hasn't landed anything, yet
19:14:36 <edrz> as in no new code checked in? or what?
19:14:46 <tumbleweed> edrz: https://za.pycon.org/events/sprints
19:15:02 <tumbleweed> as in the drag and drop scheduler isn't done enough for a PR, yet
19:15:04 <tumbleweed> other bits happened
19:15:57 <edrz> ok.
19:16:24 <edrz> are we still in a meeting or just chatting now?
19:16:51 <highvoltage> I think we've got our work cut out for the immidiate future and can adjourne
19:17:12 <highvoltage> immediate. it's too late to english.
19:17:32 <tumbleweed> yeah, I think we're done with wafer. indiebio
19:17:35 <edrz> verbing weirds english.
19:17:40 <indiebio> \o/ thanks all
19:17:49 <indiebio> #topic general
19:18:34 <indiebio> #note Brochure is done! revisions can be done if needed.
19:18:51 <DLange> indiebio: can you talk to tamo on Sat when you want to do the v2?
19:18:58 <madduck> \o/
19:19:08 <indiebio> #link http://media.debconf.org/dc16/fundraising/debconf16_sponsorship_brochure.pdf
19:19:33 <indiebio> DLange: yup, it sounded like she wanted it done sooner rather than later, and we agreed to do it at the braai on Saturday
19:20:01 <indiebio> #link https://titanpad.com/DC16-sponsorship-brochure-tiny-issues
19:20:42 <DLange> indiebio: great, thank you
19:20:45 <indiebio> The CMC contract is ready to be signed by SPI, who have a board meeting tomorrow. I am now working on the accomodation contract, and after that we can truly set the dates in stone
19:21:03 <indiebio> and that is all from me. Anything else from anyone?
19:21:32 <highvoltage> Pollito says "uruugughhghg". I think he's excited to be going to nkukard's house on Saturday.
19:21:43 <indiebio> kwaaaaak!
19:21:55 <nkukard> :)
19:21:56 <indiebio> (That's hello in Pollitolese)
19:21:58 <tumbleweed> indiebio: VAT
19:23:14 <indiebio> uh. I don't know what to do with VAT
19:23:21 <tumbleweed> yeah, me neither
19:23:36 <tumbleweed> we need to talk to someone. CMC or lawyers
19:24:10 <indiebio> Belinda said a long time ago to our question "What's the tax situation like? What would we get taxed on, and how much? The only tax implication is the VAT on our co-ordinating fee."
19:24:31 <indiebio> but I think the issue is more on money coming in via SPI...??
19:24:34 <tumbleweed> I think we needed to follow that up with more detailled questions
19:24:35 <tumbleweed> yeah
19:24:38 <indiebio> But SPI has a legal rep too
19:24:43 <indiebio> maybe ask them?
19:24:45 <tumbleweed> who won't know anything about ZA law
19:24:54 <indiebio> but who understands the language
19:25:06 <indiebio> surely this must be easy for someone who speaks legalese
19:25:09 <indiebio> in any country
19:25:20 <tumbleweed> I think we're talking cross-purposes
19:25:34 <tumbleweed> what the contract says about VAT is far less important than what SARS thinks
19:25:47 <tumbleweed> lealese is just english
19:26:45 <indiebio> so the research we did before was for companies
19:26:50 <tumbleweed> yeah
19:26:53 <highvoltage> I'm tempted to comment but I've fell out of the loop on current plans and whether debconf 16 will be a pty ltd or handled by an existing company, etc, etc. (how and where and when can I catch up with that?)
19:26:55 <indiebio> but this is probably more an incoming funds things
19:27:16 <indiebio> so... highvoltage, we're trying not to register a company at all
19:27:17 <tumbleweed> highvoltage: we're hoping to use UCT's conference management people, entirely
19:27:24 <tumbleweed> but that means that tax has to be sane
19:27:33 <highvoltage> ah, that was the status I last had at DC. ok then.
19:27:34 <tumbleweed> and they haven't told us much to make me believe that, yet
19:27:48 <indiebio> the thread that contains the name 'Belinda' in -team should get you as confused as the rest of us, if you search your inbox, highvoltage
19:28:04 <highvoltage> I've read that, at least :)
19:28:04 <tumbleweed> indiebio: can we meet with her any time soon?
19:28:12 <indiebio> we could
19:28:21 <indiebio> not sure it would help, but sure
19:28:24 <tumbleweed> or should I pester my advisors?
19:28:32 <indiebio> and pay R5k again?
19:29:00 <indiebio> I think we need advice on investments across boundaries, not company stuff like we asked last time
19:29:10 <tumbleweed> heh, no people who I pay a flat rate to. And aren't contracted to help on debconf (but can be arm-twisted a bit)
19:29:37 <superfly> highvoltage: we should use less, rather than CSS directly.
19:29:52 <tumbleweed> indiebio: I'll ask around tomorrow, and catch up with you
19:29:53 <indiebio> ask them then, yes tumbleweed.
19:29:56 <highvoltage> superfly: sure
19:30:00 <superfly> highvoltage: bootstrap uses less, and it offers variables, and other programmy things
19:30:14 <superfly> easier to go back and change colour schemes later
19:30:17 <indiebio> ok, and should I make a meeting with Belinda? How's your schedule the next two days, tumbleweed?
19:30:23 <superfly> (aka DebConf16+)
19:30:35 <highvoltage> superfly: ah I see what you mean, for the throughaway site. ok.
19:30:36 <tumbleweed> indiebio: fairly free. Yeah, probably good to meet her while I'm here
19:30:59 <indiebio> ok
19:33:43 <superfly> ah, wafer uses bower <3
19:34:13 <tumbleweed> these days apparently people just npm install their client side js
19:34:18 <DLange> meeting done?
19:34:24 <tumbleweed> so, bower seems on the way out
19:35:43 <tumbleweed> indiebio: #endmeeting ?
19:35:54 <indiebio> yes please
19:36:07 <indiebio> #endmeeting