19:01:59 <edrz> #startmeeting
19:01:59 <MeetBot> Meeting started Tue Jun 22 19:01:59 2010 UTC.  The chair is edrz. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:59 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:02:26 <edrz> anyone else interested in chairing?
19:02:49 <Q_> Do we have an agenda?
19:03:06 <edrz> http://wiki.debconf.org/wiki/Videoteam/Meetings#Meeting_Agenda:_Tuesday.2C_22nd_June.2C_19:00_UTC
19:03:11 <edrz> Q_:  of sorts.
19:03:20 <edrz> so,
19:03:20 <vicm3> :D
19:03:27 <edrz> #topic software
19:04:11 <edrz> we (MrBiege, simonft, edrz, some CU chemistry people) did a little 1 day stream + recording thing.
19:04:23 <edrz> just using what's in lenny
19:04:28 <edrz> everything worked well enough.
19:04:35 <MrBeige> (I backported dvswitch though)
19:04:40 <edrz> ok
19:05:07 <MrBeige> + ubuntu on michelle's laptop, one of the last two releases
19:05:12 <Q_> Right, newer dvswitch is probably always prefered.
19:05:26 <edrz> the main thing I would like to have is the fade feature.
19:05:49 <tiagovaz> hi all
19:05:50 <edrz> but, that is only in the devel branch which is not currently in a releasable state
19:05:51 <CarlFK> dvswitch will not run on Ubuntu Karmic.  Lucid and Jaunty are fine.
19:05:54 <edrz> tiagovaz: hi
19:06:07 <edrz> CarlFK: we'll be using lenny + backports.
19:06:17 <Q_> CarlFK: Who cares about ubuntu releases?
19:06:18 <edrz> (unless someone objects)
19:06:35 <CarlFK> Q_:  apparently Michelle :)
19:06:44 <edrz> anyway.
19:06:56 <edrz> we have a working stack in lenny.
19:07:35 <edrz> if enough people time can be dedicated it would be good to: 1) release dvswitch with the fade feature + any bug fixes.
19:08:06 <edrz> 2) backport libtheora0 since there are significant encoder improvements
19:08:07 <Q_> Ben isn't comming, right?
19:08:13 <edrz> Q_: correct
19:08:58 <edrz> 3) backport ffmpeg
19:09:08 <Q_> edrz: As I understand things, the encoder has much improvements for things that don't change alot, which is basicly what we have?
19:09:31 <edrz> 4) backport ffmpeg2theora (preferrably after getting it upgraded in testing/unstable)
19:09:50 <edrz> 5) rebuild other stuff as needed for 1-4
19:10:16 <edrz> Q_: yeah. something like that. :)
19:10:28 <Q_> So is anybody volunteering to do that part?
19:10:42 * edrz will try ... but wouldn't mind some help.
19:11:06 <tiagovaz> i'll try backport stuff
19:11:11 <edrz> tiagovaz: great
19:11:29 <edrz> also, for at least ffmpeg2theora there are newer releases.
19:11:53 <edrz> #action tiagovaz and edrz (at least) will work on backporting stuff
19:12:00 <Q_> Last year we had to change the settings a few times
19:12:01 <tiagovaz> for those I consider upstream if they don't go to sid in time
19:12:08 <edrz> Q_: settings of what?
19:12:14 <Q_> The encoders
19:12:29 <edrz> in order to accomplish what goal, exactly?
19:12:36 <Q_> To keep them working? :)
19:12:41 <edrz> haha. :)
19:12:42 <edrz> yeah
19:12:43 <edrz> ok
19:12:46 <edrz> we'll play with it.
19:12:52 <Q_> I think they couldn't follow or something.
19:12:52 <vicm3> #action vicm3 will also try to backport
19:12:57 <edrz> i have a full set of gear hear to test with.
19:13:04 <edrz> *here
19:13:13 <Q_> Specially in case someone moved alot, they had a problem.
19:13:18 <edrz> ok.
19:13:23 <edrz> we'll tweak and tune.
19:13:35 <edrz> anything else on software for now?
19:14:12 <edrz> #topic hardware
19:14:25 <edrz> i made a start on filling in http://wiki.debconf.org/wiki/DebConf10/Videoteam/Hardware
19:14:29 <edrz> yesterday
19:14:33 <edrz> still more work to do there.
19:14:47 <edrz> we need 1 more camera.
19:15:17 <tassia> hi
19:15:17 <Q_> We're doing NTSC this year?
19:15:20 <edrz> i have no doubt of being able to find at least one more consumer model, but would like to try and find another like xfxf_'s
19:15:23 <edrz> Q_: yes.
19:15:26 <edrz> we're in the US
19:15:29 <tassia> edrz, I have a camera
19:15:37 <edrz> tassia: NTSC or PAL?
19:15:49 <tassia> it's a cannon ZR800
19:16:00 <edrz> ok. we can get details later.
19:16:05 <Q_> Alot of camera's actually have an option for that.
19:16:10 <edrz> sure.
19:16:11 <tassia> tiago may answer :)
19:16:29 <edrz> like i said, we probably will have no trouble getting enough as we already have 3 committed.
19:16:41 <edrz> also, CarlFK will loan us PyCon's cameras if we need them
19:16:50 <edrz> right, CarlFK?
19:16:52 <edrz> :)
19:17:06 <CarlFK> I think so... bit of noise in the pycon front
19:17:17 <CarlFK> but I am in posession of them.
19:17:20 <tiagovaz> NTSC
19:17:27 <edrz> tiagovaz: great. thanks.
19:17:38 <edrz> CarlFK: are people not so happy about loaning gear?
19:17:39 <tiagovaz> it's a low quality cameras, considering we are in 2010
19:18:01 <CarlFK> edrz: that hasn't come up.  I am trying to buy it all so that I don't have to ask
19:18:02 <edrz> tiagovaz: sure. if you are already bringing it, it can't hurt to have as a backup.
19:18:07 <edrz> CarlFK: ah
19:18:24 <CarlFK> but the current offer to me is to lease it for a year, and do with it as I please
19:18:37 <edrz> so, anyway, i'm sort of considering buying one of the AG-DVX100B, like xfxf_'s
19:18:42 <Q_> What kind of hardware will be available in the venue?
19:18:44 <edrz> (for myself)
19:19:19 <CarlFK> one thing nice about the small cams: they are very light, and so a cheap $20 tripod can pan them without the jerk from 0 to panning
19:19:22 <edrz> in the main talk room CRF (Columbia's CS dept) has a PA system for us to use.
19:19:33 <Q_> Projector, audio, light, ...
19:19:47 <edrz> projectors are provided as are screens
19:19:48 <CarlFK> and the small tripods pack and setup quick
19:19:54 * edrz nods CarlFK
19:20:03 <edrz> but, nice tripods, are nice. :)
19:20:12 <CarlFK> are the projectors in the audience seats?
19:20:12 <edrz> mine are barely adequate and will suffice ...
19:20:21 <edrz> projectors are on the ceiling.
19:20:36 <bwh> Is Sledge going to take one or both of my tripods?
19:20:37 * edrz really needs to post the pictures and dimensions.
19:20:48 <CarlFK> where do you locate the twin pact? (is this too far OT?)
19:20:58 <edrz> bwh: he said "probably" need to firm that up
19:21:05 <edrz> CarlFK: yeah. not a worry.
19:21:16 <edrz> but, "at the podium"
19:21:44 <Q_> edrz: You said in your mail something about needing d-i boxes?
19:22:05 <edrz> I did? i was looking at them last night.
19:22:18 <edrz> i need some for my own use in the studio so might by what we need.
19:22:22 <Q_> Is there a mixer in the room, and where is it located?
19:22:43 <edrz> there are "a/v" mixers in the podiums.
19:23:11 <CarlFK> n the podiums ?
19:23:32 <Q_> And is that something we can actually use, and maybe move around?
19:23:32 <edrz> well, in a rack near or at where the speaker stands, yes.
19:23:44 <edrz> we have our own mixers ...
19:24:17 <Q_> We don't have 2 mixers that can do 2 mixes.
19:24:27 <edrz> i have 2 of my own that can.
19:24:29 <p2-mate> Q_: we do I think
19:24:50 <Q_> edrz: Oh, I didn't know you had something. :)
19:24:57 <p2-mate> Q_: the larger behringer mixer can do 2 mixes (forgot the model)
19:25:09 <edrz> we're covered. if i hadn't gotten sick this weekend on my trip up to NYC i would have had all this documented.
19:25:26 <edrz> my main concern had beedn the PA in Davis (main talk room)
19:25:37 <edrz> we've heard complaints from people who have had to use it.
19:25:47 <Q_> So I'm currenly going under the assumption that audio will not be a problem.
19:25:55 <p2-mate> edrz: so rent a PA ?
19:26:02 <edrz> but, the CS dept (our main host) has their own PA which we got to see since it was set up for an ACM event
19:26:12 <edrz> and they said it's no problem for us to use it.
19:26:43 <edrz> it has a little powered mixer thing for itself with balanced xlr inputs switchable between mic and line.
19:26:48 <Q_> I assume we're going to cover 2 rooms?
19:26:54 <edrz> shouldn't be an issue to run our room mix into that.
19:26:57 <edrz> Q_: yes
19:27:21 <edrz> 2 room. Davis Auditorium: seats around 200.
19:27:35 <edrz> Interschool Lab: seats around 65
19:28:22 <edrz> we also have a smaller room 414 CEPSR for BoFs, but we have not promised to cover that with video
19:28:24 <vicm3> #info test the venue PA, and maybe the acoustics?
19:29:10 <edrz> #action edrz will be taking 1 more trip up to NYC before debcamp and will be running a/v and network tests at that time.
19:29:12 <h01ger> ups
19:29:19 <edrz> UPS?
19:29:20 <Q_> edrz: And so what's the situation for the second room?
19:29:21 <h01ger> wasnt the meeting supposed to be 19 utc?
19:29:25 <edrz> no, only in the server room
19:29:26 <h01ger> anyway. hi!
19:29:33 <p2-mate> h01ger: which is 30 minutes ago :P
19:29:34 <Q_> h01ger: That's 30 minutes ago.
19:29:37 <edrz> 19:00 was 30 mintues ago, no?
19:29:42 <edrz> yeah.
19:29:43 <edrz> :)
19:29:46 <edrz> h01ger: hi. :)
19:30:09 <mfl> hi from me, too
19:30:13 <tiagovaz> h01ger: :)
19:30:18 <edrz> so. again, sorry I haven't been on top of documenting everything and communicating very well.
19:30:23 <vicm3> hi :D
19:30:31 <edrz> but, we do have most of our resources covered.
19:30:40 <edrz> let's see ...
19:30:47 <edrz> any other questions about hardware?
19:30:52 <Q_> So, moving on to servers?
19:31:01 <edrz> yeah.
19:31:05 <edrz> well, just a note:
19:31:08 <tassia> edrz, just a note
19:31:22 <tassia> we are coming back on the 5th
19:31:31 <edrz> #info devil is shipping the remaining v-t equipment to me
19:31:36 <Q_> And those we're going to connect our camera's too.
19:31:37 <h01ger> p2-mate, doh
19:31:51 <edrz> #info weasel has already shipped 3 1 TB drives to me.
19:32:05 <edrz> tassia: ok. is that in the wiki and your penta accounts?
19:32:14 <edrz> + sorry you 2 have to leave early. :(
19:32:28 <tassia> yes
19:32:32 <tassia> :(
19:32:33 <MrBeige> edrz: do a #save
19:32:49 <edrz> CarlFK: are we still able to get dvswitch capable laptops from you?
19:32:52 <edrz> MrBeige: what's that do?
19:32:56 <edrz> #save
19:33:01 <MrBeige> edrz: makes summary for h01ger
19:33:01 <tassia> edrz, I'll write the camera info at the wiki
19:33:07 <edrz> tassia: great
19:33:15 <edrz> same for anyone else who can loan us something.
19:33:16 <h01ger> MrBeige, edrz: thank you! :)
19:33:29 <CarlFK> edrz: yes.
19:33:36 <edrz> h01ger: MrBeige unfortunately, i've been bad this meeting about using the #commands ...
19:34:07 <h01ger> np
19:34:31 * h01ger thinks MeetBot should do this itself, but also that this is offtopic
19:34:52 <edrz> Q_: so, CarlFK has generously offered us PyCon's laptops for dvswitch.
19:34:58 <edrz> CarlFK: and capture too?
19:35:04 <h01ger> nice!
19:35:08 <CarlFK> capture ?
19:35:11 <edrz> CarlFK: and, do you have the specs documented somewhere
19:35:16 <Q_> Do they have firewire?
19:35:29 <edrz> CarlFK: yeah ... for just running dvsource-firewire on.
19:35:30 <Q_> And maybe we need an extra firmwire card for them?
19:35:40 <edrz> if not we can easily get enough from local folks.
19:35:41 <Q_> firewire
19:35:54 <h01ger> those laptops have firewire?
19:35:56 <CarlFK> they have 1 onboard and I will include firewire card
19:36:01 <edrz> yup. i have one pccard.
19:36:05 <edrz> oh, well, there. :)
19:36:16 <edrz> \o/ for CarlFK and PyCon. :)
19:36:24 <h01ger> then i would rather use more laptops (if possible) than stuffing a 2nd firewire port into them
19:36:30 <edrz> sure.
19:36:45 <h01ger> CarlFK, did you use those laptops with 2 firewire devices?
19:36:48 <edrz> CarlFK: is there anything on the drives you need us to save?
19:36:52 <CarlFK> h01ger: yep
19:36:55 <h01ger> cool
19:37:12 <CarlFK> h01ger: what's the concern?
19:37:25 <CarlFK> edrz: nope.  wipe em.
19:37:26 * h01ger misses in the summary what software will be backported... but i guess you covered the usual dvwitch setup :)
19:37:31 <edrz> anyway, we can get details on hardware specs and delivery dates outside the meeting.
19:37:34 <edrz> CarlFK: great
19:37:46 <edrz> h01ger: yeah. i made a list but failed to use #info
19:37:48 <h01ger> yeah. great
19:37:55 <Q_> CarlFK: With 2 laptops instead of 1 it's easier to place the audience cam further away from the twinpac
19:37:58 <edrz> i'll have to do manual minutes
19:38:07 <bwh> Note that the PyCon laptops need Nvidia proprietary drivers
19:38:20 <edrz> bwh: oh. i didn't know.
19:38:25 <Q_> h01ger: And theora, ffmpeg, ffmpeg2theora
19:38:26 <bwh> which are a pain, but they did work
19:38:27 <h01ger> CarlFK, how many laptops could you give us? having more is also good for review stations..
19:38:57 <h01ger> do the pycon laptops work with nvidia propietary drivers from non-free?
19:38:58 <edrz> we should also talk a bit about servers and the network situation.
19:39:10 <h01ger> yes
19:39:12 <CarlFK> h01ger: 2, plus xfxf_ and I will be bringing 2 more
19:39:15 <h01ger> and penta
19:39:34 <h01ger> CarlFK, i'm looking forward to finally meet you!
19:39:34 <bwh> h01ger: Don't know; I think we built them from a tarball for some reason
19:39:43 <edrz> ok. good. i have another that will suffice for grabbing, as does simonft
19:40:05 <h01ger> CarlFK, so 4? or are the ones from you and xfxf_ needed for yourself?
19:40:07 <CarlFK> h01ger: indeed.
19:40:12 <edrz> #info so, we have plenty of dvswitch + capture machines available between various team members
19:40:34 <edrz> #action edrz and CarlFK firm up details of specs, numbers, delivery outside meeting
19:40:35 <CarlFK> h01ger: we are recording PyOhio July 31 and Aug1, then drive like hell to NY
19:40:47 <h01ger> :)
19:41:03 <h01ger> impressive
19:41:11 <edrz> .oO(crazy young wippersnappers ;)
19:41:20 <edrz> so. servers.
19:41:32 <edrz> the CS dept gives us a room for debconf machines.
19:41:47 <edrz> it is directly adjacent to their server room.
19:41:51 <CarlFK> speaking of driving... I have a place to park the car for the week, but it would be good to drop the gear off at the venu.  which isn't always obvious where to go
19:42:21 <MrBeige> edrz: and I hope to get some CS students to set up the network for the coffee room (our server room) this week, so we can start testing stuff
19:42:22 <edrz> and will have gigabit internally + uplink to CU's backbone
19:42:30 <edrz> MrBeige: great
19:42:31 <Q_> You know the 1st is the first day of debconf right, including talks ...
19:42:34 * h01ger takes a note to get a 2nd mobile phone for the us
19:42:48 <edrz> CarlFK: i have the same problem. we can compare notes/ideas after meeting.
19:42:53 <vicm3> #info software to backported libtheora0, ffmpeg, dvswitch,  ffmpeg2theora, rebuild other stuff as needed for backport
19:43:02 <edrz> vicm3: thanks
19:43:12 <h01ger> edrz, MrBeige: very neat
19:43:31 <edrz> once i have the drives from weasel i'll build us a barney
19:43:49 <edrz> should have 4(or 5) X 1TB drives
19:43:54 <p2-mate> h01ger: you don't like roaming ? :)
19:44:03 <CarlFK> edrz: in 10 min Ineed to leave for the day (to go record a Hadoop meeting :)
19:44:04 <edrz> i can also provide a stream encoder machine (quad core.)
19:44:09 <edrz> CarlFK: ok.
19:44:20 <Q_> Time to move to the next topic?
19:44:22 <edrz> CarlFK: anything else you need to know or share?
19:44:28 <edrz> Q_: yup
19:44:35 <edrz> #topic people
19:44:47 <edrz> so we have a decent size team signed up.
19:45:02 <edrz> http://wiki.debconf.org/wiki/DebConf10/Videoteam/Help
19:45:09 <edrz> http://wiki.debconf.org/wiki/DebConf10/Videoteam/Help#Team_members
19:45:12 <CarlFK> edrz: don't think so, just no time for post meeting chat right now
19:45:23 <edrz> CarlFK: ok. email then.
19:45:34 <edrz> have fun. :)
19:45:57 <edrz> is there anyone else from the past known to be attending we can bug to join us?
19:46:15 * edrz can also query the penta db about it.
19:46:47 <Q_> edrz: People will always show up at the conference.
19:46:52 <edrz> but ... yeah. i'm basically pretty excited. We have a lot of returning people with a lot of experience.
19:46:59 * edrz nods.
19:47:07 * h01ger nods
19:47:09 <edrz> ok ... i forget exactly why i put this in the agenda.
19:47:18 <vicm3> and some really newbies like me
19:47:21 <edrz> except maybe to say what I said a few lines up. :)
19:47:22 <h01ger> we should have training session / events in penta
19:47:27 <edrz> vicm3: yeah. always great too.
19:47:30 <edrz> h01ger: they are there.
19:47:35 <h01ger> neat neat
19:47:39 <h01ger> great
19:47:48 <edrz> or, at least, i submitted the event. not sure if they are scheduled yet.
19:47:51 <h01ger> now we just need to do them :)
19:47:56 <edrz> haha. yup.
19:48:23 <edrz> #topic any other business?
19:48:38 * h01ger can schedule things in penta, so please poke me, should i not notice myself. i expect to become more involved gradually now, though probably not for the next 10 days ;)
19:48:39 <Q_> You skipped rooms! :P
19:48:39 <edrz> anyone?
19:48:49 <edrz> Q_: doh!
19:48:50 <edrz> #rooms
19:48:55 <edrz> #topic rooms
19:49:05 <edrz> i guess we sort of already covered this above
19:49:08 <Q_> I think we already covered it.
19:49:32 <h01ger> penta
19:49:45 <edrz> #info 2 rooms: davis auditorium (200 seats), interschool lab (65 seats)
19:49:50 <edrz> #topic penta
19:50:10 <edrz> i went through the list of people on the wiki recently and added people's video privs.
19:50:14 <h01ger> (the 2nd room is soo small? penta. whats the penta status)
19:50:15 <edrz> to penta
19:50:22 <edrz> h01ger: what do you mean?
19:50:31 <edrz> penta lives in git now.
19:50:36 <edrz> there is a test machine for testing changes.
19:50:37 <h01ger> the setup on our side
19:50:49 <edrz> h01ger: tell me more.
19:50:52 <h01ger> the video machines need to talk to penta
19:50:53 <edrz> what do we need to do?
19:50:54 <edrz> ok
19:50:56 <h01ger> schedule encoding
19:51:01 <h01ger> schedule uploading
19:51:03 <edrz> is that handled via fai and stuff?
19:51:06 <h01ger> reviewing process
19:51:12 <h01ger> fai installs software
19:51:37 <edrz> so, is it an update query to the db or a bunch of clicking through the web ui?
19:51:51 <edrz> (combination?)
19:51:52 <h01ger> we need to configure our encoding servers. but yes, we know have a penta test setup, so those things should be easier
19:52:01 * edrz nods.
19:52:20 <h01ger> at dc9 we've still used the dc8 accounts for penta ;) (iirc)
19:52:32 <edrz> as I build machines & fai-ify i'll run dummy events through pentatest.
19:52:51 <edrz> ok. anything else?
19:52:56 <h01ger> bwh, are you generally available for questions during debcamp, conf and before? (_generally_, with normal lag :)
19:53:07 <CarlFK> im off.. see ya all
19:53:17 * CarlFK get shoes
19:53:18 <edrz> CarlFK: see you. thanks.
19:53:43 <bwh> h01ger: I think so
19:53:45 <edrz> he's pretty busy with kernel team stuff.
19:53:47 <edrz> ok
19:54:00 <h01ger> bwh, great. else we have this thing called "source" :)
19:54:20 <edrz> :)
19:54:23 <edrz> Ok.
19:54:24 <bwh> Also is there a good time I could hack on the Penta video cotnroller?
19:54:31 <h01ger> bwh, now?
19:54:44 <edrz> bwh: there is the git repo and the test server.
19:55:10 <edrz> what other resources do you need at your disposable to enable your hacking?
19:55:11 <bwh> Oh good, no more bzr
19:55:15 <edrz> nope
19:55:20 <h01ger> *g*
19:55:27 <edrz> http://git.debconf.org/cgi-bin/gitweb.cgi
19:55:43 <bwh> Well I expect I'll manage to break it repeatedly as I don't know Ruby
19:55:54 <bwh> but I do know the database schema and how it's supposed to change
19:55:59 <edrz> ok
19:56:07 <bwh> so I don't want to get in anyone's way or vice versa
19:56:14 <h01ger> bwh, enjoy. break early, break often. or something ;)
19:56:19 <edrz> :)
19:56:30 * h01ger assumes its all fine before debcamp. then things need to stabilize rapidly
19:56:30 <edrz> yeah. better to break cletus than skinner. ;)
19:56:53 <edrz> bwh: we can coordinate creating dummy events/recordings if it helps.
19:57:02 <edrz> #topic next meeting.
19:57:14 <edrz> is Tuesdays at 19:00 a good day/time?
19:57:29 * edrz suggests weekly from now till DebCamp to keep them short
19:57:42 <tiagovaz> yep, ok for me
19:57:43 <tassia> it's ok for me
19:57:44 <edrz> seems we had a decent attendance today.
19:57:44 <h01ger> very fine for me
19:57:47 <vicm3> ok here
19:57:49 <edrz> good.
19:57:54 <bwh> It's not ideal for me as it is running into my current roleplaying game, but I'm not sure it's that important for me to attend
19:58:26 <edrz> #agreed future meetings Tuesdays at 19:00 UTC until DebCamp10 starts.
19:58:29 <edrz> anything else?
19:58:47 <edrz> #endmeeting