19:03:24 <pollo> #startmeeting
19:03:24 <MeetBot> Meeting started Wed Sep  7 19:03:24 2016 UTC.  The chair is pollo. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:03:24 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:03:41 <pollo> #topic Role call
19:03:45 <pollo> Say hello!
19:03:52 <ivodd> hi
19:03:52 <paddatrapper> Hello
19:04:07 <tobi> hi
19:04:18 <pollo> disclaimer: I'm in an intro to arab culture class atm, so I might be a little distracted :D
19:04:37 <paddatrapper> Lol
19:04:48 <pollo> anything to say about the agenda? http://deb.li/38YAn
19:05:03 * paddatrapper is waiting for it to load
19:05:04 <DLange> hi
19:05:19 <ivodd> do we need to plan anything for the cambridge minidebconf?
19:05:38 <pollo> ivodd: hmm, dunno. Let's add it!
19:06:00 <ivodd> ok
19:06:22 <DLange> I think you need to budget a bit for transportation, food, drinks during the day
19:06:43 <DLange> accom & travel is the biggest chunk but probably not all you want to ask the DPL for
19:06:46 <pollo> DLange: you mean about Cambridge?
19:07:16 <DLange> yes
19:07:21 <DLange> or Paris
19:07:27 <DLange> whereever you meet now
19:07:38 <pollo> ok, lets talk about this in the according topics
19:07:46 <pollo> #topic November sprints
19:08:12 <pollo> so if you've followed IRC + the ML, dates are pretty final
19:08:17 <pollo> nov 17 to 20
19:08:28 <pollo> so starting on a Thursday and ending on Sunday
19:08:33 <paddatrapper> Does anyone have a link to the wikipage handy?
19:08:49 <pollo> https://wiki.debconf.org/wiki/DebConf17/Videoteam/Sprint1
19:08:50 <tobi> I thought it starts at Friday
19:08:58 <tobi> so Nov 17 to 20 is confirmed?
19:08:59 <paddatrapper> pollo: thanks
19:09:12 <jathan> Hello.
19:09:19 <paddatrapper> olasd did confirm as far as I remember
19:09:20 <pollo> tobi: well I think we'll do a lot of the work during the weekend
19:09:44 <pollo> but starting on Thursday will give us more time to sprint
19:10:05 <pollo> I don't expect everyone to be there on the first day though
19:10:11 <pollo> jathan: 0/
19:10:29 <paddatrapper> People will probably trickle in as it gets closer to the weekend
19:10:35 <tobi> understood. Probably /me one of them (I plan to take off work on Fri, not approved yet; two days will be hard probably)
19:10:56 * tobi means take a day off
19:11:22 <jathan> Hi Pollito.
19:12:26 <paddatrapper> So budget?
19:12:35 <pollo> yeah
19:12:54 <pollo> if you haven't added yourselves to the budget demands and need some, please do it today
19:13:06 <pollo> https://wiki.debconf.org/wiki/DebConf17/Videoteam/Sprint1#Budget
19:13:23 <pollo> either olasd or I will ask the DPL for money very soon
19:13:38 <p2-mate> noone says you have to attend all days?
19:14:15 <pollo> p2-mate: indeed. You can drop in for a few hours if you wish :D
19:15:00 <pollo> atm we are toping around 1500 euros for travel
19:15:11 <pollo> someone has to do some researches for accom though
19:15:17 <DLange> as I said above, please don't forget to budget for incidentials you need during the days
19:15:20 * pollo does not have time for that
19:15:38 <pollo> DLange: yeah, travel + accom + all the rest
19:15:53 <pollo> I think we should all stay at the same place
19:16:06 <pollo> it's going to be simpler and cheaper
19:16:15 <tobi> pollo: +1
19:16:23 <pollo> often hotel rooms come with 2 bed anyway, so we can share
19:16:24 <tobi> we can also share rooms if you are ok with it
19:16:29 <pollo> ;D
19:16:52 <paddatrapper> Practise for Montreal
19:17:38 <pollo> anyone against all being in the same place?
19:17:41 <tobi> so bringing air mattresses and sleep at hacking place?
19:17:50 * tobi joking
19:18:31 <paddatrapper> Lol
19:18:38 <paddatrapper> I'm happy with that
19:18:48 <tobi> for me this is ok. Maybe olasd can cut a good deal there for us
19:19:10 <DLange> like having the heating run through the night? :)
19:19:43 * tumbleweed is back
19:21:25 <pollo> #agreed we should all sleep at the same place
19:21:33 <pollo> anyone wants to search for accom?
19:21:59 <p2-mate> burn some wood to keep things warm? :)
19:22:37 <tobi> olasd would be local .. so maybe he could make some recommendations and indeed negotiate with them?
19:23:11 <pollo> tobi: I don't think we are going to have enough negociating power with 10 people
19:23:26 <pollo> #action pollo to check with olasd if he can propose us some accom
19:23:29 <tobi> it still helps if you are local, I guess
19:23:48 <DLange> irill will probably have negotated contracts with nearby places
19:23:53 <tobi> otherwise the accom that is listed in the wiki does not seem to be so bad..
19:24:18 <pollo> tobi: it's a bit expensive though
19:24:41 <pollo> anyway, I don't think we should go over 4000 euros
19:24:52 <pollo> /s/should/will/
19:25:23 <pollo> as for the things we wish to work on, everything is on the Kanboard instance
19:26:19 <pollo> https://kanban.debian.net/?controller=BoardViewController&action=show&project_id=3&search=status%3Aopen+tag%3Asprint1
19:26:38 <pollo> the ones planned atm are tagged with "sprint1"
19:27:19 <tobi> mmm... where can I find the password?
19:27:42 <pollo> tobi: if you don't have an account yet I can create you one
19:28:01 <tobi> I think I don't... Would be nice if you could do so
19:28:11 <pollo> that kinda brings us to our next topic
19:28:16 <pollo> #topic kanboard
19:28:32 <pollo> So since last meeting we've started using Kanboard
19:28:45 <pollo> if you don't have an account and want one, just PM me
19:31:28 <pollo> you can find some infos on how to use it here: https://wiki.debconf.org/wiki/DebConf17/Kanboard
19:31:29 <pollo> I don't know if anyone has comments on Kanboard? Have you used it? Do you like it? Should we stick with that?
19:31:29 <pollo> I personally think it's an improvement on having nothing
19:32:24 <paddatrapper> It's definitely better than nothing, even if its bots keep disconnecting :P
19:32:38 <paddatrapper> Haven't used it enough to have an opinion either way
19:32:45 <pollo> paddatrapper: that should be fixed now. lavamind made the bot auto-reconnect
19:33:07 <paddatrapper> pollo: Cool. The opporunity was just too good to ignore
19:33:11 <pollo> ok, less move on then
19:33:20 <pollo> #topic nageru vs voctomix
19:33:36 <pollo> wouter brought that topic during DC16
19:34:02 <pollo> you can have a look at nageru here: https://nageru.sesse.net/
19:34:07 <paddatrapper> Why move to another setup now that we have just started to move everything to vocto?
19:34:20 <tumbleweed> It looks interesting, but I'm a bit wary of being dependant on that one upstream developer (because we used cubemap, and then got left in the lurch)
19:34:23 <pollo> I think we should clear that debate to concentrate our efforts
19:34:41 <pollo> paddatrapper: it's less heavy than voctomix
19:34:55 <pollo> we could use it with laptops for examples
19:35:33 <pollo> I share tumbleweed's fears on that, and we haven't tested it either
19:35:35 <paddatrapper> Even with the dv switch laptops?
19:35:42 <tumbleweed> paddatrapper: those things are dinosaurs
19:36:04 <pollo> did we have i3 or i5 at DC16?
19:36:10 <tumbleweed> I presume the advantage of nageru is that you encode to h264 early in pipeline, which keeps bandwidth lower?
19:36:13 <paddatrapper> tumbleweed: That's why I ask
19:36:28 <paddatrapper> pollo: i5 if I recall correctly
19:36:29 <tumbleweed> pollo: can't rember. highvoltage?
19:36:40 <pollo> vocto was running at ~70-80% on the i5
19:37:14 <pollo> but if we have complete cases like RattusRattus wants to do, it won't make a huge difference
19:37:38 <tumbleweed> I also assume that we'd use the same hardware either way
19:37:45 <tumbleweed> so it's an easy decision to revisit if we ever want to
19:38:00 <pollo> tumbleweed: if we use the same hardware, I'm not sure I see the point then
19:38:14 <paddatrapper> Just a matter of modifying scripts
19:38:15 <pollo> wouter's main point was that we could use laptops
19:38:40 <paddatrapper> Hardware meaning everything but the machine the switching software is running on I assume
19:38:43 <p2-mate> paddatrapper: nageru is more efficient and will scale to higher resolutions on the same hw
19:38:50 <tumbleweed> paddatrapper: how do we "just use laptops"? what are we capturing with?
19:38:53 <tumbleweed> err pollo
19:39:00 <tumbleweed> we are not using desktops because they have bigger CPUs
19:39:07 <tumbleweed> we're using desktops because they have pcie sockets
19:39:32 <paddatrapper> Can't fit a BM capture card in a laptop...
19:40:09 <pollo> I still think we should stick with voctomix. CCC uses that, the opsis people do, CarlFK does
19:40:26 <pollo> I think trying to have a similar stack is a good way to move foward
19:40:29 * h01ger nods pollo
19:40:43 <p2-mate> I think we should use the best and most efficient solution
19:40:56 <p2-mate> and the most scalable one
19:41:01 <tumbleweed> p2-mate: depends what you are optimising for
19:41:08 <h01ger> p2-mate: and change every half year?
19:41:24 <pollo> have software that is supported by a wide community is more efficient
19:41:46 * tobi aggrees with pollo.
19:42:27 <pollo> it's a shame wouter ain't here though
19:42:30 <p2-mate> tumbleweed: resource use so more streams and/or higher resolution with the same hw
19:42:52 <p2-mate> pollo: not if it needs more hw resources than you have
19:43:06 <tumbleweed> p2-mate: I care about reliability more than resolution
19:43:23 <pollo> p2-mate: imho hw is not a problem. Debian has buckload of money and we can ask sponsors for hw too
19:43:37 <p2-mate> except that CPUs don't scale all the well for this
19:44:14 <p2-mate> tumbleweed: you can always make things more reliable by working on the sw
19:45:00 <paddatrapper> p2-mate: Reliability includes things like the bus factor, which is pretty high for nageru
19:45:21 <pollo> I just want us to agree to work with voctomix and stop debating about this. If it ever fails us badly for whatever reason, we can always switch, but atm it is not the case
19:45:27 <p2-mate> paddatrapper: no?
19:45:38 <p2-mate> it's GPL, you can take over the code
19:45:59 <pollo> p2-mate: if you have a lot of time to put into this yes
19:46:07 <tumbleweed> I haven't seen anyone in this team have time for such work, recently. But it would be great if we did get more involved in these projects
19:46:19 <paddatrapper> p2-mate: can doesn't mean will. A project like that needs more time then we possibly have
19:46:42 <tumbleweed> pollo: +1. I'm not against revisiting this later, I've always thought nageru looked interesting, and sesse does seem to do a damn good job of writing efficient, reliable software
19:47:01 <tumbleweed> but I don't think we have any big problems vocto atm
19:47:04 <paddatrapper> +1
19:47:08 <p2-mate> -1
19:47:27 <CarlFK> I think the current conf-video-community is struggling as it is.  (like, we don't have a good automated deployment plan)
19:48:46 <pollo> #agreed we will use voctomix for now. If it fails us, we'll look at other things, but it is not the case at the moment
19:49:03 <pollo> #topic Cambride mini-conf
19:49:19 <pollo> anyone knows if they have dates?
19:49:33 <ivodd> https://wiki.debian.org/DebianEvents/gb/2016/MiniDebConfCambridge
19:49:34 <tumbleweed> tehy have had dates for aaages
19:49:40 <tumbleweed> I mean, we based our dates around theirs
19:49:54 <paddatrapper> 10-13 Nov
19:49:55 <pollo> oh yeah, true
19:50:22 <pollo> I guess they'll want video?
19:50:29 <pollo> I know I won't be able to make it
19:51:07 * tumbleweed will
19:51:16 <tumbleweed> RattusRattus will presumably :P
19:51:19 <ivodd> tumbleweed: add yourself to the wiki
19:51:25 <ivodd> I'll be there as well
19:51:46 <tumbleweed> ivodd: they knew I was going before they had dates :) But yes I must
19:51:49 <pollo> does one of you want to check with them what their needs are?
19:51:57 <ivodd> and olasd is listed as '90%'
19:52:16 <ivodd> there will be 1 talkroom
19:52:29 <ivodd> the question is, what equipment and what software we'll be using
19:52:32 <paddatrapper> I can't make it - only finish on the 11th
19:52:55 <pollo> ivodd: I think the vocto setup went pretty well
19:52:57 <tumbleweed> ivodd: I'd assume vocto?
19:53:05 <pollo> but that would be taking a little risk
19:53:09 <paddatrapper> Well RattusRattus already has the opsis boards
19:53:12 <ivodd> I'd assume so too, but the means we'll have to get some desktops
19:53:19 <tumbleweed> or at least borrow some
19:53:22 <ivodd> yes
19:53:24 <tumbleweed> which should be easy enough in cambridge
19:53:31 <ivodd> yes, but we need to plan for that
19:53:32 <tumbleweed> does he have the decklink cards too?
19:53:38 <pollo> tumbleweed: yes
19:53:41 <ivodd> last times we got everything from paris
19:53:50 <DLange> does it run on ARM hardware?
19:54:20 <tumbleweed> I'd very much doubt it
19:54:36 <DLange> hm, asking ARM for Intel PCs ... sounds odd :)
19:54:58 <pollo> DLange: drivers for the capture cards won't compile on ARM I think
19:55:43 <DLange> perhaps RattusRattus can bring a PC from the university that was so generous for DC15 with their stuff
19:55:52 <ivodd> is there anything else we need to borrow, other than a decent PC
19:56:02 <ivodd> and is all the equipment we need in paris?
19:56:18 <pollo> ivodd: yeah, cameras are there
19:56:23 <pollo> how does it work for the budget? Does it include your travel needs?
19:56:48 <pollo> if not, the only thing needed will be funds to move the hardware from Paris
19:57:40 * paddatrapper needs to pop out
19:57:47 <paddatrapper> Hopefully will be back before long
19:57:59 <ivodd> we'll need to check with olasd (he listed himself as 'Video Team Donkey?')
19:58:32 <pollo> ivodd: do you want to poke him and check with RattusRattus for budget?
19:58:39 <ivodd> ok
19:58:58 <pollo> #action ivodd to check with olasd and RattusRattus about Cambrige mini-conf budget
19:59:03 <pollo> anything else?
19:59:18 <pollo> #topic Misc
20:00:43 <pollo> #endmeeting