17:58:59 <paddatrapper> #startmeeting
17:58:59 <MeetBot> Meeting started Tue May 19 17:58:59 2020 UTC.  The chair is paddatrapper. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:58:59 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:59:03 <paddatrapper> #topic roll call
17:59:08 <paddatrapper> hi
17:59:21 * CarlFK sits with nattie
17:59:29 <paddatrapper> agenda: http://deb.li/oNCD
17:59:32 <highvoltage> o/
17:59:51 <nattie> ohai!
18:00:05 * nattie wonders how there's suddenly a notional CarlFK on her couch
18:00:28 <CarlFK> I smelled food.
18:00:30 <paddatrapper> **magic**
18:00:53 <nattie> i wasn't even cooking this time!
18:01:03 <nattie> *anyway*.  holler.
18:01:18 <paddatrapper> #topic MiniDebConf Bordeaux
18:01:26 <paddatrapper> https://lists.debian.org/msgid-search/00d4ba31-bbf1-276e-b316-204d8caa8a8b@chastagnet.fr
18:01:40 <nattie> "in principle yes", which is an answer they seem happy with for the moment
18:01:45 <tumbleweed> Urgh, I've just come out of an exhausting 90min meeting
18:01:46 <pollo> 9/
18:01:50 <tumbleweed> pretend I'm here
18:01:56 <paddatrapper> #info 10-11 October at an engineer school in Talence near Bordeaux in France
18:01:58 <nattie> tumbleweed: who says we don't all the time?
18:01:59 <paddatrapper> heh
18:02:02 <paddatrapper> ok
18:02:47 <paddatrapper> obviously it is way too early to expect people to know if they are able to go
18:02:59 <paddatrapper> But if possible, getting people there would be nice
18:03:06 <highvoltage> our covid-19 infection rate is climbing so fast I would guess that it would at least rule out kyle, wouter and myself going to europe by then
18:03:09 <olasd> oh, hi
18:03:21 <paddatrapper> this is more to have it on our radar
18:03:25 <nattie> *nods*
18:03:28 <highvoltage> and you can probably rule out people from the US going to europe by then too
18:03:29 <pollo> I'm 100% sure I won't be there :)
18:03:45 <nattie> it's very sweet that they got 'round to asking us at last
18:03:50 <olasd> pollo: pfah, didn't make a canoe during confinment?
18:04:15 <pollo> olasd: make?! My family has had a bark canoe for generations!!
18:04:24 <olasd> so, yeah, obvs, if the sanitary conditions are sensible, I'll be in Bordeaux
18:04:58 <olasd> (which looks like a somewhat big if... we'll see)
18:05:27 <olasd> (sorry, got to handle the quiche currently in the oven)
18:05:40 <paddatrapper> #info availability is COVID-19 dependant
18:05:57 <paddatrapper> #topic Streaming CDN
18:06:49 <highvoltage> oh yeah that's for the online minidebconf
18:07:13 <pollo> highvoltage: has anyone had time/energy to put towards the miniconf?
18:07:23 <highvoltage> pollo: yep, a little
18:07:45 <pollo> I haven't seen a CFP or anything else go around and iirc the dates were beginning of June?
18:07:45 <highvoltage> can we use the usual debconf cdn for distributing the feed for people who are just watching?
18:08:20 <olasd> pollo: you need to read d-d-a better, even I saw the announcement and CfP ;p
18:08:27 <highvoltage> (not sure who usually sets that up, from what I understand it's basically spinning up some DO droplets and running ansible)
18:08:28 <pollo> Oops
18:08:32 <tumbleweed> highvoltage: yes
18:08:35 <paddatrapper> pollo: 29/30 May
18:09:23 <CarlFK> might want to consider who should watch and who should 'participate'
18:09:44 <nattie> yeah
18:09:48 <highvoltage> pollo: also https://wiki.debian.org/DebianEvents/internet/2020/MiniDebConfOnline
18:09:58 <olasd> highvoltage: I've usually done the spinning up of do droplets; I'd be happy to do so again
18:10:13 <highvoltage> olasd: thanks that would be great
18:10:26 <olasd> what will you be streaming from?
18:10:28 <highvoltage> paddatrapper set up jibri on the jitsi instance
18:10:34 <paddatrapper> #info olasd usually spins up droplets for CDN
18:10:36 <olasd> ah, well that answers that
18:10:43 <paddatrapper> olasd: FFmpeg from jibri
18:10:44 <highvoltage> so it will come from jitsi/jibri
18:10:46 * nattie is still happy to help test stuff
18:10:56 <paddatrapper> would just need an RTMP endpoint to push to
18:11:09 <olasd> ack; that's easy enough
18:11:15 <paddatrapper> thanks
18:11:15 <highvoltage> not sure whether we'll have a talkmeister double as a director and hit the record button
18:11:16 <pollo> paddatrapper: woots, that's great!
18:11:24 <highvoltage> or if we should have a dedicated director to do that
18:11:26 <olasd> (jibri looks like an awful pile of trash, congrats for making that work)
18:11:33 <paddatrapper> took a while to get working...
18:11:40 * tobi late... srry
18:11:43 <nattie> highvoltage: there are arguments for both
18:11:44 <paddatrapper> It isn't too bad, but the troubleshooting is a nightmare
18:12:12 <pollo> That's jitsi in a nutshell
18:12:33 <highvoltage> pretty much any web video software
18:12:53 <olasd> paddatrapper: I have a RTMP endpoint and nginx and whatnot setup on my server if you want to try stuff out; for the real deal we can spin the streaming infra up during minidebcamp? or do you need that beforehand?
18:12:55 <paddatrapper> yeah... but in Java
18:13:21 <olasd> anyway we can sync up post-meeting
18:13:23 <paddatrapper> olasd: thanks. Can spin it up during minidebcamp
18:13:25 <paddatrapper> cool
18:13:36 <highvoltage> I think first day of debcamp would be nice
18:14:06 <olasd> *nod*
18:14:15 <highvoltage> minidebcamp was kind of urbec's idea, who sadly had to bail out due to work
18:14:48 <highvoltage> so I'm not 100% sure what we'll do but at the worst we can hang out and chat and test things / work out some wrinkles for the weekend talks
18:15:10 <paddatrapper> can use the chance to test other options
18:15:17 <paddatrapper> e.g. BBB
18:15:23 <olasd> we can pretend that everything that happened in Debian during those two days was part of the minidebcamp :P
18:15:35 <paddatrapper> sounds like a plan!
18:15:44 <highvoltage> BBB I'd like to do well in advance, hope to have a BBB set up tomorrow (I've said so every day for the last week, but I think tomorrow will work out)
18:16:56 <highvoltage> paddatrapper: I gues that takes care of that topic
18:17:10 <paddatrapper> #topic Any other business?
18:17:27 <highvoltage> oh you should probably task olasd in the meeting notes with the droplets setup
18:17:48 <paddatrapper> #right
18:17:51 <paddatrapper> #undo
18:17:51 <MeetBot> Removing item from minutes: <MeetBot.items.Topic object at 0x15b6950>
18:17:59 <paddatrapper> #action olasd to setup CDN droplets
18:18:00 <olasd> if you want to do a bbb tryout without fully setting it up https://ensemble-bbb.scaleway.com/ is a decent set of instances
18:18:19 <paddatrapper> #info if you want to do a bbb tryout without fully setting it up https://ensemble-bbb.scaleway.com/ is a decent set of instances
18:18:30 <paddatrapper> #topic Any other business?
18:18:33 <paddatrapper> anythin else?
18:18:38 <highvoltage> yeah
18:18:51 <highvoltage> I want a part of that quiche now it sounds delicious
18:19:07 <olasd> it looks pretty good
18:19:14 <olasd> and I think I nailed the crust
18:19:25 * highvoltage *triggered*
18:20:08 <olasd> :p
18:20:52 <olasd> do we have any word on whether DebConf will happen IRL? when was the decision deadline?
18:21:09 <highvoltage> 5 June'ish I think
18:21:17 <phls> what is CDN on "debconf cdn"?
18:21:24 <highvoltage> content distribution network
18:21:34 <phls> thanks
18:21:56 <nattie> the decision is meant to be public by June 8
18:21:56 <highvoltage> (in this case, just a bunch of nodes that repeats the streams in regions around the world)
18:22:34 <gwolf> olasd: We are right now drafting a survey to aid the decision process
18:22:35 <phls> like youtube?
18:22:58 <tumbleweed> phls: like a mirror network
18:23:06 <highvoltage> phls: yep, just our own self-hosted one. it's what you'd usually see if you access the stream from the debconf web page from various regiouns around the world
18:23:17 * gwolf thinks the odds of it happening are low. But I'm often seen as a pesimist. Maybe I need a happy twin that can bake quiche crusts?
18:23:20 <olasd> gwolf: alright. (I'm not getting involved personally, just figured a status update would be relevant wrt. the video team)
18:23:57 <highvoltage> well Isreal is doing quite well in flattening the curve
18:24:10 <phls> do you intend send from jitsi to youtube?
18:24:13 <tumbleweed> without the south africans, olasd, and pollo, the video team would be quite understaffed
18:24:19 <highvoltage> the rest of the world is mostly flaming away so I think it's safe to say that most people won't be able to travel
18:24:30 <paddatrapper> phls: no, to our own mirror network
18:24:35 <paddatrapper> like we do for debconf
18:24:44 <phls> or just from jitsi to our cdn?
18:24:52 <phls> ok
18:25:14 <tumbleweed> we don't usually stream to youtube. No reason to change that now
18:25:25 <highvoltage> phls: my guess is that the videos will make it to youtube via the debconf video archives, so just not live
18:25:38 <olasd> the smell in my "office" (two doors away from the kitchen) is starting to be very overpowering. any other other business? :P
18:25:40 <tumbleweed> we could mirror to youtube too. But nobody has really bothered in the past
18:25:59 <paddatrapper> #topc Next Meeting
18:26:00 <tumbleweed> it'd probably get some random viewers, rathre than the usual debconf crowd
18:26:01 <pollo> Any idea If the CDN will hold up?
18:26:02 <highvoltage> it might be nice for attracting audiences
18:26:16 <pollo> Traffic will surely be much higher ...
18:26:18 <paddatrapper> 23 June @18:00 UTC?
18:26:19 <highvoltage> but for a first run of minidebconf online I think we should play it safe
18:26:28 <paddatrapper> pollo: we can add more nodes if necessary
18:26:33 <tumbleweed> pollo: It's very scaleable, I wouldn't be worried
18:26:41 <highvoltage> pollo: I doubt it will be higher than a usual DebConf's demand
18:26:53 <tumbleweed> also, we haven't really had noticeable load in the past
18:27:10 <olasd> it's just https downloading a bunch of files off of a ramdisk
18:27:16 <olasd> it's not like it's very demanding
18:27:33 <highvoltage> how much bandwidth does a single stream use?
18:27:47 <olasd> 1.5Mbps in the best quality
18:27:53 <olasd> or something like that
18:28:08 <highvoltage> and those DO droplets, I think they get 100mbps by default?
18:28:15 <paddatrapper> yeah that is around the numbers we were throwing around in the minidc channel too
18:28:27 <olasd> ah, no, 2.5Mbps
18:29:02 <nattie> paddatrapper: why 23 and not 16 june?
18:29:28 <paddatrapper> nattie: because I counted wrong :P
18:29:37 <paddatrapper> 16 June @ 18:00 UTC?
18:29:43 <highvoltage> (I think it might run out of network before it runs out of CPU, but if it's trivial to spin up more instances as tumbleweed says then it's still not too much of an issue, but it's kind of interesting knowing how much one instance can handle)
18:29:45 <phls> i'm thinking just about the range (i'm not sure this is the correct word). It's much easier use youtube to watch on tv, for instance
18:30:01 <tumbleweed> highvoltage: we've never tested one to load
18:30:20 <olasd> streaming a single room to youtube is like two lines of config to add to nginx and two buttons to click on the youtube interface
18:30:27 <highvoltage> tumbleweed: cool, maybe we can do some tests during the minidebcamp
18:30:28 <olasd> if we really croak under the load, we can resort to that
18:30:46 <phls> i don't know, I believe we will have a demand much highier now
18:31:02 <phls> olasd, cool
18:31:18 <tumbleweed> my experience of conferences online is that nobody attends
18:31:32 <highvoltage> phls: do you have any stats yet on fique iem casa use debian that you can share so far?
18:31:40 <highvoltage> (sorry for spelling :))
18:31:41 <tumbleweed> you aren't *at* the venue, so you just do some work or read the internet, unless you're *really* interested in a talk
18:32:08 <phls> we are having between 50 and 100 attends watching on live
18:32:27 <paddatrapper> that's impressive actually
18:32:46 <phls> more attends than in our minidebconfs :-)
18:33:20 <highvoltage> I think in that case it helped having youtube live streams because subsribers to the debianbrazil channel get a notification saying 'debianbrazil is streaming live now'
18:33:48 <phls> yes, it's true
18:34:15 <highvoltage> I also read a feature request on peertube for supporting that kind of streaming. so perhaps eventually the whole of peerutbe could become a live streaming cdn too. or maybe it's just wishful thinking but still :)
18:34:24 <highvoltage> (sorry for clogging up AOB)
18:34:33 <paddatrapper> it would be nice to have that eventually
18:34:34 <highvoltage> paddatrapper: +1 for meeting date
18:34:43 <paddatrapper> not sure how they would handle the scaling issue though
18:34:52 <highvoltage> paddatrapper: just a reminder that that's a public holiday for us
18:35:15 <paddatrapper> highvoltage: yeah, true
18:35:18 <highvoltage> paddatrapper: I guess it would also use webtorrent
18:35:31 <paddatrapper> not that I think we would be able to go anywhere by then...
18:35:39 <CarlFK> er, n2.  derp.
18:35:46 <CarlFK> whopps.  hi!
18:36:04 <highvoltage> yeah it's just easier to forget about meetings when you're possibly spending more time with family than at a screen
18:36:11 <paddatrapper> true
18:36:17 * paddatrapper adds it to my calendar
18:36:48 <paddatrapper> #agreed 16 June @ 18:00 UTC
18:36:53 <paddatrapper> #endmeeting