18:01:02 <tumbleweed> #startmeeting Weekly DebConf Video meeting
18:01:02 <MeetBot> Meeting started Thu Jul 23 18:01:02 2020 UTC.  The chair is tumbleweed. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:02 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:01:06 <tumbleweed> #topic roll call
18:01:10 <olasd> ohai
18:01:10 <tumbleweed> o/
18:01:13 <ivodd> hi
18:01:31 <tumbleweed> #topic actions from the last meting
18:01:37 <tumbleweed> #link http://meetbot.debian.net/debconf-video/2020/debconf-video.2020-07-16-18.00.html
18:01:52 <tumbleweed> #link http://deb.li/oNCD Agenda
18:02:18 <olasd> neither of my items got done; I'll carry them over to next week
18:02:20 <tumbleweed> I didn't touch VNC
18:02:32 <tumbleweed> wouter reported back on sreview earlier this week
18:02:35 <olasd> I have a multi-hour train ride on wednesday, might get some hacking done
18:02:44 <tumbleweed> he said early next week
18:03:04 <tumbleweed> #action olasd to update the docs for RTMP streaming option (carried over)
18:03:16 <tumbleweed> #action olasd to look at making a thomann basket for the missing equipment (carried over)
18:03:21 <olasd> thx
18:03:21 <tumbleweed> meh, we should probably be using tickets rather than this
18:03:38 <olasd> at least for the first one
18:04:03 <tumbleweed> I made some progress on recording playback, but that whole thing needs to be reworked
18:04:23 <tumbleweed> #action tumbleweed to continue to work on recording playback
18:04:41 <tumbleweed> paddatrapper has been ansibling jibri
18:05:04 <tumbleweed> dunno about his resolution action
18:05:13 <tumbleweed> or the documentation one
18:06:05 <olasd> ah, you're taking notes, I was wondering
18:06:11 <tumbleweed> yeah
18:06:15 <tumbleweed> done
18:06:21 <tumbleweed> #topic salsa issues
18:06:30 <tumbleweed> #link https://salsa.debian.org/debconf-team/public/data/dc20-online/-/issues
18:06:49 <ivodd> I think most of these are on the agenda later, or mentioned before (action items)
18:06:59 <olasd> looks that way
18:07:05 <tumbleweed> moving on
18:07:11 <tumbleweed> #topic Video Stack
18:07:11 <olasd> I suggest moving these two points to the end of the meeting for next time
18:07:16 <highvoltage> (partly reading here due to power failure)
18:07:18 <tumbleweed> Sensible, yes
18:07:56 <tumbleweed> so, been making some progress on voctoweb
18:08:06 <tumbleweed> I decided to learn modern frontend web-dev and write it in vue.js
18:08:10 <tumbleweed> pretty happy with that
18:08:24 <tumbleweed> it's a lot more maintaniable like this (but less hacktastic)
18:08:25 <highvoltage> I think that's what gitlab uses too
18:08:29 <tumbleweed> yeah
18:08:43 <tumbleweed> I honestly just picked it because I'd heard of it and never used it
18:09:09 <ivodd> they creation of the previews kills the voctocore output, so that's an import issue to look at
18:09:14 <highvoltage> they keep talking about how happy they are with it, so it can't be too bad. usually people start hating a library as it ages :)
18:09:18 <olasd> after last week's meeting, I've been poking at casparcg a little; it might be a decent option to have a remote-controllable source for playback, web display and other static stuff
18:09:46 <tumbleweed> cool
18:10:14 <tumbleweed> yeah, I don't think we're going to get gstreamer pipelines done to do this
18:10:57 <olasd> (I could get it to play the loop, to render the now/next schedule, and to show a web page with some javascript and a clock)
18:11:15 <ivodd> olasd: can you try feeding that into vocto?
18:11:48 <olasd> I should, yes
18:11:57 <tumbleweed> you need a VM for it?
18:13:20 <olasd> yeah, I was about to say I should try to run it on infomaniak, which means finding where to run it
18:13:52 <olasd> supposedly it /can/ use a GPU, but I don't think we're going to use much fancy stuff so a plain vm should be fine
18:14:15 <tumbleweed> start with a plain one, see how it goes, I guess
18:14:21 <olasd> yeah
18:14:29 <tumbleweed> #action tumbleweed to spin up a VM for casparcg
18:14:44 <tumbleweed> #action olasd to attempt to set up a loop with now/next in it in casparcg
18:15:09 <olasd> lgtm
18:15:15 <tumbleweed> #topic Streaming setup
18:15:19 <tumbleweed> meh?
18:15:26 <olasd> no changes detected
18:15:27 <tumbleweed> dunno how much there is to say here
18:15:37 <tumbleweed> #topic Advice for directors & talkmeisters
18:15:48 <tumbleweed> paddatrapper had an action here, without him, we may want to skip
18:15:54 <ivodd> well
18:15:58 <tumbleweed> feels like we need o volunteer wrangler, too
18:16:15 <ivodd> maybe we should talk about the idea of multiple parallel tracks (which is somewhat related):
18:16:41 <ivodd> my feeling is that the setup for directors/talkmeisters will be rather complex, so we'll probably need people around with detailed knowledge of it
18:16:51 <ivodd> so that makes it harder to run 2 tracks at once, so we should try to avoid that
18:19:10 <tumbleweed> yes, we should try to avoid that
18:19:12 <olasd> yeah, I guess I agree
18:19:15 <olasd> ha
18:19:24 <tumbleweed> or at least fall back to a much simpler second track (jitsi-only)
18:19:43 <ivodd> well, jitsi-only isn't really a track
18:19:50 <ivodd> but people can do that if they want
18:19:55 <olasd> it's a webcam in a hallway :P
18:20:30 <tumbleweed> it can have a record button
18:20:46 <tumbleweed> but yeah
18:21:20 <gwolf> I'm not following along the meeting, but will chime in nonetheless
18:21:28 <gwolf> Content Team did not receive so many talks
18:21:42 <gwolf> I believe we can push for a single-track DebConf
18:21:51 <ivodd> that's good :)
18:22:07 <ivodd> it has the added benifit that people can follow everything if they want (assuming they don't sleep, maybe)
18:22:17 <gwolf> It'd be better communicated betwen the teams better than just by a comment in a meeting ;-) But I think it can be done
18:22:31 <gwolf> The only point that would irk me is... language-specific miniconfs
18:22:41 <tumbleweed> well, that's the concern here
18:22:41 <olasd> gwolf: I think ivodd's concern was about the new language tracks popping up over the last few days
18:22:41 <gwolf> that's not likely to be on the "main" track
18:22:46 <tumbleweed> 2 of those suddenly appeared
18:22:51 <gwolf> right
18:22:54 <tumbleweed> after we all thought they were not happening
18:23:33 <olasd> I guess in the end this all will depend on how much interest these really gather, and how their schedules can be accommodated
18:23:35 <gwolf> as a lurker, the setup seems more involved than what I'd be happy to operate being "just" an outsider volunteer
18:23:57 <tumbleweed> yeah, that's why we said having a core video team member on board for each miniconf was required
18:24:03 <olasd> *nod*
18:24:03 <tumbleweed> not just outside volunteers
18:24:04 <gwolf> olasd: The Spanish one is quite likely to happen... Although I insist, it's much closer to a DebianDay than to a DebConf
18:24:32 <gwolf> tumbleweed: Yes. Say, now that you are a bonafide Californian, do you care to take accelerated Spanish lessons?
18:24:44 * tobi is late again... srry…
18:24:45 <tumbleweed> gwolf: not a bonafide Californian for much longer :P
18:25:04 <gwolf> tumbleweed: Oh, are you being deported? They are great deporting to my country, y'know
18:25:12 <gwolf> ( /me stops hijacking a meeting)
18:25:38 <tumbleweed> don't know if we can conclude any actions from this discussion
18:25:54 <ivodd> tumbleweed: we'll know more once we have done a test run
18:25:55 <olasd> make sure the scheduling / content team knows of our concerns about parallel tracks
18:25:58 <gwolf> well, I will ask Content to keep what we do aligned to a single track
18:26:07 <tumbleweed> yeah
18:26:18 <tumbleweed> #topic advice/training for presenters
18:26:23 <gwolf> But as for lang-specific... I think it's up to the video team to be very clear about the need for involvedness...
18:27:05 <ivodd> gwolf: yeah, I don't think there's an issue there
18:27:06 <tumbleweed> document is done, published
18:27:12 <olasd> tumbleweed: I've seen some positive feedback from people about this advice
18:27:27 <ivodd> so, all good :)
18:27:30 <tumbleweed> any negative feedback yet? I do worry that it's not prescriptive enough for somebody who has no idea
18:27:47 <olasd> (but that's a sample of 1 feedback, so...)
18:27:49 * gwolf relayed to -content
18:28:05 <olasd> when's the deadline for pre-recordings?
18:28:17 <olasd> (i.e. "when should we expect people to start panicking?")
18:28:23 <tumbleweed> 16th
18:28:43 <tumbleweed> #topic Any Other Business
18:28:48 <tumbleweed> Anybody?
18:29:16 <ivodd> not from me
18:29:33 <tumbleweed> #topic Upcoming Meetings
18:29:38 <tumbleweed> I guess agian next week
18:29:45 <tumbleweed> We postponed the test run. It feels like we should, again
18:30:01 <ivodd> yeah, there's nothing to test yet
18:30:39 <olasd> I'll have time on Saturday to poke at my actions
18:31:41 * tumbleweed intends to do more of that too
18:31:51 <olasd> maybe this will be an impromptu sprint
18:32:08 <ivodd> maybe we should just call it a sprint
18:32:21 <olasd> sounds good to me
18:32:36 <tumbleweed> #agreed impromptu sprint this weekend
18:32:46 <tumbleweed> then... we're done
18:32:49 <tumbleweed> #endmeeting