18:00:34 <pollo> #startmeeting
18:00:34 <MeetBot> Meeting started Tue Sep 15 18:00:34 2020 UTC.  The chair is pollo. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:34 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:00:46 <pollo> #topic Roll Call
18:00:57 <pollo> Please say hi if you are here for the meeting
18:00:57 <paddatrapper> \o
18:01:09 <pollo> #link Agenda: http://deb.li/oNCD
18:01:12 <lenharo> hi
18:01:44 <tobi> \o
18:01:58 <nattie> hola!
18:02:48 <pollo> #topic DC20 Teardown status -- Status of final video publication
18:02:53 <pollo> wouter: you here?
18:03:11 <olasd> (hi, sorry, got distracted)
18:03:13 <pollo> I haven't had time to look at this myself, I don't know if there are still videos in limbo
18:03:30 <olasd> there's definitely videos still in limbo, people keep asking for them on irc and on our mailing list
18:03:51 <pollo> #info There are still videos we haven't reviewed and published yet
18:04:36 <pollo> in theory Sreview still works and all we need to do is to review the missing ones
18:04:54 <pollo> anyone wants to try to sync up with wouter and try to get this done?
18:05:03 <srud> Atleast one I know of.. A Malayalam talk..which gets messed up and that seems to need manual intervention to fix it
18:05:44 <olasd> there is confusion about the status of most videos; tumbleweed started a round of final reviews of the published videos, and then videos got encoded and published again. So we should start that again.
18:06:57 <terceiro> I'm also slacking off to get the videos published in the website
18:07:13 <terceiro> but I'm kind of waiting on the overall status of the videos themselves
18:07:32 <pollo> sadly, I don't think we'll solve this issue during this meeting, as wouter ain't here
18:07:37 <pollo> anything else to add?
18:07:54 <olasd> yes
18:08:08 <olasd> at this point, should we sync the contents of the review machine to vittoria so we can tear down infomaniak infra?
18:08:44 <pollo> wouldn't that make it even harder to get through the last videos?
18:09:00 <pollo> afaiu the setup on the review machine is not regular Sreview and lots of things have been done manually
18:09:05 <olasd> nothing has happened for the last two weeks
18:10:15 <olasd> (and I don't think that's accurate)
18:10:23 <pollo> let's try to fix this before Sunday, if we haven't let's move things to vittoria?
18:10:43 <olasd> but I also won't have time to be looking into it at all
18:10:54 <pollo> I can allocate some time
18:11:05 <olasd> (I'm busy / offline next weekend)
18:11:53 <pollo> anyone against moving the review machine's content to vittoria Sunday if we aren,t done with reviews?
18:12:21 <olasd> I mean, we've been pinged repeatedly to tear down the infra
18:12:29 <olasd> so we should actually get on with it
18:12:40 <pollo> yes, and I've done work towards this
18:12:58 <olasd> sure
18:13:07 <olasd> (#agreed and move on?)
18:13:20 <terceiro> wait
18:13:25 <olasd> we should sync the recordings anyway
18:13:42 <terceiro> I'm concerned that tearding down will slow down finishing even more
18:13:43 <pollo> #agreed we'll try to finish the missing reviews before Sunday. If not, we'll move the recordings to vittoria and shut the infomaniak reviewing box
18:14:18 <pollo> terceiro: that's also my concern, but I agreed with olasd the machines at infomaniak need to be torn down as soon as we can
18:14:26 <terceiro> ack
18:14:44 <pollo> anything else?
18:15:03 <pollo> #topic DC20 Teardown status -- Status of etherpad archival
18:15:13 <pollo> I wrote a python script to do this
18:15:35 <pollo> #link https://salsa.debian.org/debconf-video-team/ansible/-/merge_requests/304
18:15:57 <pollo> I exported the pads in the 3 formats to the dc20-data repository
18:16:20 <pollo> #link https://salsa.debian.org/debconf-team/public/data/dc20-online/-/merge_requests/6
18:16:33 <pollo> I don't have much else to add
18:16:54 <terceiro> thanks for that
18:17:13 <olasd> did you give the links to the people with wafer access so they can replace the ones on the website with the static exports? :)
18:17:20 <terceiro> should we update the links in the website to point to the archived versions?
18:17:24 <olasd> yes
18:17:27 <terceiro> yeah
18:17:44 <terceiro> #action terceiro to update dc20 website to point the etherpad links to the archived versions
18:17:48 <pollo> I think it would be nice if the html version could be rendered
18:18:12 <olasd> is the html version standalone or does it need assets?
18:18:34 <pollo> looks standalone, it includes css
18:18:50 <pollo> https://salsa.debian.org/debconf-team/public/data/dc20-online/-/blob/1a9d2a6937b66caa02816fe3fae46befec512347/etherpads/etherpad/103-meet-the-community-team.html
18:19:45 <pollo> hugh, not pretty though
18:19:46 <terceiro> it seems gitlab won't give you a rendered version
18:20:00 <terceiro> it's either text/plain, or download
18:20:03 <pollo> the rendered html is actually hard to read because of colors
18:20:25 <pollo> anyway, nice to have, but not crucial. Linking to the text version is fine imo
18:20:50 <olasd> it shouldn't be too hard to get the html versions in the static wafer?
18:22:11 <pollo> https://imgur.com/FEfKL7b.png
18:22:20 <pollo> here's what the rendered html looks like in my FF
18:22:26 <pollo> I think I prefer the plain text
18:22:41 <olasd> beautiful
18:22:42 <terceiro> ugh
18:23:19 <pollo> anything to add?
18:24:01 <olasd> yes
18:24:19 <olasd> I think we should export the etherpad db before tearing down the machine in case we need to revert one of the exports to an old version
18:24:51 <olasd> (or alternatively we should review the exports)
18:24:54 <pollo> where should we dump it, vittoria?
18:24:59 <olasd> (but I think the former is easier)
18:25:13 <olasd> I guess so
18:25:56 <pollo> can I action you for that? I'd have to read Postgresql manuals, I don't have tons of experience with it
18:26:27 <olasd> yeah
18:26:56 <pollo> #action olasd to export the etherpad DB to vittoria before teardown
18:27:31 <olasd> #info export on vittoria:~olasd/etherpad_dc20_20200915.sql.gz
18:27:52 <pollo> #topic DC20 Teardown status -- Archival of prometheus data
18:27:56 <olasd> (when my 'net stops crying)
18:28:10 <pollo> I archived the grafana dashboards
18:28:28 <pollo> #link https://salsa.debian.org/debconf-team/public/data/dc20-online/-/merge_requests/7
18:28:45 <pollo> we still need to export the prometheus data
18:28:52 <pollo> preferably to something readable like CSV
18:29:16 <olasd> the default tsdb retention time is 15 days
18:29:20 <olasd> so I expect the data is gone already
18:29:30 <pollo> that's sad
18:29:45 <olasd> you can action me to check
18:30:08 <pollo> #action olasd to check if the prometheus data is still there (default autoremoval == 15days)
18:31:09 <olasd> yep, data before sept. 1 is gone
18:31:24 <olasd> https://prometheus.online.debconf.org/graph?g0.range_input=30d&g0.expr=up&g0.tab=0
18:31:37 <pollo> #info data before sept. 1 is gone, we don't have any prom data to archive
18:31:46 <olasd> so I guess prometheus can go away (and we should file a ticket to override that default in the future :P)
18:31:46 <pollo> we should change that in ansible though
18:31:48 <pollo> sounds important
18:32:23 <pollo> #action pollo to open an issue on ansible about prometheus time default
18:32:33 <pollo> #topic DC20 Teardown status -- Any other things to archive?
18:33:04 <pollo> looking at https://salsa.debian.org/debconf-team/public/data/dc20-online/-/issues/18, I think not
18:34:22 <olasd> did loopy get fully archived off of the obs host?
18:34:32 <pollo> I archived the nginx stuff
18:34:38 <olasd> yeah I saw that
18:34:48 <pollo> I thought the rest was in peertube
18:35:01 <olasd> the videos, yes; the scripts, obviously not
18:35:13 <pollo> #action pollo to check with highvoltage is something on obs1 wrt loopy needs to be archived
18:35:18 <olasd> thanks
18:35:33 <pollo> moving on? I have to leave in ~10mins
18:35:43 <olasd> I'll untick obs1 from the check list until that's done
18:36:09 <pollo> #topic DC20 Teardown status -- What should be kept running at infomaniak?
18:36:21 <pollo> looks like obs1 and review
18:36:38 <pollo> and we're aiming for Sunday as a deadline
18:37:30 <CarlFK> is Sunday the day stuff goes away?  (thus get stuff saved before Sunday starts)
18:37:57 <pollo> I'll try to close all pending issues before Sunday yes
18:38:20 <pollo> CarlFK: were you still playing with groot.online.debconf.org ?
18:38:25 <olasd> CarlFK: Sunday is the last day stuff goes away. Get stuff saved *now* or tell people *now* that stuff needs to be saved.
18:39:06 <CarlFK> pollo:  groot can go.
18:39:08 <olasd> I can have a sniff through home directories and start shutting down stuff from the infomaniak interface if it looks "fully ansibled"
18:39:49 <pollo> #action olasd to verify and shut down infomaniak machines when possible
18:40:16 <pollo> #topic MiniDebConfs -- MiniDebConfs schedule
18:40:20 <pollo> #chair olasd
18:40:20 <MeetBot> Current chairs: olasd pollo
18:40:50 <pollo> a lot of MiniDCs incoming and I feel the level of energy we have ain't enough
18:41:02 <olasd> definitely a concern
18:41:35 * pollo leaves
18:41:47 <pollo> sorry, medial appointment :(
18:42:04 <olasd> anyone still around who's not me?
18:42:39 <olasd> paddatrapper, nattie, lenharo, tobi, terceiro (you talked during this meeting :P)
18:42:53 <terceiro> hi sorry
18:42:54 <terceiro> :)
18:42:59 <lenharo> hi
18:42:59 <olasd> yeah, no worries
18:43:06 <nattie> i'm here, but if someone else prefers to chair, that's grand
18:43:19 <paddatrapper> olasd: yup
18:43:24 <olasd> I don't need a chair, I need to not be alone in the meeting...
18:43:32 <terceiro> heh
18:43:48 <olasd> because, frankly, I don't think i'll be much involved in the MiniConfs. I've raised my concerns already
18:44:28 <paddatrapper> I also don't think there is much news here. The dates have been set (tentatively I think)
18:44:33 <olasd> so has anything evolved wrt the prospective schedule?
18:44:47 <paddatrapper> #link http://deb.li/i4Y5M
18:45:04 <paddatrapper> 21-22 November - Gaming
18:45:11 <olasd> #chair paddatrapper
18:45:11 <MeetBot> Current chairs: olasd paddatrapper pollo
18:45:19 <paddatrapper> 28-29 November Brasil
18:45:34 <paddatrapper> 5-6 December - India
18:45:40 <paddatrapper> Suppose those should be #info
18:45:41 <olasd> #info expected schedule of miniconfs is still 3 weekends, 21-22 november, 28-29 november and 5-6 december
18:46:14 <olasd> #topic MiniDebConfs -- Setup of permanent infra for testing, training and miniconfs
18:46:19 <olasd> paddatrapper: any progress here?
18:46:23 <paddatrapper> none yet
18:46:38 <olasd> have an idea where to host this?
18:47:04 <paddatrapper> Probably Hetzner in VMs on a host if possible
18:47:15 <paddatrapper> Though we may run into issues with Jitsi and NAT
18:47:20 <paddatrapper> so maybe 2 VMs
18:47:32 <paddatrapper> s/VMs/machines
18:47:32 <olasd> 2 hosts you mean?
18:47:34 <olasd> right
18:47:42 <paddatrapper> yeah
18:47:52 <olasd> #info the current working theory is using a hetzner machine or two as VM hosts to run this infra
18:48:15 <olasd> should I #action you again about it?
18:48:24 <paddatrapper> Yes please
18:48:38 <olasd> #action paddatrapper to flesh out hosting for the permanent testing/training/miniconf infra
18:48:50 <olasd> anything else on the subject?
18:49:04 <paddatrapper> nothing from me
18:49:13 <terceiro> cool
18:49:33 <olasd> #topic MiniDebConfs -- any other business
18:49:54 <olasd> I've heard through the grapevine that the .fr minidebconf in Bordeaux has been postponed
18:50:01 <olasd> (unsurprisingly)
18:50:32 <nattie> yeah
18:50:42 <nattie> they don't want to do an online one
18:51:38 * tobi mumlbes MDC Regensburg dates are not known yet. Will be 2021 though.
18:52:16 <olasd> I see the teams for the online minidebconfs are getting/have gotten a bit more fleshed out; but yeah, looks like we'll need these people to give energy the video team if they want their events to succeed
18:52:34 <paddatrapper> #info MDC Regensburg will be in 2021
18:53:12 <olasd> #info MDC Bordeaux postponed for now
18:53:12 <terceiro> yeah
18:54:04 <olasd> #topic Review of last meeting's action items
18:54:38 <olasd> paddatrapper: has there been progress on the blogging?
18:54:58 <olasd> #action highvoltage to investigate HLS/Video.js tunable settings for switching resolutions (carried over from last meeting)
18:55:16 <paddatrapper> not yet. Hopefully this week or next (just need to sit down and actually write)
18:55:41 <paddatrapper> #action paddatrapper and highvoltage to flesh out a blog post (carried over from last meeting)
18:55:45 <olasd> *nod*
18:55:57 <olasd> #topic Any Other Business?
18:56:03 <paddatrapper> nothing from me
18:56:06 <olasd> neither
18:56:14 <terceiro> too
18:56:35 <olasd> taptaptap on the desk
18:56:41 <olasd> #topic Next meeting
18:56:53 <olasd> I guess we should meet next week to review the teardown actions?
18:56:58 <paddatrapper> Yeah
18:57:21 <paddatrapper> Then hopefully can lower the frequency
18:57:46 <olasd> #agreed Next meeting on Tuesday 2020-09-22 @ 18:00 UTC (review of the DC20 teardown)
18:57:52 <olasd> #endmeeting