17:58:19 <olasd> #startmeeting
17:58:19 <MeetBot> Meeting started Tue Dec  1 17:58:19 2020 UTC.  The chair is olasd. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:58:19 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:58:27 <olasd> #addchair tumbleweed
17:58:31 <olasd> #chair tumbleweed
17:58:31 <MeetBot> Current chairs: olasd tumbleweed
17:58:36 <olasd> better
17:58:36 <tumbleweed> ohai
17:58:41 <olasd> #topic Roll Call
17:58:51 <phls> hi
17:58:54 <olasd> #link Agenda http://deb.li/oNCD
17:58:58 <sahilister[m]> hello o/
17:59:05 <olasd> (will that work? who knows!)
17:59:07 <pollo> 0/
17:59:40 <olasd> any paddatrapper or highvoltage s around?
17:59:46 <tumbleweed> woo, people from both .br and .in minis
18:00:05 <wouter> hi
18:00:07 <pollo> br-in-g them in!
18:00:10 * pollo hides
18:00:19 <olasd> har har
18:00:24 <wouter> what's g?
18:00:32 * nattie extracts the pun tax from pollo
18:00:46 <sahilister[m]> g = global or germany?
18:00:54 <nattie> global then
18:01:10 <nattie> pollo: one jar of preserved tomatoes, please!
18:01:23 <olasd> alright, I guess that's all of us
18:01:25 <highvoltage> highvoltage is around but working
18:01:32 <olasd> ah, I just had to ask :P
18:01:36 <olasd> #topic 2.1. mdcobr2020 - Video encoding check-in
18:01:53 <tumbleweed> all done, I think
18:01:55 <nattie> oh yeah, i'm hereish, in my usual way
18:01:59 <wouter> I forgot, yet again, to swich LQ to VP9...
18:02:10 <wouter> but meh, don't think it's crucial
18:02:16 <wouter> I'll try to not forget before the .in one ;)
18:02:16 <tumbleweed> terceiro: you probably want to import video links to th esite
18:02:18 <olasd> it did sound that way; is there a final review expected?
18:02:25 <pollo> olasd: done
18:02:27 <olasd> great
18:02:31 <tumbleweed> pollo: are we going to do an etherpad export again?
18:02:34 <tumbleweed> (did they even use etherpad)
18:02:38 <olasd> #info All encodings done, and a final review happened
18:02:44 <pollo> tumbleweed: for?
18:02:45 <terceiro> tumbleweed: yes, I will
18:02:51 <tumbleweed> pollo: .br mini
18:02:55 <pollo> ah, yes etherpad export, sorry
18:02:58 <olasd> #action terceiro to import video links to the website
18:03:05 <pollo> #action pollo to export the BR etherpads
18:03:22 <olasd> anything else for this topic?
18:03:38 <terceiro> tumbleweed: did you do that for mdco games?
18:03:46 <terceiro> (otherwise I can do it at the same time)
18:04:21 <tumbleweed> terceiro: yes
18:04:29 <terceiro> cool
18:04:30 <tumbleweed> although the games one had to deal with weird data issues that you won't have to
18:04:40 <terceiro> k
18:04:49 <olasd> alright
18:04:52 <olasd> #topic 2.2. mdcobr2020 - Feedback
18:05:01 <pollo> I think things went well?
18:05:05 <terceiro> they did
18:05:07 <olasd> I've seen happy organizers, at least :-)
18:05:14 <phls> yes, it was very nive
18:05:15 <phls> nice
18:05:20 <olasd> #info Things went well overall
18:05:25 <tumbleweed> didn't see any fires, we never got called in to fix anything
18:05:27 <terceiro> there were some hiccups, but mostly caused by speakers not listening to advice
18:05:39 <pollo> yes, very few pre-recorded videos
18:05:45 <wouter> terceiro: can you summarize them?
18:05:48 <tumbleweed> and some firefox
18:05:53 <wouter> perhaps it's something we might be able to work on?
18:05:57 <terceiro> speaker with flaky internet connection
18:06:02 <wouter> ... then again, perhaps not :)
18:06:02 <terceiro> speaker without a proper mic
18:06:13 <nattie> did y'all have test calls?
18:06:15 <terceiro> it's mostly a matter of being more on top of them
18:06:18 <wouter> right
18:06:38 <wouter> it might be useful if we had a low-speed Internet option for people to join the conference
18:06:43 <phls> just 2 pre-recorded videos
18:06:43 <pollo> we have
18:06:44 <wouter> but I'm not sure that's possible
18:06:51 <wouter> oh
18:06:51 <pollo> wouter: there's a phone option in jitsi
18:06:57 * wouter goes quiet
18:07:00 <olasd> #info Some issues were caused by presenters not following the advice, e.g. poor quality of internet connection or bad microphone
18:07:08 <wouter> pollo: not what I meant, but okay
18:07:20 <pollo> not sure what you mean then
18:07:29 <pollo> we have low-res streams too
18:07:30 <phls> i believe it's a good idea add a warning on the doc for more than one jitsi room sending streaming to vogol
18:07:54 <wouter> pollo: nvm, I'm actually not sure myself :)
18:08:16 <tumbleweed> phls: what was the issue there? were they fighting each other?
18:08:17 <wouter> video conference requires bandwidth, we're not magicians, I shouldn't have said anything
18:09:07 <terceiro> IMO it's unreasonable to expect someone to present at an online conf without having a minimally decent internet connection
18:09:35 <phls> tumbleweed, no, because I asked here first what could happen if we do that
18:09:50 <olasd> terceiro: live, definitely; but uploading slides somewhere and talking over them on mumble could work
18:09:51 <pollo> terceiro: well, pre-recorded videos + phone Q&A would certainly be an option
18:10:29 <olasd> I mean, there's a few options for low-bandwidth live talks that /could/ be explored if the need is present (I'm not sure it actually is)
18:10:33 <terceiro> sure
18:10:51 <paddatrapper> Sorry, I've had irl commitments tonight. Not going to be around for the meeting
18:10:55 <terceiro> my point is we should not optimize for that
18:11:09 <olasd> yeah, definitely
18:12:28 <olasd> tempted to "#info We could give clearer advice to organizers for what happens when multiple Jitsi rooms try to stream to the same vogol" but I'm not sure that's what you meant, phls
18:12:48 <olasd> (and then I'm not sure where and how)
18:12:56 <tumbleweed> I also don't actually know what would happen
18:13:00 <tumbleweed> I'd have to try it out to see
18:13:11 <tumbleweed> IIRC at dc20, it'd just kick the old one out, which seems fine
18:13:14 <terceiro> the advice should be "don't"
18:13:14 <olasd> should I #action you?
18:13:23 <wouter> #info there were some issues with speakers not following advice and having bad equipment/internet connections, but these were minor overall
18:13:24 <tumbleweed> terceiro: err, in that scenario, it seems fine
18:13:34 <olasd> wouter: I already did that, I think
18:13:42 <wouter> #undo
18:13:44 <wouter> yes, you did
18:13:55 <wouter> but apparently I can't undo -- tumbleweed, could you do that for me? ;)
18:14:02 <olasd> you can't #info either
18:14:04 <olasd> so that's fine
18:14:05 <pollo> tumbleweed: I think they flicker in and out, alternating, until one dies
18:14:22 <tumbleweed> olasd: the docs say #info is for everyone
18:14:24 <wouter> oh, hah
18:14:28 <olasd> ah, interesting
18:14:30 <olasd> #undo
18:14:30 <MeetBot> Removing item from minutes: <MeetBot.items.Info object at 0x14e2a10>
18:14:31 <tumbleweed> #undo
18:14:31 <MeetBot> Removing item from minutes: <MeetBot.items.Info object at 0x166ca90>
18:14:33 <olasd> lol
18:14:34 <tumbleweed> lol
18:14:35 <phls> olasd, basically a warning saying: don't start more than on streamings on the same time
18:14:40 <tumbleweed> I was hoping it would say what it removed
18:14:40 <olasd> #info Some issues were caused by presenters not following the advice, e.g. poor quality of internet connection or bad microphone
18:14:41 <wouter> hah
18:15:00 <wouter> tumbleweed: it does, to some extent
18:15:07 <olasd> so, anyway, tumbleweed: #action or not?
18:15:31 <olasd> or anyone else (to check what happens when 2 jitsi rooms stream to the same vogol)
18:15:41 <olasd> (and write the resulting advice)
18:15:54 <tumbleweed> sure, I'll take an action
18:16:16 <olasd> #action tumbleweed to check what happens when 2 jitsi rooms are streaming with the same streaming key, and write the resulting advice
18:16:45 <olasd> #topic 2.3. mdcobr2020 - tear down streaming CDN
18:16:55 <wouter> that's been done?
18:16:57 <tumbleweed> yeah
18:17:00 <olasd> #info all done by tumbleweed
18:17:04 <tumbleweed> now that we have this long-lived stack
18:17:11 <tumbleweed> there is a question of whether this should stay up
18:17:14 <tumbleweed> or some of it should
18:17:22 <tumbleweed> right now, there's a single streaming frontend at hetzner
18:17:30 <tumbleweed> which is probably enough for a miniconf
18:17:31 <pollo> I don't think we need a full distributed CDN via DO
18:17:36 <olasd> or whether we really need it at all
18:17:39 <olasd> indeed
18:17:51 <wouter> it cost us 12USD to run it, I don't think that's a problem?
18:17:52 <tumbleweed> it probably makes sense to have one regional one for regional miniconfs
18:18:02 <highvoltage> the next one is nect month I don't think the CDN needs to stay up but it might be nice keeping it up for collective experiments and improvements
18:18:34 <terceiro> or make it very easy to bring it up when needed
18:18:37 <tumbleweed> it is
18:18:43 <highvoltage> (sorry too much caffeine that sentence needed some punctuation :p)
18:18:44 <tumbleweed> it could be even easier, of course
18:18:46 <wouter> I think it already is?
18:19:02 <tumbleweed> but it's half an hour's work at most to bring it up
18:19:19 <wouter> most of which is "wait for ansibl to finish", I guess?
18:19:20 <terceiro> provided one gets a hold of one of you
18:19:21 <terceiro> :)
18:19:25 <tumbleweed> or olasd
18:19:27 <tumbleweed> or a DSA
18:19:42 <highvoltage> define "easy". before DC20 it was easy to bring the stack up but in reality it took quite a while to sort everything out (of which some time was sorting out which 'hardware' to use which at least did take up quite some of that time)
18:19:42 <olasd> I don't think DSA has access to the DO account?
18:19:42 <pollo> they'll need to anyway if they want to have a miniconf
18:19:43 <tumbleweed> wouter: no, clicking things in DO, adding DNS records
18:19:45 <pollo> at least for now
18:19:54 <tumbleweed> and then a few mins of ansible, eah
18:19:55 <tumbleweed> yeah
18:20:04 <highvoltage> ah sounds ok at least
18:20:11 <wouter> isn't there an ansible module for DO too?
18:20:11 <terceiro> yeah I don't think we have a problem with this atm
18:20:16 <wouter> if so we might be able to use that
18:20:24 <olasd> actually I have a 10 line python script somehwere to automate most of that
18:20:24 <wouter> (should make things slightly faster)
18:20:28 <tumbleweed> pollo: actually, no, I think a miniconf doesn't need this
18:20:31 <tumbleweed> but it's nice to have
18:20:39 <tumbleweed> certainly would have been nice to have one in .br for the mini there
18:20:52 <tumbleweed> or we should ask talk to DSA about using one of their CDN providres
18:20:55 <pollo> I mean "they'll need to reach out to us anyway if they want to have a miniconf, for now"
18:21:28 <pollo> when peertube gets HLS support we can try to get a minimal "you don't need us" config
18:21:38 <terceiro> cool
18:21:59 <tumbleweed> I don't know if I'd trust our peertube instance for conference live streams
18:22:03 <tumbleweed> without signifciant beefing up
18:22:16 <tumbleweed> I'd steer clear of that
18:22:22 <tumbleweed> but that's because we've got something that we know works
18:23:23 <tumbleweed> shall we move on?
18:23:29 <olasd> do we have anything to agree on within this topic?
18:23:29 <wouter> yes please
18:23:34 <wouter> don't think so
18:23:47 <olasd> #topic 3.1 .in mini - timeline
18:24:33 <olasd> #info The dates for the MiniDebConf online India are 23-24 January 2021
18:24:42 <olasd> #link https://wiki.debian.org/DebianIndia/MiniDebConfOnlineIndia2021
18:24:50 <terceiro> I was proded in private mail about a site; will be bringing it up RSN
18:24:59 <terceiro> (wafer)
18:25:06 <wouter> was about to ask that :)
18:25:23 <wouter> terceiro: will you let me know when it's live? I can then add it to SReview
18:25:30 <wouter> (recently fixed the parser, so it's now idempotent again)
18:25:30 <jcristau> tumbleweed: i don't think we'd have a problem setting up a cdn to serve debconf stuff, fwiw.  let us know.
18:25:41 <olasd> #link first meeting minutes: https://wiki.debian.org/DebianIndia/MiniDebConfOnlineIndia2021/Meeting1
18:25:47 <terceiro> wouter: yes
18:26:20 <terceiro> tumbleweed: I will ping you wrt DNS
18:26:30 <tumbleweed> jcristau: thanks, let's chat after the meeting
18:26:45 <olasd> what should be *our* timeline wrt the .in minidebconf?
18:27:12 <tumbleweed> I think we should ask for a schedule to be ready a week in advance
18:27:30 <tumbleweed> and give them a list of things we need (title slides, etc.)
18:27:49 <tumbleweed> pollo: whoops, missed in your recent edits
18:28:10 <wouter> do the .in minidc people want to use the SReview upload functionality for prerecorded talks?
18:28:37 <pollo> tumbleweed: edits where?
18:28:37 <phls> do you know if MDCO India will be in english?
18:28:45 <sahilister[m]> Yes for me. Will ask around and revert here. (about SReview)
18:28:49 <tumbleweed> pollo: https://debconf-video-team.pages.debian.net/docs/working_with_videoteam.html
18:29:01 <olasd> phls: I think multiple languages, according to the first meeting
18:29:04 <pollo> ah it's ok, paddatrapper reviewed th rest
18:29:14 <sahilister[m]> For MDCO we plan, English, Hindi, Malaylam + one or two.
18:29:17 <tumbleweed> pollo: no, I mean, we could have listed all the things we will need
18:29:19 <wouter> sahilister[m]: okay, I'll make that happen then
18:29:28 <tumbleweed> e.g. schedules, opening slides
18:29:29 <phls> cool
18:29:32 <pollo> tumbleweed: I don't think that's the goal of that page
18:29:49 <pollo> anyway, wrong topic :)
18:29:50 <olasd> should we pad the list after the meeting?
18:29:57 <olasd> so it can be sent afterwards?
18:30:00 <tumbleweed> olasd: +1
18:30:07 <tumbleweed> and I think we should find a place for it in our docs
18:30:19 <olasd> #agreed write the list of videoteam requirements on a pad after the meeting so we can send it to the .in organizers
18:30:54 <olasd> training of volunteers in the week before the conf? dry run of a talk at that point too?
18:31:02 <pollo> we haven't talked about timezones...
18:31:13 <pollo> it'll be hard for me to do anything for that miniconf
18:31:28 <wouter> what will the timezone be?
18:31:37 <tumbleweed> india
18:31:38 <terceiro> UTC+5:30
18:31:41 <sahilister[m]> UTC + 5:30
18:31:42 <wouter> yes, obviously :)
18:31:59 <pollo> that's a 10h shift on my side
18:32:04 <olasd> #info conference timezone will be UTC + 05:30
18:32:12 <wouter> I might be able to help out -- it's not too bad for me
18:32:27 <wouter> depending on what time the miniconf is going to start
18:32:38 <wouter> (although I won't be able to help until the end, probably)
18:32:45 <tumbleweed> I may be able to be around for the start of their days, if they do start earlier
18:32:53 <tumbleweed> but hard to commit to that at this point
18:32:56 <olasd> anyway, we'll need a rough idea of the schedule blocks so we can plan our core volunteers
18:33:03 <olasd> fairly soon
18:33:05 <wouter> yeah, absolutely
18:33:25 <sahilister[m]> Will discuss and mention the rough schedule in a week here.
18:33:32 <sahilister[m]> for .in MDCO.
18:33:41 <wouter> sahilister[m]: thanks
18:33:51 <olasd> great, thanks (we probably won't have a meeting *next* week, but we'll be around)
18:34:03 <wouter> #info rough schedule for .in mdco expected some time next week
18:34:05 <olasd> #action sahilister[m] to give us the schedule outline
18:34:09 <wouter> ...
18:34:14 <wouter> we need to stop doing that ;)
18:34:24 <olasd> backseat chairing ;p
18:34:30 <wouter> something like that
18:34:31 <olasd> #chair wouter
18:34:31 <MeetBot> Current chairs: olasd tumbleweed wouter
18:34:44 <wouter> iek
18:35:06 <olasd> #topic 3.2 .in mini - Meeting schedule?
18:35:23 <olasd> I'm pretty sure we need a break for one or two weeks (or three)
18:35:26 <pollo> for the videoteam or the local team?
18:35:30 <olasd> for the video team
18:35:41 <olasd> it's a video team meeting, isn't it?
18:35:44 <tumbleweed> this is a .in subitem
18:35:53 <olasd> tumbleweed: you wrote it
18:35:55 <tumbleweed> because we need to come back at a good point to engage with them
18:35:57 <highvoltage> maybe he meant the local video team or the global video team
18:36:00 <highvoltage> *ducks*
18:36:11 <pollo> anyway, yes, I need a break
18:36:26 <olasd> tumbleweed: yeah, definitely; but we've been having weekly meetings forever at this point
18:36:33 <tumbleweed> I'm guessing about 2 weeks before .in sounds about right?
18:36:42 <pollo> would 1st week of jan be too late?
18:37:02 <olasd> meeting on jan 5 gives us two more meetings before the event
18:37:05 <olasd> which sounds fine?
18:37:09 <pollo> +1
18:37:09 <wouter> yeah, I think that works
18:37:16 <wouter> and I'm not doing anything before then anyway
18:37:24 <olasd> I mean, I don't think we'll want to upend the stack before then anyway
18:39:16 <olasd> the other question is meeting time; 18:00 UTC is 01:30 AM India time which isn't great for the organizers; can we push that earlier?
18:39:53 <tumbleweed> 2 hours earlier is the most that's comfortable from here
18:39:56 <tumbleweed> 3 at a push
18:40:12 <pollo> both work for me
18:40:30 <olasd> I guess we should talk it through with sahilister[m] and others when we send our list of requirements?
18:40:39 <olasd> see what works for them
18:40:39 <tumbleweed> yeah
18:41:08 <olasd> #agreed next meeting on or about January 5th; in the meantime, send a list of requirements and agree on a meeting time that would work for .in volunteers as well as video team members
18:41:10 <wouter> wfm
18:41:32 <olasd> #topic 4. Video Archive Documentation
18:41:47 <pollo> nothing yet, let's add it to the next agenda
18:41:51 <olasd> ack
18:42:08 <olasd> #info no progress so far
18:42:20 <olasd> #topic 5. Working with the video team guidelines email
18:42:28 <olasd> #link https://storm.debian.net/shared/iBkmYf38dqUk6y4hrKvFxFe2yVPsWT2G_vnz3GFB0YD
18:42:51 <olasd> what triggered this? the vietnam announcement or anything else?
18:42:52 <pollo> if people are ok with the text, I'll send it after the meeting
18:43:07 <pollo> there's a vietnam minidc?
18:43:13 <olasd> well, lack-of-announcmenet
18:43:27 <olasd> ah, thailand, not vietnam
18:43:29 <olasd> (ugh)
18:43:45 <pollo> no, I just felt our documentation didn,t have a great starting point for organisers
18:43:51 <highvoltage> you may just have errored MiniDC Vietnam into existance
18:43:58 <wouter> highvoltage: :)
18:44:20 <olasd> pollo: I think the text is fine; I wonder if this should be turned into a "bits from the video team" also announcing availability of videos from the other events (and thanking volunteers)?
18:44:44 <tumbleweed> in that case maybe extend to say that this infra is up
18:44:50 <pollo> that could be done, although phls already sent an email wrt minidc_br videos
18:44:54 <tumbleweed> and you can feel free to use it for adhoc things
18:45:24 <pollo> tumbleweed: you mean vogol+jitsi?
18:46:07 <tumbleweed> + streaming + obs
18:46:11 <tumbleweed> i.e. online conference stuff
18:46:22 <pollo> it still needs manipulations on our side though
18:46:42 <pollo> I think we're not yet at the point where people can do stuff without us
18:46:54 <wouter> should teh text also encourage people to organize miniconferences?
18:47:14 <pollo> wouter: "To encourage you to organise local events"
18:47:15 <tumbleweed> pollo: sure, but it's not like it's a huge ask to support an event
18:47:35 <tumbleweed> we used the example of the .br weekly streams before. We could totally support things like that
18:47:35 <wouter> do we still have a lot? dinner's here
18:47:46 <tumbleweed> although if there was enough of that, we'd need a calendar
18:47:48 <olasd> it does take one of us to be available for the duration of the event in case something goes wrong
18:48:00 <pollo> tumbleweed: I'm not up for that on my side though
18:48:03 <nattie> pollo: shall i join in the effort of writing?
18:48:06 <wouter> pollo: ah yes, missed that
18:48:17 <olasd> (not exactly *paying attention* but being available to react)
18:48:23 <pollo> I was excited about peertube for that reason
18:48:38 <pollo> nattie: sure
18:48:49 <tumbleweed> I assume peertube streaming needs something to feed it
18:48:57 <tumbleweed> the kind of infra we have :P
18:49:14 <pollo> yes, but we can make that 100% automated
18:49:14 <tumbleweed> sure, fair point about needing some support
18:49:19 <olasd> anyway, I think the original scope of the mail is fine, and I think the current text is ok, even though it's a bit open ended
18:49:40 <highvoltage> yeah peertube also takes an rtmp feed for live streaming
18:49:50 <olasd> if the videos for past events have been announced we don't need to do that again, I guess
18:50:10 <olasd> (can't find the announcements but...)
18:50:16 <tumbleweed> probably the biggest thing we need to be involved with, in our setup, is recordings
18:50:23 <tumbleweed> and support
18:50:42 <tumbleweed> the jitsi, mixing, streaming stuff all basically runs itself
18:51:08 <pollo> agreed
18:51:13 <olasd> yeah
18:51:19 <tumbleweed> I'm quite happy with not advertising anything, though
18:52:59 <pollo> olasd: https://lists.debian.org/debian-project/2020/11/msg00019.html
18:53:02 <olasd> shall pollo send the email as-is (after some wordsmithing) then?
18:54:08 <olasd> *crickets*
18:54:18 <pollo> I'm all for it :)
18:54:22 <wouter> +1
18:54:25 <nattie> sure
18:54:39 <olasd> #agreed pollo to send the working with the video team guidelines email
18:55:02 <olasd> #topic 6. INSERT NEW ITEMS HERE
18:55:08 <olasd> #topic 7. Any other business
18:55:10 <olasd> (scnr)
18:55:40 <olasd> *crickets*
18:55:41 <wouter> tumbleweed: I fixed the config for lq encodings
18:55:43 <olasd> ah
18:55:48 <wouter> they now will be vp9
18:55:54 <tumbleweed> great
18:55:55 <olasd> #info wouter fixed the config for lq encodings to make them vp9
18:55:57 <wouter> thought it also means that it will lie about the json files
18:56:01 <tumbleweed> I guess that will double encoding times :)
18:56:05 <wouter> s/thought/though/
18:56:06 <wouter> probably
18:56:17 <olasd> any other other business?
18:56:20 <tumbleweed> the json files are full of lies about the encoding profiles anyway
18:56:25 <wouter> :)
18:56:29 <wouter> tumbleweed: sorry about that
18:56:46 <olasd> #topic 8. Next Meeting
18:57:00 <tumbleweed> np. I don't think it's reasonable to expect sreview to use the archive-meta data format for that, internally
18:57:00 <olasd> #agreed next meeting: January 5th 2021 (time TBD with the .in minidebconf team)
18:57:13 <olasd> #endmeeting