17:59:53 <pollo> #startmeeting
17:59:53 <MeetBot> Meeting started Thu Jul  8 17:59:53 2021 UTC.  The chair is pollo. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:59:53 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:00:00 <pollo> #topic Roll Call
18:00:13 <pollo> Please say hello if you are here for the meeting!
18:00:32 <nattie> yo
18:00:39 <pollo> meanwhile, have a look at the proposed agenda: mhttps://deb.li/oNCD
18:00:44 <nattie> though as always only in an observer role
18:00:50 <highvoltage> hello if you are here for the meeting!
18:02:18 <wouter> o/
18:02:53 * wouter wonders what the mhttps protocol is... ;-P
18:03:07 <pollo> mobile HTTP, the new AMP!
18:03:13 * pollo hides
18:03:33 <wouter> is that related to WAP, then?
18:04:43 * pollo takes for granted tumbleweed will join and moves on :)
18:04:50 <pollo> #topic Matrix integration
18:04:56 <wouter> if only because you just mentioned him ;)
18:04:59 <wouter> yeah, so
18:05:10 <wouter> I did talk to the element people about that, and asked for documentation
18:05:13 <tumblingweed> Hi, but not really here
18:05:21 <wouter> it's essentially a case of "the documentation is the code"
18:05:32 <wouter> at this point I'm not in favour of trying to get that up and running anymore
18:05:46 <pollo> +1, I think we're too late anyway
18:05:51 <tumblingweed> Yeah
18:05:53 <wouter> I wanted to give it a closer look, but didn't have the time, so
18:06:05 <highvoltage> experiments might be nicer for next mdco
18:06:09 <pollo> #agreed We won't be using Matrix FOSDEM-like for DC21
18:06:36 <pollo> anything to add ?
18:06:55 <wouter> not from me
18:06:59 <pollo> #topic Review system
18:07:24 <pollo> I think audio normalisation was the only thing left ?
18:07:32 <wouter> tests for it, yes
18:07:37 <wouter> haven't gotten around to that yet
18:07:51 <wouter> but since we have VMs now, I'm thinking I'll set things up, and then we can test the system we'll use for prod
18:08:01 <wouter> and if I find issues, time enough to fix them still currently
18:08:12 <pollo> are we going to use vittoria as the main SReview node this year, and spin encoders on Infomaniak's HW ?
18:08:13 <wouter> I don't anticipate any problems, but...
18:08:29 <wouter> eh, good question
18:08:50 <wouter> stuff has to end up on vittoria in the end anyway
18:08:55 <wouter> so I'm inclined to want to use that
18:09:03 <wouter> encoders at infomaniak seems like a good idea
18:09:13 <pollo> I don't have anything against it, I think this went well for other confs
18:09:22 <wouter> although there isn't *that* much to do, I think we can cope with just vittoria
18:09:32 <wouter> (and that does make things slightly easier)
18:09:54 <wouter> I'll just start with setting up stuff on vittoria for now, the upload will need to be there anyway
18:10:03 <pollo> more encoders mean faster releases, which means we're more likely to be done by then end of the conf
18:10:17 <wouter> mmm
18:10:20 <tumblingweed> Encoders at infomaniak = tunneled pgsql?
18:10:25 <wouter> I don't think it will make that much of a difference, but okay
18:10:33 <pollo> we tend not to be good at managing videos post-conf
18:10:46 <wouter> tumblingweed: yup, I haven't finished writing the ReST stuff for updating the db yet
18:11:03 <pollo> oh, I thought it was the gridengine thingy
18:11:29 <tumblingweed> Keeping dbs in sync sounds painful
18:11:31 <wouter> I would run a gridengine instance at infomaniak if we run encoders there
18:11:46 <wouter> that's fairly trivial, especially now that I fixed the ansible stuff for that
18:11:46 <tumblingweed> But the individual jobs poke the db
18:11:55 <wouter> yes, that's the issue, indeed
18:12:09 <pollo> if it's trouble let's not do that, I thought it was a feature that we already had
18:12:23 <wouter> it's not trouble, it's just a bit of work
18:12:38 <wouter> the hardest part is asking DSA to poke a hole in the firewall
18:13:09 * pollo shrugs
18:13:10 <highvoltage> oh yeah rather not do that then
18:13:11 <wouter> but it's fine, I'll set up an encoder at infomaniak
18:13:19 <wouter> adding another one is trivial once we have one
18:13:39 <pollo> #info we're likely to use vittoria + encoders at Infomaniak
18:13:45 <pollo> anything else?
18:13:59 <wouter> we were going to use it for upload processing too, right?
18:14:06 <pollo> sure
18:14:11 <wouter> should it also handle slide uploads, or do we want to handle that differently this year?
18:14:32 <pollo> if we can have 1 single place speakers upload things, I'm all for it
18:14:41 <pollo> we can dump them in git-lfs later
18:14:46 <wouter> well, the code is there, but it's a bit hairy
18:15:16 <wouter> I also don't think it's a great way of handling things, but maybe that's just me
18:15:27 <pollo> I think asking people to upload their slides to salsa yields poor results anyway, few do it
18:15:51 <wouter> fair point, I guess. Okay, I'll enable that too, then.
18:16:15 <pollo> #info speakers will upload their talks into Sreview and will also be able to upload slides
18:16:17 <wouter> not sure whether it still works, I hacked a bit on the upload handling for FOSDEM, but it shouldn't be too complicated to fix if it's broken
18:16:58 <pollo> #topic Q&A webapp
18:17:19 <pollo> #link https://q-and-a.online.debconf.org
18:17:28 <pollo> there's a working prototype!
18:17:36 <wouter> \o/
18:17:39 <wouter> how well does it work?
18:17:48 <pollo> it's a little buggy around the edges
18:18:02 <pollo> If I find the motivation, I want to try my hand at CSS styling
18:18:27 <pollo> I think it's reasonable to assume we can use that instead of the etherpad
18:18:38 <pollo> I would personnally not offer the etherpad at all
18:19:00 <wouter> what CSS styling would you want to do? It seems fine from my POV
18:20:07 <pollo> I'd like to see if I can manage to make it look like the mockups I made: https://salsa.debian.org/debconf-team/public/data/dc21-online/-/issues/2#note_236656
18:20:31 <pollo> but it's certainly fine as-is :)
18:20:37 <wouter> might be nice to have it also order questions so the most popular one is on top, rather than the oldest one?
18:20:57 <wouter> is that a planned feature?
18:21:00 <highvoltage> well it is still a prototype
18:21:19 <wouter> sure, hence my asking it as a question, rather than filing a bug ;)
18:21:41 <pollo> sure, the idea is we don't need to scroll, so we can screen capture it easily
18:21:59 <wouter> right, that's what I thought too
18:22:59 <pollo> anyway, work to be done, but a _lot_ of progress thanks to tumbleweed :)
18:23:07 <pollo> #topic Streaming
18:23:14 <pollo> I think we can remove that one?
18:23:23 <pollo> I doubt changing the way we stream now is a great idea
18:23:48 <wouter> yeah, don't think we can make many changes anymore right now
18:25:08 <pollo> #topic Ansible & migration to Bullseye
18:25:15 <pollo> Very much ongoing!
18:25:40 <pollo> I'd say we're close to merging in the master branch
18:26:05 <wouter> did I sufficiently fix the Vagrant stuff, or do you need me to poke at things some more?
18:26:26 <wouter> (had a short look at it and I think I fixed things, but didn't look at it any further)
18:26:30 <pollo> I haven't looked at that at all lately, can't say
18:27:07 <wouter> right
18:27:11 <wouter> well, if there's anything, let me know
18:27:40 <pollo> #topic New Video Archive Mirror
18:27:52 <pollo> no news from jeb
18:27:57 <pollo> I'll re-re-poke next week
18:28:45 <pollo> #topic Any Other Business
18:29:25 <wouter> we set up some VMs earlier today, what's the status on them?
18:29:39 <pollo> up and ansibled afaiu
18:31:02 <pollo> #topic Next Meeting
18:31:25 <pollo> Thursday July 15th from 18:00 to 19:00 UTC ?
18:31:29 <pollo> I think we should start having weekly meetings
18:31:35 <wouter> +1
18:32:07 <nattie> sure
18:32:32 <pollo> #agreed Next Meeting Thursday July 15th from 18:00 to 19:00 UTC
18:32:37 <pollo> #endmeeting