17:59:53 <pollo> #startmeeting
17:59:53 <MeetBot> Meeting started Thu Aug 12 17:59:53 2021 UTC.  The chair is pollo. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:59:53 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:59:58 <pollo> #topic Roll Call
18:00:07 <pollo> hello folks! DebConf start in a week!
18:01:08 <wouter> o/
18:01:57 <wouter> tumbleweed, paddatrapper: you guys here?
18:02:17 <highvoltage> hello if you are here for the meeting
18:02:43 <paddatrapper> \o
18:03:14 <highvoltage> I almost had a heart attack, at least it's only DebCamp that starts in a week
18:03:27 <wouter> highvoltage: +1
18:03:55 <pollo> hehe
18:04:06 <pollo> #topic Review system
18:04:27 <wouter> I was stuck configuring the encoder on DSA poking a hole in the firewall
18:04:47 <wouter> that happened yesterday (after some poking), just need to finish configuring the encoder now
18:04:51 <wouter> and then tests etc
18:05:09 <pollo> wouter: afaiu, the upload links have been sent to the content team?
18:05:13 <wouter> upload URLs have been sent to terceiro and tumbleweed, terceiro is busy sending them to speakers
18:05:22 <pollo> #info upload URLs have been sent to terceiro and tumbleweed, terceiro is busy sending them to speakers
18:05:58 <wouter> I intend to get things up and running by the end of the week re: postprocessing/encoding
18:06:07 <wouter> question though:
18:06:11 <pollo> do you think the encoder could be set up by saturday? I'd like us to plan full test
18:06:13 <wouter> where are the raw encodings going to be?
18:06:19 <wouter> hope so
18:06:39 <wouter> I'll try to get it ready by noon SAST
18:06:49 <wouter> (on saturday)
18:07:00 <pollo> files are saved on voctomix1-2 and we'll transfer them to vittoria?
18:07:28 <wouter> well, if they're going to be transcoded on the encoder host, they'll need filesystem access
18:07:31 <pollo> #info encoder1 still needs to be setup, ETA Saturday
18:07:34 <wouter> which means vittoria is $far_away
18:07:49 <wouter> preferably some NFS host at infomaniak would be great
18:07:53 <pollo> isn't the NFS server role for that?
18:07:55 <wouter> (we can transfer to vittoria afterwards)
18:08:01 <wouter> yeah, but we would need something like that
18:08:37 <wouter> alternatively I can look into doing weird shit with my SReview::Collection abstraction layer and transfer raw files over HTTP, but that would be a last minute hack
18:08:50 <wouter> I'd rather not redo last year's last minute hack experience ;-)
18:08:57 <pollo> can't vittoria be the NFS host?
18:09:06 <wouter> NFS over public Internet is a bad idea
18:09:11 <wouter> I doubt DSA will agree to that
18:09:22 <wouter> (we can ask of course, but...)
18:09:53 <pollo> what's the point of using vittoria as the Sreview host then?
18:10:17 <wouter> I guess that's a fair enough question...
18:10:26 <wouter> I just hadn't thought of that bit yet
18:10:32 <pollo> for dc20 we used a local machine at Infomaniak
18:10:59 <wouter> for dc20 we did everything at infomaniak, which turned out to maybe not have been a great idea re: merging stuff back afterwards
18:11:20 <wouter> (I had to mangle file names in the database etc)
18:12:27 <wouter> anyway, I can set up an NFS server at infomaniak that also does the local gridengine, and then everything communicates with vittoria for db access etc?
18:12:38 <wouter> that's how we would usually do things at an in-person debconf
18:13:02 <pollo> sure
18:13:05 <wouter> or alternatively we just completely forget about encoders at infomaniak, but then things might be slower
18:13:14 <pollo> couldn't that be encoder1?
18:13:14 <wouter> (the point of using infomaniak is "moar encoder speed")
18:13:28 <wouter> we'd have to drop it and recreate it with larger storage I guess, but sure
18:13:49 <pollo> we can migrate it, afaiu openstack takes care of that
18:13:54 <wouter> (since I haven't done that much on encoder1 yet, that doesn't really cost us much)
18:13:57 <wouter> oh, okay, nice
18:14:03 <wouter> anyway, yeah, that's definitely possible
18:14:07 <pollo> can I action you to give me the specs you need?
18:14:13 <wouter> sure
18:14:23 <wouter> mostly "enough storage to hold everything"
18:14:38 <pollo> #agreed we'll use encoder1 as the local storage at Infomaniak and only use vittoria for DB access
18:14:49 <wouter> (well, and webinterface)
18:15:03 <pollo> #action wouter to give pollo specs for the jacked-up encoder1
18:15:27 <pollo> anything else?
18:15:28 <wouter> pollo: that also means that the video copy script would need to copy to encoder1
18:15:39 <pollo> sure
18:15:41 <wouter> not sure where that config lives
18:15:49 <pollo> probably in the voctomix role
18:16:08 <pollo> #action pollo to make sure the sreview copy script is configured for encoder1
18:16:18 <wouter> that's all then, I think
18:16:39 <pollo> #topic Q&A webapp
18:17:12 <pollo> since last meeting I set up the issue tracker with tumbleweed's todo: https://salsa.debian.org/debconf-video-team/q-and-a/-/issues
18:17:39 <pollo> I did implement the schedule importer, but the MR needs to be reviewed and merged
18:17:58 <pollo> I'm planning to tackle at least 1 other issue in there, but I can't do them all :)
18:18:05 <wouter> sure
18:18:17 <wouter> I think "room name" and "moderation" are probably the most critical, in that order?
18:18:35 <pollo> room name is mostly done, see https://salsa.debian.org/debconf-video-team/q-and-a/-/merge_requests/5
18:18:41 <wouter> cool
18:19:04 <pollo> I'd say moderation > hide questions
18:19:22 <wouter> yeah, that's what I was thinking too
18:19:42 <pollo> anyway, help welcome, it's "not very complex" :P
18:19:53 <wouter> it's in the wrong language ;-P
18:20:07 <pollo> #action DC21 schedule
18:20:12 <pollo> #undo
18:20:12 <MeetBot> Removing item from minutes: <MeetBot.items.Action object at 0x1548bd0>
18:20:16 <pollo> #topic DC21 schedule
18:20:32 <pollo> #info schedule is now final
18:20:40 <wouter> do we need to do anything more about that?
18:21:05 <pollo> not really, there's a topic about volunteering that's related
18:21:09 <terceiro> hi
18:21:17 <terceiro> actually, I think I will need to do at least 1 more change
18:21:27 <terceiro> when I do that, what exactly breaks?
18:21:38 <wouter> nothing, I hope ;)
18:21:59 <pollo> Sreview should be able to update the schedule fine
18:22:01 <terceiro> pollo: you wanted a final schedule to open up volunteer sign ups?
18:22:13 <pollo> yeah, but it's final enough that it's ok
18:23:07 <wouter> terceiro: are the GUIDs static by now, or will things look weird?
18:23:37 <terceiro> wouter: even when they are static, they are tied to specific shedulings (and not to the talk itself)
18:23:56 <terceiro> so I think when I move a talk, "it's guid" changes
18:24:12 <terceiro> because it's not really the talk guid, it's the schedule item (talk x slot) guid
18:24:13 <wouter> terceiro: that completely misses the point then, as far as I'm concerned
18:24:24 <wouter> I need something that moves with the talk if it gets rescheduled
18:25:13 <wouter> anyway, it's not critical, as long as you remember that if the talk gets rescheduled, the upload URL changes too
18:25:25 <wouter> I gave you something so you can look it up again, which should help
18:25:54 <wouter> (and we can fix this for next time)
18:26:02 <terceiro> let's hope we do
18:26:04 <terceiro> :)
18:26:09 <wouter> you better ;-P
18:26:32 <pollo> anything else?
18:27:01 <pollo> #topic DC21 infra
18:27:17 <pollo> #info jibri has been fixed
18:27:21 <paddatrapper> \o/
18:27:26 <pollo> with that, the only thing that is broken is the etherpad
18:27:56 <wouter> which is going to be replaced by the q&a app, correct?
18:27:59 <pollo> it's not crucial, but annoying. We can problably fix it manually if we run out of time, but it'd be nice if the ansible role could be fixed
18:28:04 <pollo> wouter: not for BoFs
18:28:12 <wouter> oh, okay
18:28:15 <wouter> that makes sense, indeed
18:28:33 <pollo> I'd like us to schedule a general test
18:28:52 <pollo> I wanted to hold a training session this Saturday, but I guess it's a little soon
18:28:56 <pollo> not sure we'll be ready
18:29:22 <pollo> can we try to be ready for a test next Tuesday?
18:29:32 <wouter> I think that should be doable, yes
18:29:40 <paddatrapper> seems feasible
18:30:08 <pollo> is Tuesday 18:00 UTC too early, my schedule is very flexible
18:30:25 <wouter> that's 20:00 over here, should be fine for me
18:30:37 <paddatrapper> works for me
18:31:13 <pollo> #agreed General test of the infra Tuesday Aug 17th from 18:00 UTC to hopefully not too late afterwards
18:31:50 <pollo> anything else for this topic?
18:32:18 <paddatrapper> How much do we still need to spin up?
18:32:47 <pollo> ah true
18:32:49 <pollo> quite a bit
18:32:59 <wouter> we should probably not postpone that too long
18:33:07 <pollo> I was waiting for the VM size list, but I guess I can come up with numbers and we'll adjust
18:33:16 <pollo> #action pollo to spin the missing VMs
18:33:17 <wouter> perhaps spin up things this weekend, and see where that gets us?
18:33:28 <pollo> paddatrapper: can you paste the link to your ethercalc here please?
18:33:28 <paddatrapper> List is ip
18:33:38 <paddatrapper> yeah, just a sec
18:33:52 <paddatrapper> https://storm.debian.net/shared/3CdBgsGBwBbALlFLDW0_nWBpAl7jTEB8r4GKSZMchh9
18:33:55 <pollo> I've got DNS access now so it'll make thinks easier
18:34:01 <pollo> #link https://storm.debian.net/shared/3CdBgsGBwBbALlFLDW0_nWBpAl7jTEB8r4GKSZMchh9
18:34:15 <paddatrapper> There are sizes there for some things
18:34:33 <paddatrapper> wouter: can you update the specs required for the encoders?
18:34:50 <paddatrapper> and review (if we're running it on infomaniac
18:34:51 <paddatrapper> )
18:35:38 <wouter> checking
18:35:44 <wouter> (sorry, also having dinner in parallel ;-) )
18:35:52 <pollo> This can be done after the meeting
18:36:38 <wouter> sure
18:36:59 <pollo> Next topic?
18:37:13 <paddatrapper> yeah
18:38:12 <pollo> #topic DC21 volunteers
18:38:35 <pollo> as I mentioned previously, I wanted to hold a training session on the 14th
18:38:49 <pollo> I'll check my agenda and see if I can postpone it a week
18:39:31 <pollo> i've set up the access crendential pages and the wiki page: https://wiki.debian.org/DebConf/21/VideoVolunteering
18:39:47 <paddatrapper> I also want to try get a training session in, but depends on some other factors
18:40:32 <pollo> here's the draft "The Videoteam Needs You" email
18:40:34 <pollo> #link https://pad.riseup.net/p/videoteam-needs-you
18:41:01 <pollo> I'm planning to send it once the general test is over and we know we're good
18:41:33 <wouter> seems good
18:41:38 <pollo> tumbleweed: I need help with setting up the volunteer tasks in wafer
18:41:43 <wouter> perhaps also talk about volunteering for postprocessing reviews etc?
18:42:04 <wouter> (although usually urbec and valhalla manage to take care of that)
18:42:08 <pollo> wouter: that normally "just happens" yes
18:42:48 <pollo> I'm more concerned about filling the live slots
18:43:27 <tumbleweed> sorry, wasn't watching the time
18:44:35 <wouter> no stress, it happens
18:45:04 <pollo> anyway, wafer wrangling can also happen after the meeting :)
18:45:12 <pollo> #topic New Video Archive Mirror
18:45:18 <pollo> no news, keeping this not to forget
18:45:24 <pollo> #topic Any Other Business
18:45:26 <wouter> I think it's not our priority now ;)
18:45:47 <pollo> oh, we didn't talk about the loop
18:46:00 <pollo> afaiu, highvoltage is taking care of loopy
18:46:20 <wouter> still, would be good to record the status of that :)
18:46:29 * highvoltage will be sending out a mail for content very soon™
18:46:48 <pollo> #info highvoltage is taking care of loopy (main loop) and will be sending out a mail for content very soon™
18:46:59 <highvoltage> other than that no big surprises this time, I didn't have much time to come up with new and exciting stuff so it will pretty much be the same old formula
18:47:00 <pollo> I can take care of the maintenance loop and the backgroup loop
18:47:05 <highvoltage> great
18:47:14 <pollo> but if someone is itching to do it I don't mind it either
18:47:58 <highvoltage> I wished I could have replaced the sequencer by now, oh well, perhaps for a future minidebconf that also uses it
18:48:05 <pollo> #action pollo to take care of the maintenance and the background loops
18:48:15 <tumbleweed> re sizes earlier, the flavours available at infomaniak are: https://paste.debian.net/1207412/
18:48:17 <highvoltage> other than that any questions? I don't have much to say on that on this stage
18:48:50 <highvoltage> (otherwise ask and I'll answer after the meeting, also multitasking here right now)
18:48:52 <pollo> tumbleweed: we'll probably need a special queue for the large encoder
18:49:11 <pollo> as disk sizes are pretty low
18:49:18 <tumbleweed> one can add volumes
18:49:31 <pollo> ah, good
18:49:34 <wouter> tumbleweed: was just about to ask :)
18:50:09 <wouter> tumbleweed: is there a list somewhere with current VMs and their current types?
18:50:31 <pollo> wouter: they are mostly very small atm
18:50:43 <tumbleweed> wouter: https://paste.debian.net/1207413/
18:50:45 <pollo> the list should be the ethercal pasted earlier
18:51:14 <tumbleweed> it has desired sizes
18:51:16 <tumbleweed> no tactual sizes
18:51:51 <pollo> anything else?
18:52:23 <tumbleweed> what critical things do we need to look at?
18:52:30 <tumbleweed> etherpad
18:52:40 <wouter> q&a app improvements, I guess?
18:52:42 <tumbleweed> q & a issues (and review pollo's open MR)
18:52:48 <pollo> that's about it
18:52:58 <tumbleweed> spin up more VMs
18:53:06 <pollo> I'm taking care of that
18:53:08 <wouter> yeah, pollo actioned that
18:53:09 <tumbleweed> test run
18:53:11 <tumbleweed> yeah
18:53:15 <pollo> already scheduled
18:54:09 <tumbleweed> pollo: FWIW, paddatrapper reminded me that you need to bounce ssh connections to adayevskaya through master.debian.org (or something)
18:54:38 <wouter> through vittoria works too
18:54:44 <wouter> IIRC
18:54:46 <tumbleweed> probably through any DSA datacenters
18:54:50 <wouter> right
18:55:42 <pollo> ah, adayevskaya being the DNS thing, thanks
18:55:54 <pollo> #topic Next Meeting
18:56:03 <wouter> should we do one this weekend?
18:56:11 <wouter> after the test run etc
18:56:32 <pollo> We're meeting next Tuesday, I don't expect things to be done before that
18:56:47 <tumbleweed> my availability should improve after next Thursday
18:56:47 <pollo> I think meeting next Thursday is reasonnable
18:57:07 <wouter> okay, was just a suggestion
18:57:24 <pollo> Next Meeting Thursday August 19th from 18:00 to 19:00 UTC ?
18:57:29 <wouter> wm
18:57:34 <wouter> wfm, even
18:57:53 <tumbleweed> I'll be on a plane (probably without internet)
18:58:05 <wouter> going where?
18:58:10 <pollo> would Friday be better?
18:58:24 <tumbleweed> Canada, after putting the yacht on the hard
18:58:57 <tumbleweed> I'm sure I can catch up later
18:59:11 <pollo> #agreed Next Meeting Thursday August 19th from 18:00 to 19:00 UTC
18:59:15 <pollo> #endmeeting