20:05:37 <elmig> #startmeeting
20:05:37 <MeetBot> Meeting started Wed Nov 17 20:05:37 2010 UTC.  The chair is elmig. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:05:37 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:06:04 <elmig> otavio, bubulle : around?
20:06:31 * otavio is around
20:07:09 <elmig> i start with a summary of last meeting:
20:07:27 <elmig> - #599203 - data corruption due to os-prober - thanks to cjwatson;
20:07:46 <elmig> this was a ugly bug that was closed by cjwatson
20:08:01 <elmig> any comments?
20:08:26 <elmig> this bug was filled because a data corruption in a SAN
20:09:21 <elmig> #info - #599203 - data corruption due to os-prober - thanks to cjwatson;
20:09:58 <elmig> #info - partman-{ufs,zfs} is now localized - thanks to bubulle;
20:11:09 <elmig> #info - - #568877 - Hibernation with swap in LVM fails - thanks to otavio;
20:11:35 <elmig> i believe this was already commited by otavio
20:12:50 <otavio> yes; all those issues are fixes in dailies
20:13:07 <otavio> it looks like there's a partman segfault with an specific language
20:13:24 <elmig> we also discussed about: - Mail kfreebsd list regarding manual refactoring;
20:13:27 <otavio> cjwatson: did you  have time to look at the 5mb bug in parted?
20:13:38 <elmig> i don't know if someone pinged the mailing list
20:13:41 <elmig> (i haven't)
20:13:52 <elmig> otavio: i have that issue in my list
20:14:05 <otavio> elmig: the partman segfault?
20:14:10 <elmig> y
20:14:29 <otavio> elmig: good
20:14:38 <elmig> #action - Mail kfreebsd list regarding manual refactoring;
20:14:47 <cjwatson> otavio: hi.  yes, I have it in my local git tree, but I'd also like to fix the zero-length device thing (awaiting review on the patch I sent today)
20:15:02 <elmig> i don't know if zumbi is around...
20:15:04 <cjwatson> that's a really annoying one for automatic installs
20:15:07 <otavio> cjwatson: can you take a look into the partman segfault one?
20:15:16 <cjwatson> which bug'
20:15:17 <cjwatson> ?
20:15:32 <otavio> elmig: do you have the bug number off-hand?
20:15:37 <elmig> y
20:15:38 <cjwatson> is that the one cloned off the <1-cylinder bug?
20:16:01 <elmig> let's end the summary and i go the list of important bugs
20:16:03 <elmig> of this week
20:16:14 <elmig> #info - kernels for 3 arches lagging (sh4, alpha, m64k) - zumbi will ping porters page on this;
20:16:30 <elmig> i saw activity on the mailing list regarding this
20:16:57 <elmig> anyone can tell the status on this?
20:17:36 <otavio> elmig: those are "not released arches"
20:17:41 <otavio> elmig: so not "important" ATM
20:17:46 <elmig> #info - automated builds infrastructure status (gaudenz);
20:17:58 <elmig> any developments on this?
20:18:19 <elmig> #agreed sh4, alpha, m64k not released arches. low priority
20:18:37 <cjwatson> m68k, fwiw
20:18:43 <cjwatson> (not 64)
20:18:50 <elmig> yes :)
20:18:59 <elmig> #info - document how to use custom kernels with d-i (wiki, repo - installer/doc/ ?) - zumbi;
20:19:12 <elmig> i suppose he is not around. movinf on
20:19:31 <elmig> ok, current issues:
20:19:32 <cjwatson> isn't there a wiki page for that already?
20:19:49 <cjwatson> DebianInstaller/CustomKernelModify or some such
20:20:06 <otavio> cjwatson: i think it is outdated but is a start already
20:20:08 <elmig> #info check DebianInstaller/CustomKernelModify on wiki
20:20:25 <elmig> #info - #603459: debian-installer: Squeeze installer hanged at partitioning step when the language is selected as Turkish
20:20:33 <elmig> (this was the bug)
20:20:38 <cjwatson> I can look at that tomorrow
20:20:58 <elmig> partman fails with turkish language
20:21:11 <elmig> there's already an thread on -boot on this
20:21:36 <cjwatson> I guess it's the usual entertainment with turkish case rules
20:21:37 <elmig> there's some tips to reproduce it in turkisk
20:21:53 <elmig> any ideas to nail this?
20:22:00 <cjwatson> I'll sort it out
20:22:33 <elmig> #agreed cjwatson look into #603459
20:22:40 <cjwatson> I'm on the N900 right now so I can't look immediately
20:22:59 <elmig> #info - - "new" udebs, what should be added to the approval list - http://lists.debian.org/debian-boot/2010/10/msg00460.html
20:23:12 <elmig> otavio: please take a look into this
20:23:44 <elmig> it's about kfreebsd udebs
20:24:32 <elmig> #info - "incorrect partition tables, causing data loss and corruption" - http://lists.debian.org/debian-boot/2010/11/msg00651.html
20:24:52 <elmig> this issue is regarding overlapping partitions
20:25:27 <cjwatson> blink, oh my
20:25:30 <elmig> the cilinder that finishes one partition is the same the next starts
20:25:43 <cjwatson> I can look at that one too since it's probably to do with my code ...
20:26:08 <cjwatson> it might be notabug though, since we don't do cylinder alignment any more
20:26:21 <cjwatson> so you have to check the sector numbers, not just cylinders
20:26:24 <otavio> elmig: about http://lists.debian.org/debian-boot/2010/10/msg00460.html I talk with RM people
20:26:38 <elmig> #agreed about http://lists.debian.org/debian-boot/2010/10/msg00460.html I talk  with RM people
20:26:44 <elmig> (otavio)
20:26:53 <cjwatson> the cfdisk error suggests that we need an additional constraint though
20:27:59 <elmig> #agreed cjwatson will look into partitioning issue
20:28:08 <cjwatson> anyway, will look at that one tomorrow too, might as well just lob all the blocking partitioning stuff my way
20:28:14 <elmig> ( i will tested it on a vm and report if i found something)
20:28:41 <elmig> there was a RFC to -boot:
20:28:45 <elmig> #info - RFC: future size of embed area in partition labels - http://lists.debian.org/debian-boot/2010/11/msg00617.html
20:29:03 <otavio> IMO we ought to align in 1mb
20:29:13 <elmig> i guess this needs to be discussed in squeeze+1
20:29:22 <cjwatson> we always align to 1mb now
20:29:27 <elmig> in/for
20:29:32 <cjwatson> unless you explicitly preseed otherwise
20:29:53 <cjwatson> robert is several months out of date :)
20:30:01 <cjwatson> I'll follow up to him
20:34:40 <otavio> goo
20:34:41 <otavio> good
20:37:01 <cjwatson> ... anything else on the agenda?
20:39:58 <otavio> oops
20:40:07 <otavio> elmig had connection problems
20:41:46 <elmig> I am having connection problems
20:42:20 <otavio> elmig: we noticed :-)
20:42:29 <otavio> elmig: anything else in agenda?
20:42:48 <otavio> I ought to start moving packages into testing to allow us to upload installer
20:42:48 <elmig> Otavio I have sent u my notes
20:43:09 <otavio> and then get the images build and the media too
20:43:14 <elmig> Please use them as I cannot write fast in my phone
20:43:16 <otavio> so starting the tests
20:43:23 <elmig> :)
20:43:36 <cjwatson> none of the stuff on my list will impede uploading the initrds
20:44:11 <otavio> cjwatson: yes I know
20:44:24 <elmig> Otavio, received it?
20:44:27 <otavio> cjwatson: well, parted does
20:44:36 <otavio> cjwatson: libparted-udeb is inside initrd
20:44:37 <cjwatson> it does?
20:44:44 <cjwatson> never used to be
20:46:14 <cjwatson> well, just waiting for Jim to review my patch on bug-parted - he's normally quick
20:46:17 <otavio> cjwatson: IIRC it has something that depends on it
20:46:22 * otavio checks
20:46:26 <otavio> mom
20:48:22 <otavio> cjwatson: it does not
20:48:36 <otavio> cjwatson: but it blocks netinst images OK
20:48:52 <otavio> cjwatson: I mean bussiness card ones
20:49:16 <elmig_> i have network again
20:49:17 <cjwatson> ok, expected
20:50:12 <elmig_> #info - "Several leakage fixes" series of patches thanks to maximilian attems. Commit?
20:50:44 <elmig_> this is mostly adding frees() and closing open files
20:50:55 <cjwatson> the last leak fix required another udpkg upload to fix a segfault :P
20:50:58 <elmig_> one struct is removed in one of the last patches
20:51:13 <otavio> cjwatson: can you take a look on this changeset done by maks?
20:51:14 <elmig_> this can go after beta2?
20:51:17 <cjwatson> I'd recommend only doing things in long-running processes
20:51:26 <otavio> cjwatson: this would be rc1 material
20:51:32 <cjwatson> where leak fixes are actually worthwhile
20:51:49 <joeyh> I looked it over, and it looked ok, but I'd prefer to defer insignificant leak fixes
20:52:26 <elmig_> after beta2 or post-squeeze?
20:53:02 <joeyh> post squeeze
20:54:20 <elmig_> agreed?
20:54:33 <otavio> elmig_: sure. I trust joeyh advice :-)
20:54:49 <otavio> elmig_: post-squeeze material.
20:54:57 <cjwatson> well, it makes sense to me.  the only thing I'd want to do would be things like cdebconf or main-menu leaks
20:54:58 <elmig_> #agreed leak fixes minor, after squeeze
20:55:11 <otavio> maks: keep those in a branch so you can "put it back" once we migrate to git
20:55:32 <otavio> cjwatson: those does make sense
20:55:35 <elmig_> wheeze goals wiki page. Time to create it?
20:55:51 <otavio> elmig_: I guess so.
20:55:56 <joeyh> when is the git migration?
20:55:57 <elmig_> we need a place to write down these things
20:56:05 <otavio> joeyh: just after rc
20:56:10 <elmig_> #agreed create wheeze goals wiki page
20:56:19 <otavio> joeyh: My plan is began of december if all goes well
20:56:50 <elmig_> who will do it? otavio? joey?
20:57:09 <otavio> joeyh: can we could on you do make it together with me?
20:57:53 <joeyh> yes, I should have time to work on it then
20:57:58 <otavio> good
20:57:59 <elmig_> #agreed move to git in december (2010) - otavio, joey
20:58:08 <elmig_> #info - - initrd is too fast for md - http://lists.debian.org/debian-boot/2010/11/msg00310.html
20:58:10 <otavio> joeyh: good and thx
20:58:34 <otavio> elmig_: this is a initramfs-tools or mdadm issue
20:58:51 <elmig_> reassign it?
20:58:56 <otavio> elmig_: or a kernel one. Since async probing looks to have caused it
20:58:57 <elmig_> anyone will look into this?
20:59:33 <otavio> elmig_: I'd say to assign it to mdadm.
21:00:03 <elmig_> #agreed assign md issue (too fast) to mdadm
21:00:22 <elmig_> - #601782 installation report - beta1 installer fails with kernel error - drivers/md/md.c:6192, invalid opcode
21:01:41 <elmig_> any ideas on this?
21:02:14 <otavio> elmig_: reassign to linux-2.6
21:02:43 <elmig_> #agreed #601782 reassign to linux-2.6
21:02:52 <elmig_> #info - Trouble running the installer image for kFreeBSD/i386 - screen problems - http://lists.debian.org/debian-boot/2010/11/msg00250.html
21:03:04 <elmig_> there's a photo with the problem
21:03:19 <elmig_> the screen is not all used
21:03:20 <elmig_> just a few lines
21:04:43 <otavio> aurel32: http://lists.debian.org/debian-boot/2010/11/msg00250.html can you take a look?
21:05:09 <joeyh> looks to me like each character is being displayed 1 pixel tall
21:05:16 <joeyh> or maybe 4 pixels
21:06:00 <elmig_> #info - #600671 - grub2 failed to install with lvm
21:06:46 <elmig_> grub2 needs lvm module?
21:07:05 <elmig_> there's a log of what happened
21:07:16 <elmig_> grub installer fails iirc
21:07:36 <elmig_> but i don't see/know if needs to use lvm module
21:07:38 <cjwatson> urgh.  add yet another one to my list
21:07:52 <maks> otavio: ok no trouble they are in a branch can sent pull request any time you guys moved to git.
21:07:57 <elmig_> #agreed cjwatson will look into #600671
21:08:16 <maks> can you please fix the oneliner I sent in the manual concerning the preseed file
21:08:33 <elmig_> #agreed maks will keep leak fixes in git
21:08:40 <otavio> maks: don't you have commit rights?
21:09:01 <maks> it is referencing an outdated initramfs generator.
21:09:19 <maks> no please keep seeing me as an "outsider" (:
21:09:30 <elmig_> #agreed apply fix to the manual concerning preseed file
21:10:01 <elmig_> there is also a patch to improve remote installation documentation
21:10:07 <elmig_> (ssh)
21:11:16 <elmig_> btw, is it safe to change to manual in this point in time? :>
21:11:35 * elmig_ looks for bubulle
21:11:50 <otavio> elmig_: if we unfuzzy it, yes
21:12:12 <elmig_> ufff
21:12:15 <elmig_> #info - Installer artwork - http://wiki.debian.org/DebianArt/Themes/SpaceFun
21:12:25 <elmig_> there's an image for the installer...
21:12:34 <otavio> Yes .. and for syslinux boot too
21:12:44 <otavio> I wonder if we ought to apply it or not
21:13:05 <elmig_> as a whole yes, imho
21:13:10 <elmig_> in this point in time... dunno
21:13:39 <otavio> elmig_: it should be trivial to get it done. I can work on this. The problem is if we ought or no to "use" desktop artwork for it
21:14:09 <elmig_> even grub got the theme
21:14:15 <elmig_> it's already in sid
21:15:20 <elmig_> the cd covers is also nice, we could linkt to it from the installer page
21:15:27 <cjwatson> consistency across the distro does seem nice to have
21:16:12 <elmig_> #agreed otavio will look into the new artwork
21:16:27 <elmig_> (i can help you with this)
21:16:37 <elmig_> #info - Bug#602421: installation-reports: Squeeze Installation - apt does not appear to be scanning multiple DVDs correctly during graphical installation
21:17:10 <elmig_> this BR is filled by jon 'maddog', he changed a lot of dvds for nothing
21:17:19 <CIA-2> debian-installer: 03otavio * r65661 10manual/en/appendix/preseed.xml:
21:17:19 <CIA-2> debian-installer: preseed example use initramfs-tools as default
21:17:19 <CIA-2> debian-installer: Use the default generator as recommendation.
21:17:19 <CIA-2> debian-installer: Signed-off-by: maximilian attems <max@stro.at>
21:17:45 <maks> otavio: thx.
21:18:08 <elmig_> #info mak's preseed fixed - already applied
21:18:38 <elmig_> it suggests that scanning multiple discs is not working
21:18:43 <CIA-2> debian-installer: 03otavio * r65662 10manual/ (19 files in 19 dirs): unfuzzy translations due preseed example change
21:19:18 <elmig_> anyone familiar with this?
21:19:41 <otavio> who did it was fjp. I never played with this code
21:19:46 <otavio> cjwatson: have you done?
21:19:53 <otavio> joeyh: ?
21:20:26 <elmig_> what package deals with this? cdrom-retriever?
21:20:35 <cjwatson> apt-setup
21:20:50 <cjwatson> I converted it to in-target, suppose it could have been that
21:21:04 <elmig_> #info the BR can be related with apt-setup
21:21:05 <cjwatson> but I already have enough action items, I think
21:21:19 <elmig_> cjwatson: can i write one more for you?
21:21:45 <elmig_> i can test it on the weekend and report what i find
21:22:00 <elmig_> #agreed test multiple cds installation
21:22:09 <elmig_> #info - #603353 - dummy dpkg status causes warning. patch from Loïc Minier.
21:22:17 <cjwatson> um, the more I have the longer it will take, serialisation not really a good thing here
21:22:34 <cjwatson> surely somebody with more bandwidth could work it out
21:22:49 <cjwatson> I would recommend against #603353
21:23:01 <cjwatson> not for squeeze anyway
21:23:26 <cjwatson> it shouldn't be necessary
21:23:58 <elmig_> post-squeeze then?
21:24:19 <otavio> elmig_: the DVD problem ought to be before; the warnings post
21:24:20 <cjwatson> I've been discussing this with loic, I don't think debootstrap should change
21:25:28 <otavio> cjwatson: agreed
21:25:49 <elmig_> #agreed #603353 not for squeeze
21:26:12 <elmig_> if it's a won't fix needs to go to the BR
21:26:40 <elmig_> so, new blockers for release?
21:27:05 <elmig_> (new know blockers, from the agenda)
21:27:32 <elmig_> the turkish languae issue?
21:27:54 <otavio> sure
21:28:11 <elmig_> any more?
21:29:38 <elmig_> otavio: i have proposed changes to the errata
21:30:15 <elmig_> i can commit it when i have back my internet connection
21:30:51 <elmig_> (it's the turkish language issue and missing fonts)
21:30:52 <otavio> Will you be online longer?
21:30:57 <otavio> ahh those OK
21:30:59 <otavio> commit them
21:31:07 <otavio> missing fonts fixed in dailies
21:31:13 <elmig_> dunno i am spending my data plan :P
21:31:26 <elmig_> so... Beta2 announcement?
21:31:27 * bubulle arounc for 5 minutes..:-(
21:32:06 <elmig_> as you were not here we decided to change all localized messages :)
21:33:04 <elmig_> bubulle: feel free to expose your points
21:33:19 <bubulle> quickly reading backlog ATM
21:33:36 <elmig_> otavio: Beta2, when will be released?
21:34:03 <elmig_> (and the announcement that needs to be prepared)
21:34:16 <bubulle> ah, apparently cjwatson has a clue about the failing turkish partman...
21:35:29 <bubulle> talked abou tthis bug report about /tmp being 777?
21:35:48 <elmig_> nope
21:35:55 <bubulle> just from today
21:36:26 <bubulle> #603798
21:36:48 <bubulle> also, #575309 which I reveived but I fear it's too late for this
21:37:39 <otavio> for b2 probably
21:37:51 <otavio> for rc1 depends on what we need to change
21:37:56 <bubulle> for rc1, I'm not that keen to have such invasive change
21:38:05 <elmig_> #info #603798 /tmp 777
21:38:28 <bubulle> I have a virtual machine currently trying to reproduce #603798
21:39:21 <otavio> I do need to go out
21:39:49 <elmig_> #agreed #575309 - not for beta2, needs to be evaluated to RC1 or post-squeeze
21:40:00 <elmig_> otavio: beta2 release date?
21:40:07 <bubulle> elmig_: no other issue I see
21:40:14 <bubulle> no objection from me for b2
21:40:52 <bubulle> for rc1, probably some more changes to console-setup and maybe switch from console-data to console-setup in the text installer
21:40:56 <elmig_> bubulle: there's a patch to the manual... not sure it can be commited
21:41:03 <bubulle> ah, and also how about graphical installer by default?
21:41:05 <elmig_> regarding remote installation
21:41:20 <elmig_> good question :)
21:41:27 <bubulle> elmig_: youpi wasn't really enthusiast about that patch
21:41:35 <bubulle> let him the decision
21:42:06 <elmig_> #agreed wait for youpi's comment on the manual patch (ssh installation)
21:42:07 <bubulle> about graphical installer by default on i386 and amd64, I think we decided to do it quite a while ago but never did
21:42:20 * bubulle doesn't remember where such magic lies
21:42:40 <elmig_> installer/build/ maybe
21:44:42 * bubulle just completed a base system install with separate /tmp
21:45:02 <bubulle> my /tmp is 1777 as expected
21:46:11 <elmig_> i have no more points in my list
21:46:16 <elmig_> anyone?
21:46:41 <phil> We want volatile to be named -updates for squeeze.
21:46:54 <phil> Is that still doable from d-i PoV?
21:47:01 <bubulle> as long as templates aren't changed, I'm fine with that..:-)
21:47:02 <phil> It would be carried on the main mirrors.
21:47:29 <bubulle> (except dropping entire paragraphs which is OK)
21:47:30 <elmig_> #info volatile to be changed for -updates for squeeze
21:47:47 <phil> The update policy was outlined in a recent post on d-d-a (RT meeting minutes), which is basically "everything what's in there will go into the next point release".  So for speedy urgent updates like regression fixes and also volatile software.
21:48:07 <phil> This is currently blocking on a d-i statement if that's feasible.  (Granted, only asked in here, not on the ML.)
21:48:36 <bubulle> I think this is feasible as we briefly discussed together (don't remember if that was on IRC or by mail)
21:48:50 <phil> IRC.
21:48:55 <elmig_> apt-setup needs to be changed?
21:48:58 <bubulle> changes have to be made in apt-setup
21:50:23 <bubulle> apt-setup/generators/92volatile
21:50:32 <elmig_> #info apt-setup will need a patch to the volatile name change
21:50:43 * bubulle really has to go
21:51:19 <elmig_> thanks all for participating
21:51:20 <elmig_> #endmeeting
21:51:27 <phil> Thanks.
21:51:30 <maks> ext4 item elmig_ ? (at least the menu list ordering would be cool)
21:52:00 <maks> ext3 -> ext4 -> ext2 is a strange order.
21:52:37 <elmig_> iirc there was no decision to change the default fs for squeeze on di
21:52:38 <cjwatson> that part is obviously easy to change.  I'd be pretty cautious of changing the default though.
21:53:01 <cjwatson> however I have a vague memory that the order governs which one is offered as the default in manual partitioning
21:53:04 <otavio> bubulle: for rc1 move to console-setup?
21:53:29 * cjwatson tries to find the code
21:53:57 <phil> We'd possibly veto an ext4 choice without nodelalloc at this point.
21:54:01 <cjwatson> yes, I think it does, there's nothing else setting that default
21:54:07 <phil> Due to dpkg not really coping with it.
21:54:12 <cjwatson> so I really think that the order ought to go hand in hand with the default filesystem
22:21:26 <cruejones> cjwatson: hi, sorry for mucking in the ubuntu irc
22:27:16 <cjwatson> that's ok
22:27:27 <cjwatson> do you have a full syslog of this bad-mirror problem?
22:28:02 <cjwatson> (cruejones is trying to netboot off a DVD as a mirror substitute, which I suspect won't work for various reasons but it's odd that it would say it's a bad mirror)
22:28:23 <cruejones> yes, I do
22:28:52 <cruejones> and I just compared my /dists/lenny/Release file to a public mirror and can't find a difference
22:29:09 <cruejones> any good place to pastebin the syslog?
22:29:12 <cjwatson> which netboot initrd did you get?
22:29:17 <cjwatson> paste.debian.net should work
22:30:22 <cruejones> hmm, no ssh or ftp on the netinstall initrd
22:30:29 <cruejones> only have console access
22:30:33 <cjwatson> "save debug logs" on the installer main menu
22:31:20 <cruejones> cool, thanks
22:31:31 <youpi> about the manual patch for ssh installation, I don't like duplication of documentation, yes. A hypertext reference is all we need here
22:32:35 <youpi> about using console-setup instead of kbdchooser in the text installer, we'd probably need to reduce its size first
22:32:56 <youpi> else it might cause initrd size issues
22:33:14 <cjwatson> seems a bit late for such a change really
22:33:18 <cjwatson> much though I prefer console-setup
22:33:34 <youpi> yes, I didn't plan to switch the text installer for squeeze
22:34:07 <cruejones> syslog @ http://paste.debian.net/100087/
22:36:06 <cruejones> wonder if this message has anything to do with it "INFO: mirror does not have any suite symlinks"
22:36:48 <cjwatson> well
22:36:51 <cjwatson> what does http://192.168.2.101/install/debian-5.06-x86_64/dvd1//dists/lenny/Release look like?
22:37:46 <cruejones> http://paste.debian.net/100088/
22:40:09 * cjwatson wades through code
22:42:26 <cjwatson> sorry, this code is really hard to follow, but I think the intent is that it checks dists/foo/Release for Suite and Codename and checks that it can be accessed using both dists/<suite>/Release and dists/<codename>/Release
22:42:36 <cjwatson> so I suspect that it will work better if you make a stable -> lenny symlink
22:42:47 <cjwatson> you also have a bunch of:
22:42:48 <cjwatson> Nov 17 21:52:45 main-menu[1014]: (process:2894): wget: server returned error: HTTP/1.1 403 Forbidden
22:43:02 <cjwatson> so check your HTTP server configuration
22:43:06 <cjwatson> not to mention its error logs
22:43:41 <cruejones> ok, I can try that - and those forbiddens are strange - not sure what it is trying to get, will check apache logs
22:45:09 <cjwatson> dear netboot install running in kvm here: it's a LOCAL MIRROR, it's not that hard
22:47:03 <cruejones> cjwatson: both the <suite> and <codename> /dist/<>/Release files are also there
22:47:12 <cruejones> I suspect the forbidden now
22:47:31 <cruejones> can access via web so not sure why debian installer is having an issue
22:48:07 <cruejones> web->browser
22:54:17 <CIA-2> debian-installer: 03di-l10n-guest * r65663 10packages/po/ (4 files in 4 dirs): [l10n] [SILENT_COMMIT] Updated packages/po/* against package templates
22:55:29 <cruejones> ok, /dists is not available because it is really a unionfs mount created to get ride of the symlinks on the iso - installer does not seem to like symlinks
22:55:42 <cruejones> need to figure out how to get apache to share this as well
22:58:43 <cruejones> cjwatson: many thanks for the help - i need to look into this weird apache/unionfs issue to proceed
23:02:01 <youpi> otavio: will you fast-track brltty for beta2?
23:02:20 <youpi> (it's really just a question, I don't ask for it, I'm just wondering)
23:20:07 <CIA-2> debian-installer: 03di-l10n-guest * r65664 10packages/ (6 files in 6 dirs): [l10n] [SILENT_COMMIT] Synchronising with translation files from packages/po
23:47:14 <cjwatson> hmm, I suspect gdb will work better if I use mklibs-copy
23:47:29 <youpi> indeed :)
23:47:34 * cjwatson is having a go at the Turkish bug before bed, but may have to give up and start fresh tomorrow
23:47:53 <cjwatson> happens for me with a self-made image, fortunately
23:49:58 <cjwatson> so insert debug build of cdebconf, persuade it to dump core, scp out ... just tedious
00:27:04 <CIA-2> debian-installer: 03sthibault * r65665 10packages/console-setup/debian/ (72 files in 2 dirs):
00:27:04 <CIA-2> debian-installer: * debian/keyboard-configuration.templates: Rename Bulgarian into Bulgarian
00:27:04 <CIA-2> debian-installer:  (phonetic layout), rename Bulgarian (BDS layout) into Bulgarian. Fix
00:27:04 <CIA-2> debian-installer:  translations accordingly.
00:27:04 <CIA-2> debian-installer: * debian/keyboard-configuration.config: For Bulgary, use the BDS layout by
00:27:05 <CIA-2> debian-installer:  default, as this is what non-technical people usually know.
01:00:54 <cjwatson> some hideous bug in the depths of stralign by the looks of it ...
01:01:01 <cjwatson> (the Turkish partitioner crash)
01:03:16 <cjwatson> valgrind is showing up some useful stuff
01:04:20 <otavio> youpi: yes. Will do
01:04:50 <otavio> youpi: I want to move more changes as possible into beta2 to reduce the amount of changes of rc1
01:07:35 <youpi> ok, I have a tiny fix needed for some braille devices, I guess I should upload it then
01:24:36 <bwh> otavio: Is the ext4 switch done/planned to be done?
01:25:49 <otavio> bwh: as default? no
01:26:07 <otavio> bwh: I think it is too late for changing it
01:26:25 <otavio> bwh: althought I am using ext4 in production without any issue
01:28:51 <bwh> otavio: Why is it too late to change it?
01:29:43 <youpi> because bugs hide well enough
01:30:31 <bwh> What kind of bugs?
01:30:36 <youpi> any
01:30:53 <youpi> could be just an assumption that ext3 is being used in some d-i script for instance
01:31:12 <bwh> Don't be ridiculous, users get to choose the filesystem anyway
01:31:35 <youpi> and has the ext4 choice really been tested in all kind of configurations?
01:32:15 <bwh> It's been tested with every other distro
01:32:32 <youpi> I said "in some d-i script for instance"
01:33:01 <bwh> If you have some specific objection like it will use more reserved space, please say so, otherwise this objection could be made to any change
01:33:18 <youpi> did I say that?
01:33:25 <youpi> I said "bugs hide well"
01:33:35 <youpi> "in some d-i scripts for instance"
01:33:50 <youpi> it has nothing to do with ext4 itself, and ext4 testing by other distros either
01:33:55 <bwh> If there is a bug in handling ext4 it had better be fixed anyway, since many users will want to use it
01:34:14 <otavio> bwh: dpkg has issues with it
01:34:20 <otavio> bwh: this is a good reason to me
01:34:23 <youpi> bwh: sure, but that's not a reason to make it a default
01:35:10 <otavio> bwh: I am focused in making d-i work better and not going to change defaults that late in release.
01:35:17 <bwh> Well, shit, let's just make our users live with crappy ext3 for another few years
01:35:32 <bwh> because we can't be bothered to test ext4 properly
01:35:44 <otavio> bwh: you might have talked to us when we were preparing alpha1
01:36:01 <otavio> bwh: that would have been the right time to change it
01:36:36 <bwh> Sure, this should have been changed earlier. You're saying no functional changes are allowed now?
01:37:15 <otavio> bwh: dpkg has issues with it
01:37:24 <youpi> otavio: I've uploaded the fixed brltty=4.2-6 package. I guess I still need to request debian-release for an unblock?
01:37:27 <otavio> bwh: we need to have this fixed before doing it
01:37:30 <bwh> dpkg is, erm, yeah, special
01:37:37 <otavio> bwh: and this is late for it
01:37:44 <bwh> and I will look at and answer that message shortly
01:37:48 <KiBi> youpi: yeah, and otavio to ack it; or ask it for you :)
01:38:07 <otavio> KiBi: will do it together with other udebs
01:39:20 <otavio> youpi: you and bubulle are planning to get console-setup into text installer?
01:39:28 <youpi> I didn't plan to
01:40:24 <youpi> at least since there may be size issues, non-detection of serial console / UML, and other things like that which haven't been fixed
01:40:57 <youpi> (and it has been tested only in graphical images, i.e. only a few architectures)
01:42:55 <derrick> I'm trying to read a preseed file off a usb stick when installing 5.0.6.  I'm booting with the args expert file=/hd-media/preseed.cfg and when d-i tries to load th file,  it gives an error.  I dropped to a terminal and
01:43:02 <derrick> checked the usb stick,  and it's not even mounted.  I tried mounting manually and it mounts fine and the file is there.  Anyone have any ideas?
01:43:33 <youpi> what errors does it give?
01:43:47 <bwh> derrick: What is the boot device?
01:44:38 <derrick> failed to retrieve the preconfiguration fil,  the filed needed could not be rtrieved from file:///hd-media/preseed.cfg.  Th installation will proceed in non-autmated mode
01:45:29 <derrick> was the error,  I booted off the cd drive /dev/sr0 and the usb stick cam up as sda,  with my 2 sata drives as sdb, and sdc
01:47:22 <cjwatson> bwh: since Ubuntu switched to ext4 I've had nothing but complaints about how slow the installer is
01:48:03 <cjwatson> I'd switch back except that would be politically hideous
01:48:10 <derrick> There isn't much else helpful when booting with DEBO
01:48:45 <derrick> DEBCONF_DEBUG=5
01:49:35 <cjwatson> nodelalloc sounds promising but I've not yet done performance comparisons
01:50:42 <cjwatson> (well, OK, before I had complaints about how slow the installer is, I had several hundred bugs about how unreliable dpkg was, but we all know the story there)
02:33:24 <cjwatson> otavio: FYI - I basically see the structure of the stralign bug in #603459, but it's tedious arithmetical code so I'll be better off fixing it after sleep
02:33:37 <bwh> cjwatson: Hrm.
02:36:27 <cjwatson> otavio: it doesn't actually look specific to Turkish - it'll only happen with non-ASCII text, certainly, but I think it's more to do with the relative shapes of columns aligned using ${!TAB}
02:37:08 <cjwatson> and how the differences between printed character width and byte length compare to the variance in column length
02:37:33 <cjwatson> so not common, precisely, but I would be surprised if only Turkish happened to hit it
02:48:30 <otavio> cjwatson: oh man. What a boring bug to debug
02:55:16 <cjwatson> tell me about it.  I believe it happens when the first column of a two-column layout contains two different strings one of which has the longest printed width but the other of which has the longest byte length
02:55:46 <cjwatson> anyway.  bed
05:40:27 <aurel32> otavio: I have already seen that, got some more details, but I have no idea what is the issue
07:12:56 <CIA-2> debian-installer: 03tenzin-guest * r65666 10win32-loader/l10n/po/dz.po: Dzongkha Translation update
09:07:37 <CIA-2> debian-installer: 03cjwatson * r65667 10packages/cdebconf/ (debian/changelog src/strutl.c):
09:07:37 <CIA-2> debian-installer: * Compute stralign cell byte sizes in a separate pass after computing cell
09:07:37 <CIA-2> debian-installer:  character widths. This allows us to add correct per-cell padding of one
09:07:37 <CIA-2> debian-installer:  byte per character difference from the maximum cell width. The previous
09:07:37 <CIA-2> debian-installer:  algorithm gave the wrong size when the cell with the longest byte length
09:07:38 <CIA-2> debian-installer:  was not the cell with the longest character width (closes: #603459).
09:07:40 <CIA-2> debian-installer: * Don't bother padding cells in the last column.
11:02:20 <WAB> hello :) I'm have a little trouble with squeeze install on netbook samsung n150. Anybody can help me a little ?
11:03:48 <WAB> I install primary system, and have problem with Xorg configuration
11:03:49 <WAB> :)
11:04:15 <WAB> (EE) open /dev/fb0: no such file or directory
11:04:34 <WAB> (EE) intel(0): No kernel modesetting driver detected
11:04:52 <WAB> (EE) Screen(s) found, but none have a usable configuration
11:05:28 <WAB> and "dpkg-reconfigure xserver-org" doesn't work, after this command notning happen
11:05:45 <WAB> what is going on?
11:07:08 <cjwatson> probably better ask the X guys - you're beyond the stuff that this channel typically deals with
11:07:26 <cjwatson> (I think some X people do hang out here, but still the wrong channel really :-) )
11:12:24 <WAB> cjwatson, hm, I'm here because I know it's only installing question.
11:12:31 <WAB> cjwatson, even http://wiki.debian.org/InstallingDebianOn/Samsung/Samsung%20N150
11:12:56 <CIA-2> debian-installer: 03cjwatson * r65668 10packages/cdebconf/debian/changelog: releasing version 0.152
11:13:05 <CIA-2> debian-installer: 03cjwatson 07packages * r65669 10/cdebconf/0.152/: tagging version 0.152
11:13:06 <cjwatson> WAB: the installer doesn't do any X configuration
11:13:38 <cjwatson> WAB: the X packages are entirely responsible for that
11:13:56 <WAB> cjwatson, hm, so, I have only primary system, then mayby I dont have hardware detection or so?
11:14:03 <WAB> hm
11:14:45 <cjwatson> so, if you want help, you need to ask people who know about X, rather than people who know about the installer
11:15:21 <WAB> cjwatson, ok thank, so I need to find X irc channel :)
11:16:36 <WAB> cjwatson, and I need only one thing more, do you know where I find list of package for installation "primary system" "graphical environment" "server ssh" etc ?
11:23:18 <symoon> WAB: /usr/share/tasksel/debian-tasks.desc from taskel-data package
11:25:15 <WAB> symoon, thank :)
11:26:29 <KiBi> WAB: there's nothing to reconfigure. That sounds like your kernel might be missing some bits. cat /proc/version?
11:33:01 <WAB> KiBi, Linux version 2.6.32-5-686 (Debian 2.6.32-27) (maks@debian.org) (gcc version 4.3.5 (Debian 4.3.5-4 ) #1 SMP Sat Oct 30 22:47:19 UTC 2010
11:34:29 <KiBi> /join #debian-x please.
11:39:57 <WAB> KiBi, thanks
11:40:53 <jcristau> 00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller << what the hell is that one?
11:41:38 <WAB> i don't know :)
11:41:55 <WAB> wait, I make lspci
11:42:20 <jcristau> ah pineview
11:42:51 <WAB> 00:02:1 Display controller: Intel Corporation N10 Family Integrated Graphics Controller
11:43:27 <WAB> 00:02:0 VGA compatibile controller: Intel Corporation N10 Family Integrated Graphics Controller
12:50:24 <mjt> 00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller (rev 02)
12:50:35 <mjt> that's pinetrail (D510)
12:55:09 <jcristau> the driver calls it pineview (pnv).
14:49:30 <jcristau> bubulle: i'm supposed to get otavio's ack before unblocking udev
16:03:49 <otavio> jcristau: it can go. I will ask for unblocks tomorrow  Iguess
16:04:32 <jcristau> otavio: ok
16:05:01 <otavio> jcristau: I am busy at work now, ping me if you need something
16:21:23 * cjwatson tries to deal with #568529
16:21:30 <cjwatson> ("overwrites MBR of installation medium")
16:22:51 * Sledge saw that last night too :-(
16:32:32 <cjwatson> Ubuntu's grub-installer has patches to avoid it, but I need to adjust for the isohybrid stuff
16:58:15 <CIA-2> debian-installer: 03tbm * r65670 10packages/flash-kernel/ (debian/changelog initramfs-tools/hooks/flash_kernel_set_root):
16:58:15 <CIA-2> debian-installer: Don't set a default root device when the specified root device
16:58:15 <CIA-2> debian-installer: does not exist.
17:04:01 <CIA-2> debian-installer: 03tbm * r65671 10packages/flash-kernel/debian/changelog: releasing version 2.37
17:04:34 <CIA-2> debian-installer: 03tbm 07packages * r65672 10/flash-kernel/2.37/: tagging version 2.37
17:14:09 * cjwatson tortures kvm/d-i into thinking that a hard disk is a USB device for these purposes
17:33:46 * bubulle reads cjwatson's changelog for fixing #603459 and eh's....
17:36:34 <KiBi> yeah
17:41:09 <cjwatson> moderately painful to find; what I did was to run with DEBCONF_DEBUG=20 which showed it dying immediately after a "Splitting [...]" debug message, which narrowed it down to either strchoicesplit or just afterwards, then I set up the exact same debconf question in a cdebconf instance on a real system and ran it under valgrind
17:42:04 <cjwatson> cdebconf does annoying things to the terminal, but if you avoid using valgrind's --log-file option then you can intersperse debugging messages from cdebconf with fprintf(stderr, ...); fflush(stderr);
17:42:28 <cjwatson> and just redirect that to a file, so from there it's iteration of printf debugging
17:42:33 <bubulle> otavio: we need to ask an unblock for tasksel
17:42:39 <bubulle> and upload a new version, indeed
17:43:05 <jcristau> and i guess you need busybox/mipsel
17:43:07 <jcristau> grrr
17:59:04 <cjwatson> ok.  so the result of this is slightly ugly (it forces you to get asked grub-installer/bootdev rather than grub-installer/with_other_os or grub-installer/only_debian when installing from USB) but I think that's OK for now as it means you're prompted to think about it a bit more and correctness should trump relatively minor usability problems anyway
17:59:23 * cjwatson is just testing a normal USB install
17:59:28 <cjwatson> er, normal CD install
20:03:26 <CIA-2> debian-installer: 03joeyh * r65673 10scripts/togit/README: update with pre and post conversion checklists
20:47:23 <CIA-2> debian-installer: 03erispre-guest * r65674 10win32-loader/l10n/po/nl.po: Updated dutch PO translation
21:09:53 <CIA-2> debian-installer: 03holger-guest * r65675 10packages/po/ (sublevel1/de.po sublevel2/de.po sublevel3/de.po): Polishing german d-i translation
22:15:13 <CIA-2> debian-installer: 03bubulle * r65676 10packages/console-setup/debian/ (changelog po/id.po po/ku.po po/pa.po po/uk.po):
22:15:13 <CIA-2> debian-installer: * Ukrainian (Borys Yanovych). Closes: #603863
22:15:13 <CIA-2> debian-installer: * Indonesian (Arief S Fitrianto). Closes: #603879
22:15:13 <CIA-2> debian-installer: * Punjabi.
22:15:13 <CIA-2> debian-installer: * Kurdish (Amed ?\195?\135eko Jiyan).
22:28:42 <CIA-2> debian-installer: 03bubulle * r65677 10packages/console-setup/debian/ (changelog po/sv.po): Swedish (Daniel Nylander).
23:20:31 <CIA-2> debian-installer: 03di-l10n-guest * r65678 10packages/ (18 files in 18 dirs): [l10n] [SILENT_COMMIT] Synchronising with translation files from packages/po
23:29:30 <CIA-2> debian-installer: 03elmig-guest * r65679 10packages/kernel/kernel-wedge/ (debian/changelog modules/ide-modules): revert sl82c105
00:16:20 <CIA-2> debian-installer: 03cjwatson * r65680 10packages/arch/i386/grub-installer/ (debian/changelog grub-installer): (log message trimmed)
00:16:20 <CIA-2> debian-installer: * Merge changes from Ubuntu by Evan Dandrea and myself:
00:16:20 <CIA-2> debian-installer:  - Set a sensible default boot device, so that we aren't installing GRUB
00:16:20 <CIA-2> debian-installer:  to installation media which may be removed later. The disk containing
00:16:22 <CIA-2> debian-installer:  /cdrom is very unlikely to be a sensible default. If we had to fall
00:16:22 <CIA-2> debian-installer:  back to (hd0), then we can't tell exactly which disk that is, but if
00:16:24 <CIA-2> debian-installer:  /cdrom seems to be a USB stick then (hd0) may not be safe. If we hit
01:31:31 <cruejones> hi, wondering if debian stores a preseed file somewhere on the filesystem after running through a manual install?
01:33:23 <youpi> no, but you can extract it
01:33:28 <youpi> $ debconf-get-selections --installer > file
01:33:36 <youpi> $ debconf-get-selections >> file
01:33:42 <youpi> However, a file generated in this manner will have some items that should not be preseeded, and the
01:33:43 <youpi> example file is a better starting place for most users.
01:33:53 <youpi> (from the installation manual, preseed section)
01:37:18 <cruejones> youpi: thanks
01:37:35 <cruejones> so if I just use the generated files it will not work?
01:37:57 <youpi> it will
01:38:02 <youpi> but it will preseed _everything_
01:38:19 <youpi> i.e. debconf for all installed packages
01:38:37 <cruejones> ok, so if say I want to rebuild a system exactly the same way it will do that
01:38:44 <youpi> yes
01:38:57 <cruejones> cool - that is what I was looking for
01:38:58 <cruejones> thanks!
01:39:07 <youpi> that'll not include the list of packages, however
01:39:18 <cruejones> ok
01:39:31 <youpi> but you can use dpkg --get-selections  then dpkg --set-selections; apt-get dselect-upgrade for that
01:39:56 <youpi> (and since all debconf will be preseeded already, it shouldn't ask any question)
01:39:57 <cruejones> ok, thanks
02:10:08 <mattyp> got an installation question.. anyone?
02:11:01 <womble> mattyp: /topic
02:11:09 <womble> This channel is for development, not support
02:11:16 <womble> #debian is the place you want.
02:11:25 <mattyp> ok thanks
09:24:34 <wferi> Md: I ran into a problem with udev during lenny->squeeze upgrade: apt-get install udev just froze uninterruptably. The system otherwise works pretty well, I can open new urxvts, but sudo freezes.
09:24:58 <wferi> ps shows an udevd --daemon child of udev.postinst configure 0.125-7+lenny3
09:25:41 <wferi> Md: I'm pretty sure it's safe to reboot, but wondered if you're interested in examining this situation.
09:55:25 <wferi> maybe it's something related to session opening, and udev was bitten by it only accidentally.
09:55:50 <wferi> Unfortunately syslogd is also out for a lunch, no isn't much information available.
09:57:33 <wferi> cronjobs are also stuck, /USR/SBIN/CRON processes are growing in number.
10:00:12 <wferi> console logins freeze after printing motd and  checking mail, and that's the butlast PAM session module followed by pam_unix.so only.
10:00:42 <wferi> rebooting...
15:26:58 <CIA-2> debian-installer: 03cjwatson * r65681 10packages/arch/i386/grub-installer/grub-installer: correct parenthesisation to match intent expressed in comment
15:31:01 <CIA-2> debian-installer: 03cjwatson * r65682 10packages/arch/i386/grub-installer/debian/changelog: releasing version 1.57
15:31:20 <CIA-2> debian-installer: 03cjwatson 07packages * r65683 10/arch/i386/grub-installer/1.57/: tagging version 1.57
15:53:05 <jcristau> cjwatson: \o/ thanks for fixing that
15:53:15 <jcristau> (grub-installer)
15:53:23 <cjwatson> np, hopefully that will be a complete fix ...
16:16:41 <jcristau> otavio: i just signed the mipsel busybox log so it should get into testing tonight, if i didn't mess it up, fyi
17:29:49 <otavio> heh good
17:53:53 <CIA-2> debian-installer: 03faw * r65684 10packages/po/ (4 files in 4 dirs): [l10n] Updating Brazilian Portuguese (thanks to Adriano Rafael Gomes)
18:58:39 <CIA-2> debian-installer: 03bubulle * r65685 10packages/console-setup/debian/ (changelog po/ast.po po/eu.po po/pt_BR.po po/sv.po):
18:58:39 <CIA-2> debian-installer: * Brazilian Portuguese (Felipe Augusto van de Wiel (faw)). Closes: #603977
18:58:39 <CIA-2> debian-installer: * Basque (I?\195?\177aki Larra?\195?\177aga Murgoitio).
18:58:39 <CIA-2> debian-installer: * Asturian (ivarela).
18:59:08 <CIA-2> debian-installer: 03bubulle * r65686 10packages/po/sublevel1/lo.po: Added Lao translation
19:05:17 <CIA-2> tasksel: 03bubulle * rddf3847 10tasksel/ (debian/changelog tasks/po/es.po): Fixed encoding in spanish translation. Closes: #603936
19:05:18 <CIA-2> tasksel: 03bubulle * r1a18286 10tasksel/ (debian/changelog tasks/po/sl.po): Slovenian (Vanja Cvelbar). Closes: #603516
19:11:23 <bubulle> otavio: uploading tasksel would be nice
19:12:28 <otavio> will do
19:14:11 <CIA-2> debian-installer: 03bubulle * r65687 10installer/ (build/pkg-lists/gtk-common debian/changelog):
19:14:11 <CIA-2> debian-installer: Add ttf-sinhala-lklug-udeb to graphical installer to properly
19:14:11 <CIA-2> debian-installer: support the Sinhala language
19:17:45 <bubulle> otavio: everything is ready for having Sinhala after beta2 (can't do it now as it would require a full mass upload)
19:18:05 <bubulle> and Brazilian Portuguese is now back to 100%!
19:26:28 <otavio> bubulle: it is a shame we lost b2 :-(
19:26:30 <otavio> bubulle: ok
19:27:24 <bubulle> otavio: not that bad: a few strings will be untranslated in b2, but not that many (mostly freebsd stuff, IIRC)
19:27:38 <jcristau> what's the progress on b2?
19:27:51 <jcristau> (by which i mean what is missing?)
19:29:47 <otavio> jcristau: I will ask for the unblocks today (for initrd)
19:30:29 <jcristau> and then?
19:30:37 <otavio> jcristau: then upload installer
19:30:48 <otavio> jcristau: then build images cds and test
19:30:51 <jcristau> ok
19:32:24 <jcristau> if you make the unblocks request in the next 2 hours it'll make the next run
19:58:36 <elmig> so, when it's b2 coming out?
20:07:49 <KiBi> “soon”.
20:09:06 <niktaris> hi, is anyone working on the greek d-i translation ?
20:09:28 <elmig> hen it's ready :)
20:10:48 <niktaris> elmig, the Greek translation ?
20:11:10 <elmig> no, beta2, which is being worked on
20:11:40 <niktaris> elmig, nice. less work for me :)
20:11:53 <elmig> why?
20:13:25 <niktaris> I am doing some testing and found beta1 (?) incomplete regarding the Greek translation. If it's fully translated then I don't need to do it. If nobody was working on it I would gladly step in and help
20:13:47 <elmig> consider yourself enlisted ;-)
20:13:58 <elmig> go contact -greek team :)
20:15:14 <cjwatson> otavio: what do you think about the patch I sent to bug-parted for zero-length devices?
20:15:49 <cjwatson> otavio: I was thinking about incorporating the non-test part of that (the test changes are giant and required changes to autotools source files and such)
20:16:07 <cjwatson> had been hoping for a review from Jim
20:17:12 <cjwatson> niktaris: I think you may have been confused because elmig's conversation about b2 started shortly before you joined the channel - I don't think it was related to Greek support
20:17:13 <niktaris> elmig, done :)
20:18:11 <niktaris> cjwatson, hi , I just subscribe to -greek. I'll ask there. there is always something to translate :)
20:20:53 <stpierrc> hello I tried to install debian squeeze and when booting to the installed system only get vertical colored lines. The system is a dell insprion 1501 with a radeon 200m graphics card. Any suggestions on how to get into the system?
20:21:20 <elmig> there some vga options
20:21:24 <elmig> have you tried?
20:22:26 <stpierrc> it installed grub2 and I can get a screen with vgatest that shows some colored boxes
20:23:20 <stpierrc> I also tried vbeinfo but could not figure out how to change the mode
20:23:57 <elmig> http://d-i.alioth.debian.org/manual/en.i386/ch05s04.html#ftn.id321754
20:24:10 <elmig> humm, installed system
20:26:23 <stpierrc> thank you
20:57:55 <CIA-2> debian-installer: 03otavio * r65688 10installer/build/translation-status: Update translation-status for Beta2 release
20:59:12 <otavio> cjwatson: let me look
20:59:41 <otavio> jcristau: thx for the hints
21:00:00 <otavio> jcristau: I forgot the kernel-wedge
21:01:09 <jcristau> otavio: added
21:03:28 <otavio> cjwatson: it looks quite safe to have in. The test code (using the getenv) I don't like too much even tought I see the reason why you did it.
21:04:33 <otavio> cjwatson: couldn't the test be done using ld_preload?
21:04:51 <otavio> elmig: you forgot to push the ppc changes
21:06:05 <elmig> just a min
21:07:02 <CIA-2> debian-installer: 03elmig-guest * r65689 10packages/kernel/linux-kernel-di-powerpc-2.6/ (debian/changelog modules/powerpc/ide-modules): add sl82c105 to powerpc
21:07:15 <elmig> done
21:08:28 <jcristau> what about armel?
21:08:31 <cjwatson> otavio: I considered LD_PRELOAD.  The problem is that stat is a mess - it's often implemented as a macro and I don't see an even remotely portable way to override it with LD_PRELOAD.
21:08:58 <cjwatson> or did you mean overriding _device_get_length or whatever it is?
21:09:25 <cjwatson> that's static and I'm not sure it's possible to override it with LD_PRELOAD
21:09:30 <cjwatson> (I forget the fine details)
21:09:59 <otavio> jcristau: since noone complained about it I think we shouldn't add it.
21:10:35 <otavio> cjwatson: I thought about override ioctl for this specific case
21:10:40 <jcristau> that makes no sense
21:10:57 <otavio> jcristau: we don't add all possible drivers into d-i
21:11:18 <otavio> jcristau: specially on armel since it has memory and space restrictions
21:11:25 <jcristau> *shrug* ok
21:11:42 <cjwatson> otavio: I suppose that might be possible.  can you follow up to my mail saying that and I'll look at it when I get a chance?  in the meantime, shall I just grab the minimal patch for the bug itself?
21:11:57 <otavio> cjwatson: yes, please do
21:12:03 <otavio> cjwatson: will do that
21:12:04 <cjwatson> damn, I see my patch has tab-damage too.  I'm usually more careful than that :-/
21:12:13 <otavio> cjwatson: hehe
21:20:50 <CIA-2> debian-installer: 03otavio * r65690 10packages/kernel/linux-kernel-di-powerpc-2.6/debian/changelog: releasing version 1.73
21:20:51 <otavio> jcristau: I will upload the ppc kernel update; can you hint it too?
21:21:04 <CIA-2> debian-installer: 03otavio 07packages * r65691 10/kernel/linux-kernel-di-powerpc-2.6/1.73/: tagging version 1.73
21:21:34 <jcristau> yeah
21:23:23 <CIA-2> tasksel: 03otavio * r676b22e 10tasksel/debian/changelog: releasing version 2.85
21:24:14 <otavio> jcristau: please add tasksel on the set too.
21:56:21 <cjwatson> otavio: pushed and uploaded parted 2.3-4
21:56:53 <otavio> cjwatson: thx
21:59:53 <CIA-2> debian-installer: 03otavio * r65692 10packages/console-setup/debian/changelog: releasing version 1.60
22:00:11 <CIA-2> debian-installer: 03otavio 07packages * r65693 10/console-setup/1.60/: tagging version 1.60
22:00:37 <elmig> cjwatson: fixed some serious bugs
22:00:42 <elmig> thanks
22:00:54 <otavio> I guess from my side d-i b2 looks good.
22:01:14 <otavio> jcristau: please add tasksel and this console-setup into hints file.
22:01:21 <jcristau> tasksel done
22:01:24 <jcristau> c-s too late
22:01:27 <otavio> jcristau: thos are  the missing ones
22:01:42 <otavio> jcristau: no problem, please add for tomorrow then
22:02:15 <otavio> jcristau: this fix a bug with a language (a typo)
22:03:22 <jcristau> sounds like it could be delayed to the rc then?
22:04:28 <jcristau> argh
22:04:40 <jcristau> i didn't want to unblock udev
22:05:33 <jcristau> otavio: so actually the ppc kernel and tasksel were too late too, so that'll have to wait a bit too
22:05:40 <elmig> damn, i forgot to close meeting :(
22:05:44 <elmig> #endmeeting