19:00:43 <serpent_> #startmeeting
19:00:43 <MeetBot> Meeting started Wed Sep 11 19:00:43 2019 UTC.  The chair is serpent_. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:43 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:01:01 <serpent_> It's first Wednesday of the week, so let's start
19:01:42 <serpent_> I guess the most important is sprint (hotels, etc. - if someone does not yet have one)
19:02:00 <serpent_> And it looks like there is progress in AWS and Azure images
19:02:43 <kuLa> I think yes and yes :-)
19:03:27 <serpent_> So, remainder. If you have additional information (detailed amount, etc.) for your travel/hotel and want to be reimbursed by Debian/SPI, write those to me by the end of the week
19:04:09 * noahm is here. hello.
19:04:14 <serpent_> Sam wants also to have some details about what is intent of reimbursed people to achieve during sprint - pleas attach those also
19:04:39 <kuLa> noahm: hi
19:05:14 <kuLa> serpent_: I thnik having goals for sprint woudl help with reimbursements and talking to DPL
19:06:06 <serpent_> We have some initial agenda at wiki page
19:06:31 <serpent_> To summarize:
19:06:51 * kanashiro waves o/
19:07:03 <serpent_> account status, image finder, building images - I guess Salsa workflow and better layout on cdimag.d.o is under that
19:07:22 * kuLa says hello kanashiro
19:08:05 <serpent_> Hello
19:08:09 * kanashiro says hi back to kuLa
19:08:15 <serpent_> Anything else for agenda?
19:08:46 <kuLa> I have nothing to add
19:08:47 <waldi> serpent_: it would be nice if we had already some ideas or so on those topics
19:08:48 <serpent_> Testing and more automation did not see much progress - do we also want to touch this
19:09:11 <serpent_> #topic Sprint agenda
19:09:43 <serpent_> So account status is definitely importand
19:10:02 <serpent_> Do we want to touch user management?
19:10:39 <serpent_> For that we'd need people from SPI and/or DSA, so we can discuss more technical details of merging Debian LDAP and cloud providers' users
19:11:18 <waldi> i would start with the non-technical aspect. which kind of people need what kind of access
19:11:18 <kuLa> having ppl from SPI may be probelmatic
19:11:24 <serpent_> Or do we (at least for now) want to just manually manage accounts (e.g. for Cloud Team members) and touch this topic when more DDs want access
19:11:34 <serpent_> Yes, I know
19:11:44 <serpent_> It leads to next topic - delegates.
19:11:54 <serpent_> But let's first finish official accounts
19:12:25 <serpent_> Just accounts and publishing, or also user management?
19:12:47 <serpent_> I'd not set goals too wide, to avoid spreading us too thin
19:13:12 <serpent_> Especially as only 10 people added themselves to wiki as participants
19:14:31 <serpent_> Any comments? I don't want to monopolise discussion :-)
19:15:02 <waldi> we need to talk about users
19:15:23 <serpent_> OK, then let's add this to agenda
19:16:01 <serpent_> #agreed User management in cloud providers
19:16:38 <serpent_> #action Everyone who is interested in user management: please read Gobby documents and minutes from last year
19:17:11 <serpent_> We discussed basics, and had some technical details there, e.g. differences between cloud providers
19:17:38 <serpent_> Do we want to also touch OpenStack providers there?
19:18:32 <kanashiro> zigo may want to talk about that
19:19:12 <serpent_> It slightly overlaps with next item on agenda (or even two items): image finder and building (and publishing) images
19:20:22 <serpent_> So should we move to image finder?
19:20:43 <serpent_> What's status there? Do we have it deployed so we can test it a bit?
19:21:13 <kanashiro> no, we don't have it deployed yet, that is the plan for the sprint
19:21:48 <kanashiro> arthurbdiniz is fixing some stuff and it should be ready to be deployed until there
19:21:55 <serpent_> Ah, OK. I thought that we'd have it deployed somewhere (not under d.o domain, but under d.n domein) before
19:22:31 <serpent_> OK. Just to be sure that everyone is up to date - can he also prepare some (short) description of deployment process or details?
19:22:32 <waldi> 01
19:23:01 <kanashiro> the deploy should not be hard, what we want to check is how to gather data from the current publishing system
19:23:52 <serpent_> As we'll have representatives from all 3 providers, it shouldn't be too complex to get details how to fetch info about already-existing images ;-)
19:24:39 <kanashiro> serpent_, we currently have a docker image (I am planning to use that for now) but I can ask arthurbdiniz to write up the deployment process
19:24:47 <serpent_> #idea We could have some short (up to 1h) code review - and database schema review
19:24:48 <noahm> It's not clear that we actually want to fetch details from providers. It may be preferable to drive the finder from the CI system, which is doing the publication.
19:25:01 <serpent_> Do we have Dockerfile somewhere?
19:25:38 <serpent_> If we have current Dockerfile, we might not need deployment process description
19:25:39 <kanashiro> yes, the data we need should be provided by the CI system
19:25:44 <serpent_> (code as documentation :-) )
19:25:57 <kanashiro> serpent_, and yes, we have a Dockerfile in the git repo
19:26:07 <serpent_> Cool
19:26:26 <serpent_> #action Check Dockerfile of Image Finder before sprint
19:27:08 <serpent_> So I guess this leads us to Building images topic
19:27:18 <serpent_> More details what it includes?
19:29:31 <serpent_> Salsa workflow and cdimage.d.o layout, or also something else?
19:29:59 <waldi> no idea
19:32:01 <kanashiro> spread the knowledge about the tooling used to build/publish images is included here? IIRC this is one of the topics discussed in our BoF
19:32:21 <serpent_> Sounds good.
19:32:54 <serpent_> In other words - we'll (together) go through all steps included in building image - from debian-cloud-image repo commit to publishing it?
19:33:18 <waldi> i hope we'll have some black boards
19:33:47 <noahm> yeah, and we can probably present from a laptop as well
19:36:03 <serpent_> I updated wiki with above details
19:36:17 <serpent_> More items for agenda?
19:38:47 <kanashiro> serpent_, did you add a topic about smoke testing images? I might have missed that
19:39:04 <serpent_> No - what's that about?
19:39:33 <kanashiro> I don't know people were trying to do that, but I have no idea about the current status
19:39:55 <noahm> I think the idea there is to actually test images that have been registered with the cloud provider
19:40:06 <noahm> That is, does it actually boot, etc?
19:40:09 <serpent_> Is it about publishing (semi-) regularily debian-testing image?
19:40:30 <serpent_> Ah - this is about automated testing of our images?
19:40:47 <noahm> I think we want such testing for our testing images, as well as our stable release images.
19:40:53 <serpent_> Using tests (possibly extended) we (Ross, Helen. me) were working on last year?
19:40:56 <kanashiro> yes, testing boot, network, and etc.
19:41:37 <serpent_> I guess this goes under "Salsa workflow and CI setup" but we can add more details there
19:42:51 <serpent_> OK, added "Live testing of images on cloud providers' infrastructure"
19:45:43 <serpent_> During last meeting (and on mailing list) we also have mentioned separate Salsa group and mirror naming and management
19:46:00 <serpent_> Should we also put those as topic/agenda for sprint?
19:46:38 <noahm> We should spend some time on the mirrors at the sprint, for sure.
19:46:59 <serpent_> #agreed Package mirror management
19:49:55 <serpent_> waldi: did you start working on new Salsa group?
19:50:31 <waldi> serpent_: yep, the transition is actually already finished
19:51:26 <serpent_> OK, we might discuss it shortly at sprint (e.g. account management there) but I guess rather so everyone understands that
19:51:41 <waldi> sure
19:52:09 <serpent_> #action Present our Salsa project setup
19:52:33 <serpent_> Do we want to touch Docker images (by Debian, official ones)?
19:52:46 * rvandegrift is late, but now catching up
19:52:50 <serpent_> I'm not sure if we have anyone proficient it Docker
19:53:09 <waldi> what about vagrant?
19:53:18 <noahm> serpent_: I know Docker quite well, but I don't want to touch any of this without involving the DDs that are already publishing images to Docker Hub.
19:54:29 <serpent_> OK. Let's discuss options during sprint then, without much commitment
19:54:46 <kuLa> noahm: +1 I tnink we should try again to bring them in
19:54:58 <serpent_> I guess for Vagrant it's similar - if we have someone who knows it, we can start with it
19:57:49 <kuLa> as far as I know marcello^ is quite familiar with it
19:58:45 <serpent_> #action Discuss Docker and Vagrant - at least status, possibly roadmap for Cloud Team to get involved in Debian images there
20:00:12 <serpent_> One hour passed. Do we have other topics (except for next meeting time/date) or should we slowly wind down?
20:01:22 <waldi> next meeting would be one week before the sprint
20:01:45 <serpent_> #topic Next meeting
20:03:28 <waldi> we can skip that one i think
20:03:37 <noahm> Do we have enough to warrant another meeting before the sprint?
20:03:54 <noahm> unless we have any last-minute things to synchronize
20:03:55 <serpent_> I'd suggest either skipping, or doing it during sprint (for people who'll not come).
20:04:35 <serpent_> But I guess they'll still want to be on IRC for more time than a mere 1h
20:06:22 <serpent_> #idea Skip next meeting, discuss time/date of subsequent (November) meeting during Sprint
20:10:26 <serpent_> Does it silence mean that we're done and should finish meeting?
20:10:34 <waldi> yes
20:11:40 <kuLa> yup
20:12:05 <serpent_> #action Add latest points (Docker/Vagrant) to Sprint wiki page
20:12:31 <serpent_> #action I'll summarize it a bit and send email to list, but earliest on Tuesday
20:12:38 <serpent_> #endmeeting