17:01:23 <dondelelcaro> #startmeeting
17:01:23 <MeetBot> Meeting started Thu Jul 25 17:01:23 2013 UTC.  The chair is dondelelcaro. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:23 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:01:29 <dondelelcaro> #topic Who is here?
17:01:29 <vorlon> hi there
17:01:37 <dondelelcaro> Don Armstrong
17:01:53 <Diziet> Ian Jackson
17:02:11 <aba> Andi Barth
17:02:13 <dondelelcaro> rra sent his regrets yesterday
17:02:41 <vorlon> Steve Langasek
17:03:44 <aba> bdale obviously not
17:04:01 <dondelelcaro> cjwatson: ping
17:04:07 <dondelelcaro> anyway, I think we can get started
17:04:27 <dondelelcaro> #topic Next Meeting?
17:04:45 <dondelelcaro> currently the calendar has the next meeting at the same time on the 29th of august
17:04:50 <Diziet> 28 days would be 22nd of August.
17:05:00 <Diziet> 29th works too
17:05:05 <dondelelcaro> however, I believe bdale is setting up a meeting during debconf
17:05:08 <Diziet> Yes.
17:05:14 <dondelelcaro> and I'm not going to be available the 29th
17:05:15 <Diziet> I haven't heard about a specific time.
17:05:15 <aba> we have a tech ctte bof
17:05:18 <dondelelcaro> yeah
17:05:22 <aba> Diziet: let me check
17:05:59 <aba> initial planing is 11th afternoon
17:06:03 <dondelelcaro> I'd be ok with forgoing the meeting for august and talking on IRC or similar during or after the BoF, or whatever works for y'all
17:06:20 <aba> 22 and 29 is the same for me
17:06:40 <aba> (one of the days is work-busy, but I don't know which - the first with good weather)
17:06:47 <dondelelcaro> heh
17:07:13 <dondelelcaro> should we still have an IRC meeting in August?
17:07:26 <dondelelcaro> or should we just have the BoF?
17:07:38 <Diziet> I'm going to be travelling from mid September.
17:07:45 <vorlon> hopefully the BoF would be sufficient
17:07:56 <vorlon> are we going to have a way for folks to "dial in" remotely to the BoF?
17:08:07 <dondelelcaro> dunno; I'll at least try to be on IRC
17:08:10 <aba> vorlon: you mean apart from irc?
17:08:17 <dondelelcaro> and I can work with whatever people want to do
17:08:20 <vorlon> I mean whatever we plan to do
17:08:36 <vorlon> IRC works, if someone at the BoF is reading the IRC window :)
17:08:44 <aba> vorlon: I hope to remember.
17:09:08 <dondelelcaro> ok; lets go with just the BoF for august unless someone argues otherwise
17:09:10 <aba> (but the bof has a bit of different focus I assume - at least IIRC recent years)
17:09:27 <dondelelcaro> plus whatever discussions happen at debconf
17:09:53 <Diziet> I think we should do the meeting in August too if we can.
17:09:56 <dondelelcaro> ok
17:10:07 <dondelelcaro> I'm ok with doing it if we move it to the 22nd
17:10:14 <Diziet> OK
17:10:23 <aba> ok with me - there are chances I'm not there, but we'll see
17:10:36 <dondelelcaro> how about I keep it, and we can decide to do differently if we have to
17:10:57 <dondelelcaro> #agreed move august meeting to the 22nd at the same time, possibly supplant in favor of BoF
17:11:06 <dondelelcaro> #topic #717076 Decide between libjpeg-turbo and libjpeg8 et al.
17:11:33 <Diziet> It looks like we're tidying up loose ends to make libjpeg-turbo work.
17:11:39 <Diziet> Does anyone think that's not the right general approach ?
17:12:50 <Diziet> Perhaps we should have a resolutions saying "we prefer libjpeg-turbo; we are aware of some compatibility issues namely (blah blah blah), which seem to be soluble."
17:13:09 <dondelelcaro> I think that assuming the set of packages is actually tested, we can do/consider the switch
17:13:26 <Diziet> Do we need to be in control of that ?
17:13:28 <aba> for the moment, I'd say it looks like it is -turbo
17:13:41 <Diziet> Or can we leave that to the judgement of the -turbo maintainers ?
17:13:41 <aba> but details need to be sorted out - as always.
17:14:07 <dondelelcaro> Diziet: I don't know if we need to be in control of it; I'm just leery of mandating a change when the change hasn't been tested
17:14:12 <aba> we could leave that to their judgment (saying that we reserve right to review if necessary)
17:14:17 <Diziet> aba: Right.
17:14:21 <dondelelcaro> aba: that's true
17:14:28 <Diziet> dondelelcaro: I don't think we should say "it must change NAAOW"
17:14:57 <Diziet> We should just say "we think we should move to libjpeg-turbo.  the -turbo maintainer is to decide on the appropriate transition plan and schedule, and if anyone disagrees please come back to us"
17:15:22 <dondelelcaro> Diziet: ok; that seems reasonable
17:15:33 <jcristau> Diziet: bill disagreees
17:15:40 <dondelelcaro> that's actually sort of along the lines of what I was thinking, with a two part decision
17:16:11 <Diziet> jcristau: I see Bill wrote  | I am not going to answer such drivel. You will have to contend with what I sent to debian-devel. Show a bit of respect.
17:16:28 <Diziet> But without any reference, unfortunately.
17:16:41 <Diziet> I'm not going to go trawling through -devel to find which message(s) Bill means.
17:16:57 <Diziet> If Bill thinks this is a mistake I would like him to explain it to us, or at least point us to where the previous explanation was.
17:16:58 <aba> jcristau: obviously he disagres
17:17:52 <Diziet> I also think that "drivel" is not a friendly way to write.  It would be better to say something like "I don't want to repeat again my answers to your message, which I consider entirely wrong.  Please see <references>"
17:18:10 <aba> and AFAIC the release team has not yet taken a poisiotn on that . Is this right?
17:18:11 <jcristau> i assume https://lists.debian.org/debian-devel/2013/04/msg00720.html
17:18:21 <Diziet> jcristau: Thanks
17:18:26 <jcristau> and maybe https://lists.debian.org/debian-devel/2013/04/msg00829.html
17:18:37 <dondelelcaro> Diziet: #632949 also has a bit of a thread about it too
17:18:42 <dondelelcaro> (from 2012)
17:19:24 <Diziet> I'm not unsympathetic to the idea that we might be making a mistake, but I haven't seen the argument made in a coherent and cohesive way.
17:19:36 <jcristau> aba: i'm not sure why they should
17:19:46 <Diziet> jcristau: Me neither...
17:19:47 <aba> jcristau: I'm also not sure.
17:20:00 <dondelelcaro> ok
17:20:03 <aba> but of course they might have an opinion, and I just wanted to be sure that I didn't miss it
17:20:30 <dondelelcaro> so are we in agreement that we should start drafting an advisory along the lines of what Diziet proposes?
17:21:02 <Diziet> jcristau: If you agree with Bill that this is the wrong thing to do then I'd encourage you to try to convince us...
17:21:41 <Diziet> I feel (at least) that the other side of the argument hasn't been put forward very well.
17:21:56 <dondelelcaro> (namely, to propose to switch to -turbo, maintainers of -turbo to come up with transition plan, if others disagree with transition plan/transition, come back to -ctte?)
17:22:08 <Diziet> That sounds like what I would propose.
17:22:27 <Diziet> #action Diziet to draft libjpeg resolution along lines discussed on irc
17:22:45 <dondelelcaro> we can of course revisit this during the drafting stage if new information comes in
17:22:50 <dondelelcaro> #topic #685795 New ctte member
17:22:54 <Diziet> Unless someone else wants to do it of course.
17:22:59 <Diziet> Ah yes.
17:23:04 <dondelelcaro> I think this is just waiting on bdale
17:23:15 <dondelelcaro> which is totally understandable, and ok
17:23:32 <dondelelcaro> probably during debconf it'll get sorted out.
17:23:43 <dondelelcaro> topic #636783 super-majority conflict;
17:23:45 <dondelelcaro> #topic #636783 super-majority conflict;
17:24:13 <Diziet> Sorry, I have done nothing about this.
17:24:17 <Diziet> It's still blocking on me.
17:24:24 <dondelelcaro> no worries; that's fine
17:24:38 <dondelelcaro> #topic #681419 Depends: foo | foo-nonfree
17:24:39 <aba> no worries (at least I have escaped from blocking it)
17:25:15 <dondelelcaro> I forget what we were stuck on here
17:25:26 <vorlon> I had an action to present a counterargument
17:25:29 <vorlon> which I haven't gotten to yet
17:25:30 <Diziet> Indeed.
17:25:43 <dondelelcaro> ah, ok
17:26:03 <dondelelcaro> #action vorlon to present counterargument to Diziet regarding Depends: foo | foo-nonfree
17:26:06 <aba> hi bdale
17:26:12 <bdale> hi!
17:26:20 <bdale> sorry, quite distracted today
17:26:21 <Diziet> bdale: Welcome!
17:26:34 <dondelelcaro> #topic Additional Business
17:26:41 <aba> none here
17:27:04 <Diziet> None here either.
17:27:19 <dondelelcaro> Nothing here either; I hope you all have a good time at DebConf!
17:27:22 <Diziet> Thanks :-).
17:27:34 <Diziet> I'm now sure it'll be good (now that I have a hotel...)
17:27:35 <bdale> dondelelcaro: will miss seeing you there
17:27:44 <aba> Diziet: you have an hotel?
17:27:47 <Diziet> Although I bet it's going to be hot.
17:27:49 <Diziet> aba: Yep.
17:27:58 <Diziet> In Gorgier-St-Aubin, about 5km away.
17:28:03 * aba tries the sponsored facilities
17:28:09 <Diziet> Good luck...
17:28:19 <Diziet> It's basically not got a website.  I had to do the booking in my absolutely terrible French.
17:28:24 <vorlon> Diziet: did you get a hotel room with a name? :)
17:28:25 <aba> only the hard survive. or so.
17:29:09 <bdale> keithp and I are also staying on-site, but will have a car if we need to escape...
17:29:22 <vorlon> (ref: http://www.chateauvaumarcus.ch/index.php?page=chambre.html)
17:29:31 <vorlon> bdale: don't forget your towel
17:29:32 <Diziet> vorlon: Ah, right...
17:30:57 * bdale is likely to buy one just for the occasion
17:31:08 <bdale> (we don't exactly have a lot of spares yet)
17:32:01 <dondelelcaro> #endmeeting