17:58:52 <dondelelcaro> #startmeeting
17:58:52 <MeetBot> Meeting started Thu Dec 19 17:58:52 2013 UTC.  The chair is dondelelcaro. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:58:52 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:58:57 <dondelelcaro> #topic Who is here?
17:59:01 <dondelelcaro> Don Armstrong
17:59:11 <cjwatson> Colin Watson
17:59:31 <dondelelcaro> #pingall debian-ctte meeting starting
17:59:51 <dondelelcaro> Meetbot: pingall debian-ctte meeting starting
17:59:51 <MeetBot> debian-ctte meeting starting
17:59:51 <MeetBot> aba adsb ansgar bdale ben3 buxy carnil cjwatson Diziet dondelelcaro emias gregoa gyx jcristau keithp KGB-3 kmacleod lucas Maulkin MeetBot Mithrandir pb2004 rra tjader vorlon weasel
17:59:51 <MeetBot> debian-ctte meeting starting
17:59:55 * vorlon waves
18:00:02 <vorlon> Steve Langasek
18:00:50 <dondelelcaro> Ian said that he will be a bit late
18:01:12 <rra> Russ Allbery
18:01:27 <bdale> Bdale Garbee
18:01:36 <Diziet> Hi.
18:01:48 <Diziet> I'm actually here, although will want to go a bit before 19;00
18:02:15 * bdale is half asleep, after being up most of the night with keithp getting AltOS 1.3 released...
18:02:20 <Diziet> Heh.
18:02:22 <dondelelcaro> #topic Next Meeting?
18:02:26 * ansgar watches from the sidelines.
18:02:41 * rra was also up late, but due to watching League of Legends instead, which doesn't sound like anywhere near as good of an excuse.
18:03:04 <dondelelcaro> currently it's scheduled for thursday, january 30th at the same time. is that OK for everyone?
18:03:09 <vorlon> bdale: when you both had a meeting this morning?  Tsk ;)
18:03:12 <rra> That's good here.
18:03:15 <vorlon> dondelelcaro: sure
18:03:33 <cjwatson> vorlon: we'll just commandeer the office a bit late? :)
18:03:42 <cjwatson> (yeah, that should work)
18:03:53 <dondelelcaro> cool; if someone has a problem, let me know and we'll see what we can do.
18:03:54 <bdale> vorlon: we shipped new product to customers on Mon that requires this release .. goal was to have it out before they started receiving boxes.  we *almost* made it.
18:04:13 <dondelelcaro> #agreed next meeting Thursday, January 30th at 18:00 UTC
18:04:18 <dondelelcaro> #topic #717076 Decide between libjpeg-turbo and libjpeg8 et al.
18:04:20 <bdale> wfm
18:04:27 <Diziet> I haven't done this.  Sorry.
18:04:34 <vorlon> bdale: heh :)
18:04:52 <dondelelcaro> Diziet: no worries; we moved the meeting up.
18:05:17 <dondelelcaro> #action Diziet to draft resolution asking libjpeg-turbo to make a transition plan
18:05:24 <dondelelcaro> #topic #685795 New ctte member
18:05:38 <dondelelcaro> welcome to keithp! I probably should have removed this from the agenda; my bad...
18:05:44 <dondelelcaro> #topic #636783 super-majority conflict;
18:05:50 <bdale> it's nice being able to mark one "done"
18:06:01 <dondelelcaro> yeah
18:06:05 <aba> re
18:06:12 <dondelelcaro> I think this one is just waiting on Diziet to start on the rest of it
18:06:20 <Diziet> Yes.
18:06:31 <dondelelcaro> cool
18:06:33 <Diziet> #action Diziet to move forward with constitutional resolutions
18:06:42 <dondelelcaro> #topic #681419 Depends: foo | foo-nonfree
18:07:08 <cjwatson> this is still waiting for vorlon to articulate his continued disagreement with Diziet I believe?
18:07:09 <dondelelcaro> I don't remember where we were with this at all; I think vorlon was doing something here
18:07:12 <dondelelcaro> right
18:07:13 <Diziet> Yes.
18:07:20 <vorlon> yes
18:07:29 <Diziet> We tricked you by bringing the meeting forward.
18:07:29 <cjwatson> (I felt we'd reached a compromise I was content with; vorlon didn't)
18:07:38 <vorlon> Diziet: indeed ;)
18:07:40 <Diziet> #action vorlon to write up response to Diziet about Depends: foo | foo-nonfree
18:07:42 <cjwatson> (more or less)
18:07:48 <vorlon> cost me that all-important weekend
18:07:53 <dondelelcaro> heh
18:08:07 <cjwatson> your pre-Christmas weekend *isn't* consumed by panic-shopping?
18:08:16 <cjwatson> well done for being more organised than me if so
18:08:25 <dondelelcaro> #topic #719738 lvm2 - Add systemd support
18:08:25 <vorlon> cjwatson: I delegate all of that to Patty :)
18:08:31 <aba> cjwatson: there is still the monday
18:08:32 <vorlon> (except for shopping for her, but, well)
18:08:47 <Diziet> lvm2/systemd> I tho8ught we had reached some kind of agreement amonst the parties on this one
18:08:57 <rra> I think we got a resolution on this that everyone *seemed* happy with, but there was some remaining commentary by the lvm2 maintainer that I don't think was clarified and that I didn't understand.
18:09:10 <vorlon> rra: yes
18:09:23 <Diziet> Do we have a patch that supposedly does what was agreed ?
18:09:27 <dondelelcaro> I think that currently we're waiting on a patch which doesn't use a generator and instead uses a static file
18:09:28 <vorlon> something along the lines of "I'm happy to accept this when systemd stops being buggy", without clarifying what bug he meant
18:09:37 <rra> Yeah, that was it.
18:10:03 <bdale> so, what's our action here?
18:10:06 <dondelelcaro> but I can't remember if Bastian had okayed that
18:10:17 <aba> but we're waitimng for the answer since some time
18:10:30 <rra> Well, having the patch would be good as that makes everything concrete.  I'm not sure if we should wait on Bastian to clarify what he meant before people start working on the patch.
18:10:42 <Diziet> rra: Certainly we shouldn't.
18:10:50 <dondelelcaro> #action dondelelcaro to get Bastian to ACK/NAK the patch; if no response, proceed with patch
18:10:58 <Diziet> dondelelcaro: There isn't yet a patch, is there ?
18:10:59 <rra> Absent some unforseen problem with the patch, I'm not seeing the justification for not taking it given what was discussed.
18:11:12 <Diziet> Or am I looking in the wrong place ?  #719738 doesn't seem to have it.
18:11:13 <dondelelcaro> Diziet: as far as I know, no.
18:11:18 <aba> it's 728486
18:11:32 <dondelelcaro> basically, I was hoping to get an ACK on the idea of the patch to avoid people doing make-work
18:11:38 <aba> dondelelcaro: perhaps you might adjust the bug# in the agenda
18:11:39 <bdale> no
18:12:31 <Diziet> OK so here's the thing: suppose we tell Michael o go ahead and make a patch and then Bastian points out some actual technical defect in the patch.
18:12:48 <bdale> then the patch gets improved
18:12:51 <Diziet> In this case we would expect Michael to fix it and presumably not to mind.
18:13:07 <bdale> this is one of those cases where trying to make an agreement over something *other* than actual code seems bad
18:13:16 <Diziet> OTOH if the complaint is borderline or unconvincing, we would overrule Bastilan.
18:13:23 <Diziet> Bastian
18:13:29 <bdale> right
18:13:34 <dondelelcaro> ok; sounds good.
18:13:35 <aba> I think that's the idea
18:13:48 <bdale> clearly the next step is for a patch to actually appear, then we're talking concrete decisions not concepts
18:13:51 <Diziet> I think we should be quite firm that coming up with objections late in the day is not constructive.
18:13:54 <Diziet> Right.
18:14:06 <rra> Yeah, agreed.  So I think we should make it clear that folks should go ahead and write the patch.
18:14:10 <dondelelcaro> OK
18:14:23 <aba> Diziet: sure, that's why I think we should tell Bastian to bring up any objections to systemd now
18:14:26 <vorlon> yes; if we're satisfied that patching to not use a generator resolves the issue, then it's incumbent on the lvm2 maintainer to present arguments why there's still a problem, otherwise we would overrule
18:14:33 <Diziet> So I disagree with the action that Don proposed.
18:14:39 <Diziet> I would say we xhould action Don to ask Michael to produce a patch.
18:15:04 <Diziet> vorlon: What I'm saying is that we should be less sympathetic to arguments produced very late, particularly ones which could have been produced now and weren't.
18:15:18 <dondelelcaro> how about I have michael start working, and simulatenously ask bastian to provide technical objections in a timely maner if there are any
18:15:35 <rra> That works for me.
18:15:39 <dondelelcaro> s/have michael/ask michael/
18:15:42 <Diziet> I don't object to you asking BAstian that.
18:15:43 <aba> sounds good
18:15:44 <bdale> personally, I'd ask for an actual patch to be created and not poke bastian again
18:15:48 <Diziet> But what bdale said.
18:15:53 <bdale> to poke him again sounds like assuming bad faith
18:15:58 <dondelelcaro> okie dokie
18:16:14 <bdale> but I'm easy either way
18:16:30 <vorlon> bdale: how's that?  He said "systemd was buggy" and didn't elaborate; I don't think it assumes bad faith to ask him to explain
18:16:31 <dondelelcaro> I was thinking more along the lines of making sure that there wasn't some other technical objection that could be easily resolved early that we were missing
18:16:55 <aba> I think re-pinging would be better because - well, the last mail could just be dropped (such things do happen)
18:16:58 <bdale> vorlon: that's an entirely different thing that telling him he needs to not delay commenting on a patch that doesn't actually exist yet
18:17:05 <dondelelcaro> that's what I would be asking to clarify
18:17:15 <vorlon> bdale: ah
18:17:42 <cjwatson> yes, I think I'm with bdale on that part
18:17:52 <Diziet> I don't object to pinging him again about http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=728486#143
18:18:09 <Diziet> But I think Michael should not be asked to wait.
18:18:12 <vorlon> indeed
18:18:15 <aba> yes
18:18:15 <dondelelcaro> ok
18:18:16 <Diziet> OK.
18:18:21 <bdale> agreed
18:18:32 <dondelelcaro> #action dondelelcaro to have michael go forward with patch for LVM2-systemd integration
18:18:54 <dondelelcaro> #action dondelelcaro to ping bastian about http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=728486#143
18:19:02 <dondelelcaro> #topic #727708 Decide which init system to pick
18:19:21 <Diziet> I have been spending quite a bit of time with reference manuals, and also with my upstream daemon maintainer hat on.
18:19:36 <Diziet> I've been playing about with providing integration for userv.
18:19:41 <keithp> argh. commute fail. Sorry for being late...
18:19:44 <bdale> I noticed that.  and rra's summary of features.  thanks for both.
18:19:46 <Diziet> I have come to some tentative conclusions.
18:19:58 <vorlon> keithp: is it pancake day?
18:20:00 <Diziet> I want to play with vorlon's VMs and try to debug my integration.
18:20:07 <bdale> keithp: it's ok .. you made it in time for the real fun
18:20:17 <Diziet> I will probably manage that this weekend and then I expect to write up my views.
18:20:21 <keithp> vorlon: more like car shop day
18:20:26 <vorlon> heh
18:20:31 * rra has also been spending quite a lot of time investigating, and while I'm lagging a bit behind Ian in putting that investigation into action, I hope to work on both some upstream integration and some Debian packaging integration over the next week.
18:20:34 <bdale> Diziet: cool
18:20:52 <Diziet> However, frankly, if people were in more of a hurry I would be prepared to commit myself to a position now.
18:20:59 <cjwatson> I have only just started playing with vorlon's VMs (well, just the systemd one actually, no point in me spending more time familiarising myself with upstart)
18:21:18 <vorlon> keithp: so earlier I had set up VMs for each of the TC members on EC2, to play with Debian with each of upstart and systemd as pid1; would you like me to set some up for you?
18:21:23 <Diziet> When we started this we were hoping for a decision by "Christmas" or some such.
18:21:26 <keithp> vorlon: yes plz
18:21:31 <vorlon> keithp: ok, will do
18:21:32 <cjwatson> I'm digesting the documentation and would like to add systemd support to openssh so that I have at least *some* implementation experience with it
18:21:37 <aba> Diziet: orthodox christmas is Jan 6th
18:21:47 <cjwatson> which I plan to do before Christmas ( :-) )
18:21:52 <Diziet> I think we should set out a schedule now.
18:21:55 <rra> I'm quite impressed by both systems and the degree to which both of them have a large wishlist of things that had always bothered me about init scripts.  I will say that the sd_notify stuff is the first thing directly related to the core init functionality where I saw something that one of the systems did that the other one doesn't and that strikes me as clearly correct and forward-looking and something we would very much benefit from.
18:22:10 <vorlon> are others finding the VMs useful?  I would like to not keep them running indefinitely, they're cheap VMs but not free ;)
18:22:11 <bdale> Diziet: I think I said by the end of the calendar year
18:22:28 <vorlon> aba: no, Orthodox Christmas is December 25th, Julian calendar :-)
18:22:31 <cjwatson> I rather wish that the "Multiple" debate position were better set out
18:22:41 <rra> vorlon: I'm planning on using the upstart one to do some testing, because my plan to reuse one of my other systems didn't happen due to work chaos.
18:22:46 <dondelelcaro> vorlon: I haven't had a chance to poke around in them yet, but I should do so. However, I've got VMs here, so it's not necessary to keep them up for me.
18:22:47 <vorlon> rra: ok cool
18:22:48 <aba> vorlon: my calender of course :)
18:22:54 <cjwatson> So if I can manage it I'd like to come up with some appropriately probing questions there
18:22:55 <Diziet> We should allow some weeks for intra-TC discussion, which has been been a bit sporadic so far.
18:23:28 <bdale> vorlon: I haven't had time to play with the VMs yet but hope to soon
18:24:07 <Diziet> Suppose we say that we expect TC members to finish their primary research, and report on it, by the end of the calendar year, and then allow 3 weeks for discussion.
18:24:20 <dondelelcaro> Diziet: that sounds reasonable
18:24:25 <bdale> wfm
18:24:30 <Diziet> I would prefer a more aggressive schedule but I don't want to bounce anyone into anything.
18:24:33 <aba> sounds good
18:24:39 <rra> That works for me.  I could commit sooner, but that would let me convert at least one package to fully supporting both init systems in the way that I would want to do so going forward, including upstream integration.
18:24:43 <vorlon> Diziet: agreed on both points
18:25:20 <vorlon> (I would like to see a decision sooner, but AFAICS only 4 of the TC members have been significantly engaged on the bug so far, so I don't know where the others are in their investigations)
18:25:21 <cjwatson> Yes, I think that schedule would be fine with me
18:25:22 <dondelelcaro> #agreed TC members to finish primary research on initsystems, and report on it by the end of the calendar year
18:25:23 <rra> By both, I mean upstart and systemd, since I still don't have enough information about OpenRC to really do much there, and it's not in Debian.
18:25:28 <bdale> rra: that actually sounds like a great thing for each of us to try and do .. actual experience with each system on a package if not already done
18:25:34 <Diziet> I expect us to have to spend the last week of those three arguing about transition and compatibility and timing and stuff, which is all going to have to be covered in the resolution or deliberately avoided.
18:25:45 <rra> bdale: Yeah, that was my thought.  I wanted to make the code actually hit a real system rather than speculating based on docs.
18:25:52 <keithp> yeah, I've only seen the systemd side of service integration in the form of X patches
18:26:28 <keithp> hrm. I do have a daemon package in the archive; getting that working on both shouldn't be hard either
18:26:47 <bdale> in the reading of docs and code I've done, openrc seems clearly superior to initscripts but not really competitive with systemd or upstart.  am I missing anything?
18:26:58 <Diziet> Can I say we're agreed to have a target vote start date, for our disposal resolution, of 21st of January ?
18:26:59 <rra> Yeah, I'll probably use lbcd, which is a UDP-based daemon and hence will be an interesting experimental case for some things I want to try.
18:27:05 <keithp> bdale: solves a much smaller problem, that's for sure
18:27:06 <vorlon> bdale: if you're missing it, so are the rest of us
18:27:11 <rra> bdale: Not so far as I can tell.  In other words, that's also my impression.
18:27:15 <dondelelcaro> Diziet: we'll probably need to have a draft resolution before then
18:27:17 <aba> bdale: looks to me the same
18:27:20 <cjwatson> Do people think #716812 would be an appropriate thing for me to ask the systemd maintainers about in the ctte discussions?  I don't necessarily want to privilege my own packages, but it seems to me to exemplify a particular class of integration problem
18:27:20 <Diziet> bdale: Have you found any good docs ?  I couldn't find them.
18:27:31 <bdale> on openrc?  I don't think there are any.
18:27:43 <rra> That's kind of a problem for me.
18:27:51 <rra> systemd and upstart both have excellent manuals.
18:27:53 <bdale> it's clearly a work in process
18:28:02 <Diziet> Personally I can't take something like that seriously unless it has a reference manual.
18:28:05 <bdale> with objectives not on the same level as systemd or upstart to my analysis
18:28:38 <aba> cjwatson: I actually thing this is a very interessting bug
18:28:44 <bdale> so, one thing that keeps bothering me in the email threads that I think I'll just inject here
18:28:45 <Diziet> cjwatson: I think it's perfectly fine to bring your experiences with the competing systems to the ctte table, and that includes your own bug reports relating to your packages.
18:28:50 <rra> Agreed.
18:29:03 <aba> because it calls for convertion of packages to systemd which is - well, IMHO uncalled
18:29:10 <Diziet> Indeed one reason I've been so forthright about filing bugs including wishlist bugs is that I wanted to get a feel for what it's like to interact with each project.
18:29:54 <cjwatson> Right, will slot that into my to-do list then, thanks.  (It may of course be that the systemd maintainers simply haven't thought about this and Shawn isn't representative of their position; I don't know the name.)
18:29:57 <rra> I think it's a good idea to convert to upstream interfaces if ones appear that are superior to existing Debian integrations.  (I'm in favor of switching to fdo Desktop files for menus, for example.)  However, they have to actually be better.  There's no reason to replace working integrations with inferior ones just because they're upstream.
18:30:05 <Diziet> I would encourage any tc member who has had such interactions with any of the projects to tell us the bug#s so we can get a bigger sample.
18:30:10 <bdale> there seems to be this notion that to pick either systemd or upstart, we're hitching ourselves to upstream decision making and resource investment with no Debian-level contributions.  that just seems weird.  historically, we've been quite engaged in helping to define, describe, and code upstream functionality that matters a lot to us
18:30:28 <Diziet> bdale: Yes, absolutely.
18:30:33 <Diziet> I agree with that concern.
18:30:39 <Mithrandir> cjwatson: he's not part of the maintainer team, and you're right, I haven't been aware of -binfmt before.
18:31:05 <cjwatson> Mithrandir: all right, I'll bring it up in mail rather than ambushing you on IRC :-)
18:31:05 <bdale> I don't want to make a decision based on the assumption that someone is going to write code that doesn't yet exist, but equally I don't want to get too worried about whether I think upstream will always make the right decisions or always be there to do all the work for us
18:31:12 <Mithrandir> cjwatson: no worries. :-)
18:31:13 <Diziet> Personally I would expect us to do substantial work on these systems, maintain significant local patches, etc.
18:31:32 <Diziet> An important factor for me is how easy that would be.
18:31:33 <aba> bdale: I'd put that as that, and that we do the technical right decisions
18:31:44 <rra> I think that has gotten a little distorted in the discussions, in that I think the discussions have mostly been in the context of "how much will Debian have to *carry* this package versus having an existing community to plug into meaningfully."  So there's been lots and lots of discussion of upstream direction that minimizes Debian involvement because it's not relevant to that question.  But that doesn't mean we wouldn't have involvement.
18:32:08 <bdale> ok, that's fair
18:32:17 <Diziet> Can I suggest that we take this very interesting line of discussion to email ?
18:32:18 <vorlon> Diziet: well, hmm; I'm hesitant to bring it up because it's not actually germaine to the question of pid 1, but bug #731887 raised eyebrows for me
18:32:23 <Mithrandir> (please tell me to not interrupt if you prefer to have your meeting alone)
18:32:24 <Mithrandir> Diziet: part of the vision for systemd is to not have to have a lot of local patches and such, and I'm, to the largest extent possible going to avoid so for systemd.
18:32:31 <Diziet> vorlon: Please mention by email, and we can read later.
18:32:35 <vorlon> ok
18:32:43 <rra> I know it's been a concern going in that the systemd maintainers wouldn't be open to Debian's needs and desires, and the systemd maintainers have said a few times that they don't think that concern is grounded in their experience.
18:32:58 <keithp> right, given how central init is to the system, the question is not whether we'll have to support and maintain our own fork, the question is how big a fork that will be, and how receptive upstream will be to taking generally useful changes
18:33:01 <bdale> Mithrandir: I don't mean a lot of local patches, I mean actively engaging in trying to drive upstream decision making and/or working on actual code to offer upstream
18:33:15 <bdale> I, too, would love to see Debian not have to diverge significantly from upstream on something like this
18:33:16 <Mithrandir> bdale: oh, absolutely.  That's already being done.
18:33:23 <bdale> I know it has
18:33:34 <cjwatson> I think every well-organised upstream wants to avoid local patches, but there's a line between that and the position where maintaining local patches is painful because of extraneous social reasons (not saying that's the case here, but it's not unheard of for upstreams to give us massive grief for our local integration patches)
18:33:37 <bdale> but the *tone* of some of the email discussion is troublesome to me in this regard
18:33:40 <keithp> rra: frankly, I've gotten some push-back from systemd maintainers when suggesting that debian would have non-upstreamable changes
18:34:21 <rra> keithp: Yes, that's also true.  I know they really want systemd to work the same everywhere.  And that is a little concerning, particularly if, say, a Hurd developer wants to start porting it.
18:34:28 <cjwatson> I mean, it's an important difference between GRUB Legacy and GRUB 2 that the latter involves much more manageable distro patch stacks, but it's not a problem if they're needed
18:34:29 <aba> bdale: not only to you
18:34:30 <Diziet> I say again, this is very interesting and I know everyone wants to correct everyone else being wrong on the irc channel but can we take it to email ?
18:34:33 <rra> Since it sounds like those changes wouldn't be possible to upstream, at least right now.
18:34:48 <Mithrandir> rra: in that case, they should aim for implementing the same interfaces, IMO.
18:35:00 <Mithrandir> systemd has an explicit list of stable interfaces, after all
18:35:00 * cjwatson takes Diziet's point and cans it
18:35:03 <cjwatson> (for now)
18:35:20 <dondelelcaro> lets step back for a second and try to hash out the rest of the schedule for the initsystem question
18:35:23 <Diziet> If you want to reply to some of this stuff, you can c&p the messages into your irc client.
18:35:27 <Diziet> dondelelcaro: Yes, please.
18:35:36 <Diziet> So report by end of 31/12.
18:35:44 <dondelelcaro> Diziet was suggesting a vote on the 21st; I think that might be early, but we should definitely have a draft resolution by then
18:35:58 <Diziet> Then we're going to spend a few weeks in a series of giant email discussions.
18:36:35 <Diziet> I expect all of those discussions to happen in parallel: the ones about the merits of various systems, as well as the policy implications and the sane options open to the TC.
18:36:52 <bdale> dondelelcaro: actually, if primary research is to be done by 31 Dec, I'd love to not wait until the 21st to start a vote
18:36:58 <Diziet> I'm hoping that at the end of 2-3 weeks we'll have settled down into a smallish number of reasonable options.
18:37:08 <aba> bdale: well, I think we need time for discussions
18:37:09 <Diziet> Which we can then rank and job's done.
18:37:16 <aba> (could be wrong but that's my assumption)
18:37:44 <Diziet> I think that after 2-3 weeks anyone who's not convinced probably isn't going to be.
18:37:48 <bdale> I'm *ok* with the 21st, definitely don't think we need lots longer, though.  I like the idea of a hard deadline to keep us all focused
18:38:16 <Diziet> How about this for a suggestion:
18:38:39 <Diziet> Could we hold a special ad-hoc irc meeting on (say) the 14th to agree where we're at and set/vary/confirm the schedule.
18:38:53 <Diziet> I guess 13th if we prefer Thursdays...
18:39:19 <bdale> what year are you looking at?
18:39:31 <keithp> february?
18:39:32 <Diziet> January
18:39:33 <rra> That sounds like a pretty good idea.  And I think it would be the 9th or the 16th.
18:39:34 <dondelelcaro> you mean the 16th?
18:39:43 <Diziet> January 2014
18:39:46 <bdale> Jan 16th is indeed a Thu in 2014
18:39:54 <Mithrandir> 9th is middle of LCA, where I suspect a bunch of the CTTE will be at.
18:39:59 <vorlon> not in the Julian calendar!
18:40:00 <Diziet> Oh I'm confused.
18:40:14 <Diziet> Yes, 16th
18:40:23 <aba> would be ok for me
18:40:28 <keithp> wfm
18:40:30 <dondelelcaro> ok; the 16th works for me
18:40:35 <bdale> wfm
18:40:43 <dondelelcaro> does the 16th not work for anyone?
18:40:59 <Diziet> #agreed Provisional target date for vote start 21st January.
18:41:14 <Diziet> #agreed Special initsystem irc meeting 16th January same time.
18:41:17 <dondelelcaro> #action dondelelcaro to schedule a CTTE meeting for the 16th of January to set/vary/confirm initscripts voting schedule
18:41:26 <Diziet> Great.
18:41:45 <bdale> keithp: do you have dondelelcaro's calendar feed for meetings in your calendar?
18:41:52 <keithp> nope
18:42:01 <bdale> dondelelcaro: can you forward the info to him, please?
18:42:06 <dondelelcaro> keithp: it'll be in the topic once we stop the meeting
18:42:09 <keithp> caldav server of some kind?
18:42:12 <keithp> dondelelcaro: thanks
18:42:14 <cjwatson> I have no significant travel commitments in January until the 27th
18:42:20 <dondelelcaro> keithp: it's actually just a static file served from git
18:42:29 <cjwatson> So anything in early January is fine
18:42:32 <bdale> works great, though
18:42:37 <vorlon> right, so there's an ics feed you can import
18:43:05 <keithp> dondelelcaro: sweet; I can just add that as a remote and merge it to my git-based caldav server repository
18:43:13 <vorlon> :-)
18:43:55 <dondelelcaro> ok; anything else on the init system topic for the time being?
18:44:21 <dondelelcaro> #topic Additional Business
18:44:27 <dondelelcaro> anything else?
18:44:36 <bdale> not here
18:44:37 <Diziet> Nothing from me.
18:44:51 <rra> One thing I'll mention is that we don't really have anyone active on Policy work right now.  Just as an FYI.
18:44:51 <aba> nothing here
18:45:14 <rra> Charles stepped down to concentrate on other things for a while, and I've not had time for a while and am struggling to change that.
18:45:17 <Diziet> rra: You mean you're short of policy editors ?
18:45:21 <rra> Yes.
18:45:22 <Diziet> Aha.
18:45:27 <rra> At least ones with time to be active.
18:45:27 * keithp was kept up until after 2am by "someone" on the ctte for several days in a row and is barely functioning...
18:45:28 <Diziet> I'd be happy to help.
18:45:53 <rra> That would be great.  We have a *huge* bug backlog, and we also have a huge change for documenting triggers that Charles put a lot of effort into but didn't get to a mergable point.
18:46:22 <Diziet> One condition: I'm not a great fan of the proposer/seconder bureaucracy thing.
18:46:29 <rra> And in general if anyone sees an opportunity to encourage someone to go work on Policy a bit, that would be great.
18:46:32 <Diziet> We should just do what appears right.
18:46:50 <Diziet> The TC is there as an appeal body, right.?
18:46:57 <rra> Diziet: If it's not working, we could change it.  We should discuss how to change it, obviously.  But the current maintenance process is not timely, so clearly it's not working great.
18:46:58 <Diziet> Anyway this is probably off-topic for the meeting.
18:47:01 <rra> Yes.
18:47:14 <dondelelcaro> anything else?
18:47:15 <bdale> thanks for the heads-up, though, it matters
18:47:24 <Diziet> bdale: Right, indeed.
18:47:47 <dondelelcaro> #endmeeting