18:07:58 <dondelelcaro> #startmeeting
18:07:58 <MeetBot> Meeting started Thu Dec 18 18:07:58 2014 UTC.  The chair is dondelelcaro. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:07:58 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:08:06 <dondelelcaro> #topic Who is here?
18:08:10 <bdale> Bdale Garbee
18:08:14 <dondelelcaro> Don Armstrong
18:08:37 <wookey> I am
18:08:51 <dondelelcaro> vorlon, keithp, cjwatson: ping
18:08:51 <cjwatson> dondelelcaro: Please tell me what you want and I'll reply when I'm around.
18:09:03 <dondelelcaro> heh
18:09:18 <bdale> cjwatson: we should talk about when you want your resignation to take effect
18:09:30 <dondelelcaro> well, I'll just continue on for the time being, and if it's just us, we can at least hit on #771070
18:09:48 <dondelelcaro> #topic Next Meeting?
18:10:16 <bdale> when would the default be?
18:10:20 <dondelelcaro> I believe the next meeting would be the 29th of January
18:10:25 <dondelelcaro> it's not currently on the calendar
18:10:28 <dondelelcaro> does that work for you?
18:10:31 <dondelelcaro> (it's OK for me)
18:10:38 <bdale> checking
18:11:07 <bdale> ok for me, keithp may be in transit to FOSDEM by then .. looking
18:11:46 <Mithrandir> that's pretty likely.
18:11:56 <dondelelcaro> would one week earlier be better?
18:12:07 <bdale> he'll be on the ground in Brussels, should be ok to meet .. I'm not flying over until Fri (Sat early am arrival) due to other commitments
18:12:07 <dondelelcaro> (the 22nd)
18:12:14 <dondelelcaro> ah, OK
18:12:14 <bdale> 22nd would be fine with me
18:12:21 <bdale> that's the week between LCA and FOSDEM travel
18:12:39 <dondelelcaro> cool; why don't I pencil that in, and if someone objects, we can reschedule
18:12:46 <bdale> yeah, let's try for the 22nd
18:13:07 <KGB-3> 03Don Armstrong 05master 22a4df0 06debian-ctte 10meetings.ics remove old events; schedule meeting for 1/22
18:13:11 <dondelelcaro> #topic #769972 New member selection process
18:13:22 <dondelelcaro> I think for this we've got nominees, we just need to start discussing them
18:13:27 <bdale> yes
18:13:38 <dondelelcaro> #agreed start discussing nominees for new CTTE member
18:13:44 <dondelelcaro> #topic #636783 constitution: super-majority bug
18:13:45 <bdale> I guess the last time, we each sort of ranked them and talked about them in email
18:13:53 <dondelelcaro> right
18:13:54 <Mithrandir> member? I assume members?
18:13:59 <bdale> yes
18:14:01 <bdale> 2 or 3
18:14:02 <dondelelcaro> yes, plural
18:14:44 <dondelelcaro> #action everyone to rank nominees and talk about them in e-mail
18:15:04 <dondelelcaro> I think for #636783 we can just hold off until after the voting on retiring
18:15:11 <bdale> so we were going to wait on the super-majority bug, et al, until after the term limits GR ran it's course, right?
18:15:21 <dondelelcaro> bdale: right; that's my understanding
18:15:31 <bdale> and that hasn't quite gone to a vote yet
18:15:41 <dondelelcaro> right
18:15:54 <bdale> defer until Jan, then
18:16:01 <dondelelcaro> #agreed shelve #636783 until january
18:16:06 <dondelelcaro> #topic #741573 menu systems and mime-support
18:16:18 <bdale> no keithp yet?
18:16:30 <dondelelcaro> last time we agreed that keithp would present this to policy once it had been cleaned up slightly
18:16:33 <dondelelcaro> I think that's still the case
18:17:11 <bdale> ok
18:18:10 <dondelelcaro> #action keithp to present #741573 to policy and work to get consensus
18:18:14 <dondelelcaro> #topic #762194 Automatic switch to systemd on wheezy->jessie upgrades
18:18:33 <dondelelcaro> I wrote up the draft for this, got some good feedback
18:18:50 <dondelelcaro> I still need to introduce the bugs that Nikolaus pointed out
18:19:23 <dondelelcaro> but beyond that, I think it was waiting on vorlon to have a chance to examine it
18:20:14 <bdale> ok
18:20:24 <dondelelcaro> bdale: did you have any comments on it yourself?
18:21:16 <bdale> it's the classic situation where I can see both sides.  I think it's probably better overall for the project for the update to happen, but I remain quite concerned that there's a well-documented and working opt-out path for anyone who doesn't want it
18:21:34 <dondelelcaro> yeah, that's basically my position as well
18:21:45 <bdale> wrt your draft, I read it but I don't have the details clearly in mind atm
18:21:48 <dondelelcaro> OK
18:22:26 <bdale> so, what happens if we don't act on this today/soon?
18:22:37 <dondelelcaro> nothing, I think?
18:22:45 <dondelelcaro> but it would be good to get it out soonish
18:22:52 <dondelelcaro> just to remove any FUD
18:23:17 <bdale> ok, then do you want to poke vorlon about reviewing your draft and we can then proceed in email?
18:23:22 <dondelelcaro> sure, will do
18:23:41 <dondelelcaro> #action dondelelcaro to poke vorlon about reviewing draft for #762194, and proceed in e-mail
18:23:47 <dondelelcaro> #topic #750135 Maintainer of aptitude package
18:24:02 <dondelelcaro> err, I forgot to ping aba. anyway, I think this still needs to be dealt with
18:24:28 <dondelelcaro> I'm a bit concerned that we haven't done anything here, but I'm not sure what to do next
18:25:17 <bdale> let me pull up the bug
18:26:17 <bdale> yeah, ok, I'm not sure what to do about this today either
18:26:25 <dondelelcaro> ok.
18:26:34 <dondelelcaro> let me ping aba and try to get this rolling again
18:26:40 <dondelelcaro> #action dondelelcaro to ping aba re #750135
18:26:47 <dondelelcaro> #topic #771070 Coordinate plan and requirements for cross toolchain packages in Debian
18:28:27 <dondelelcaro> I sort of took executive action on this to merge these two bugs since the time to resolve the other has passed
18:28:50 <bdale> right.  I know wookey is here, not sure where things stand at this point?
18:29:15 <wookey> well. I just sent a long reply to 771070 which has been in gestation for weeks
18:29:21 <wookey> sorry it took so long
18:29:38 <bdale> ok
18:30:18 <wookey> Essentially the cross-toolchains team is now just working independently, having added back in a big patchset for the stuff doko took out
18:30:48 <wookey> That seems to be sustainable, if not very satisfactory
18:31:13 <wookey> And we are looking to see if there are ways to converge
18:31:15 <wookey> more
18:31:22 <dondelelcaro> cool
18:31:38 <dondelelcaro> is this something that we can help at all with? Or would it be better for us to get out of the way?
18:31:48 <wookey> I'm really not sure.
18:31:49 <bdale> ok .. I started reading your email, wookey, but it's large enough that it'll take time for me to digest
18:32:01 <dondelelcaro> wookey: OK
18:32:05 <wookey> yes, I thinkg the question really is do you want to read all that, and the big wiki page
18:32:32 <wookey> and see if you care to come to conclusions about what's best or leave the rest of us to see how it goes
18:32:35 <bdale> yes, actually, I'm willing .. cross-compilation is something I care about, both for naked arm targets and Linux targets
18:32:51 <bdale> been a while since I personally did any related toolchain work, though
18:33:08 <wookey> well, this is nearly all about packaging, rather than toolchains themsevles
18:33:25 <bdale> I'm more than happy for "the rest of you" to work out the right path, but when there's a disagreement, we're supposedly here to help sort it
18:33:33 <wookey> apart from the multilib aspect, which does affect what your toolchain can do
18:34:46 <wookey> At the moment we are trying to get 'dokos way' actually working (which is sort of is now).
18:35:11 <bdale> ok
18:35:33 <bdale> if that happens, likely to be the primary approach for stretch era?
18:35:34 <wookey> But there are several questions about should the build really be using the old 'classic cross' paths
18:35:42 <bdale> oic
18:35:43 <wookey> should we insist on multilib
18:36:26 <wookey> how much should be care about things like mipsn32 and pp64 (which are not in the archive so harder to support, multiarch or no
18:36:29 <wookey> )
18:36:30 <bdale> ok .. I'll do more reading .. not sure there's much value in more discussion right here right now
18:36:40 <bdale> unless dondelelcaro wants to chime in
18:36:54 <keithp> sorry I'm late -- local transit adventures
18:36:58 <dondelelcaro> not really; I'm very much a neophyte in this area
18:36:59 <bdale> ugh
18:37:42 <dondelelcaro> OK; shall we continue this in e-mail, then?
18:38:18 <wookey> I think that makes sense
18:38:31 <dondelelcaro> OK
18:38:33 <dondelelcaro> #topic Additional Business
18:38:48 <bdale> none here
18:38:50 <dondelelcaro> I don't think I have anything concrete here
18:39:03 <dondelelcaro> I should note that I've changed the default appearance for CTTE bugs in the BTS
18:39:36 <bdale> I saw that .. neat
18:39:49 <dondelelcaro> so you can now usertag things "consensus-seeking, discussion, drafting, published" with the tech-ctte@packages.debian.org user, and have it migrate from one state to the other
18:40:02 <wookey> is this meeting nominally monthly? It just doesn;t seem long since the last one?
18:40:05 <dondelelcaro> (the states are rather arbitrary, so if someone proposes something better, just go ahead and change them)
18:40:11 <dondelelcaro> wookey: yeah, it's roughly monthly
18:40:20 <dondelelcaro> wookey: usually the last thursday of the month
18:40:27 <keithp> but, holidays...
18:40:30 <dondelelcaro> wookey: we moved back last months, and moved up this month
18:40:44 <dondelelcaro> #endmeeting