16:59:20 <dondelelcaro> #startmeeting
16:59:20 <MeetBot> Meeting started Wed May 27 16:59:20 2015 UTC. The chair is dondelelcaro. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:20 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:59:25 <dondelelcaro> #topic Who is here?
16:59:28 <dondelelcaro> Don Armstrong
16:59:40 <dondelelcaro> MeetBot: pingall ctte meeting starting now
16:59:40 <MeetBot> ctte meeting starting now
16:59:40 <MeetBot> aba abrotman adsb ansgar babilen bdale berni buxy carnil cjwatson clopez dam Diziet doko dondelelcaro frozencemetery gnugr gregoa hartmans helmut jcristau keithp KGB-3 kini lucas Maulkin MeetBot Mithrandir OdyX rootbeer ScottK themill tjader vorlon weasel
16:59:40 <MeetBot> ctte meeting starting now
17:00:07 <keithp> howdy
17:00:11 <bdale> Bdale Garbee
17:00:23 <hartmans> Sam Hartman
17:00:59 <dondelelcaro> OdyX, aba, Mithrandir: ping
17:01:04 <dondelelcaro> vorlon sent his regrets
17:01:11 <dondelelcaro> #topic Next Meeting?
17:01:21 <dondelelcaro> currently it's scheduled for 2015/06/24 17:00 UTC
17:01:43 <dondelelcaro> I was remiss in not trying to ping everyone about the meeting, so hopefully this time was OK
17:02:05 <dondelelcaro> the one after that is 2015/07/29 17:00 UTC
17:02:16 <dondelelcaro> if someone has a problem, raise it on the mailing list, I guess.
17:02:41 <dondelelcaro> #topic #741573 menu systems and mime-support
17:02:49 <hartmans> how is the June meeting so early. Is that the last week?
17:02:57 <dondelelcaro> hartmans: yeah
17:03:04 <OdyX> Im' here.
17:03:20 <dondelelcaro> hartmans: the next wednesday is the 1st of july
17:03:28 <bdale> both dates are ok on my calendar
17:04:29 <dondelelcaro> currently, keithp is suposed to send out patches, hartmans was to ping charles about them, and I was supposed to draft a ballot
17:04:44 <dondelelcaro> I haven't drafted a ballot, but I will work on that this week, and take care of that
17:04:47 <hartmans> I did ping Charles
17:04:55 <hartmans> He was quite unhappy with our approach.
17:05:06 <hartmans> Which lead to my mail to the bug which we discussed last meeting.
17:05:38 <hartmans> I recently sent mail expressing frustration about the communication within the TC and hope that we can work to hear each other better.
17:06:39 <OdyX> Which mail was that?
17:07:05 <hartmans> Sent about 4 min before the meeting.
17:07:16 <hartmans> I haven't gotten my copy, although I recently cleared my greylist database
17:07:29 <bdale> oh, ok, I was just getting confused looking through my email history...
17:07:34 <OdyX> ah okay, good then :)
17:07:46 * bdale re-syncs with his server
17:07:51 <dondelelcaro> I haven't received it either
17:08:03 <hartmans> OK. Well, I could paste it, or we could take this to email.
17:08:19 <bdale> not here yet
17:08:24 <dondelelcaro> yeah; it hasn't hit ldo yet
17:08:31 <dondelelcaro> I guess we can just do e-mail about it
17:08:40 <hartmans> One clarifying question.
17:08:41 <OdyX> And-or at a later point in the meeting :)
17:08:42 <dondelelcaro> #agreed discuss hartmans e-mail over email re communication within CTTE
17:08:50 <dondelelcaro> yep
17:09:03 <hartmans> Are we deciding how to decide, or do you believe we're in a position to have a draft ballot with actual final decisions on it?
17:09:22 <bdale> I'd prefer the latter
17:09:28 <dondelelcaro> I'd also prefer the latter
17:09:35 <OdyX> ditto
17:09:42 <hartmans> OK.
17:09:49 <bdale> largely because we've already had this in our to-do list for eons
17:09:51 <hartmans> I would vote FD first on any such ballot at this point.
17:10:26 <hartmans> But let's take to email.
17:10:33 <bdale> so going through another round of "what are we supposed to be doing here" really doesn't seem like a good answer, even though I'm happy generally to continue to talk about how we should think about such questions and form solutions in the future
17:10:39 <dondelelcaro> OK. I think once the ballot actually exists, I'll try to convince you otherwise, but I look forward to that discussion
17:11:02 <dondelelcaro> and frankly, if there's an option that you'd prefer to see, it can go on the same ballot
17:11:07 <dondelelcaro> and we can actually decide
17:11:20 <hartmans> Nod. my preferred option is to go do what I outlined in the bug.
17:11:23 <dondelelcaro> yeah
17:12:00 <dondelelcaro> #action dondelelcaro to actually draft the ballot this time for the menu system question
17:12:08 <dondelelcaro> #topic #636783 constitution: super-majority bug
17:12:22 <dondelelcaro> I think these are still waiting around; they're certainly not critical at this juncture
17:12:31 <dondelelcaro> does anyone have anything to report on this?
17:12:36 <OdyX> Yeah, they need someone to sit and untangle.
17:13:08 <dondelelcaro> OdyX: OK to just leave them for the next meeting?
17:13:30 <OdyX> Sure
17:13:53 <OdyX> As long as noone did the untangling, I can't really grasp the issues enough to form an opinion…
17:14:05 <dondelelcaro> got it
17:14:49 <dondelelcaro> #topic #771070 Coordinate plan and requirements for cross toolchain packages in Debian
17:15:03 * hartmans sighs
17:15:36 <dondelelcaro> this issue is still happening; still trying to get the parties to actually agree on a common set of plans
17:15:59 <dondelelcaro> unfortunately, what might eventually occur is the CTTE getting involved to decide on a specific course of action once the plans are written
17:16:00 <hartmans> Is the latest that doco is upset because the meeting minutes were published?
17:16:04 <dondelelcaro> yes
17:16:39 <dondelelcaro> currently, doko is working on an alternative set of plans which reflects his understanding of the agreement
17:16:56 <hartmans> So, in that mail, he asked a question that might be worth pondering especially when we get involved.
17:17:28 <hartmans> What level of involvement do we expect from maintainers in responding to concerns raised by other parties.
17:17:49 <hartmans> He objected to the idea that he'd need to start his own formulation of the situation but also objected to using wookie's formulation.
17:18:06 <hartmans> o, cool.
17:18:16 <hartmans> It sounded like that was exactly what he didn't want to do
17:18:29 <dondelelcaro> he didn't want to start from scratch, but I think that's really the only way forward
17:18:35 <hartmans> nod.
17:18:48 <dondelelcaro> otherwise, wookey and other people will continue to work around doko
17:18:51 <hartmans> That was basically what I was going to say. Is that he needs to do something,
17:19:18 <hartmans> And I certainly know that if one party has reasonable technical points and another party is silent, I'm likely to be more influenced by the party that is talking.
17:19:19 <bdale> I fight against stop energy when I see it
17:19:30 <bdale> saying "no" without offering an alternative is just obstructive
17:19:31 <OdyX> Would that be solvable by (yet another) face-to-face meeting between concerned people, eventually with a third-party mediator (such as at DebConf) ?
17:19:45 <dondelelcaro> OdyX: I don't know; they had a third party mediator last time.
17:19:54 <dondelelcaro> OdyX: but it probably wouldn't hurt
17:20:01 <dondelelcaro> maybe actually recording the entire meeting instead of just taking notes
17:20:02 <hartmans> Thanks for the update.
17:20:11 <OdyX> The minutes should have been published by that third-party mediator then…
17:20:20 <dondelelcaro> yeah
17:20:34 <dondelelcaro> maybe just having a third party mediator who published specific notes
17:20:37 <dondelelcaro> and a plan
17:20:48 <dondelelcaro> esp. if things haven't been resolved by that point in time
17:22:14 <OdyX> Should we try to make this happen at the next DebConf ?
17:22:33 <OdyX> It feels like the situation is deadlocked currently, and we've been asked to help.
17:22:38 <hartmans> I propose we also give the parties the option of referring plans to us and delegating the decision
17:22:50 <dondelelcaro> OdyX: I think that would be awesome; I don't know if wookey and doko will both be there
17:22:56 <dondelelcaro> hartmans: that also sounds reasonable
17:23:07 <bdale> seems likely they'll both be there
17:23:50 <dondelelcaro> cool; I won't, so someone besides me will have to organize
17:23:57 <dondelelcaro> does someone want to start on that?
17:24:12 <dondelelcaro> I'm totally OK with calling in at pretty much any time or trying to be useful if that helps
17:25:59 <bdale> several of us plan to be there, I guess the question is who, if anyone here, wants to try and organize a meeting?
17:26:02 <dondelelcaro> yeah
17:26:59 <OdyX> I'm not overly comfortable with the perspective of mediating such a meeting, but I think it needs to be done. So in absence of other vict^W volunteers, I'll do it.
17:27:03 <hartmans> I can help at debconf. I don't want to volunteer much time for this before, and would be delighted if my help were not needed
17:27:30 <hartmans> odyx: Make sure they want that first though.
17:27:30 <bdale> OdyX: if you're willing to organize the meeting, I think enough of us can/will be there that you won't necessarily have to play mediator
17:28:29 <OdyX> hartmans, bdale: good. I'll send a mail to all parties asking them to consider the idea and we'll see where we can go from there.
17:28:41 <bdale> sounds like a plan
17:28:51 <dondelelcaro> #action OdyX to organize possible meeting re #771070 at Debconf; others to potentially mediate
17:29:00 <dondelelcaro> #topic #750135 Maintainer of aptitude package
17:29:30 <hartmans> I think I'm looking for feedback from the rest of the TC on a proposal I sent out
17:29:59 <dondelelcaro> I think Mithrandir gave some feedback, IIRC, but the rest of us need to weigh in
17:30:01 <hartmans> There are a couple of issues where only I and one other have spoken and we disagree, so additional input would be very helpful
17:30:10 <hartmans> I think we can probably do this with one ballot option.
17:30:15 <bdale> was the proposal in email?
17:30:22 <hartmans> On the bug
17:30:23 <keithp> bdale: yes, may 17
17:30:42 <bdale> thanks, found it, reading again
17:31:44 <OdyX> Well. I don't disagree enough to vote this ballot below FD. I'd prefer something with a small "formal decision part" with only what we're saying as a body, and general considerations after and before that.
17:32:13 <hartmans> What does that mean?
17:32:27 <hartmans> I.E. are we voting on the formal decision part or not?
17:32:47 <bdale> I don't understand your question
17:32:52 <hartmans> Because to me, this resolution has no formal decision at all; there is nothing formal about it at all.
17:32:59 <dondelelcaro> OdyX: so you mean to have just the part where we're taking action as a CTTE delineated, and the rest separated?
17:33:02 <aba> well, it is a recommendation
17:33:06 <aba> which we also could do
17:33:50 <aba> (re btw)
17:34:15 <OdyX> dondelelcaro: yes, such as "with the powers of §6.1.5, we say _blah_", here comes context and general advice.
17:34:17 <bdale> yeah, ok. whether there's a "decision" or not, anything we vote on gets taken by the project as deeply authoritative. so the idea of keeping the part we officially vote on vs the commentary putting it in context separate is maybe what Odyx is asking for?
17:34:32 <OdyX> yes. Sorry for the loosy phrasing.
17:35:02 <hartmans> for myself, I care about what we vote on, and care less about the wording and how formal things appear in the wording.
17:35:07 <aba> I think separating "what are the circumstances", "what advice do we offer", "misc" might make sense
17:35:10 <bdale> np, as a group we're still working out how to work well together after the significant change in TC membership in recent months, *and* struggling generally with how to deal with some questions ..
17:35:17 <OdyX> Limiting what is authoritative to only what's strictly needed IMHO helps avoiding the close word-by-word scrutiny and second-guessing of the rest of the decision.
17:35:41 <aba> so this means we agree on the content, and "just" need to seperate it?
17:35:50 <hartmans> aba: perhaps
17:36:12 <hartmans> If the idea is that we're only voting on the part that is currently in the advice section, then I'd vote FD about that
17:36:15 <bdale> fwiw, I'm fine with what hartmans wrote as being a good thing for the project to do
17:36:20 <OdyX> I do agree with the content. I wouldn't go as far as hartmans' proposal goes in the general "for a healthy team" considerations, but I'd vote this above FD.
17:36:49 <hartmans> If we're going to vote on something I'd prefer to have context. I'd be fine not voting at all (no resolution) though.
17:36:56 <aba> hartmans: I think we should vote on the full text, however with "Background ..., therefore we offer advice ..., ..."
17:37:01 <hartmans> But I think the context is far more important here than the actual recommendation
17:37:22 <dondelelcaro> hartmans: previously, we've included context in the ballot, but only the specific parts where we use CTTE powers have any force
17:37:26 <aba> (so yes, the background is part of our reasoning and should be voted on)
17:37:34 <bdale> dondelelcaro: right
17:37:42 <bdale> I think we're kind of all talking around/past each other here
17:37:48 <bdale> it's fine for the ballot email to provide lots of context
17:37:53 <bdale> we assume people will read and digest that
17:38:09 <hartmans> I'm happy with wording that makes it sound more informal
17:38:11 <bdale> but it's advantageous to have the part we actually vote on be constrained in size and scope
17:38:30 <bdale> I'm also totally ok with the idea that there are things that can be resolved without taking a vote
17:38:52 <bdale> the only issue then is how we know when to close the bug and walk away .. we've been horrible at actually bringing non-voted things to closure in the past
17:39:05 <dondelelcaro> right; that's really the only reason why I'm more vote happy
17:39:17 <bdale> and having the same list of things to talk about each month on IRC gets really, really, old both for us and for the project at large
17:39:46 <dondelelcaro> anyway, I think I have an idea of some ways that this can be reworked to address OdyX's concerns (and my own), and I'll try to respond to this ballot
17:39:47 <hartmans> Basically, I'm likely to support proposals that do not significantly change how much text is voted on here.
17:39:56 <aba> dondelelcaro: alternative text "as things seem to have cleared up to a point where we don't need to use our constitutional powers, we consider it resolved" and vote on that?
17:40:08 <dondelelcaro> aba: yeah, basically
17:40:22 <bdale> that could work
17:40:31 <dondelelcaro> we should try to have this voted on before next meeting
17:40:50 <dondelelcaro> #action dondelelcaro to rework the ballot slightly to see if OdyX's (and dondelelcaro's) concerns can be addressed
17:40:57 <keithp> Seems like we're also recommending a specific course of action here though, but not requiring
17:40:57 <OdyX> well, I was proposing that at the latest meeting (accept MIA as a fact, move on), we didn't want that…
17:41:13 <dondelelcaro> #topic Additional Business
17:41:14 <bdale> keithp: sure, nothing wrong with that kind of advice
17:41:43 <aba> e.g. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=717076#235 has a resolution with reasoning in extra
17:41:48 <keithp> so the ballot would be to transmit that recommendation publicly
17:43:07 <dondelelcaro> anything else?
17:44:30 <bdale> nothing here
17:44:43 <hartmans> hmm
17:44:44 <OdyX> .
17:44:51 <hartmans> So, at the last meeting you mentioned busybox-static.
17:44:58 <hartmans> As far as I'm concerned that's off our plate
17:45:01 <dondelelcaro> right
17:45:14 <hartmans> ok
17:45:18 <dondelelcaro> I just haven't pulled it off of the additional business section
17:45:31 <hartmans> np
17:45:44 <hartmans> all for me
17:45:45 <KGB-3> 03Don Armstrong 05master d61ffa3 06debian-ctte 10meetings/agenda.txt busybox resolved
17:45:51 <dondelelcaro> #endmeeting