17:00:02 <OdyX> #startmeeting
17:00:02 <MeetBot> Meeting started Tue May 31 17:00:02 2016 UTC. The chair is OdyX. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:02 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:00:09 <OdyX> #topic Check-in round
17:00:20 <hartmans> Sam Hartman
17:00:21 <OdyX> Didier 'OdyX' Raboud
17:00:26 <fil> Philip Hands
17:01:18 <Mithrandir> Tollef Fog Heen
17:01:32 <OdyX> aba, dondelelcaro, keithp: ?
17:01:48 <keithp> yup, I'm here
17:02:13 <keithp> Keith Packard
17:02:40 <OdyX> he he. Hello bdale
17:03:01 * bdale apparently hasn't removed the ctte calendar provider from his calendar config yet...
17:03:05 <OdyX> Let's wait until *:05 to proceed.
17:03:25 <OdyX> bdale: you can candidate at the end of the year, don't worry :)
17:03:31 <bdale> pfft
17:05:17 <OdyX> There. Let's proceed.
17:05:26 <OdyX> #topic Next Meeting?
17:05:33 <OdyX> Option B "Tuesday 17:00 UTC (June 28th)"
17:05:36 <OdyX> Option M "Thursday 18:00 UTC (June 30th)"
17:05:43 <OdyX> Any opinions ?
17:05:44 <keithp> I thought we were meeting during debconf?
17:05:51 <Mithrandir> either works, I'll be at debcamp for both
17:05:57 <Mithrandir> but I'll just have arrived for the first one
17:06:18 <keithp> I won't be there for debcamp, just debconf
17:06:18 * fil is at debcamp too
17:06:22 <Mithrandir> but what keithp said, push it out a week?
17:06:27 <OdyX> I won't be at DebCamp. I suspect it might make sense to drop the IRC meeting in favour of one IRC meeting during DebConf.
17:06:45 <hartmans> I will find an end of June meeting before I arrive at debconf I think on the 1st really hard
17:07:09 <OdyX> So what about we push it one week, same time ?
17:07:15 <Mithrandir> wfm.
17:07:17 <keithp> sounds awesome
17:07:36 <Mithrandir> we need to meet and create some content for the ctte bof too, but we can do that throughout the week
17:08:00 <OdyX> Tuesday 5th ?
17:08:11 <OdyX> 17 UTC
17:08:15 <OdyX> #save
17:08:20 <Mithrandir> if that's not in the middle of dinner
17:08:55 <OdyX> Let's agree on the principle, and fine-tune when we have more info.
17:08:58 <Mithrandir> wfm
17:09:23 <hartmans> wfm
17:09:26 <OdyX> #agreed Push end-of-June meeting to early-July, during DebConf, around Tue 5th, 17UTC. Fine-tune when DebConf program is known.
17:09:35 <OdyX> I'll handle that and communicate through the list.
17:10:10 <OdyX> #action OdyX to handle the meeting coordination.
17:10:18 <OdyX> #topic 766708 Cross toolchain packages in Debian
17:10:29 <OdyX> fil: the stage's yours.
17:10:56 <OdyX> We've duly received your private report, but some transparency to a public meeting makes sense, I think.
17:11:37 <fil> well, I've chatted to all the people that seemed likely to have an opinion about it, and they are all between indifference and thinking the bug should probably be closed
17:12:17 <aba> yup, here.
17:12:33 <fil> for reasons that are mostly about the fact that it's not really aged well
17:12:40 <OdyX> There's still a tension between the protagonists around the cross-toolchain question, right?
17:12:52 <fil> and that it's a mix of two bugs that makes the waters muddy
17:13:09 <fil> OdyX: yes
17:14:00 <OdyX> #info #766708 & 771070 are two mixed issues, which aged since their creation.
17:14:07 <fil> I beleive so -- or at least there's something that needs resolving -- not sure about the tension being between the protagonists, or more between the proposed solutions
17:14:49 <OdyX> Although I don't like this type of "timeout" outcome, closing this seems to be the least worse of all other possibilities, right ?
17:14:50 <fil> the underlying issues would seem to be behind #815172, for instance
17:15:24 <Mithrandir> do they want us involved or do they just want to make an attempt to work it out between the various solutions?
17:15:37 <OdyX> That'd be asking fellow developers to produce a "state of the issue" for us, again.
17:15:38 <fil> I'd think so -- that bug seems to be acting more as a blocker to progress than aything esle
17:16:07 <hartmans> We could close with willingness to get involved if anyone has specific requests of us.
17:16:09 <aba> Mithrandir: they'd like us to find some solution that everyone is happy with.
17:16:13 <fil> (that was in reference to the timeout comment BTW)
17:16:18 <aba> I'm pretty sure this one doesn't exist.
17:18:04 <Mithrandir> hartmans: I think that sounds fine.
17:18:13 <aba> hartmans: sure.
17:18:26 <OdyX> So… Although that's not a fantastic outcome; closing this one with a excerpt of our understanding of the status & a statement of our willingness is a fine course of action.
17:18:55 <OdyX> I just dislike the "timeout" part, that might (again), be due to our lack of bandwidth at critical times.
17:18:55 <hartmans> odyx: yeah. /me is sad it's come to this.
17:20:10 <OdyX> It's a bad outcome in absolute, but I feel it's the best amongst our possibilities, right ?
17:21:39 <hartmans> agreed
17:21:40 <fil> it seems to me that this needed a very quick decission, and that as soon as the deadlines had passed there's not much motivation to apply effort to it -- if the only result is that we learn to make a decission of some sort before such deadlines in future, that would be positive
17:22:34 <OdyX> It's not glorious, but so be it. Let's head for a better future.
17:23:38 <OdyX> Let's "#agreed Close #766708 with an excerpt of our understanding of the status & a statement of our willingness to be involved again; as well as a promise to be quicker" ?
17:23:54 <hartmans> second
17:24:17 <keithp> that seems like a responsible option at this point
17:24:24 <OdyX> #agreed Close #766708 with an excerpt of our understanding of the status & a statement of our willingness to be involved again; as well as a promise to be quicker
17:24:51 <OdyX> fil: I suspect you're our best informed person there.
17:25:37 <OdyX> #action fil to Close #766708 as #agreed, eventually asking privately for feedback before.
17:25:49 <OdyX> (again, please say if I'm too pushy).
17:25:59 <OdyX> #topic Additional business
17:26:08 <fil> Hmm, I knew you'd say that -- I'm still pretty light on the background TBH. I just spent some time nudging poeple on IRC -- I can knock something up on the list, but would definitely want others to check it over
17:26:43 <OdyX> :)
17:26:59 <OdyX> That's arguably part of the problem too: we're all way too light on the background…
17:27:58 <hartmans> no additional business from me
17:28:15 * fil also gets the feeling that one half of the argument has yet to be coherently expressed
17:28:17 <OdyX> There was ansgar's "Consider "/usr w/o initramfs or programs in /bin depending on libraries in /usr/lib"
17:29:08 <OdyX> In the past, the TC has not taken subjects upfront, but rather waited for them to be brought to it.
17:29:25 <keithp> I think it's in our interests to understand the evolving situation though
17:29:43 <OdyX> (and I don't have good remembrances of the cases in which TC members brought general design topics to the TC)
17:29:43 <keithp> I know I've been watching the discussions with interest, expecting them to appear here at some point...
17:29:48 <hartmans> I think we could volunteer to come up to speed and ask the proponents if it would be helpful for us to learn the issue and become involved in the discussion before it gets to us.
17:29:53 <hartmans> Would we like to do that?
17:30:15 <OdyX> DebConf looks like the good moment to do that.
17:30:20 <hartmans> agreed
17:30:58 <keithp> it might be good to assign a TC member to provide a report on the issue for us
17:31:10 * fil hides
17:31:11 <keithp> provide a bit more context and data for the debconf meeting
17:31:36 <OdyX> That'd amount to not closing the bug, no ?
17:31:42 * hartmans hides I hope to be back to being productive by mid July, but doing this in June is something I cannot do
17:32:21 <Mithrandir> OdyX: I think keithp is talking about the bits raised by ansgar, not the cross-toolchain bits.
17:32:29 <OdyX> ah, good :)
17:33:08 <keithp> sorry, yes
17:33:34 <Mithrandir> only piece of additional business from me is that I'll be switching employers as of next week, to FINN.no.
17:33:53 <Mithrandir> (they use debian and will be paying my airfare to .za. Yay)
17:33:59 <keithp> nice!
17:34:23 <Mithrandir> yeah, I hope it'll be good
17:34:30 <Mithrandir> have high hopes. :-)
17:34:30 <OdyX> For me there's a underlying "procedural" question: do we wait until the situation becomes heated and someone brings the question to us, or do we pick the issue proactively, under §6.1.2, ideally §6.1.5.
17:35:05 <hartmans> my preference is get involved proactively informally as a body of debian developers who can get involved in a discussion.
17:35:12 <keithp> hartmans: agreed
17:35:34 <Mithrandir> I'm somewhat wary of using 6.1.5 and would prefer to at least start with just what hartmans suggests.
17:35:43 <hartmans> That is, we're a group of eight developers (well seven). We can go talk about debian issues if we want. We ask some of the proponents informally if it would help for us to do that sort of informal ground work
17:36:46 <OdyX> hartmans: absolutely. There's just §6.3.5 to be kept in mind.
17:36:56 <keithp> hartmans: I think this is slightly more than informal; it's a 'fact finding missing' for us to become aware of the nuances of the issues so that we can help guide things
17:37:03 <Mithrandir> OdyX: that's just as the committee.
17:37:24 <Mithrandir> individual members are free to do as much detailed design work when wearing non-ctte hats.
17:37:34 <Mithrandir> (as much as they want)
17:37:43 <OdyX> Mithrandir: sure. As long as we don't restrict the discussion to ctte forums.
17:38:09 <Mithrandir> indeed, I'd think it should be held on -devel (or -project, when appropriate)
17:38:17 <OdyX> keithp: is this something you'd be interested to bootstrap and coordinate ?
17:39:58 <keithp> OdyX: I think I can
17:40:04 <OdyX> Great, thanks!
17:40:26 <keithp> I think my irc may have dropped something though; was there a link to a discussion posted at the top of this item?
17:40:34 <hartmans> no
17:40:59 <OdyX> #action keithp To start the enlightenment of the TC members on the "consider "/usr w/o initramfs or programs in /bin depending on libraries in /usr/lib" question.
17:41:34 <keithp> wilco!
17:41:46 <OdyX> Having a BoF about this would @DebConf would help everyone visualize what the questions at stake are.
17:42:02 <OdyX> meh. s/would @DebConf/at DebConf would/
17:42:13 <OdyX> Still wrong.
17:42:15 <OdyX> Anyway :-P
17:42:17 <OdyX> #save
17:42:25 <OdyX> Thanks for the transparency Mithrandir.
17:42:34 <OdyX> #topic Check-out round
17:43:13 <OdyX> IRC is frustrating as we're getting more and more used to "John Doe is typing" live-notifications; but it went well enough I suspect.
17:43:34 <OdyX> See you (all?) at DebConf!
17:43:53 <keithp> looking forward to it!
17:43:58 <Mithrandir> see you all around indeed.
17:44:03 <Mithrandir> it'll be good
17:44:04 <fil> likewise
17:44:26 <aba> see you
17:44:35 <hartmans> yes, looking forward.
17:44:40 <OdyX> 45 minutes in. Good timing!
17:44:58 <OdyX> #endmeeting