18:02:08 <OdyX> #startmeeting
18:02:08 <MeetBot> Meeting started Tue Aug 30 18:02:08 2016 UTC.  The chair is OdyX. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:02:08 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:02:10 <OdyX> #save
18:02:16 <OdyX> Chair ?
18:02:40 <OdyX> http://meetbot.debian.net/debian-ctte/2016/debian-ctte.2016-08-30-18.02.html <- it records indeed.
18:03:07 <OdyX> hartmans, dondelelcaro, keithp, marga, fil, Mithrandir, aba: We have started meeting. Are you there ?
18:03:20 <hartmans> Sam hartman
18:03:26 <keithp> Keith Packard
18:03:37 <OdyX> Didier Raboud
18:03:48 <Mithrandir> Tollef Fog Heen
18:03:50 <OdyX> (I need someone to volunteer to chair, pretty please)
18:04:08 <dondelelcaro> Don Armstrong
18:04:14 <fil> Philip Hands
18:04:34 <OdyX> #topic Next Meetings ?
18:04:50 <hartmans> I can chair if you don't have a volunteer.
18:04:51 <OdyX> I've decided for September: Confirmed: date -d 'Thu Sep 29 18:00:00 UTC 2016'
18:04:56 <OdyX> #chair OdyX,hartmans
18:04:56 <MeetBot> Current chairs: OdyX hartmans
18:05:10 <OdyX> and October is tentative date -d 'Thu Oct 27 18:00:00 UTC 2016'
18:05:43 <OdyX> I'll continue deciding one meeting in advance, so please keep your preferences up-to-date :)
18:05:56 <hartmans> Cool.
18:06:03 <hartmans> Anything else or shall we move on to the fun?
18:06:08 <OdyX> Let's move on.
18:06:48 <hartmans> #topic #835507 Please clarify that sysvinit support decision is not going to ex\
18:06:48 <hartmans> pire
18:07:10 <hartmans> #topic #835507 Please clarify that sysvinit support decision is not going to expire
18:07:22 <hartmans> There's been a lot of discussion.
18:07:43 <OdyX> I've stated my opinion on the bug, and I was tempted to push for a "A: no statement; FD" ballot. I can be convinced a "A: no statement; B: Ian's statement; FD" ballot.
18:08:06 <dondelelcaro> I think that no statement is really needed; policy just needs to be updated
18:08:16 <hartmans> I think there may be two open issues here: 1) what/how do we respond to this issue and 2) is there anything we can do to help the policy process actually come up with a modern init system policy.
18:08:27 <Mithrandir> I don't think we need a statement either, but policy should be updated.
18:08:44 <OdyX> Do we want to _set_ policy ourselves ?
18:08:49 * fil thought that OdyX's response to Ian was 100% correct FWIW
18:09:08 <dondelelcaro> OdyX: I don't think so; the hard work here is writing up the policy, and that would require detailed design work
18:09:13 <Mithrandir> on the other hand, are people confused about the lifetime of ctte rulings?  I don't actually think so.
18:09:18 <dondelelcaro> well, potentially would require
18:09:20 <hartmans> OdyX:  In my ideal world 3 or 4 of us go start hashing this out on debian-policy and bring it back to the TC if that stalls.
18:09:41 <OdyX> I'm short on bandwidth, but I'm tempted to get my hands dirty in the policy process.
18:09:53 <dondelelcaro> hartmans: yeah, that's what I suggest too.
18:10:04 <OdyX> I don't want to engage alone, and especially not iff I can't sustain some rythm.
18:10:28 <hartmans> I'd kind of like to sit this one out but could have arms twisted if necessary.
18:10:49 <OdyX> So. We're in agreement that a) no new statement is needed; b) debian-policy process is currently broken, and needs to be fixed.
18:11:05 <OdyX> as for b), I think it's as much of a TC problem than a project problem.
18:11:11 <OdyX> Where has aba been? :)
18:11:37 <Mithrandir> I don't think policy being stalled is a TC problem, it's a project-wide problem
18:11:46 <Mithrandir> we might help fix it, though.  Not sure.
18:11:52 <OdyX> to avoid confusion: it is a concern of TC members, and it should really be a project-wide concern, as well.
18:11:55 <hartmans> Mithrandir:  Except for 6.1.1.  I think we have more responsibility than average for policy.
18:12:00 <dondelelcaro> there basically aren't any active policy editors
18:12:39 <hartmans> On the lack of a statement.  Do we want to presume Ian will insist on a vote?  Or just close the bug?
18:13:09 <Mithrandir> I was about to ask a similar question.  I think we might want to vote on it, but open to doing either.
18:13:18 <OdyX> We tried avoiding a vote, and decided we wanted to say "we agree without a vote, please ask if you want a formal vote"
18:13:46 <OdyX> I mean: in general.
18:13:49 <hartmans> I'm fine with that. any objections?
18:14:02 <hartmans> If not should I #agreed We will close the bug unless Ian requests a formal vote?
18:14:08 <OdyX> That might be a good test-case, to also test the waters together with the rest of a project.
18:14:16 <OdyX> I'd #agreed with a volunteer.
18:14:31 <OdyX> and "unless someone requests a formal vote"
18:14:48 <hartmans> ah, right.
18:14:55 <hartmans> Who wants to close the bug?
18:15:00 <Mithrandir> I can write up something to that effect.
18:15:05 <Mithrandir> unless somebody else wants to
18:15:22 <keithp> Mithrandir: I'm good with you doing it
18:15:26 <hartmans> #agreed Mithrandir will close the bug unless someone requests a formal vote.
18:15:27 <OdyX> Mithrandir: please do. I have some more bandwidth these days, I can review.
18:15:45 <Mithrandir> review would be good, so I'll float it around when I have a text.
18:15:48 <hartmans> Okay, now do we have volunteers to get involved in the policy porcess on this issue?
18:15:56 <hartmans> I think we can separate this from the policy editor problem.
18:16:13 <OdyX> Actually is "will close the bug leaving the door open for someone to request a formal vote" (the unless is not postponing the bug closure)
18:16:24 <OdyX> It's actually a fleet of issues.
18:16:25 <hartmans> In that if we get  a proposal seconded and have worked through comments and the only thing blocking is lack of editor, we can bring that to the TC and the TC can review under 6.1.1
18:16:38 <OdyX> and a quite big amendment to policy.
18:16:54 <fil> Mithrandir: works for me - I ought to have time to help, if needed
18:16:55 <dondelelcaro> hartmans: hep
18:17:01 <dondelelcaro> s/hep/yep/
18:17:04 <OdyX> #save
18:18:46 <OdyX> I'll gladly be involved. But the bootstrap part needs someone policy-fluent.
18:18:53 <hartmans> Was fil offering to help with the bug closure or the policy discussion?
18:19:06 <fil> bug closure
18:20:34 <hartmans> So no one wants to help OdyX with policy?
18:20:43 <OdyX> It feels our problems are connected; new TC members, expiring TC members (could-be policy editors ?), menu in policy, systemd in policy ?
18:21:08 <fil> are we on to the menu policy thing, or is this policy re. TC votes, or some such?
18:21:09 <OdyX> and if it boils down to any of us 8 _only_ to be involved in all this, we have a larger problem.
18:21:22 <hartmans> We believe that the init system policy is broken
18:21:37 <hartmans> and some of us think it would be good to get that fixed--good enough that TC effort should be spent.
18:21:40 <OdyX> I was just wide-rambling, sorry :)
18:22:11 <dondelelcaro> it's the old problem; people who know how to fix the issues don't have free time to dedicate to the thankless task of documenting how it all should work
18:22:17 <OdyX> yep.
18:22:22 <hartmans> Well, yeah, but if among the eight of us we cannot find volunteers to fix what we believe is a critical problem in policy, I'd wonder whether we're an ongoing concern.
18:22:49 <OdyX> If I could only start one of the two (systemd/menu) in policy, which one should that be ?
18:22:54 <hartmans> I guess we move on for this meeting,?
18:23:05 <hartmans> systemd
18:23:23 <Mithrandir> (agree re systemd as more pressing than menu)
18:23:26 <keithp> I would like to help with the menu stuff in policy, but agree that systemd is more pressing
18:23:32 <hartmans> #topic New members process; need a champion
18:23:45 <hartmans> September 1 is coming out, we want to have our big push very soon.
18:23:57 <hartmans> So, we need a volunteer to get us new members.
18:24:34 <OdyX> #action OdyX to start something on systemd in policy, counting on TC members' constructive support.
18:24:55 <dondelelcaro> all of the stuff to do the push is in git; someone just needs to edit it and send the e-mails
18:25:06 * dondelelcaro shouldn't do it for obvious reasons
18:25:31 <OdyX> dondelelcaro should do it for obvious reasons
18:25:53 <fil> :-)
18:25:56 <dondelelcaro> if the last time was any indication, I'll no longer be a CTTE member before the process is finished
18:26:18 <dondelelcaro> so while I can send the initial e-mails, I cannot champion it
18:26:20 <hartmans> To clarify I think we're asking for a volunteer to run drumming up nominations.
18:26:23 <OdyX> okay. I'll do it (first) if noone else volunteers to send a few mails.
18:26:32 <hartmans> I think we can ask for a volunteer to make sure we review candidates and stuff later.
18:26:59 <dondelelcaro> if it's just sending the e-mails, I'm OK with taking care of that
18:27:08 <hartmans> excellent.
18:27:17 <dondelelcaro> but someone else needs to drive the whole process
18:27:24 <hartmans> #action dondelelcaro To send emails starting our membership process.
18:27:43 <hartmans> dondelelcaro:  Do they?  Or can we have a different driver at each stage to make the job smaller?
18:28:43 <OdyX> I'll be as pushy as last time, don't worry.
18:29:16 <OdyX> But I expect more nominations from TC members and Debian members, for the process to be somewhat meaningful.
18:30:14 <hartmans> Shall we move on?
18:30:19 <OdyX> #topic #741573 Menu System Policy
18:30:23 <OdyX> :)
18:30:33 <OdyX> I'll postpone this post-systemd-policy integration.
18:30:48 <hartmans> So, what I think we're waiting for here is OdyX and aba to coordinate
18:30:51 <hartmans> and understand state.
18:30:52 <OdyX> if aba can take it and make progress on that front, that's great.
18:30:54 <hartmans> anything to report?
18:30:57 <OdyX> nope.
18:31:06 <hartmans> Okay, let's defer until next time then.
18:31:31 <hartmans> #topic Additional Business
18:31:31 * fil wonders if this is the moment to again mention my mad scheme for for sending random mails out saying "Here is your TC nomination form, please use it"  (or perhaps, "please pass it on to the wisest DD you know to nominate someone" if you want well connected folk to do the nominations)
18:31:31 <OdyX> Like for all TC subjects, this is the kind of topic that needs a 2-3h burst of free mind-time to get a clear state in-mind.
18:31:54 <hartmans> fil:  I like the less-well-connected version in terms of diversity implications.
18:32:03 <hartmans> empower yourself:-)
18:32:12 <OdyX> fil: any fresh idea for getting new TC members is welcome, for what I'm concerned.
18:32:26 <hartmans> So, any additional business?
18:32:31 <OdyX> and when I write "new" I mean "from new corners of our ecosystem"
18:32:37 <fil> hartmans: we could try both and see if either produces useful results
18:32:43 <hartmans> sure
18:32:59 <hartmans> going once?
18:33:10 <OdyX> they're not conflicting.
18:33:33 <hartmans> Do we  need meeting time to discuss this idea?
18:33:59 <OdyX> it fits in the "TC member mandate" to find innovative ways to find their replacements, IMHO :)
18:34:10 <hartmans> agreed.
18:34:28 <hartmans> If not, thank you all.
18:34:33 <hartmans> #endmeeting