17:59:49 <marga> #startmeeting
17:59:49 <MeetBot> Meeting started Thu Dec 22 17:59:49 2016 UTC.  The chair is marga. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:59:49 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:59:54 <hartmans> I'm fairly distracted today
17:59:57 <marga> #topic Roll Call
18:00:02 <marga> Margarita Manterola
18:00:11 <fil> Philip Hands
18:00:13 <hartmans> Sam Hartman
18:00:19 <Mithrandir> Tollef Fog Heen
18:01:05 <marga> Is that quorum? :-/
18:01:22 <Mithrandir> does that matter? We're generally not voting in a meeting.
18:01:38 <Mithrandir> (as in, does it formally matter, I agree having so few folks around is a tad sad)
18:01:47 <marga> No, sure. It just feels weird to me, but whatever.
18:01:49 <marga> #topic Next Meetings
18:02:07 <marga> #info date set for January: 2017-01-26 18:00 UTC
18:02:23 <marga> #info date tentative for February: 2017-02-22 19:00 UTC
18:02:27 <Mithrandir> that might be interesting for me, I'll be on holiday then. I'll update my votes.
18:02:40 <marga> For Jan or Feb?
18:02:43 <Mithrandir> January.
18:02:53 <Mithrandir> worst case, you make do without me.
18:03:22 <marga> Ah, I see that it's still available.  Then maybe it's not as set as I understood
18:03:35 <marga> #info Date for January is still open for voting
18:03:49 <Mithrandir> I mean, I might be around, but nothing we need to discuss now.
18:03:59 <marga> #topic Review of previous meetings' TODOs
18:04:22 <marga> So, we had 3.  I actually had one myself that somehow didn't get reflected in the agenda:
18:04:29 <marga> - OdyX to start something on systemd in policy, counting on TC members' constructive support (not done)
18:04:36 <marga> - OdyX to figure out the state of the menu-system patch proposing to implement the rest of the TC decision (not done)
18:04:43 <marga> - OdyX and aba to find way forward within policy process reflecting input from debconf policy bof
18:04:59 <marga> This last one was not annotated, but I think it was also not done.
18:05:04 <OdyX> all three haven't seen any progress, but there was some policy work in that area.
18:05:13 <OdyX> any progress by _me_ is what I'm saying.
18:05:44 <OdyX> marga: ah I probably haven't looked at the previous meeting's log, sorry for that.
18:05:53 * lamby is lurking
18:06:14 <marga> The one I should have had was moving on with the New TC members nominations.  For which I did a bit right after the meeting and then flew to Argentina and failed to keep at it.
18:06:37 <marga> (we can discuss further on the actual point).
18:06:43 <marga> Anything else on this topic?
18:07:49 <marga> Alright, let's move on then.
18:07:52 <marga> #topic #841294 Maintainership of 'global' package - Retrospective
18:08:23 <fil> BTW OdyX if there's anything anywhere on the agenda you particularly want to contribute to, we should probably jump to that first before you go
18:08:48 <OdyX> nah I think I've written my thoughts by mail.
18:09:33 <marga> Ok, then about global retrospective: I'm not sure what to say.  The whole thing turned into a very ugly flamewar that deeply saddened me.  I'm not sure what we could do better in the future, though, which I think should be our focus now.
18:09:44 <OdyX> for global, what I can say is that it's been _incredibly_ frustrating to write mails with basically zero feedback, leaving without a clue if what I wrote was anywhere near good or useful.
18:10:07 <OdyX> I gathered feedback myself.
18:10:51 <Mithrandir> I agree it didn't turn pretty at all, and I think having what ends up about people in many ways might not best be discussed in public.
18:11:08 <Mithrandir> you end up with a non-helpful peanut gallery.
18:11:18 <aba> sorry the last months were incredibly painful due to non-debian events to me.
18:11:34 <aba> so I contributed less than intended.
18:11:35 <hartmans> OdyX:  I understand your frustration.
18:11:47 <hartmans> IUt is very painful to seek feedback and not get what you need
18:12:01 <fil> regarding this -- I note that I noticed only very late on how the timeline on the main bug went -- If i'd noticed that earlier, I'd have been much less patient I think, but having been patient I think at least Ron had every chance to present a case
18:12:28 <hartmans> Ron did present a case.  Some of us just disagreed with it.
18:13:04 <marga> I would prefer if we didn't start discussing what happened.  But rather, what we can do better in the future.
18:13:36 <marga> Or maybe just take this as something to ponder.  Because I think we SHOULD do better, but I don't know how.
18:14:30 <fil> hartmans: quite -- I wasn't suggesting that he did not -- although I wasn't always sure what he was wibbling on about, but that was up to him
18:14:45 <OdyX> (I'm drifting towards offline now, sorry…)
18:15:54 <fil> I also felt like I was acting in a vacuum -- I think we could probably do better if we actually used -private a little in such cases
18:17:11 <lamby> fil: To clarify, OdyX potentially using -private to express frustration/etc. regarding lack of feedback?
18:17:28 <marga> Yes, I thought about that as well. On the one hand, sometimes it's easier to discuss without fearing sudden aggression coming out of nowhere.  On the other hand, it feels like we should be able to discuss in the open.  But yeah, maybe we should have made use of -private.
18:19:37 <marga> Alright, any other thoughts?
18:19:58 <ScottK> FWIW, the one thing vaguely like this I've been involved in, I had private conversations with multiple at the time TC members, including on the phone.
18:20:02 <ScottK> I think it was helpful.
18:20:31 <ScottK> Particularly since voice is a lot higher bandwidth than typing (at least for me).
18:20:50 <aba> for everyone, as it's easier to transport additional information
18:20:58 <hartmans> I do think we should be more willing to use rtc.debian.org and phone
18:21:42 <marga> #info For the future: when a bug becomes such a flamewar, we should keep in mind that there are other media (private mail alias, private mail, voice calls, group voice calls, etc). And use those as appropriate.
18:23:48 <marga> Alright, I hear crickets, so let's move on.  I invite anybody that has thoughts on this to send emails to our mailing list.  I really feel we should be prepared and do better in the future.
18:23:51 <fil> lamby: it's mainly that it's not possible to know what other TC members think when they're silent in public -- I should perhaps have asked in private.  We dealt with this case completely in the open AFAIK, which perhaps means that things that might have been usefully said in private went unsaid
18:23:51 <marga> #topic #846002 blends-tasks must not be priority:important
18:25:10 <Mithrandir> under this bug, thanks a lot to fil for wading into it
18:25:14 <marga> Indeed
18:25:34 <marga> fil, you've done a lot of work here, so I'd like to hear your opinion on it
18:26:13 <fil> I've been trying to ameliorate this by inserting a simple menu just before the problematic on -- of course my latest test was sabotaged by the dejavu font name change, but I might be able to d something about that tonight
18:27:04 <marga> While I really like your solution, it doesn't actually solve the complaint about the priority
18:27:14 <fil> I think that the priority is wrong, but reducing it will not make things all better
18:27:15 <marga> Should we rule on that?
18:28:16 <Mithrandir> there's a meta-question here: who decides what goes into the installer/tasksel?  Are we ok with teams grabbing that space for themselves?
18:28:19 <aba> I think aobut saying "priority should be reduced, but what happens in next stable is up to the RMs because we don't want to spoil the release"
18:28:35 <jcristau> Mithrandir: shouldn't that be up to the installer team?
18:28:47 <aba> jcristau: yes
18:29:03 <fil> well, it would be good if we could keep the 3 blends somewhere in d-i for now, so the priority question is perhaps the wrong thing to worry about, since if we reduce it then there will probably be something more painful required to get that back in again
18:29:09 <jcristau> since that pretty heavily affects the ux for the installer
18:29:23 <Mithrandir> jcristau: yes and no, part of the idea when we started d-i was to give maintainers of affected packages more responsibility (and more say) in how their piece of software worked in the installer.
18:29:35 <Mithrandir> on the other hand, we don't want it to be free-for-all
18:29:48 <aba> fil: for this I don't want anyone force to downgrade it now. Rather "priority is obvoisly wrong but don't break something just for the sake of it"
18:29:49 <marga> fil, but I agree with jcristau that this should be decided by the maintainers of the installer and not by some random team.
18:30:23 <aba> marga: of course the installer maintainers could set up some way how others could subscribe their packages in. Basically just how they want to do it
18:30:47 <jcristau> Mithrandir: this isn't really affected packages though, more like random hijacking of the task install screen
18:31:19 <Mithrandir> jcristau: yes, I lean that way too, so I think that we should let the d-i folks have d-i work the way they want.
18:31:25 <fil> clearly we cannot have random people throwing stuff into d-i by playing with priorities, but I don't thik that's quite what happened here
18:31:50 <marga> Isn't it?
18:33:17 <Mithrandir> it's not like somebody added, say, an emacs task (to pick something I think would be crazy, but which I think some people could go "yeah, I kinda want that", so I don't think the "random" label is completely warranted.
18:33:35 <fil> when the vast list was inserted ages ago, well, perhaps, but now it's been trimmed back I think that was done as a collaborative act, was it not?
18:33:52 <hartmans> Do we need to rule?  It sounds like the installer folks will do something, up to including either adopting  fil's fixes or rolling back
18:33:52 <Mithrandir> I don't think (but I could be wrong) that the d-i team has anything against making blends accessible in the installer, assuming somebody finds a good way to do it.
18:34:20 <marga> I think we should rule
18:34:35 <aba> marga: what should be part of the ruling?
18:34:40 <jcristau> Mithrandir: yes, the random part was hyperbole
18:34:44 <marga> My position is that the package needs to go away and the values need to be integrated into tasksel.
18:35:40 <marga> If there's not enough peoplepower to do that in tasksel, then there would need to be a solution for that.
18:35:43 <Mithrandir> because you want it to be owned by the d-i team?
18:35:48 <marga> Yes.
18:36:11 <marga> Ah, I don't know if that question was for me :)
18:36:40 <fil> the big problem is that people have not had much time regarding d-i, so the team has been pretty much KiBi, and he's been swamped -- this was just a way of routing around that to get the tasks in
18:37:33 <marga> Well, maybe our ruling can also encourage people to help out with the maintance of d-i
18:37:41 <Mithrandir> marga: assuming you answered my latest question, it was for you, sorry if that wasn't clear.
18:37:46 <fil> as KiBi recently said, the right time to play with this was months ago -- sadly I was too busy back then, so I'm doing stuff now
18:38:34 <Mithrandir> it's worrisome if team d-i is basically KiBi though (not because he's not doing a great job, but because of all the usual reasons to avoid small/single-person teams)
18:39:04 <marga> fil, as I said, while I really like your solution and I think we should do it (be it now or later), I think that the blends-tasks package needs to go away regardless of when the better solution is applied to d-i.
18:39:08 <aba> so how do you feel for a rule for next stable and give KiBi / d-i / RMs a free hand for stable to deviate if useful?
18:40:19 <marga> Uhm, I'd be ok with saying that blends-tasks needs to go away (get integrated into tasksel) and let d-i maintainers decide if that happens before or after stretch
18:41:03 <fil> Mithrandir: well, quite -- that's why I've been trying to get more active.  I think once the automatic testing stuff works a bit better, I should be able to lower the bar to contributing to little more than pushing git and waiting for an email about how well things went
18:41:26 <marga> Mithrandir, I agree it's worrisome, but I know that d-i has been recruiting for quite a while now, and they haven't had much success there :(
18:42:03 <Mithrandir> mhm, not something we can fix here and now at any rate.
18:42:18 <marga> What does the rest think of my proposal?  Should I send it as a ballot?
18:42:27 <fil> it's duanting to contribute too -- it's weird enough to make it quite fragile
18:42:40 <jcristau> Mithrandir: d-i has been mostly a single person team for a very, very long time
18:42:55 <jcristau> might be a bit worse now, though
18:43:40 <Mithrandir> marga: I agree with the contents.  Can we wrap it in a way that makes the blends folks ok-ish with it?
18:44:14 <aba> marga: works for me
18:44:22 <marga> Mithrandir, any advice for that?
18:45:59 <Mithrandir> I guess just asking them to work together won't be sufficient, since that's why it ended up in our court.
18:46:35 <Mithrandir> can we say something like "we request the d-i team to work with the blends team(s)? to find a solution everybody can live with"?
18:46:41 <marga> ok
18:46:46 <marga> #action Marga to send a proposed ballot to the list today
18:46:53 <aba> thanks
18:47:01 <marga> Let's move on.
18:47:02 <Mithrandir> it probably needs polishing, but we can do that on the list.
18:47:07 <Mithrandir> (my suggestion, that is)
18:47:11 <marga> #topic #839172 TC decision regarding menu policy not reflected yet
18:47:26 <fil> I think they're going to be pretty upset if the 3 blends that are left disapear now -- quite rightly IMO.  The fact that it's implemented with priorities is unfortunate -- let's not rule narrowly on the priorities without considering the consequences
18:48:16 <marga> This is a pending TODO from quite a bunch of meetings back (I think even before I joined)
18:49:48 <fil> marga: predates me too AFAIK
18:50:04 <aba> well, this is bascially the result of a schisma on the policy side.
18:50:27 <aba> we (Debian) have the prerequisits now to resolve it but someone has to spend work on it.
18:50:37 <marga> What work?
18:50:50 <marga> Updating the policy?
18:51:09 <aba> right
18:51:13 <marga> And the policy maintainers won't do it because they disagree with the ruling?
18:51:23 <aba> eh, rather:
18:51:49 <jcristau> the only vaguely active policy maintainer seems to be the menu maintainer
18:51:51 <aba> Let me see if I can push it while still on the ctte, i.e. between Christmas and New Years eve
18:52:44 <aba> well, one disagrees with the ruling, the other two didn't push it yet.
18:52:55 <marga> #action aba to give it a try before the end of the year
18:53:02 <marga> #topic #836127 New TC members
18:53:21 <hartmans> I am about to have to disappear.
18:53:35 <jcristau> aba: which other two?
18:53:49 * aba is one of the other two
18:53:55 <jcristau> active policy maintainers?
18:54:00 <hartmans> I don't have enough information in order to rank nominees.
18:54:01 <jcristau> i kind of doubt that
18:54:10 <hartmans> In particular there are several nominees where I don't know how to rank.
18:54:26 <marga> So, this has stalled since I flew south for the summer. Sorry about that, I find it hard to keep going through routine when I'm out of my normal environment, and I've been focusing my Debian energy on packages due to the upcoming freeze.
18:54:39 <fil> aba: just in case you don't manage it (menu), can we agree that the TC strongly encourage you to do so at your earliest convenience
18:55:07 <aba> fil: sure. The best to help is peobably to ping me on Tuesday or so on IRC :)
18:55:33 <marga> So, I propose that I will A) compile a list of the current nominees B) Do a bit of research on each of them to present a short bio of them. After that, others can add any other facts that I missed to the bios.
18:55:42 * fil sets an alarm :-)
18:56:20 <fil> marga: that would be great -- thanks :-)
18:56:36 <marga> The problem with the current date is that we will soon lose input from two ctte members.  So, I'd ask aba and dondelelcaro to please give their feedback before EOY.
18:57:17 <aba> I intended to not give feedback because I won't sit with anyone of them in the ctte
18:57:26 <aba> if you want I can give feedback of course
18:57:50 <marga> I think feedback is useful anyway.
18:58:15 <Mithrandir> I think we trust you enough not to try to get somebody in who would be bad to have on the committee. :-P
18:58:36 <marga> #action marga to compile a list of nominees and work on presenting short bios about them. To be done before Dec 25th.
18:58:59 <marga> #topic Additional Business
18:59:44 <marga> Anything anybody wants to bring up?
19:00:33 <Mithrandir> nothing from me
19:00:39 <aba> Thanks for all the fish!
19:01:19 <Mithrandir> indeed, I'd like to say a big thank you to the outgoing members.
19:02:11 <marga> #agreed We thank the outgoing committee members for their years of participation in the committee.
19:02:26 <marga> And with that...
19:02:27 <marga> #endmeeting