19:00:35 <OdyX> #startmeeting
19:00:35 <MeetBot> Meeting started Wed Feb 22 19:00:35 2017 UTC. The chair is OdyX. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:35 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:00:45 <OdyX> Who's here?
19:00:47 <fil> Philip Hands
19:00:50 <Mithrandir> Tollef Fog Heen
19:00:52 * OdyX is Didier 'OdyX' Raboud
19:01:07 <keithp> good morning!
19:01:10 <keithp> keith Packard
19:01:27 <fil> keithp: good evening :-)
19:01:37 <OdyX> Let's proceed
19:01:43 <OdyX> #topic Next Meetings?
19:02:11 <OdyX> So I propose, following the last meeting(s) feedback(s) to try to have these in a somewhat regular manner.
19:02:23 <OdyX> That would be "Third Wednesday in a month, 19 UTC.
19:02:32 <OdyX> What do you think '
19:02:42 <hartmans> Sam Hartman
19:02:50 <Mithrandir> that time generally works for me.
19:02:57 <keithp> OdyX: that works for me at least, and a regular time would be nice to put on a calendar
19:03:00 <hartmans> I don't have a problem with 3rd Wed 19 UTC
19:03:07 <fil> a fixed date improves my chances of remebering to turn up, and that time works for me
19:03:15 <hartmans> Fixed date ++
19:03:23 <OdyX> It's a two-fold discussion, a) whether regular works; b) whether that pick works,
19:03:46 <OdyX> #agreed There seems to be consensus in favour of a fixed time-in-the-month.
19:04:13 <Mithrandir> I don't care about regular vs ad-hoc, so whatever works for folks.
19:04:28 <OdyX> Good. Let's take that as granted, and keep this as a possible change in the future.
19:04:39 <OdyX> It's not set in stone, but a good start, I think.
19:04:41 <OdyX> Good.
19:04:53 <OdyX> #topic Review of previous meetings' TODOs
19:05:06 <OdyX> Three TODO's were mine, I haven't progressed at all.
19:05:31 <OdyX> 1) something about systemd in policy is hard to dive into, also there was some work in policy recently
19:05:51 <OdyX> 2) menu-system patch needs me (+ someone) to take time+energy.
19:06:12 <OdyX> 3) "OdyX and aba to find way forward within policy process reflecting input from debconf policy bof" I'm not sure what is expected from me.
19:06:36 <OdyX> Let's move on then (but I _do_ welcome your input on all these three items).
19:06:45 <OdyX> #topic #850887 Decide proper solution for binutils' mips* bug
19:07:34 <OdyX> On that; besides reflections on (as usual) how we (as TC) could'a/would'a have done better, I think it should be closed.
19:07:51 <OdyX> hartmans: you were closest to that subject, what is you insight on that one ?
19:07:58 <OdyX> s/you/your/g
19:08:17 <hartmans> I think it should be closed as well.
19:08:28 <hartmans> doco keeps wanting to add more content, but I think we've waited long enough.
19:08:41 <hartmans> Do you want me to close it?
19:08:55 <OdyX> Well. I don't see the point in keeping it open.
19:09:08 <hartmans> Also, I think even after being closed we are interested in anything doko wants to say
19:09:15 <OdyX> That was roughly a timing discussion, where doko would have waited, and RT proceeded faster.
19:09:26 <OdyX> Both were right, from where I sit.
19:09:51 <hartmans> Well, perhaps; since he's never told me what he wants to say I don't know if it is about the timing or something else. But I don't think holding it open helps.
19:10:33 <OdyX> hartmans: oh, absolutely. Closing a bug means "the TC shouldn't be expected to take a formal decision", but doesn't mean "the TC is closed to further feedback/opinions".
19:10:56 <OdyX> hartmans: please close it with reasonable hindsight, if that works for you.
19:11:03 <hartmans> OK, if you want to give me an action I can close
19:11:34 <OdyX> #action hartmans to close #850887 'decide proper solution for binutils\' mips* bug'
19:11:37 <OdyX> #save
19:11:45 <OdyX> #topic #846002 blends-tasks must not be priority:important
19:12:13 <OdyX> I'm not overwhelmingly happy of how it got to closure.
19:12:41 <OdyX> But I think it should be closed as well with a hint for involvees to talk to eachother after the stretch release.
19:13:13 <OdyX> It feels like the "ever-again" "development has to happen just after a release, not just before a freeze" problem.
19:13:26 <OdyX> fil: any opinions here ?
19:13:29 <fil> nope, me neither -- is the priority actually going to get dropped, and if so is KiBi's kludge going to be backed out?
19:13:49 <Mithrandir> development has to slow down as we get to a freeze> yes, and that's not something the CTTE can fix/change.
19:14:06 <OdyX> s/can/is willing to, either, /
19:14:12 <hartmans> No, but we could perhaps come up with guidance for when people could bring issues forward.
19:14:40 <hartmans> That is, perhaps we could get onto the release team schedule that in order to have reasonable chances of resolving issues, they should be brought to the TC by date x
19:14:53 <hartmans> if they are to be resolved for a given release
19:14:57 <OdyX> As for that subject, we voted, and there was result, so we should at least announce result, and move forward.
19:15:39 <Mithrandir> hartmans: that sounds reasonable.
19:15:50 <OdyX> I will admin I expected marga to do it, and will therefore coordinate with her how we should do that, at least.
19:15:57 <OdyX> s/admin/admit
19:16:15 <OdyX> (not blaming marga, _at all_ )
19:16:20 <Mithrandir> ok, so you'll ensure it gets announced and closed? I can do it if not.
19:16:43 <keithp> thanks
19:16:47 <OdyX> #action OdyX to coordinate with marga (eventually with Mithrandir's help) to close #846002 with the vote's result.
19:17:13 <OdyX> Mithrandir: let's coordinate between us; if you have more bandwidth/time, so much the better.
19:17:23 <OdyX> #topic #839570 Browserified javascript and DFSG 2 (reopening)
19:17:25 <OdyX> #save
19:17:26 <Mithrandir> I don't, but it's not nice to let you carry all the todos either.
19:17:36 <hartmans> I was supposed to rclose this right?
19:17:44 <hartmans> If so, my bad and I'll deal with it within an hour
19:17:59 <OdyX> I haven't checked the minutes, but that's my recalling, yes.
19:18:03 <OdyX> Ack, thank you!
19:18:09 <hartmans> ok, will do
19:18:13 <OdyX> #agreed hartmans do close that one in the next hour.
19:18:20 <OdyX> #topic #839172 TC decision regarding menu policy not reflected yet
19:18:33 <OdyX> Regarding that, I have a running TODO item to tackle that.
19:18:41 <OdyX> It's _hard_ to dive into it.
19:18:50 <keithp> can I help with that at all?
19:19:07 <OdyX> keithp: yes!
19:19:31 <OdyX> keithp: we should find a timeslot to cook a suitable initial patch to Policy together, if that works for you!
19:19:40 <keithp> sounds like a fine idea
19:20:17 <OdyX> #agreed keithp & OdyX to find some time to prepare an initial "discussion-ready" patch for the 'Debian menu' Policy in Debian policy
19:20:25 <OdyX> #topic #836127 New TC members
19:20:27 <OdyX> #save
19:20:33 <OdyX> Great.
19:21:07 <OdyX> I think most of us gave feedback about the candidacies we got.
19:21:38 <OdyX> What's blocking us in the process towards getting this towards a initial shortlist-of-two to give the DPL ?
19:21:38 * fil appologises for not responding to date -- life has been getting in the way -- I should have time very soon
19:21:40 <hartmans> For the public record, I'm really sad when I think about this process.
19:21:48 <OdyX> Oh, I concur.
19:21:56 <Mithrandir> ditto
19:22:03 <hartmans> We have a number of candidates, but I don't think we have a quality process for choosing between them.
19:22:09 <OdyX> I share hartmans's sadness, and am taking my part of the blame.
19:22:37 <hartmans> I think that name recognition by current members of the TC is the most effective technique we have come across so far, and I think we're all aware of the shortcomings of that.
19:22:50 <OdyX> Do we Condorcet them all (adding NOTA), or condorcet them individually, or a different process ?
19:23:29 <OdyX> "to condorcet" >> Merriam-Webster
19:23:48 <keithp> it seems like a ballot containing all of them is indicated here
19:23:50 <Mithrandir> hartmans: on the other hand, is it better to delay because we think we have a less-than-optimal process?
19:24:02 <keithp> anything else would show a explicit preference based on the order of ballots?
19:24:12 <OdyX> I think we should nominate at least one to the nominees we have, as it's as much our shortcoming, than the project's.
19:24:36 <OdyX> Can we agree to private-condorcet them all ?
19:24:43 <Mithrandir> wfm.
19:24:47 <hartmans> I think it would be fine to conduct a poll containing all the candidates and look at the ranked results.
19:25:06 <OdyX> (aka run a standard resolution across the names we had, in private, including NOTA).
19:25:06 <hartmans> I don't know that we then pick the top 3... Ultimate we should vote on a slate.
19:25:12 <hartmans> rather top two
19:25:33 <OdyX> worst case we condorcet, take the winner, and condorcet again.
19:25:39 <hartmans> But, I think the rankings may help us see what is next, and then people may want to propose slates or something.
19:26:19 <OdyX> I concur. At some point, the ranking process helps to clear the waters, and see where we stand.
19:26:28 <hartmans> So, let's do that.
19:26:29 <OdyX> Who would like to start that ?
19:26:48 <OdyX> I can propose a single ballot with all candidates on it, and see where it goes.
19:27:06 <Mithrandir> sounds like a start.
19:27:19 <keithp> I agree
19:27:22 <OdyX> hartmans: you wanted to only have people there that are proposed, or can you live with a "everyone-ballot" ?
19:27:52 <hartmans> I don't know what you mean by prop,proposed?
19:28:04 <hartmans> I was thinking we'd start by ranking all accepted nominations
19:28:08 <OdyX> aka "people actively wanted on a ballot" vs "nominees"
19:28:35 * fil is also not understanding that distinction
19:29:03 <hartmans> I think OdyX is asking if we want people on the ballot who have no affirmative support within the TC
19:29:11 <OdyX> exactly.
19:29:14 <Mithrandir> (if there are any such)
19:29:26 <hartmans> In the past I've argued that such affirmative support should be required for putting a candidate forward.
19:29:28 <OdyX> the distinction we made in the last round was "one actual TC member wants that person on the ballot" vs "we have that nominee, but no explicit support from a TC member (yet)".
19:29:39 <hartmans> I still think that, but this is something I view as a poll to understand our thinking,
19:29:48 <hartmans> so I think all accepted nominations is right
19:29:57 <OdyX> Good. We're in rough agreement then.
19:30:16 <OdyX> Unless someone steps in, I'll prepare a ballot, and start a private vote.
19:30:21 <Mithrandir> I think all nominations is fine, if a candidate has no support they'll end up being ranked at the bottom.
19:30:32 <hartmans> Mithrandir: not true.
19:31:11 <hartmans> Mithrandir: Without requiring active support you tend to get people who are acceptable to everyone ranked fairly highly even when no one thinks they would be great.
19:31:13 <Mithrandir> you think they'll end up near the middle in case of antipaties?
19:31:20 <OdyX> (just to make sure we have everyone on the same page; we're talking about a private vote on the TC private alias, to help the TC reach conclusion; the public process is "the TC checks with the DPL for eventual veto's, runs the public vote, and the DPL nominates").
19:31:30 <Mithrandir> yes, this is the private discussion
19:32:13 <OdyX> Iff we understand that initial poll as a consensus-finding poll, and not a proper decision, we should move on with it.
19:32:17 <hartmans> Mithrandir: My observation that acceptable but not favored candidates do well in rankings based on experience within student groups at MIT and within the IETF's nominations process.
19:32:40 <OdyX> and ping us in sequence so that we get that through before I have to resign as chair (end of March).
19:33:16 <OdyX> Good. I see no volunteers; I'll take that, but please ping me!
19:33:47 <OdyX> #action OdyX to start private Standard Resolution procedure to sort out the most favored candidates.
19:33:49 <OdyX> #save
19:34:25 <OdyX> #topic Additional Business
19:34:31 <OdyX> have one.
19:34:42 <OdyX> DebConf17. Who plans to attend ?
19:34:47 * OdyX raises hand.
19:35:06 * fil o/
19:35:26 <OdyX> I will check my flights' and then file a TC session in the talks.
19:35:34 <hartmans> I think I will be. Have not yet asked for the travel approval but can do that shortly
19:36:07 <OdyX> I have very good memories from Cape Town, and would really like to see the TC back together IRL @DebConf.
19:36:30 <fil> I've so far done nothing about it, so should look at flights etc.
19:36:33 <OdyX> It's been super-useful to ease understanding between us-.
19:36:37 <Mithrandir> I am.
19:36:46 <keithp> I plan on being there
19:37:31 <OdyX> Good.
19:37:36 <OdyX> Any other varia ?
19:38:29 <hartmans> I have none
19:39:19 <OdyX> Good.
19:39:33 <OdyX> Thank you for the productive meeting,
19:39:44 <fil> thanks for chairing
19:39:45 <OdyX> 40 minutes; that's (too) good, perhaps.
19:40:07 <OdyX> Just an idea, should we have a "questions from the public" part ?
19:40:21 <OdyX> (or are we just us 5 around)
19:40:53 <Mithrandir> we could welcome questions from outside the TC during the "other business" bit.
19:41:00 <Mithrandir> (or as a separate step)
19:41:25 <OdyX> We do welcome questions anytime though, and on the list as well.
19:41:32 <OdyX> (and individually, as well).
19:41:33 <fil> That seems like it would only be wise when nothing contentious is happening ;-)
19:41:38 <OdyX> :-)
19:41:42 <OdyX> Good.
19:41:44 <OdyX> #endmeeting