19:04:43 <Mithrandir> #startmeeting
19:04:43 <MeetBot> Meeting started Wed Mar 22 19:04:43 2017 UTC.  The chair is Mithrandir. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:04:43 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:05:06 <fil> Philip Hands here
19:05:09 <Mithrandir> #topic who are here?
19:05:15 * marga Margarita Manterola
19:05:17 <Mithrandir> Tollef Fog Heen
19:05:25 <hartmans> Sam Hartman
19:05:54 <fil> Philip Hands
19:06:09 <Mithrandir> #topic Next meeting?
19:06:46 <Mithrandir> Seems like the new schedule of the third Wednesday hasn't sunk in, but if people are ok with it, let's stick with it for a few more cycles to see how it works out?
19:07:15 <marga> It would be April 19th
19:08:01 <Mithrandir> just after Easter, no problem for me at least.
19:08:35 <hartmans> I have no problem with that
19:08:35 <Mithrandir> moving on.
19:08:36 <marga> I'd say that we should go with it.
19:08:38 <Mithrandir> okies
19:08:41 <Mithrandir> #topic Review of previous meetings' TODOs
19:09:18 <Mithrandir> OdyX has a few items which seem to be stuck (systemd in policy, menu, debian policy bof)
19:09:32 <Mithrandir> (not trying to shift blame, sorry if it appeared that way)
19:09:37 <Mithrandir> what can we do to get those unstuck?
19:09:48 <Mithrandir> IIRC they've been stuck for a bit?
19:09:53 <marga> Indeed
19:10:09 <marga> I think we could try to split them
19:11:20 <marga> What's the systemd in policy todo exactly?
19:11:42 <Mithrandir> IIRC it's that systemd is basically unspecified in Policy.
19:11:51 <fil> isn't the underlying problem that policy is stuck?
19:12:28 <Mithrandir> I think so, yes.
19:12:43 <marga> I think I could volunteer for that one.
19:13:23 <fil> aba seemed to think he might be able to unstick it IIRC, but as is often the case those best placed to do the work are too busy
19:13:41 <Mithrandir> I don't have bandwidth at the moment to jump into unsticking policy, I'm afraid.
19:14:02 <marga> Is the menu one the same thing?
19:14:13 <marga> i.e. updating policy?
19:14:33 <Mithrandir> I'm not sure what the definition of done is for that one.
19:15:03 <hartmans> The menu one is that our recommendation on menus and desktops was only partially implemented
19:15:05 <fil> AFAIK that is the thing that is causing the log-jam, as it is a matter of dispute, is it not
19:15:10 <hartmans> and now policy is in a messy state
19:15:32 <marga> sigh
19:15:52 <marga> What's the BOF one?
19:17:26 <Mithrandir> it does look a bit like "fix the policy process". I hope it's not that comprehensive. :-)
19:18:06 <marga> Ok, so I volunteer to help OdyX with this.
19:18:33 <Mithrandir> thanks.
19:18:51 <Mithrandir> ok to move on, or does anybody have more to say on this?
19:19:14 <fil> marga: talkig to aba about it, and offering to help, might be the way to go, as I think he had plans, but seems not to have had time
19:19:25 <marga> ok
19:19:56 <Mithrandir> (for irc meetings, I miss work chat's "$x is typing" notification…)
19:19:59 <Mithrandir> but, moving on.
19:20:01 <Mithrandir> #topic #857257 Supporting configuration file changes between versions in unstable/testing
19:20:49 <marga> Is there actually something to discuss?
19:21:09 <Mithrandir> this looks like pretty much a no-brainer to me. You have to support upgrades inside of testing/unstable too, unless you have Really Good Reasons.
19:21:37 * marga nods
19:21:48 <fil> I don't think there's anything for us here -- it looks like it's going to get kicked out, and that strikes me as just right -- meanwhile. Praveen's not bothered to respond, as is his way when special pleading doesn't get what he wants *grump*
19:21:48 <Mithrandir> if you don't want that, use experimental.
19:22:20 <Mithrandir> (where I still think people should try to support upgrades to some reasonable level, but where more leniency is granted)
19:22:26 <marga> Should we issue a clear opinion about this?
19:22:50 <Mithrandir> I think that'd be fine.
19:22:55 <marga> I mean, the whole thread is already pretty clear
19:23:08 <marga> But it would make sense to issue an opinion and make it even clearer
19:23:46 <fil> I was perhaps overly polite in the bug -- the code is garbage IMO
19:24:08 <Mithrandir> either is fine with me, just closing the bug as "no, this is clearly covered by policy already" or as a formal statement.
19:26:23 <fil> how about "Please don't bother us with overly specific requests for exceptions unless you're very sure there's nothing else horribly wrong with your code" ;-)
19:26:29 <Mithrandir> I can close the bug, if somebody wants to make it a formal statement I'm happy to vote on it.
19:26:32 <marga> heh, nah.
19:26:39 <Mithrandir> but I'm not going to write it up myself.
19:27:25 <Mithrandir> #action tfheen to close 857257
19:27:28 <Mithrandir> #topic #850887 Decide proper solution for binutils' mips* bug
19:27:37 <Mithrandir> (let me know if I'm moving too quickly)
19:28:01 <Mithrandir> where is this stuck now?  Isn't it just to be closed as overtaken by events?
19:28:54 <marga> I also don't know.  I remember doko asking for us to keep the bug open. But nothing else.
19:29:41 <fil> hartmans: did Matthias get back to you about why the bug should stay open?  (I've forgotten where this got to)
19:30:03 <hartmans> No, sorry, i'll go close this.  I promised to do so a the last meeting then got sick
19:30:08 <Mithrandir> hard to know when it's not documented in the bug and no response to Sam's question from two month's back.
19:30:16 <Mithrandir> hartmans: thanks, and I hope you're well again.
19:30:37 <Mithrandir> #topic #846002 blends-tasks must not be priority:important
19:31:00 <Mithrandir> is there anything left?
19:31:20 * marga sighs
19:31:33 <marga> Publishing the results of the vote?
19:31:34 <marga> It's now so late that it's really moot
19:31:45 <marga> This is my fault, I dropped the ball
19:32:12 <fil> I'm not sure that this is something we can do anything about, but I find it unfortunate that KiBi's patch seems likely to stay around, despite it not being needed any more (debianedu had to patch around that)
19:32:50 <Mithrandir> stay around post-stretch, or just for stretch?
19:33:28 <fil> stretch I'd assume
19:33:51 <Mithrandir> I can see that being less-than-optimal, but is it something we should chase?
19:34:04 <fil> post-stretch we can fix things properly -- hopefully in a point release of stretch, but that's probably up to KiBi
19:34:53 <fil> no, it's up to KiBi, no point trying to micro-manage
19:35:16 <Mithrandir> ok, I suggest we action this as marga to close the bug and publish the results of the vote? (Assuming she's fine with that?)
19:35:39 <marga> Mithrandir, does it still make sense?  It's been months :-/
19:35:45 <Mithrandir> just close it, then
19:36:00 <marga> Ok
19:36:10 <Mithrandir> #action marga to close #846002
19:36:21 <Mithrandir> moving on
19:36:22 <wouter> marga: not that my opinion on the matter matters, but I think it makes sense to publish, even if it's been months
19:36:39 <wouter> there's been a vote, after all, might help for future reference on similar things
19:36:50 * wouter goes back to quietly following now ;)
19:37:07 <Mithrandir> #topic #839172 TC decision regarding menu policy not reflected yet
19:37:48 <Mithrandir> how is this different from the the bits covered in reviews?
19:38:36 <marga> I think it's the same
19:39:02 <Mithrandir> ok, let's skip it then
19:39:06 <Mithrandir> #topic #836127 New TC members
19:40:19 <marga> We should vote publicly?
19:40:43 <Mithrandir> we should, if the result of the private vote is clear.
19:40:50 <Mithrandir> I think it might be, but I haven't checked.
19:41:15 <Mithrandir> marga: are you driving it to completion? I feel like you've taken on everything this meeting.
19:41:35 <Mithrandir> maybe somebody else can champion the rest of it?
19:41:38 <marga> lol
19:41:50 <marga> Yeah, I'd let someone else drive this part
19:43:36 <fil> fair enough -- I'll check if the conclusion is clear yet, and if so publish a vote
19:43:45 <Mithrandir> thanks
19:43:47 <marga> Thanks
19:44:05 <Mithrandir> #action fil to check if conclusion is clear and publish public vote
19:44:13 * fil suspects it's not quite there yet
19:44:21 <Mithrandir> anything more on this?
19:44:59 <marga> I guess not
19:45:02 <Mithrandir> #topic Additional Business
19:45:16 <Mithrandir> Nothing from me.
19:46:10 <marga> I have one thing
19:46:25 <marga> I think this "Respond within one week" policy backfires
19:46:41 <marga> It's a reinforcement feedback loop that affects us all at some point or other in time
19:46:49 * fil agrees
19:47:15 <marga> For new TC members, can we not tell them that? :)
19:48:04 <fil> it seems to encourage a policy of "wait at least a week before responding" (for me at least ;-) )
19:48:14 <hartmans> I don't understand
19:48:25 <hartmans> What is your concern?
19:49:47 <marga> My concern is that given the delays in getting replies to emails, conversations take a long time.  The reinforcement feedback loop part is that while at some point I was paying a lot of attention to the debian-ctte folder, given how my mails go ignored for days, I now sometimes have a tendency to not visit the folder more than once a week.  This leads to conversations taking longer and so on
19:50:28 <marga> i.e. the fact that my mails go unreplied triggers a change in my own behavior of not replying timely to other people's emails
19:50:56 <Mithrandir> people are different here, I reply when I can, and try to do it straight away in normal cases
19:50:57 <fil> quite, it seems to make every round of discussion take at least a week, which is pretty useless for decissions that will be worthless if they take longer than a few days
19:51:21 <hartmans> OK.
19:51:24 <hartmans> One thing to consider...
19:51:35 <hartmans> This is much better than when I joined the TC.  At least people look once a week.
19:51:42 <fil> lol
19:51:58 <hartmans> so, I agree it's broken.  I think saying nothing may make it worse, but I will not stand in the way of trying to improve.
19:52:58 <marga> Ok, how about something like "Please try to give priority to replying to emails, with a maximum time of a week"?
19:53:06 <marga> Or something along those lines, possibly better worded
19:53:45 <Mithrandir> I have no problems with that.
19:55:05 <hartmans> That sounds great
19:55:11 <marga> :)
19:55:16 <fil> How about saying that if you wish your opinion to be taken into account it needs to be provided in a timely manner -- certainly no more than a week later than the thing you're replying to
19:55:16 <Mithrandir> let's run with that, then
19:56:33 <marga> SGTM
19:56:37 <marga> Nothing else from my side
19:57:02 <Mithrandir> closing out, then
19:57:04 <hartmans> Nothing here
19:57:06 <Mithrandir> #endmeeting