18:59:39 <OdyX> #startmeeting
18:59:39 <MeetBot> Meeting started Wed Jul 19 18:59:39 2017 UTC.  The chair is OdyX. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:59:39 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:00:05 <hartmans> Sam Hartman
19:00:07 * marga Margarita Manterola
19:00:11 <fil> Philip Hands
19:00:17 <OdyX> marga, fil, hartmans, Mithrandir, bremner, ntyni : ping
19:00:21 <OdyX> Didier Raboud
19:00:23 <ntyni> Niko Tyni
19:00:42 <bremner> err, right. David Bremner
19:00:49 <Mithrandir> Tollef Fog Heen
19:01:14 <OdyX> Oh, forgot keithp
19:01:21 <OdyX> (I'm bad at names, and lists)
19:01:38 <Mithrandir> (just use pingall. :-) )
19:01:56 <OdyX> yeah, right :)
19:02:08 <marga> But there's a lot of extra people
19:02:20 <bremner> not sure why else anyone would idle here, other than to watch meetings
19:02:39 <Mithrandir> yes, that.
19:02:48 <OdyX> #topic Review of previous meetings' TODOs
19:02:59 <OdyX> I had the chair formal vote: check
19:03:26 <OdyX> and closing 862051 acknowledging consensus: no check
19:03:53 <OdyX> marga: closure mail for other contenders ?
19:04:02 <marga> ... not done
19:04:05 <marga> Bad Marga
19:04:23 <Mithrandir> I don't think we can just close 862051, as I wrote in the mail, since it means reverting a previous decision by the ctte.
19:04:43 <Mithrandir> need to fix up the suggested text with feedback
19:04:43 <hartmans> Mithrandir:  this is nodejs
19:04:45 <hartmans> ?
19:04:48 <OdyX> marga: do you intend to do it, and do you have capacity ?
19:04:54 <OdyX> (Let's close one topic at a time :-) )
19:04:55 <Mithrandir> hartmans: yes.
19:05:19 <marga> I should do it, it shouldn't take that long
19:05:37 <OdyX> #action marga to send closure mails to other contenders (which list stays TC-only)
19:05:41 <hartmans> Mithrandir:  I'm fine  if we want to have a formal resolution if you would prefer that.  I can make arguments on both sides of the procedural issue
19:05:42 <OdyX> Good, let's move on
19:05:52 <OdyX> #topic #865929 Advice on dealing with GRUB upgrade failure caused by init-select
19:06:02 <OdyX> (We'll come to the nodejs one in a moment)
19:06:21 <OdyX> This was opened by cjwatson, right?
19:06:28 <Mithrandir> yes
19:06:28 <fil> yup
19:06:44 <OdyX> It seemed we had consensus, but at least I failed to communicate that I was in agreement with the crowd.
19:07:13 <fil> the consensus seems sane to me too (having just read it)
19:07:14 <ntyni> ack on apparent consensus
19:07:34 <OdyX> My line of thinking was that removed packages lose the right to claim configuration files, and if other packages have to do some cleanup after that, it's a policy violation that makes a lot of practical sense.
19:07:50 <OdyX> And I don't think we should be generic about that, but this particular case seemed quite clear.
19:08:44 * fil agrees, and no need to wait for policy to get round to reflecting that, as new policy is being developed by the act of fixing this
19:08:56 <hartmans> makes sense
19:08:57 <OdyX> Who could champion a resolution around these lines ?
19:09:19 <OdyX> (not mine precisely, the bug consensus)
19:09:26 <ntyni> fwiw I don't think it's even a policy violation in the first place
19:09:40 <ntyni> it's adopting an orphaned configuration file
19:09:45 <OdyX> I'm underwaters @work, so I can't commit to anything currently :-/
19:10:14 <ntyni> I guess I could take a shot though I have no experience drafting resolutions so far :)
19:10:19 <marga> Same here
19:10:36 <bremner> by resolution we just mean the requested advice, right?
19:10:39 <ntyni> yes
19:10:47 <OdyX> Well yes. A somewhat formal text.
19:11:02 <fil> I'd need to read it all properly again, but can probably come up with something after that
19:11:24 <hartmans> ntyni:  If you draft a first cut and  want to drop me mail at hartmans@debian.org (copying the list if you like) I'd be happy to review
19:11:38 <hartmans> I don't currently have cycles to put together the advice but would be happy to do my best at resolutionification
19:11:50 <ntyni> thanks, works for me (unless fil wants to do it? :)
19:11:55 <OdyX> fil & ntyni care to collaborate on that one?
19:12:01 <ntyni> sure, fine by me
19:12:09 <fil> me too
19:12:14 <hartmans> my rationale is to get more people familiar writing resolutions which is why I suggested working with you.
19:12:24 <ntyni> cool, I'll get back to you both then :)
19:12:33 <hartmans> O, no, fil is totally qualified
19:12:40 <OdyX> #action fil & ntyni to draft a resolution for #865929
19:12:41 <hartmans> I'll stand aside and let things move faster
19:12:54 <ntyni> okay
19:13:08 <OdyX> I don't want anyone feel excluded, but I'm all for efficiency.
19:13:16 <OdyX> Anything else to add to that one?
19:13:39 <OdyX> #topic #862051 Rename nodejs back to node for buster, now that ax25-node has been removed?
19:13:48 <fil> hartmans: thank you for your confidence (however misplaced ;-) )
19:13:49 <OdyX> There we have it: node vs nodejs :)
19:14:26 <bremner> so we have consensus+bikeshedding on wording?
19:14:51 <bremner> (says the first bikeshedder)
19:15:19 <OdyX> Ian's resolution is going too much into details, but generally fine
19:15:24 <Mithrandir> I asked for wordsmithing and feedback, so I don't really think bikeshedding is the right term.
19:15:32 <bremner> ack
19:15:32 <OdyX> I don't like the "4. indefinitely"
19:16:01 <OdyX> Well, actually, re-reading it, it seems fine if you remove 4.
19:16:10 <bremner> 4 seems anyway redundant?
19:16:11 <Mithrandir> I'm slightly leaning towards just saying 1. resolution repealed and in the surrounding text noting that this means nodejs is free to do whatever they want (within the normal boundaries of policy)
19:16:30 <hartmans> Mithrandir:  I support that
19:16:31 * fil thinks the only thing we actually need to resolve is 1. ... what he said
19:16:36 <bremner> that also occured to me
19:16:40 <OdyX> Mithrandir: I'm doing misjustice to your proposal; I was just reading the buglog from the bottom.
19:17:03 <OdyX> I'm fine with that.
19:17:18 <OdyX> "that" being your proposal being "just 1."
19:17:39 <Mithrandir> ok, seems like we're in agreement.  I'll do another round with a proposal and assuming nobody has major complaints take it to a vote.
19:17:43 <Mithrandir> so we can get this closed out.
19:17:50 <bremner> sounds good to me
19:18:05 <ntyni> works for me too
19:18:11 <ntyni> & thanks :)
19:18:12 <OdyX> #action Mithrandir to do another round with a proposal and assuming no major complaints, take #862051 to a vote.
19:18:17 <marga> I agree, will the rationale include that it's repealed due to it being obsolete?
19:18:51 <Mithrandir> marga: it already does, see the first sentence.
19:19:05 <Mithrandir> or first paragraph, really.
19:19:29 <marga> Ok, yeah, sorry. I was just mentioning the proposed shortening
19:19:44 <marga> Anyway, fine with me
19:19:44 <Mithrandir> right, I'll keep the intro
19:19:45 <OdyX> #info https://bugs.debian.org/862051#63 is Mithrandir's original proposal.
19:20:02 <OdyX> Good, we keep things moving.
19:20:05 <OdyX> #topic #839172 TC decision regarding #741573 menu policy not reflected yet
19:20:21 <OdyX> It's on the agenda as it's an open bug. Nothing moved in that area.
19:20:43 <OdyX> But I'm happy to see the Debian Policy Team back alive.
19:20:43 <marga> We will work on it during DebConf?
19:20:47 <OdyX> We will.
19:20:52 <marga> K
19:21:12 <bremner> at least one policy editor will be there
19:21:16 <OdyX> #info Work will get moving in that area at DebConf17.
19:21:23 <OdyX> #topic Additional Business
19:22:04 <OdyX> #info The DebConf TC BoF is scheduled
19:22:16 <Mithrandir> yay, when?
19:22:24 <marga> Nothing from me. See most of you on monthly
19:22:31 <marga> Montreal :)
19:22:42 <OdyX> https://debconf17.debconf.org/talks/203/
19:22:49 <OdyX> Aug 07, 17:00 local time
19:23:08 <hartmans> Despite my being a flake I did manage to register for debconf thanks to help from the debconf team
19:23:10 <OdyX> #action OdyX to add all present TC members as co-speakers
19:23:23 <fil> hartmans: great :-)
19:23:26 <OdyX> (I was in a hurry as my initial submission apparently disappeared)
19:23:28 <OdyX> hartmans: cool
19:23:49 <hartmans> I will be in Keith and bdale's hotel
19:23:57 <keithp> hartmans: cool
19:24:05 <OdyX> ohai :)
19:24:16 <keithp> yeah, oops; trying to get out of the house and spaced the meeting
19:24:21 <Mithrandir> no additional business from me.  Looking forward to seeing folks in Montreal.
19:24:25 <ntyni> some kind of remote participation would be nice for the BoF, I guess a video stream + irc would do
19:24:39 <OdyX> Oh you ain't there :-(
19:24:46 <ntyni> yeah :(
19:24:46 <bremner> we may have to grovel to videoteam
19:25:17 <bremner> oh, wait, if it's scheduled that should be ok with video
19:25:19 <bremner> nvm me
19:25:20 <OdyX> #action All DC17-present TC members to keep remote TC members in mind before and during the BoF.
19:25:45 <ntyni> thanks
19:25:57 <OdyX> Great.
19:26:07 <ntyni> and have a good time in Montreal
19:26:24 <OdyX> It's been productive and quick; hopefully still somewhat human.
19:26:34 <OdyX> Looking forward to see (most of) you there in some weeks!
19:27:04 <OdyX> #endmeeting