#debian-ctte Meeting

Meeting started by marga at 17:59:25 UTC (full logs).

Meeting summary

  1. Roll Call (marga, 17:59:28)
  2. Review of previous meetings AIs (marga, 18:00:46)
    1. https://salsa.debian.org/debian/tech-ctte/-/commit/096c18b0707a81530f56435a921139b7aab80d32 (marga, 18:05:17)

  3. #971515 - kubernetes: excessive vendoring (private libraries) (marga, 18:06:48)
    1. ACTION: spwhitton to send the drafted reply declining to overrule (marga, 18:07:18)

  4. #975075 - Should NetworkManager support elogind? (marga, 18:08:01)
    1. https://tracker.debian.org/news/1221865/accepted-udisks2-291-3-source-into-unstable/ (marga, 18:08:35)
    2. ACTION: marga to draft a closing statement, explaining what happened and why we are declining to overrule, but encouraging people to talk to each other as much as possible. (marga, 18:16:17)

  5. #975381 - libinih: drop Debian's custom vendorisation (marga, 18:17:03)
    1. ACTION: gwolf will close the bug presenting the TC's answer (gwolf, 18:22:56)
    2. ACTION: gwolf to encourage them to resubmit if they can rephrase in the context of Debian and with a better summary? (marga, 18:24:21)

  6. #976462 - Should dbgsym files be compressed via objcopy --compress-debug-section or not? (marga, 18:25:31)
    1. ACTION: spwhitton to ping doko for more input regarding this bug. (marga, 18:29:46)
    2. ACTION: spwhitton to ping the old bug asking whether it's still relevant. (marga, 18:37:18)

  7. #978636 - move to merged-usr-only? (marga, 18:37:43)
    1. https://lists.debian.org/debian-devel-announce/2019/03/msg00001.html (marga, 18:42:58)
    2. ACTION: spwhitton to start a vote on us agreeing to usrmerge being mandatory for bookworm+, without ruling on the technical details, assuming a technical migration can be agreed on. any action/implementations on this should happen in experimental/otherwise outside the critical path for bullseye (marga, 18:59:21)

  8. Possible future Python issue (marga, 19:01:24)
    1. https://archive.is/eqtdf here is an archive of the discussion on GitHub (which is not an official forum) (ehashman, 19:03:20)
    2. ehashman to continue working with doko and tumbleweed to address upstream concerns about Python packaging in Debian for bullseye and bookworm+ cycles (ehashman, 19:16:52)

  9. Recruitment efforts (marga, 19:19:39)
    1. ACTION: ntyni to write to the nominee asking if they are willing to join (marga, 19:25:18)
    2. ACTION: marga to have a go at fil's script to ask for more nominees. (marga, 19:25:28)


Meeting ended at 19:25:55 UTC (full logs).

Action items

  1. spwhitton to send the drafted reply declining to overrule
  2. marga to draft a closing statement, explaining what happened and why we are declining to overrule, but encouraging people to talk to each other as much as possible.
  3. gwolf will close the bug presenting the TC's answer
  4. gwolf to encourage them to resubmit if they can rephrase in the context of Debian and with a better summary?
  5. spwhitton to ping doko for more input regarding this bug.
  6. spwhitton to ping the old bug asking whether it's still relevant.
  7. spwhitton to start a vote on us agreeing to usrmerge being mandatory for bookworm+, without ruling on the technical details, assuming a technical migration can be agreed on. any action/implementations on this should happen in experimental/otherwise outside the critical path for bullseye
  8. ntyni to write to the nominee asking if they are willing to join
  9. marga to have a go at fil's script to ask for more nominees.


Action items, by person

  1. doko
    1. spwhitton to ping doko for more input regarding this bug.
  2. gwolf
    1. gwolf will close the bug presenting the TC's answer
    2. gwolf to encourage them to resubmit if they can rephrase in the context of Debian and with a better summary?
  3. marga
    1. marga to draft a closing statement, explaining what happened and why we are declining to overrule, but encouraging people to talk to each other as much as possible.
    2. marga to have a go at fil's script to ask for more nominees.
  4. ntyni
    1. ntyni to write to the nominee asking if they are willing to join
  5. spwhitton
    1. spwhitton to send the drafted reply declining to overrule
    2. spwhitton to ping doko for more input regarding this bug.
    3. spwhitton to ping the old bug asking whether it's still relevant.
    4. spwhitton to start a vote on us agreeing to usrmerge being mandatory for bookworm+, without ruling on the technical details, assuming a technical migration can be agreed on. any action/implementations on this should happen in experimental/otherwise outside the critical path for bullseye


People present (lines said)

  1. marga (88)
  2. ehashman (86)
  3. spwhitton (82)
  4. smcv (77)
  5. gwolf (75)
  6. ansgar (20)
  7. ntyni (12)
  8. bremner (11)
  9. doko (5)
  10. MeetBot (2)


Generated by MeetBot 0.1.4.