17:59:06 <spwhitton> #startmeeting
17:59:06 <MeetBot> Meeting started Wed Mar 17 17:59:06 2021 UTC.  The chair is spwhitton. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:59:06 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:59:07 <marga> spwhitton, sure
17:59:21 <spwhitton> #topic Roll Call
17:59:25 <marga> Margarita Manterola
17:59:28 <ehashman> Elana Hashman
17:59:29 <spwhitton> Sean Whitton
17:59:41 <Myon> Christoph Berg
18:00:06 <smcv> Simon McVittie
18:00:11 <ntyni> Niko Tyni
18:00:32 <spwhitton> we are not expecting bremner due to hour change, right?
18:00:44 <marga> Right, he mentioned he was double booked
18:01:00 <bremner> I'm sorta here. But I'm mainly in another meeting
18:01:08 <ehashman> oh no, I thought this was a better time for him
18:01:22 <spwhitton> no, but we've a topic later on to discuss chanigng th week
18:01:29 <ehashman> ++
18:01:53 <bremner> highlight me if you need my wisdom / foolishness
18:01:54 <ehashman> where's gwolf
18:02:11 <marga> In Mexico, I assume :)
18:02:21 * ehashman rolls eyes
18:02:24 <ehashman> good one :P
18:02:49 <spwhitton> #topic Review of previous meeting AIs
18:02:54 <spwhitton> they're all done!
18:02:57 <ehashman> indeed
18:03:06 <Myon> good time to join for me
18:03:07 <spwhitton> anything got anything to mention about theirs?
18:03:17 <ehashman> I'll save mine for the bug discussion
18:03:20 <spwhitton> thanks to marga, ehashman and gwolf.
18:03:21 <marga> Yes, I've closed the NM bug, Yay! :)
18:03:30 <marga> Also, welcome Myon!
18:03:37 <Myon> thanks
18:03:41 * gwolf Gunnar Wolf
18:03:44 <gwolf> sorry
18:03:44 <spwhitton> indeed, welcome Myon
18:03:49 <ehashman> welcome gwolf ;)
18:03:52 <ntyni> +1
18:03:55 <marga> And congrats spwhitton on the new appointment :)
18:03:57 <gwolf> I'm following a conference... but I'm here during the meeting
18:03:59 <ehashman> \o/
18:04:02 <gwolf> Congratulations spwhitton! :-D
18:04:05 <spwhitton> thanks marga, and thank you for your work as chair
18:04:07 <Myon> spwhitton: congrats!
18:04:22 <ehashman> a big thanks to marga and spwhitton
18:04:44 <marga> I sent the chair results to the bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=985270, but only to the -done address, so I guess it didn't CC the mailing list, sorry about that.
18:04:55 <gwolf> And, of course, thanks a lot to marga
18:04:57 <ehashman> quick link https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=985270#61
18:05:31 <spwhitton> okay then, let's move on to our one open bug
18:05:33 <spwhitton> #topic #976462 - Should dbgsym files be compressed via objcopy --compress-debug-section or not?
18:06:22 <spwhitton> ehashman's maths was very useful; there has been some mail since then
18:06:32 <ehashman> I did a data science!
18:06:51 <spwhitton> I wrote something today summarising where I think the discussion is; do others have thoughts on where it stands?
18:06:57 <ehashman> basically, I think the pathologial case is what is going to sway this. for the vast majority of cases it's fine to not compress
18:07:06 <spwhitton> yes indeed
18:07:12 <ehashman> but at the large end, it's like... bad
18:07:14 <ehashman> v bad
18:07:32 <ehashman> and \exists workarounds for the tools that can't work with compressed symbols
18:07:45 <ehashman> so, I am leaning towards continuing to compress by default.
18:07:58 <ehashman> (as I emailed)
18:08:03 <spwhitton> it's interesting how a certain number of years ago when we all had massive HDDs, disc space was rarely a good argument, but now we have smaller SSDs in many cases
18:08:13 <spwhitton> it's sort of gone back the other way
18:08:28 <smcv> well, our SSDs now are the size of our HDDs back then
18:08:40 <ehashman> there's also the VM case. I try not to assume a given install of Debian will have >16GB of space, and in some cases we might want to run as slim as 8
18:08:41 <smcv> but our web browsers are bigger
18:08:45 <ehashman> see also raspis, etc.
18:08:48 <gwolf> I also lean towards continuing to compress. There could be also a threshold - Compress when size > x (but x would have to be defined and kept up to date)
18:09:04 <spwhitton> gwolf: what exactly would a threshold achieve?
18:09:11 <ehashman> confusion :)
18:09:37 <marga> Yeah, a lot of confusion :)
18:09:46 <gwolf> very likely :)
18:10:04 <gwolf> I also don't like the idea -- And that would lead to getting into detailed design work
18:10:07 <smcv> the debhelper maintainer specifically doesn't want an on/off switch via CLI, since that's more complex than either compressing or not compressing
18:10:17 <smcv> I suspect the same argument rules out a threshold
18:10:18 <spwhitton> smcv: ah thanks for reminding us of that
18:10:20 <marga> Particularly because debug symbols are not necessarily used in a vacuum. If you're trying to debug a KDE program, you might need to install debug symbols from tens of libraries and each package might be small, but the combination ends up being big.
18:10:31 <ehashman> smcv: has said it much more nicely than me
18:10:49 <gwolf> smcv is a good conveyer of truth :-]
18:10:52 <spwhitton> it seems like we have a committee consensus, but do we want to allow doko more time to provide specific cases of non-build time tools which compression breaks?
18:10:58 <spwhitton> doko or others*
18:11:16 <ehashman> they've had over a month now, right?
18:11:34 <ehashman> if they came back with more tools, would we change our minds?
18:11:40 <ehashman> I'm pretty sure I would not.
18:11:46 <smcv> they're welcome to reopen the bug or open a new bug if they have new info?
18:11:51 <ehashman> ^
18:12:00 <gwolf> I think we have given enough time for further arguments...
18:12:17 <spwhitton> they are compressed atm right?
18:12:18 <gwolf> I am for closing the bug. Of course it can be reopened if needed.
18:12:22 <spwhitton> and people are successfully debugging
18:12:23 <ehashman> spwhitton: correct
18:12:26 <gwolf> yes, they are compressed now.
18:12:28 <Myon> I have only skimmed the bug, but I don't see any arguments saying which concrete problem with compression there are
18:12:30 <spwhitton> okay then
18:12:39 <spwhitton> so I think we can assign someone to close the bug
18:12:56 <spwhitton> given that I already wrote a short summary today, I don't mind doing it, unless someone wants to
18:12:58 <gwolf> And also, if there are tools unable to handle the compressed data... the tool can be patched to do so
18:13:19 <ehashman> I volunteer smcv who has done a better job of words than me today, but spwhitton is also fine :)
18:13:30 <spwhitton> smcv: willing?
18:13:37 <smcv> sure, why not
18:13:42 * ehashman already did the number crunching
18:13:54 <spwhitton> #action smcv to draft statement closing #976462
18:14:05 <spwhitton> okay then, I think we can move on, thank you smcv
18:14:16 <spwhitton> #topic Rescheduling monthly meetings
18:14:33 <spwhitton> let's do this now so we definitely do it -- can we move to second Wednesdays?
18:14:41 <Myon> yes
18:14:45 <spwhitton> I can
18:14:48 <ntyni> wfm
18:14:49 <bremner> yes
18:14:52 <smcv> yes
18:14:59 <ehashman> the particularly wednesday doesn't matter. I will have a conflict once DST changes again :)
18:15:12 <marga> +1
18:15:17 <spwhitton> ehashman: at that point it might be worth running a fresh poll
18:15:31 <spwhitton> gwolf: how about you?
18:15:32 <ehashman> cool, I'll provide a meeting's worth of notice at that point
18:15:40 <marga> ehashman, you're talking about the next change, right, in October/November?
18:15:44 <gwolf> I can do it, yes
18:16:14 <ehashman> yeah
18:16:18 <spwhitton> great
18:16:21 <ehashman> not for a while
18:16:30 <spwhitton> then it is done, we will next meet 14th April
18:16:32 <marga> Right, I guess we can run a new poll around that time.
18:16:43 <spwhitton> #topic Moving forward with our reimagining the TC tasks
18:17:02 <spwhitton> the first thing that occurs to me with this topic is that it would be good to assign someone to the item that fil was previously assigned to
18:17:32 <marga> Can we review what the items were? I had something assigned, but I forget what (!)
18:17:40 <spwhitton> yes let's do that
18:17:51 <spwhitton> #1: allow to be invoked early (fil)
18:18:00 <spwhitton> ahhh no
18:18:12 <spwhitton> #1: private discussion: ehashman
18:18:17 <spwhitton> #2: allow to be invoked early: fil
18:18:35 <ehashman> oh hey, we're finally not drowning in bugs
18:18:41 <ehashman> you can action me with #1 for next meeting
18:18:59 <spwhitton> #3: explicitly delegate mediation: no driver
18:19:11 <spwhitton> #4: design work: TC will not drive
18:19:20 <spwhitton> #5: abolish TC: TC will not drive
18:19:40 <spwhitton> #action ehashman to work on proposal #1 some more and report back to next meeting
18:20:18 <spwhitton> two proposals in the air at once is probably sufficient unless someone particularly wants to work on #3, so do we have volunteers for #2?
18:20:53 <spwhitton> I find it quite interesting so it could be me, but I do not have any very bright ideas about it.
18:21:35 <Myon> which bits should I read up on? I'm seeing rethinking-the-tc/earlyinvocation.org but it doesn't have #1/2/3/4/5
18:21:48 <marga> Myon, that's what fil did before leaving
18:21:50 <spwhitton> Myon: sorry, there is a file called rethinking-the-tc.md
18:22:02 <spwhitton> under talks/
18:22:11 <Myon> ah confusing filenames
18:22:15 <marga> https://salsa.debian.org/debian/tech-ctte/-/blob/master/talks/rethinking-the-tc.md
18:22:24 <Myon> ta
18:22:33 <marga> Maybe we should move that md to the other folder
18:22:45 <gwolf> I am too time-pressed right now, and I think it even shows in my lack of focus in interactions :-(
18:22:53 <gwolf> so I cannot offer myself to drive #3
18:23:28 <Myon> marga: if it wasn't an actual talk, definitely
18:23:37 <marga> I think I might take a stab at the mediation body thing (#3)
18:23:42 <spwhitton> it was a talk, so maybe we could symlink.
18:23:44 <spwhitton> marga: oh, fantastic
18:24:04 <spwhitton> #action marga to work on proposal #3 and share some ideas next meeting
18:24:17 <spwhitton> well, in that case I am inclined to leave proposal #2 with no driver for now
18:25:25 <marga> Sure, we can use fil's basis.
18:25:44 <spwhitton> if Myon is interested in working on it after getting himself up to speed, he can certainly do so
18:26:02 <spwhitton> and I might take it up at our next meeting, depending on how concrete things get with the other two proposals
18:26:10 <spwhitton> in that case, any other things on this topic?
18:26:16 <Myon> I don't think I can drive something now, but I can certainly help out in some parts
18:26:31 <spwhitton> cool
18:26:40 <Myon> are these proposals all opposing, or orthogonal?
18:26:52 <spwhitton> the ones we are actually planning to do are mostly orthogonal
18:27:00 <Myon> that sounds like a smart plan
18:27:25 <spwhitton> others were included for completeness but no-one outside the TC said they wanted to work on them, so we can pretty much forget about them, I think
18:27:36 <marga> Yeah
18:27:51 <spwhitton> #topic Any other business
18:28:01 <spwhitton> well, we already welcomed Myon and thanked marga
18:28:13 <marga> Nothing else from my side
18:28:15 <spwhitton> but once again, welcome Myon, and thanks marga!
18:28:23 <smcv> also thank you spwhitton for volunteering to chair
18:28:33 <Myon> fwiw I believe Debian could use some body driving technical matters (no idea if the TC is the correct place, though)
18:28:36 <spwhitton> no problem :)
18:28:43 <marga> And thanks Sean for volunteering!
18:28:49 <spwhitton> Myon: you mean, design work?
18:29:21 <Myon> yeah I guess that's a name for it, but that's more a feeling than an idea
18:29:33 <spwhitton> okay
18:29:40 <smcv> do you mean more like leadership and the defunct release-goals concept?
18:29:54 <marga> Well, there was this idea from a previous DPL of creating some kind of design committee
18:29:56 <Myon> probably
18:30:08 <ntyni> was that the roadmap thing?
18:30:09 <gwolf> Myon: IMO, as design work often gets in the details of each specific problemspace, no project-wide body could come up with that
18:30:16 <gwolf> ...it has to come from the affected subregions
18:30:17 <marga> Yes, the roadmap thing.
18:30:36 <ehashman> do people want us to be the Fedora TC? is that the idea?
18:30:37 <gwolf> of course, some bits of the problemspace could be projectwide ;-)
18:30:38 <smcv> I think there's a difference between detailed design and having a road map
18:30:49 <spwhitton> if the project has a discussion about this sort of stuff then the TC has a lot of relevant experience
18:31:00 <gwolf> ehashman: I am not familiar enough with Fedora to sit in its TC ;-)
18:31:23 <spwhitton> I think we are through with our official meeting however
18:31:28 <spwhitton> #endmeeting