18:00:27 <spwhitton> #startmeeting
18:00:27 <MeetBot> Meeting started Wed Aug 11 18:00:27 2021 UTC. The chair is spwhitton. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:27 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:00:29 <spwhitton> #topic Roll Call
18:00:38 <marga> Margarita Manterola
18:00:39 <spwhitton> Apologies received from Niko Tyni
18:00:41 <spwhitton> Sean Whitton
18:00:54 <marga> Maybe a pingall?
18:01:04 <spwhitton> oh, yeah, startmeeting doesn't do that
18:01:09 <spwhitton> MeetBot: pingall meeting time!
18:01:09 <MeetBot> meeting time!
18:01:09 <MeetBot> abrotman adsb bremner buxy caseih dondelelcaro dwfreed eamanu ehashman feiqu fil gregoa gwolf jcristau joostvb KGB-2 marga Maulkin MeetBot Myon ntyni OdyX smcv spwhitton themill weasel wouter zigo zwiebelbot
18:01:09 <MeetBot> meeting time!
18:01:20 <bremner> David Bremner
18:03:17 <ehashman> Elana Hashman
18:03:46 <spwhitton> waiting on smcv, Myon, gwolf
18:06:52 <marga> How long are we waiting?
18:06:56 <smcv> Simon McVittie
18:06:58 <spwhitton> I was thinking 11:10
18:07:01 <smcv> (sorry, here now)
18:07:15 <spwhitton> cos gwolf has a big chunk of today's agenda :)
18:09:09 <ehashman> k
18:09:46 <spwhitton> #topic Review of previous meeting AIs
18:10:11 <spwhitton> mine are done, though web team has not updated our page yet. I think we just wanted to get the bug filed though.
18:11:17 <spwhitton> gwolf was tasked with incorporating points from discussion into the slides and reframing them to be more of a call to action. while there could be further improvements if people are so inclined to put more time into it, I think we have a nice set of slides now :)
18:11:51 <spwhitton> has anyone had a chance to look through them?
18:12:00 * bremner looks guilty
18:12:02 <ehashman> I have not
18:12:13 <ehashman> sorry, this past month has been slammed for me
18:12:16 <marga> I've just made a couple of adjustments to the private invocation section.
18:12:16 <bremner> where are they, our git?
18:12:20 <spwhitton> marga: thank you
18:13:00 <marga> I'm looking at the thing in salsa. I'm not sure how to turn them into slides
18:13:03 <spwhitton> how about we spend at least a few minutes all reading through now and see if we have a consensus that they're ready? we don't have bugs to discuss so it seems worthwhile.
18:13:23 <spwhitton> marga: you need emacs.
18:13:29 <marga> :(
18:13:31 <spwhitton> marga: I just tested that it works
18:14:46 <smcv> I assume someone who likes emacs will be responsible for the formatting/showing and the text is the part that's important for the rest of us
18:14:58 <spwhitton> right. at least bremner, gwolf and I are capable of getting the slides built.
18:16:00 <marga> Yeah, I assumed that. Anyway, the slides look good. My only comment is that the private invocation part is a lot shorter than the early invocation part and it feels a bit unbalanced. But with regards to content they are both fine.
18:16:02 <bremner> worst case, just show the page from salsa. It's not too bad
18:16:23 <ehashman> marga: I can take an AI to balance it out
18:16:27 <ehashman> I just derped
18:17:00 <spwhitton> ehashman: that would be great. time is a bit short though -- do you think you can fit it in?
18:17:07 <marga> derped?
18:17:26 <bremner> ehashman is the youths
18:18:27 <spwhitton> The final slide says "we want to streamline the process (probably even avoid it altogether!)"
18:18:37 <spwhitton> I'm not sure I have a clear idea of what desire of ours this expresses.
18:18:56 <marga> ah, yes, what is it that we would want to avoid?
18:19:15 <spwhitton> ah, perhaps gwolf meant we want to avoid things becoming TC bugs?
18:19:54 <ehashman> spwhitton: I can look at it with an overall view
18:20:00 <ehashman> bremner: lol
18:20:04 <ehashman> marga: I messed up
18:20:18 <spwhitton> ehashman: sorry not sure what you mean by "with an overall view"
18:20:18 <marga> You didn't!
18:20:31 <spwhitton> yes, "messed up" is too harsh!
18:20:39 <ehashman> flaked? :D
18:20:57 <bremner> certainly if things can be resolved without a TC bug, that seems like a good outcome, all else being equal
18:21:00 <ehashman> spwhitton: like I will take a look and edit but keeping in mind time, I can suggest cuts elsewhere
18:21:10 <spwhitton> ehashman: ah, cool.
18:21:15 <bremner> i.e. people retiring instead of filing a TC bug would not be a good outcome
18:21:18 <spwhitton> #action ehashman to look into balancing the two main sections out a bit
18:22:38 <spwhitton> Last time we wondered whether the early invocation section was sufficiently a call to action
18:22:51 <spwhitton> Now it does a good job of asking people to get in touch earlier which is cool
18:23:44 <spwhitton> How about adding "we would also like to hear ideas about how we could be invoked earlier that Debian contributors think would help resolve disputes with less escalation"
18:24:08 <spwhitton> or .. help developing documentation of how it can be done?
18:24:11 <bremner> break that into two sentences and it will be perfect :P
18:24:27 <spwhitton> sure :P
18:24:37 <marga> I'm not sure I understand what you're asking... Other ways they can contact us?
18:25:05 <bremner> other procedural best practices?
18:25:26 <spwhitton> marga: more like other things we could do. for example sam hartman will probably suggest we write summaries of what we see in a dispute from a neutral third party perspective. and perhaps that would be useful.
18:26:19 <marga> Ok, that makes sense. The other phrase is confusing to me.
18:26:30 <spwhitton> if we had a list of early invocation-type things people can explicitly ask us to do that might encourage people to actualy ask us.
18:26:50 <spwhitton> we can always say "we won't do quite that" once the converstaion is started
18:27:03 * spwhitton adds some bullets
18:27:04 <marga> Maybe "We also would like to hear other ideas of how we can better intervene without waiting until the flamewars?"
18:27:10 <spwhitton> good.
18:27:33 <spwhitton> I'm gonna split the last slide into too
18:27:52 <spwhitton> two*
18:27:58 <bremner> I mean, I guess some people oppose all intervention by the TC. dunno what to tell those people
18:28:23 <bremner> I guess they should just get on with abolishing us
18:29:01 <smcv> "sorry, the constitution says we exist, until a supermajority votes otherwise"
18:29:59 <bremner> I guess there might be room for improvements about less intervention? maybe that's a whole other discussion though
18:30:33 <bremner> so nvm the digression
18:34:55 <joostvb> iirc there were initially more then 2 proposals; would it be useful to mention the ones which got discarded?
18:35:21 <spwhitton> joostvb: in our d-d-a post we mentioned that we're focused on two of them and we don't have much time in our session, so I'd be inclined not to.
18:35:30 <joostvb> sure
18:35:44 <bremner> people are certainly welcome to re-raise things
18:36:07 <gwolf> ufffa.... Sorry for being so late!
18:36:20 <gwolf> I was tied up with a RL system migration
18:36:22 <spwhitton> hey gwolf. we are editing your slides mercilessly ;)
18:36:32 <bremner> and if there is sufficient interest we can schedule a followup BoF
18:36:43 <gwolf> thanks a lot, that's what I wanted you to do!
18:36:54 <gwolf> let me glance at the backlog...\
18:37:12 <bremner> ignore the part where we insulted your taste in tacos
18:37:59 <marga> Do we already have a time for the BoF?
18:38:06 <spwhitton> looking at last meeting's logs, one thing that is not reflected in the slides is marga's suggestion about assigning one of us to monitor/etc. a growing dispute
18:38:17 <spwhitton> marga: we have a single 45 minute session.
18:38:37 <gwolf> marga: re:balance between sections: Yes, because I just copied ehashman's points over, in the hopes she or other people can make it balanced and pretty
18:38:37 <marga> I mean datetime
18:38:45 <spwhitton> marga: ah. yes, it's in the schedule.
18:39:07 <gwolf> spwhitton: "streamlining the process or avoiding alltogether" is basically a line from the log from our last meeting. Don't remember whose it was :-)
18:40:23 <marga> Aug 25th at 20 UTC, yes?
18:40:56 <gwolf> bremner: I like salsa, be it in tacos or otherwise. But I don't dance.
18:41:15 <spwhitton> marga: yes.
18:41:18 <gwolf> OK, I'm up to speed now... /methinks
18:42:02 <spwhitton> gwolf: can you insert a reference a marga's suggestoin from last time about possibly assigning one of us to a brewing dispute?
18:42:26 <gwolf> umh... I might not be up to speed :-) Where? What?
18:42:33 <marga> That was last time
18:42:53 <marga> I suggested we could designate someone to represent the TC and thus make the process speedier
18:43:03 <marga> Like when Elana dealt with the Python issue
18:43:06 <gwolf> Oh! And I missed on the slides a usual point we always present -- a roundup of the years' processed bugs.
18:43:16 <gwolf> Oh, OK, adding it...
18:43:18 <spwhitton> gwolf: we replaced that with our d-d-a post.
18:43:30 <bremner> and resulting -devel firestorm
18:43:33 <bremner> yay!
18:43:34 <spwhitton> gwolf: sec, I am just adding the marga suggestion right now :)
18:43:37 <gwolf> spwhitton: OK, works for me
18:43:41 <gwolf> OK, perfect
18:44:04 <spwhitton> alright. I think we need to move on to discuss timing and logistics briefly, unless anyone is in the middle of something with the slides?
18:44:05 <marga> The representative would give updates on the issue as needed (in IRC meetings or so), but would be able to interact more reliably than having to wait until all of us are in agreement.
18:44:37 <bremner> I guess there would be some disclaimers attached to such a representative
18:44:48 <bremner> or do we really delegate?
18:44:56 <spwhitton> yeah. I think we want help determining those disclaimers.
18:45:47 <spwhitton> gwolf: all the bullet points on each slide appear at once. can you make them appear one by one? or is it deliberate perhaps?
18:45:51 <marga> Yeah, there should be disclaimers
18:46:02 <gwolf> I personally don't like them appearing one by one
18:46:10 <gwolf> but that's a personal preference
18:46:13 <spwhitton> I support it
18:46:23 <spwhitton> but I was thinking that the slide I have been editing now has too many point s:)
18:46:32 <gwolf> Maybe that's because I put too many bullets, and it becomes somewhat taxing to <click> <click> <click> all the time
18:46:44 <spwhitton> well, this is the part of the presentation you will be presenting, so we can leave it to you
18:46:45 <bremner> org can certainly do the sequencing stuff
18:46:55 <marga> What we discussed last time is that this person would mostly act on their DD capacity, just as a member of the TC but with no assurances that what they say is what the TC would decide if it came to a decision.
18:47:20 <spwhitton> we're short on time so I'd like to suggest we move on to logistics for a few minutes.
18:47:35 <spwhitton> #topic Presentation timings & logistics
18:48:01 <spwhitton> so I think the idea we have right now is that I spend <5 minutes on the opening few slides and then hand over to ehashman and then she hands over to gwolf, right?
18:48:12 <spwhitton> how do we want to fit q&a in? all at the end or after each of those two sections?
18:48:13 <ehashman> yeah that's what we did last time
18:48:47 <spwhitton> and, do we want to spend less time on the private comms section as we have less points to make atm?
18:48:49 <gwolf> I'd really prefer if we manage to match the style -- By copying over ehashman's part, I meant to indicate that content should be approximately there
18:49:09 <gwolf> but, if you can turn it into several slides, I think things will be much better balanced
18:49:49 <spwhitton> I think my preference owuld be for all q&a at the end and we allot 15m to it.
18:49:56 <spwhitton> if not more, if gwolf and ehashman think they can be quick.
18:50:22 <gwolf> I think I prefer allowing time for Q&A at the end
18:50:27 <ehashman> I can probably keep mine to 3m
18:50:31 <ehashman> in terms of presenting
18:50:36 <ehashman> Q&A is good
18:50:57 <spwhitton> so we could do 5 Sean 5 elana 10 gunnar 20 q&a
18:51:10 <spwhitton> (I will endeavour to take less than 5 but let's have some round numbers)
18:51:13 <gwolf> Right, and maybe even quite less than 20
18:51:26 <spwhitton> gwolf: sorry there I'm giving you 10
18:52:01 <gwolf> Oh, right! OK, that's more like it
18:52:19 <spwhitton> ehashman, gwolf: do you want to manage your own times completely or do you want me to be keeping an eye and giving you 1 minute warnings or whatever?
18:52:21 <marga> Yeah, that sounds good
18:52:30 <marga> Do we want to discuss anything between ourselves?
18:52:38 <marga> Or just go to Q&A?
18:53:01 <bremner> probably just Q&A imho
18:53:06 <bremner> we can always talk then
18:53:16 <ehashman> spwhitton: I can manage
18:53:20 <gwolf> right, straight to Q&A sounds fine
18:53:31 <spwhitton> I've forgotten how BoF Q&As work. do I collect the questions or does the debconf person do that?
18:53:32 <gwolf> spwhitton: I guess I can manage, but won't mind being poked
18:53:43 <spwhitton> gwolf: okay cool, I'll have my mute button ready ;)
18:54:09 <spwhitton> (me, or any one of us, I mean, as opposed to the debconf folks)
18:54:51 <bremner> I think BoFs are usually self managed
18:54:57 <bremner> so, us?
18:55:08 <marga> Last time we had an external moderator, but I think it was actually detrimental for our BoF. I think we want to be the ones asking the questions.
18:55:12 <spwhitton> okay. I can do that, then, but would be happy if someone who does more video conference calls than I do would like to instead.
18:55:32 <spwhitton> bremner: can we put you in charge of screen-sharing the slides for the whole presentation?
18:55:34 <gwolf> well, we are eight presenters. One of us can volunteer to be talkmeister for the video team
18:55:47 <gwolf> and then we become the external DebConf moderator MUAHAHAHHAA
18:55:52 <spwhitton> gwolf: that's a good idea
18:56:01 <marga> Yeah, ideally we would have one of us be the talkmeister, rather than getting someone else
18:56:08 <bremner> spwhitton: normally yes, but I might have a family obligation, so better have a backup
18:56:22 <spwhitton> okay. I can be the slides backup.
18:56:33 <gwolf> I'd rather not be, as I'm one of the speakers...
18:56:35 <spwhitton> #info bremner to screen-share the slides.
18:56:48 <spwhitton> #info spwhitton to be prepared to backup screen-share the slides
18:57:24 <spwhitton> gwolf: what else does a talkmeister do?
18:57:35 <gwolf> one of the nice things in Jitsi is that many people can screen-share simultaneously. Of course, it can mess up people following us...
18:57:47 <gwolf> spwhitton: introduce the session, give any needed announcements...
18:58:04 <spwhitton> does it require any technical skills relating to video conferencing?
18:58:19 <bremner> using a mouse to click in a browser?
18:58:19 <gwolf> ...this time around, we don't need the talkmeister to run with the microphone to the audience
18:58:36 <bremner> oh sorry, I misunderstood the question
18:58:38 <gwolf> I really don't know. I have not talkmeistered during DC20
18:58:50 <spwhitton> bremner: I only minimally trust the technology involved with it comes to running it on my laptop.
18:59:08 <bremner> ok.
18:59:14 <spwhitton> so I think one of us needs to go to the video team and say "TC wants me to talkmeister the talk, what do I need to know?"
18:59:32 <spwhitton> shall I do that or is there someone else who wants to? I certianly don't mind doing it, I'm just a little apprehensive about the tech as mentioned :)
18:59:51 <marga> There's very little tech involved
18:59:51 <spwhitton> bremner: I don't mean security btw. I mean that my laptop is optimised for emacs usage and not much else.
18:59:52 <gwolf> yes. I guess they will do talkmeistering training sessions - but I'm not involved this time around
18:59:57 <bremner> well, it's also fine if videoteam wants to talkmeister. Maybe online it makes more sense that way?
19:00:00 <marga> I did it last year
19:00:12 <spwhitton> bremner: I agree with marga that we want to be in charge of our questions queue, though.
19:00:17 <gwolf> spwhitton: m-x webrtc should work
19:00:32 <spwhitton> if there is training it'll be fine.
19:00:33 <bremner> aren't the questions mostly IRC?
19:00:42 <marga> I may volunteer, but I'm not going to be home that week, so I don't know if I'll be able to attend the training
19:00:56 <marga> bremner, last year there was a gobbi
19:01:01 <bremner> oic
19:01:03 <spwhitton> indeed
19:01:05 <spwhitton> okay I'll look into this.
19:01:06 <marga> (or something like gobby)
19:01:08 <spwhitton> we are out of time :)
19:01:11 <bremner> well, that could be something to set up in advance
19:01:17 <marga> spwhitton, maybe you and me both try to get trained?
19:01:21 <spwhitton> #action spwhitton to look into talkmeistering esp. w.r.t. q&a
19:01:25 <spwhitton> #action marga to get trained too
19:01:28 <spwhitton> good.
19:01:34 <marga> So that we can have a backup
19:01:41 <spwhitton> excellent, thakn you marga
19:01:45 <spwhitton> #topic Any Other Business
19:01:51 <spwhitton> anything?
19:02:34 * gwolf twiddles fingers
19:03:56 <spwhitton> okay then :)
19:03:58 <spwhitton> thanks everyone!
19:04:00 <spwhitton> #endmeeting