17:59:23 <spwhitton> #startmeeting
17:59:23 <MeetBot> Meeting started Tue Apr  5 17:59:23 2022 UTC.  The chair is spwhitton. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:59:23 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:59:27 <spwhitton> #topic Roll Call
17:59:30 <Myon> Christoph Berg
17:59:32 <spwhitton> Apologies received from Helmut & Matthew
17:59:34 <spwhitton> Sean Whitton
18:00:21 <ehashman> Elana Hashman
18:00:28 <gwolf> Gunnar Wolf
18:00:43 <smcv> Simon McVittie
18:01:14 <spwhitton> do join the private jitsi
18:01:20 <ehashman> ah, one moment
18:02:18 <spwhitton> Apologies also received from ntyni
18:02:26 <spwhitton> #topic Private Jitsi discussion of interpersonal issues
18:09:18 <spwhitton> #action gwolf to continue his most recent draft
18:31:47 <spwhitton> #topic Review of previous meeting AIs
18:31:54 <gwolf> hello ctte
18:31:55 <spwhitton> I did mine.  ehashman didn't have a chance to do hers
18:32:05 <ehashman> I did not do my AI due to preemption by our current business :)
18:32:09 <spwhitton> yeah
18:32:11 <ehashman> but you can carry it forward
18:32:15 <spwhitton> okay great
18:32:31 <spwhitton> #action ehashman to commit private-comms slides+gobby to git procedures/
18:32:38 <spwhitton> #topic DebConf22 CfP -- what sort of talk do we want to submit?
18:32:45 <spwhitton> the CfP deadline is quite soon.
18:32:50 <spwhitton> do we want to submit something?  if so, what?
18:32:56 <Myon> we should
18:32:58 <spwhitton> is anyone currently sure to attend debconf?  I am a maybe.
18:33:05 <Myon> also maybe
18:33:06 <smcv> I'm not going to be there
18:33:07 <gwolf> I am probably
18:33:24 <gwolf> I mean, I am moving towards going... but I won't be sure until I get tickets and stuff
18:33:56 <ehashman> I will not attend in person. I might be able to attend virtually if the events are not before 8am my time
18:34:07 <spwhitton> okay that is good to know elana
18:34:27 <spwhitton> so, the thing to submit would be just "bits from the TC", right?  or did anyone have anything else in mind?
18:34:34 <ehashman> but it look like 8am my time is 5pm Kosovo time
18:34:36 <gwolf> ehashman: Although being on the East coast of the USA... means _some_ events will almost surely be before 8AM
18:34:53 <gwolf> There are still timeslots, however, where you could participate remotely
18:35:03 <ehashman> I'm on the west coast, which means stuff during business hours in Europe usually happens when I'm asleep
18:35:25 <gwolf> Oh, sorry, s/east/west/ - I _thought_ it right ;-)
18:35:43 <gwolf> FWIW, if you haven't been following, the video team explicitly does _not_ offer a virtual conference, it's an _in-person_ conference
18:35:52 <ehashman> ack
18:35:54 <spwhitton> gwolf: right but it will be streamed
18:35:56 <gwolf> _but_ they are open to us sorting out issues
18:35:58 <Myon> the usual bits talk seems right
18:36:13 <ehashman> I can still show up on IRC and/or gobby :P
18:36:14 <gwolf> it will be streamed, and we can set up infrastructure to have Elana (+others)
18:36:27 <gwolf> FWIW, if I make it to Kosovo, I'll do some videoteam work
18:36:51 <spwhitton> then all we need to do now is get a very simple submission in, right?
18:37:00 <ehashman> I think you may as well
18:37:05 <gwolf> yes. Even maybe copying the description from other years
18:37:15 <spwhitton> if we are sure we want to go back to traditional bits talk, and not do a d-d-a e-mail as we did past two years
18:37:39 <Myon> we can still mail the talk agenda to d-d-a later
18:37:45 <gwolf> Well, I think we can "fall back" to the bits talk, but attempt to do a more interesting one
18:37:49 <spwhitton> the only thing is that we got very positive feedback about switching it to d-d-a
18:38:23 <Myon> ok that seems like the d-d-a part is important, but I'd also think people expect us do do something at the conference
18:38:45 <spwhitton> Myon: okay.  both are a fair bit of effort, but maybe we can find some way to re-use text
18:38:46 <ehashman> I think it's important to send something to d-d-a for all the folks who don't attend DC
18:39:00 <spwhitton> I'll go ahead and submit the standard thing then, and we can discuss content and what to send to d-d-a nearer the time
18:39:03 <gwolf> well, we had the BoF about reimaging the way ctte works
18:39:04 <Myon> maybe we can write the text first, then do the talk based on the text, and then send it?
18:39:18 <spwhitton> #action spwhitton to submit to debconf22 CfP
18:39:35 <spwhitton> #agreed we will send something to d-d-a *and* do a traditional "Bits from the TC talk"
18:39:41 <gwolf> We came up with some good intentions... but so far, I don't think we have actually _changed_ much...
18:39:47 <Myon> both are traditions now :)
18:40:06 <spwhitton> #agreed we will assign people to come up with the talk content nearer the time
18:40:10 <spwhitton> okay then shlal we move on to bugs?
18:41:08 <gwolf> yup... I have only ~10-15 minutes left for the meeting :-(
18:41:14 <spwhitton> #topic Bug#1003653: Revision of removal of rename.ul from package util-linux
18:41:30 <spwhitton> we're waiting on the maintainer's reply to concerns that were raised about two paths shipping the same path
18:41:34 <spwhitton> two packages shipping the same path
18:41:57 <spwhitton> Matthew thinks we should issue a decision soon.
18:42:21 <spwhitton> I am happy to give the maintainer time to reply to that particular question; maybe we could set a deadline for that
18:42:58 <Myon> ack
18:43:03 <gwolf> agree
18:43:11 <gwolf> time, but not unbounded time
18:43:41 <spwhitton> suppose we set that deadline before our next meeting (which I think we should), and he doesn't reply, or he says "I am going to have both pacakges use /usr/bin/rename" which I think most of us oppose
18:43:45 <spwhitton> are we ready to just have a vote at that point?
18:43:49 <ehashman> I would be
18:43:58 <ehashman> I think before next meeting is a good deadline
18:43:58 <gwolf> Yes
18:44:13 <gwolf> I think maybe next meeting minus a week would make sense
18:44:14 <spwhitton> ehashman: I mean a deadline somewhere within the next five weeks -- so, much before our next meeting
18:44:34 <gwolf> So we could have our public in-list vote in place before the meeting
18:44:46 <spwhitton> yeah that would be nice
18:45:12 <spwhitton> am I right that there aren't any of us happy to leave the maintainer using /usr/bin/rename twice?
18:45:30 <spwhitton> I think helmut probably doesn't like that solution but wouldn't want to override the maintainer on it.
18:45:41 <Myon> it would be ok if it were a single-binary package
18:45:56 <Myon> but the current plan is to ship more things in util-linux-extra
18:45:56 <spwhitton> Myon: you mean alternatives or similar?
18:45:59 <spwhitton> oh
18:46:00 <spwhitton> right I see
18:46:01 <spwhitton> yes
18:46:04 <smcv> by single-binary package you mean a .deb containing a single executable?
18:46:07 <Myon> yes
18:46:18 <gwolf> Introducing pointless Conflicts: is bad
18:46:24 <Myon> so people can decide if they want the ul or perl rename
18:46:26 <gwolf> I don't know if against policy... but badâ„¢
18:46:32 <spwhitton> gwolf: it's against policy.
18:46:33 <Myon> gwolf: all solutions are bad
18:47:10 <gwolf> well, yes, all solutions are bad. But there you go, spwhitton confirms it: having pointless conflicts is against policy
18:47:15 <spwhitton> okay then, can we delegate someone to let eveyrone involved know that deadline, and also to come up with vote text and start the vote?
18:47:21 <spwhitton> if it comes to that.
18:47:23 <Myon> if they want to go that route, ok with me, but not if that means people have to decide between "ul rename and fincode" and "perl rename"
18:47:37 <smcv> I think util-linux-rename.deb containing /usr/bin/rename with non-policy-compliant Conflicts would be undesirable, but I'm not sure it's bad enough that I would overrule a maintainer on it
18:47:53 <spwhitton> smcv: right.  I agree.  we're talking the -extra case.
18:48:12 <smcv> but util-linux-extra.deb containing /usr/bin/rename and fincore and (etc.) I agree is significantly worse
18:48:42 <Myon> oh and hwclock, even more important
18:49:14 <spwhitton> Myon: will you have time over the next month to be actioned for those two things?
18:49:19 <Myon> I think we will be ending with *some* ugly solution, be it conflicts, alternatives, or weird names like "rename.ul"
18:49:36 <Myon> spwhitton: yes
18:49:41 <spwhitton> okay then, I will action you, thank you
18:49:47 <gwolf> yes. But we have lived with rename.ul for very long time
18:49:54 <gwolf> it is ugly, but it is our ugly.
18:49:55 <Myon> so I wouldn't want to look at policy too closely :D
18:49:58 <spwhitton> #action Myon to send deadline for discussion of Conflicts: issue to maintainer, bug etc.
18:50:29 <spwhitton> #action Myon to start vote against Conflicts: outcome if that deadline passes
18:50:41 <spwhitton> #topic Bug#1007717: Native source package format with non-native version
18:51:18 <spwhitton> alright then.  Matthew says he's convinced by Ian's text.  I've been thinking about this for some time both under the heading of policy and git packaging stuff, and I agree with it too
18:51:32 <spwhitton> what do others think?
18:52:25 <ehashman> I'm not caught up on this one yet, which text? that of the original submission?
18:52:47 <Myon> me neither, sorry
18:52:48 <spwhitton> ehashman: no, the message from Ian to -devel with the arguments that both Ian and I forwarded a copy of to the TC bug
18:52:51 <spwhitton> this is fine
18:52:55 <spwhitton> we can just defer this
18:53:02 <spwhitton> shall we just do that?
18:53:10 <Myon> does anyone besides Ian thinks there is any issue?
18:53:30 <spwhitton> Myon: yeah, Sam and Russ both expressed that they want the TC to do this.
18:53:33 * gwolf also forgot the details of this particular bug...
18:53:35 <Myon> ok
18:53:43 <spwhitton> Russ speaking as policy editor.
18:53:56 <Myon> (my first reading was "oh one of those Ian problems")
18:54:25 <Myon> +1 on deferring
18:54:39 <spwhitton> coolio
18:54:41 <ehashman> spwhitton: it would be helpful to flag the relevant text because I've already skimmed 20+ emails and still don't know what I'm looking for
18:54:49 <spwhitton> ehashman: sure, sec
18:55:11 <spwhitton> #link https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1007717#15
18:55:32 <gwolf> I'll have to leave, as I said earlier...
18:55:37 <gwolf> time to pick up kids
18:55:46 <ehashman> thank you!
18:55:48 <spwhitton> thanks gwolf!
18:55:51 <gwolf> o/ ! thanks to you all!
18:56:47 <spwhitton> ehashman: are you okay with deferring?
18:59:11 <ehashman> yes
18:59:15 <spwhitton> cool
18:59:23 <spwhitton> #agreed Defer this bug to next meeting.
18:59:27 <spwhitton> #topic Any Other Business
18:59:32 <spwhitton> Alright then, I think we are done for the day?
18:59:49 <Myon> ok with me
19:00:48 <ehashman> ack
19:01:11 <spwhitton> #endmeeting