08:00:15 <spwhitton> #startmeeting
08:00:15 <MeetBot> Meeting started Fri Aug 16 08:00:15 2024 UTC.  The chair is spwhitton. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:15 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:00:21 <spwhitton> #topic Roll Call
08:00:23 <helmut> Helmut Grohne
08:00:23 <spwhitton> Sean Whitton
08:00:26 <mjg59> Matthew Garrett
08:00:28 <tumbleweed> Stefano Rivera
08:00:29 <Myon> Christoph Berg
08:00:30 <roehling> Timo Röhling
08:00:41 <spwhitton> That's everyone who said they could make it.
08:00:55 <spwhitton> #topic Bug#1065416 -- linux-libc-dev claims to provide linux-libc-dev-ARCH-cross, but it doesn't do that completely
08:01:12 <spwhitton> I wonder if we ought to address the kernel team as a whole ourselves,
08:01:40 <helmut> I perceived waldi's offer for take-over as ironic, but it is hard to tell
08:01:59 <spwhitton> My understanding from offline conversations is that it was serious but not co-ordinated iwth the rest of his team.
08:02:25 <helmut> I also am not sure whether such a transition is reasonable on a technical level
08:02:50 <spwhitton> It's what doko favours
08:03:03 <helmut> the actual source code still resides in src:linux. of course we may have a separate source package providing linux kernel sources, but is such duplication useful?
08:03:04 <spwhitton> What sort of breakage is possible?
08:04:38 <roehling> How stable is that code anyway? It certainly makes a difference whether it is mostly solidified or subject to significant changes regularly
08:05:11 <helmut> kernel headers change regularly, but the linux kernel takes great care that older headers work with newer kernels and vice versa
08:05:13 <spwhitton> If we do have something that both sides agree to, I'm not sure it is really our place to disagree with both of them on techincal grounds, unless it's something crazy.
08:05:33 <helmut> +1 (if they manage to sort it out, let them do)
08:05:43 <spwhitton> So shall I write to the kernel team?
08:05:51 <helmut> yes, cause that avoids further conflict
08:06:00 <roehling> yes, definitely
08:06:03 <spwhitton> anyone want to do anything else, additionally or instead of?
08:06:43 <helmut> I still think it would be useful to get more understanding of how doko plans to maintain it. Otherwise, we just get different issues.
08:07:05 <helmut> This is a fragile mess and subtle changes break elsewhere especially bootstrap stuff.
08:07:13 <roehling> good point
08:07:21 <tumbleweed> it's going to be hard to get a clear description from him
08:07:35 <mjg59> I agree, but is that within the realm of what we were asked to resolve?
08:07:37 <helmut> I have little hope, but why not try?
08:07:42 <spwhitton> yeah, we can ask
08:07:47 <spwhitton> may I suggest someone other than helmut suggest it
08:07:55 <spwhitton> as helmut has already been involved a lot
08:07:56 <tumbleweed> I can
08:07:59 <spwhitton> okay
08:08:09 <spwhitton> #action spwhitton to write to kernel team regarding waldi's takeover offer
08:08:15 <helmut> Yeah, I am quite affected by that issue.
08:08:30 <spwhitton> #action tumbleweed to ask doko for more details on how he would implement waldi's takeover offer
08:08:34 <spwhitton> okay great!
08:08:50 <spwhitton> #topic postmorten for Bug#1077764 -- Ruling request on os-release specification implementation
08:08:55 <spwhitton> helmut wanted to discuss this more.
08:09:22 <spwhitton> There is also the matter I raised privately and them neglected to follow-up on; perhaps leave that side for this meeting.
08:09:43 <spwhitton> helmut: maybe you can start us off by sharing what made you want to dicsus it more
08:10:28 <helmut> I was after the social aspect of the matter and how we failed to get the desired information from luca.
08:11:12 <helmut> Also how we want to deal with people ignoring limits set by ctte members (first me then spwhitton).
08:11:25 <spwhitton> rra and I have a recent experience with this on d-policy actually
08:11:41 <spwhitton> We told Luca to stop, else we'd consider him barred from our process fo ra time.
08:11:52 <spwhitton> We weren't sure we could do it because we're not BTS admins or listmasters
08:12:02 <spwhitton> But we decided to assume we'd have their support.  He stopped.
08:12:31 <helmut> He did not stop here despite being askwed twice.
08:12:31 <spwhitton> Maybe we should assert more ownership of our mailing list and BTS pseudobug.
08:12:39 <spwhitton> Yeah but we didn't ask him qua TC members.
08:12:45 <spwhitton> We asked him just as discussion participants.
08:12:57 <helmut> I think we did. I shall make that more explicit next time.
08:13:11 <spwhitton> The difference is telling him to stop vs. asking him.
08:13:27 <spwhitton> Of course, it is not guaranteed to work!  Just sharing a case where it did.
08:13:43 <spwhitton> This is another case of governance fragmentation.
08:15:28 <helmut> Any idea how we can avoid running in circles next time? My impression was that we (at least Russ, Simon and me) wanted to learn more about Luca's point of view and despite rephrasing our questions repeatedly, we failed at getting what we wanted to understand.
08:16:07 <spwhitton> I would be inclined to think that if all three of you were failing then the problem wasn't on your side.
08:16:37 <Myon> Luca needs to learn to write shorter mails and not to re-repeat everything over and over
08:17:19 <helmut> Actually, Luca tried not to repeat himself by referencing his earlier mails (but he also repeated stuff).
08:17:43 <spwhitton> Is it fair to say that he doesn't answer the questions asked?
08:18:14 <roehling> I kind of felt like he was genuinely trying but somehow failed to grasp the key points we were asking of him
08:18:20 <helmut> I'm unsure about that. He didn't seem to understand what we were asking.
08:18:51 <spwhitton> then, going slower might have helped
08:19:06 <spwhitton> so, helmut's instinct to ask him to take a break was a very good one.
08:20:20 <helmut> I actually delayed some of my own replies to slow down the conversation.
08:21:06 <spwhitton> maybe we could be faster to say to people, "write less at once, post less often, please, else we won't put effort into understanding your point of view"
08:21:31 <helmut> But then we also ask them to summarize the matter so there is some required repetition there.
08:22:56 <roehling> Some summary is actually a good thing, because it allows you to double-check whether your point came across
08:23:12 <roehling> (provided you summarize the opposing view point, not re-iterate your own)
08:23:22 <helmut> Having read about some of other boards, some seem to assign a coordinator role for each issue. Their task could be regularly summarizing the state of discussion and decide when there would be sufficient consensus to move on. Is that something we'd want to do? Kind of a per-issue manager.
08:23:45 <spwhitton> seems worth trying.
08:23:50 <tumbleweed> yeah
08:23:54 <Myon> definitely
08:24:16 <spwhitton> perhaps someone can say they're going to take the role
08:24:17 <Myon> I wasn't looking for a day and then the thread had exploded and was unreadable
08:24:27 <spwhitton> and we say that we won't ever do more than one at once
08:24:40 <spwhitton> it would be good to write down something about this in the procedures/ dir in our git repo
08:24:46 <spwhitton> with a few notes aout the role does and does not entail.
08:24:48 <helmut> in my view, such a role is less technical and more of a moderator
08:24:49 <spwhitton> someone like to do that?
08:25:31 <spwhitton> helmut: you seem to know most about how this is done elsewhere.  would you be up for writing some notes?
08:26:34 <helmut> let me try to come up with a MR and then you may object to my ideas
08:26:48 <spwhitton> heh okay, though we can just edit it :)
08:27:03 <spwhitton> #action helmut to start a new file under procedures/ in tech-ctte.git about designated discussion moderators
08:27:19 <spwhitton> anyone got anything to add regarding #1077764 ?
08:29:57 <spwhitton> oh, matthew vernon had something he sent me
08:30:21 <spwhitton> He reiterated that it might have been useful to say something summarising the consensus that testing and unstable aren't that different
08:30:37 <spwhitton> Or, they aren't cleanly distinguishable.
08:30:59 <spwhitton> Whereas Helmut andI were inclined to prioritise obtaining a resolution.
08:31:04 <helmut> I believe that Luca got that message and disagreed
08:31:13 <spwhitton> oh really?  I think I missed that
08:31:20 <Myon> (imho they clearly are different because installed and maintained differently)
08:32:34 <helmut> Also I offered at least one option (design work) to make them distinguishable in a way that does not require changes to base-files
08:32:37 <spwhitton> Maybe there just wasn't enough mutual understanding to say much at all.  But I do see how it might have menat that we made *some* progress on this topic.
08:33:02 <spwhitton> It's good for coming to the TC to nail down something, even if it's small.
08:33:11 <spwhitton> coming to the TC to result in nailing down something*
08:34:07 <spwhitton> okay, well, let's move on
08:34:07 <helmut> I'm not actually sure that there was that much consensus on testing and unstable remaining indistinguishable. My impression was more like all of the options Luca offered were not acceptable or lacking detail to sufficiently understand them.
08:34:43 <helmut> What I'd agree with is that our resolution should have had a longer rationale.
08:34:47 <spwhitton> helmut: we could have incorporated that, by saying, they're not now, it requires something new to make them.
08:36:08 <helmut> Maybe we actually moved to voting too quickly this time around, but since Luca ignored two requests to stop, voting was an effective mechanism to make him stop. :-/
08:36:23 <roehling> in the end, the whole process felt really rushed, both in the frantic bug discussion and the fact that the topic was escalated to the TC so quickly in the first place
08:37:00 <tumbleweed> I think bouncing it back fast in that situation is reasonable
08:37:01 <roehling> I mean, the request itself is not totally unreasonable, but it was way to early to pick the biggest hammer (i.e. maintainer overruling)
08:37:03 <Myon> I think it went well to the conclusion that on the level of input, there was nothing to decide
08:37:16 <spwhitton> Luca would disagree tho
08:37:24 <spwhitton> He would say it had been discussed for years and Santiago didn't budge
08:37:26 <Myon> if there would have been more previous design work, we could have looked closer at that
08:37:29 <spwhitton> This is a bit like tag2upload.
08:37:42 <spwhitton> So I'm kind of sympathetic.
08:37:54 <helmut> tag2upload has code.
08:38:06 <spwhitton> ah I see.
08:38:13 <roehling> and has been reviewed by third parties
08:38:21 <Myon> usuallly we take months to get to "no decision" :D
08:38:40 <spwhitton> still, it appered to a lot of people that t2u was too early for a GR; maybe things look quite different on this one to Luca and us.
08:39:05 <spwhitton> okay, I'm going to move on if that' sokay
08:39:08 <helmut> I doubt tag2upload would have gotten ftp attention without the GR.
08:39:18 <spwhitton> #topic Handing over the chair
08:39:30 <spwhitton> I intend to start the vote soon so that the new chair has enough time to arrange nex tmonths' meeting
08:39:36 <spwhitton> #action spwhitton to start vote for new chair
08:39:55 <spwhitton> Emperor and roehling are explictly up for it
08:40:04 <spwhitton> Is there anyone else?
08:40:36 <spwhitton> And, thank you for volunteering, Emperor and roehling!
08:41:24 <spwhitton> I am mildly disappointed that I never got to use my casting vote, though I believe I was 50% DPL for a few days a couple of years ago?
08:41:59 <Myon> maybe you get the casting vote on the next chair :D
08:42:06 <spwhitton> nope.  there is no casting vot eon that.
08:42:24 <spwhitton> (I'm not actually disappointed, cos things are likely bad if we are down to a casting vote)
08:42:58 <Myon> true
08:43:25 <spwhitton> if a casting vote is required then I believe Kurt chooses.
08:43:49 <spwhitton> anyway, I don't think there is anything else to dsicuss, I mainly just wanted to action myself to do that.
08:43:50 <helmut> ok. let's try that. ;)
08:44:00 <spwhitton> #topic Any Other Business
08:44:05 <spwhitton> anything from anyone?
08:48:02 <spwhitton> #endmeeting