10:00:08 <Emperor> #startmeeting
10:00:08 <MeetBot> Meeting started Mon Sep 23 10:00:08 2024 UTC.  The chair is Emperor. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:00:08 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
10:00:40 <Emperor> #topic Roll Call
10:00:41 <Myon> Christoph Berg
10:00:41 <spwhitton> Sean Whitton
10:00:44 <tumbleweed> Stefano Rivera
10:00:46 <Emperor> Matthew Vernon
10:00:52 <helmut> Helmut Grohne
10:00:59 <roehling> Timo Röhling
10:01:29 <Emperor> [I think apologies from mjg59 who is having internet woe]
10:01:40 <Emperor> #topic Review previous action items
10:01:50 <Emperor> [apologies if I get any of this wrong, it's my first time chairing]
10:02:00 <spwhitton> you won't!
10:02:07 <seeS> Oh I missed roll call sorry, I'm Craig Small
10:02:14 <spwhitton> hello seeS
10:02:25 <Emperor> Helmut did produce https://salsa.debian.org/debian/tech-ctte/-/merge_requests/9
10:03:17 <Myon> sounds good, let's do it
10:03:18 <Emperor> (thank you!) I think we're at the point we can merge that as a lets-start-from-here and we can revise in line with experience
10:03:21 <helmut> At least Timo, Matthew Vernon, Sean and Stefano interacted with it on the MR
10:03:58 <Emperor> helmut: you OK to un-set draft status and merge it?
10:04:10 <seeS> I couldn't think of anything specific needed to change it and thought the concept was good.
10:04:28 <spwhitton> nice.
10:04:39 <Myon> live progress :)
10:04:49 <roehling> \o/ :)
10:04:51 <helmut> Can we apply it to existing ctte items?
10:05:21 <Emperor> helmut: I think we will likely cover that when we get to #1065416
10:05:24 <helmut> any volunteer for moderating gcc vs linux? I definitely consider my self involved.
10:05:24 <Myon> that would be a good thing
10:05:41 <Emperor> but I'd like to hold that 'til we get to it in the agenda (or I'll miss something!)
10:06:20 <Emperor> other actions: spwhitton and tumbleweed both did theirs (and we'll come to that bug shortly), so thanks again
10:06:36 <Emperor> #topic #1065416
10:07:12 <tumbleweed> so I have done some prodding and poking on both sides
10:07:28 <tumbleweed> for now, linux has reverted the change
10:07:46 <spwhitton> the ball is in doko's court right now, right?
10:07:47 <helmut> in experimental, but that's more of a buying-us-time thing than a decision
10:07:50 <tumbleweed> I still hope that they can come to an agreement on the future
10:08:17 <tumbleweed> spwhitton: the linux maintainers haven't clearly said what they want in the future
10:08:23 <spwhitton> true.
10:08:56 <Emperor> What (if anything) is the next step for this; do we need to chase the linux maintainers again to clarify their requirements?
10:09:07 <helmut> I also note that the bootstrap requirement of having some form of metadata for identifying when linux-libc-dev lies is missing due to the revert
10:11:02 <tumbleweed> anyway, you were looking for volunteers. I'm happy to stay on this one
10:11:27 <Emperor> tumbleweed: thank you that's appreciated. Shall we nominate you as moderator for this issue per our newly-minted procedure?
10:11:40 <helmut> I concur that gathering requirements from linux maintainers would be good. From my pov, reverting linux-libc-dev M-A:foreign would be a good solution and I don't quite understand why we have to do it
10:11:58 <tumbleweed> I think doko feels similarly
10:12:00 <spwhitton> helmut: that's putting a burden of work on them.  isn't it basically doko who wants this change?
10:12:09 <helmut> spwhitton: and me
10:12:19 <spwhitton> right okay.
10:12:23 <helmut> spwhitton: but I'm not nearly pushing as hard and trying to find solutions consensually
10:14:05 <Emperor> #action tumbleweed to become moderator of #1065416
10:14:19 <helmut> in any case. I believe that we very much sold the revert of the provides as a temporary thing to waldi
10:14:51 <Emperor> Yes, I think it shouldn't become permanent without either consent between the parties or a TC ruling.
10:15:29 <tumbleweed> the current siutation has problems anyway (the missing metadata for bootstrapping)
10:17:25 <helmut> my vague understanding of waldi is that he did the arch:any -> arch:all conversion mainly for reducing a) space on mirrors and b) space on installations that install linux-libc-dev for many architectures (not sure who'd do that)
10:18:02 <Emperor> Iff that's correct, it does seem to be causing us pain for a relatively minor win in terms of disk space
10:18:16 <helmut> as a result, I proposed a compromise of adding a linux-libc-dev-common containing most of the shared files and leaving linux-libc-dev arch:any + M-A:same
10:18:38 <helmut> linux-libc-dev-common would absorb 90% of the size
10:20:06 <helmut> I have never witnessed a reply from waldi regarding this proposed compromise that (as far as I can see) would resolve the space concerns as well as all of doko's and my concerns
10:21:16 <Emperor> helmut: do you want to flag that to waldi explicitly, then, see if he's happy to go with it (or explain why not)?
10:21:33 <tumbleweed> or would you prefer that I do?
10:22:18 <helmut> I think I mailed waldi directly about it and doing again would be pushing harder than I like. whilst it is my preferred solution, it is not like the only one
10:23:45 <helmut> an aspect that waldi would like to see improved as far as I can see is that we have multiple linux-libc-dev in the archive that can go out of sync. (the -$arch-cross ones)
10:25:07 <tumbleweed> yeah, if linux is able to provide the necessary cross bits, then cross-toolchain-base doesn't have to
10:25:09 <helmut> my understanding of his view is that he'd like to see linux-libc-dev-$arch-cross go away or be built from src:linux. a good reason for wanting that is that if you have both installed stuff can go wrong weirdly depending on which of them you pick with various compiler search paths that may vary between source packages (and yes, we saw that already)
10:25:10 <Emperor> if your proposal was only sent directly to waldi, would it be worth adding it to the bug thread, then? It'd mean we've a record of the suggestion, without being quite such a nag
10:25:35 <helmut> Emperor: it was sent to one of the bugs + cc waldi
10:25:51 <Emperor> OK, I'm obviously not managing to keep on top of all the mails on this issue :-/
10:26:49 <helmut> you're not alone. is it time to summarize the requirements seen by involved parties and let each of the parties confirm that it represents their view?
10:27:15 <tumbleweed> I think we're going to be repeatedly doing something like that
10:27:26 <tumbleweed> The main difficulty in this issue is the lack of involvement from both sides
10:27:49 <helmut> I concur
10:28:19 <Emperor> I think then that a summary of where we're at now would be useful
10:28:27 <tumbleweed> OK, I'll post that
10:28:37 <Emperor> Cool, thanks.
10:28:40 <spwhitton> there should probably be limits to how much we are willing to do without that involvement.
10:29:01 <Emperor> #action tumbleweed to summarize state of parties' requirements for #1065416
10:29:04 <roehling> To be fair, it is far from trivial to grasp all implications of the various proposals.
10:29:24 <Emperor> spwhitton: I agree, we are not meant to do the detailed design work in the TC
10:29:28 <helmut> tumbleweed: I am happy to review
10:29:33 <tumbleweed> I don't think either side wants our involvement
10:30:06 <Myon> is there even disagreement between them, and not just having not yet figured out the best way forward?
10:30:10 <Emperor> Ideally they can come to agreement without the TC having to rule.
10:30:31 <tumbleweed> the disagreement I see is a lack of understanding of what the other is trying to achieve
10:30:32 <Emperor> Myon: there was certainly some quite strongly-expressed disagreement at the start of the bug in question
10:31:32 <Emperor> if after tumbleweed's summary both sides are at the point of happy to work together on a solution, then that's a good outcome, and the TC can bow out and leave them to do so.
10:31:43 <Myon> indeed
10:32:11 <Emperor> Anything else on this bug we need to talk about today?
10:32:27 <spwhitton> thank you tumbleweed for your work.
10:32:35 <tumbleweed> np
10:32:41 <Emperor> +1
10:32:44 <roehling> +1
10:32:53 <Emperor> #topic recruitment/ctte-cronscript.sh
10:33:16 <spwhitton> ah yes.
10:33:22 <Emperor> spwhitton has been running this script for some time now, but it needs to be handed over as he's leaving the committee at the end of the year
10:33:36 <spwhitton> looks like I already dropped the cronjob.
10:34:11 <roehling> I can take over the cronjob
10:34:12 <spwhitton> I think I sent mail on what to grab out of master:~spwhitton
10:34:30 <spwhitton> roehling: nice.  let me know if you need any additional info.  be sure to grab the live data to avoid re-emialing the same people
10:34:33 <Emperor> roehling: great, thanks
10:34:51 <Emperor> #action roehling to take over running recruitment/ctte-cronscript.sh
10:35:05 <Emperor> #topic recruitment
10:35:48 <Emperor> We need to start thinking about recruitment, as spwhitton's term expires at the end of the year.
10:36:13 <Emperor> I think the next step of that is probably to email d-d-a to call for nominations.
10:36:27 <spwhitton> also, there are carry-over nominations, I think
10:36:39 <spwhitton> so need to write to those people to ask whether they are happy to be considered again.
10:36:45 <Emperor> spwhitton: I was going to ask you about that :)
10:36:58 <Emperor> do you have a list? [obviously don't put names here]
10:36:59 <spwhitton> Emperor: well it's a case of spleunking one's d-ctte-private archives, basically
10:37:23 <spwhitton> so no, I don't have a list to hand, unfortunately.
10:37:24 <Emperor> it's ... possible ... that I don't keep all my d-c-p email indefinitely :-/
10:37:42 <seeS> it was before my time
10:37:53 <spwhitton> I can do it if you would like to action me
10:38:18 <Emperor> thanks, I'll try and do better in future.
10:38:28 <spwhitton> not at all.
10:38:32 <Emperor> #action spwhitton to find any carry-over nominations
10:38:53 <Emperor> shall we action me as chair to email d-d-a? I'm going to be AFK from Friday, but should be able to do so before then.
10:39:04 <spwhitton> that's fine.  though it def does not have to be you.
10:39:23 <Emperor> #action Emperor to email d-d-a seeking nominations
10:39:36 <Emperor> If I drop that ball, I'll try and at least ask someone else to pick it up while I'm away.
10:39:38 <helmut> sean's term expires 2025, right?
10:39:47 <Emperor> end of this calendar year
10:39:49 <spwhitton> helmut: 31st December.
10:40:02 <helmut> looks like we might have time still %-)
10:40:13 <spwhitton> it's not the worst to operate at 7
10:40:31 <spwhitton> hopefully people will put their names forward this year.
10:40:51 <Emperor> No, but recruitment has historically been quite a long process, so I'd rather give us the time
10:41:06 <spwhitton> yeah.
10:41:08 <roehling> do we have a list of the next term expirations somewhere?
10:41:11 <seeS> At least there will hopefully be no change of DPL halfway through this time
10:41:13 <spwhitton> roehling: members.csv
10:41:19 <roehling> thanks
10:41:31 <spwhitton> roehling: also the talk slides.
10:41:49 <Emperor> you can work it out from https://www.debian.org/intro/organization#tech-ctte and the constitution, but it's a bit confusing to do so
10:41:57 <Emperor> #topic AOB
10:42:01 <Emperor> Anything else for today?
10:42:06 <tumbleweed> next meeting schedule
10:42:16 <spwhitton> thank you for chairing, Emperor :)
10:42:18 <tumbleweed> I think with the current set of timezones, we'll have to keep polling for each meeting
10:42:22 <Emperor> Are folk still wanting to do meeting-at-a-time ?
10:42:28 <tumbleweed> because there will be no time that works for everyone
10:42:49 <Emperor> (if so, was the whenisgood grid OK for you to use? It was quite handy for me as organiser)
10:42:49 <helmut> at least 3 of us are affected by a dst change soon
10:42:57 <tumbleweed> Emperor: yeah, that was fine
10:42:58 <spwhitton> whenisgood was good.
10:43:01 <roehling> +1 on whenisgood
10:43:19 <seeS> Me too, though for me its going to DST, i like whenisgood because i don't have to convert times/dates
10:43:27 <spwhitton> yeah.
10:43:34 <Myon> yes, I could click-drag whole ranges, way better than clicking 100 options
10:43:44 <tumbleweed> TIL
10:43:47 * tumbleweed clicked 100 options
10:44:04 <Emperor> OK, I'll use it again. I'm back on 13th Oct, and aim to put up a poll then for the last couple of weeks of October?
10:44:18 <Emperor> which will end up being about a month from now
10:44:29 <tumbleweed> +1
10:44:32 <roehling> I probably won't be able to make it (see d-private) next time
10:44:38 <spwhitton> sounds good.  I guess one resaon to usually prfer meetings earlier in the month is that we'll never have one late december.
10:46:11 <Emperor> Right, I think that's us done for today. Thanks for your time everyone :)
10:46:27 <Emperor> #endmeeting