08:00:01 <Emperor> #startmeeting
08:00:01 <MeetBot> Meeting started Mon Oct 28 08:00:01 2024 UTC.  The chair is Emperor. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:01 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:00:11 <Emperor> #roll-call
08:00:12 <helmut> Helmut Grohne
08:00:20 <spwhitton> Emperor: you need #topic
08:00:40 <Emperor> sorry, I'm not really quite awak yet
08:00:45 <spwhitton> haha
08:00:47 <Emperor> #topic Roll Call
08:00:50 <spwhitton> Sean Whitton
08:00:54 <Emperor> Matthew Vernon
08:01:28 <helmut> Helmut Grohne
08:02:08 <roehling> Timo Röhling
08:02:32 <Emperor> any more? I was expecting Christoph, Craig, and Matthew G to all be available at this time
08:02:46 <spwhitton> maybe give them until five past
08:02:57 <Emperor> 👍
08:05:44 <Emperor> seeS isn't on this channel currently. mjg59 / Myon are you around?
08:06:37 <Emperor> well, we should probably get started.
08:06:50 <Emperor> #topic Review previous actions
08:07:42 <Emperor> tumbleweed isn't here to comment on becoming moderator of #1065416, but I don't think I've seen the proposed summary of peoples positions.
08:08:30 <helmut> recent replies indicate that waldi and ben disagree about linux maintenance (non-violently)
08:08:57 <Emperor> Mmm, let's come to the bug itself in a bit.
08:09:36 <Emperor> roehling: you had an action to take over running recruitment/ctte-cronscript.sh ; I've seen some commits to that go past, so do I assume correctly it's now running from your crontab?
08:10:09 <roehling> Correct, the job is set up and I updated the recruitment mail to reflect the new sender.
08:10:15 <Emperor> thanks :)
08:10:25 <spwhitton> were you able to copy the data on who has already been mailed out of my HOME?
08:10:41 <roehling> Yes, that was no problem
08:10:47 <spwhitton> nice.  then I will delet my copy.
08:10:53 <roehling> +1
08:11:04 <Emperor> The other actions were for spwhitton to dig out previous nominations (which he did, and most of them replied to his ping), and for me to mail d-d-a (which I did once I figured I couldn't use thunderbird to do so...)
08:11:24 <Emperor> #topic #1065416: linux-libc-dev claims to provide linux-libc-dev-ARCH-cross, but it doesn't do that completely
08:13:44 <Emperor> Do we have anything to add on this?
08:13:54 <spwhitton> well, we should remind tumbleweed of his AI and probably re-#action it
08:14:01 <helmut> I think matthias is happy with the status quo (revert). I cannot imagine waldi to be happy. I've temporarily found a way to deal with this in bootstrapping (insepcting the files in the actual linux-libc-dev.deb), but it is not sustainable.
08:15:01 <Emperor> Mmm, so I think we should ask tumbleweed to poke the parties again and summarise their positions, see if we can get this unstuck
08:15:39 <Emperor> (it's been open since March now, which is not great)
08:15:53 <Emperor> #action tumbleweed to become moderator of #1065416
08:16:02 <Emperor> #action tumbleweed to summarize state of parties' requirements for #1065416
08:16:20 <Emperor> #topic Bug #1084924: The system-log-daemon virtual package
08:16:45 <spwhitton> let me ask a question about this that I was going to mail tot he bug
08:16:49 <Emperor> I sent a follow-up to this late yesterday (sorry)
08:16:54 <Emperor> spwhitton: please do
08:17:22 <spwhitton> you know we have python3-is-python2 or whatever?  couldn't systemd have an empty binary package syslog-is-journald which provides system-log-daemon.
08:17:31 <spwhitton> and install that on default systems.
08:17:38 <helmut> does anyone have capacity to serve as owner/moderator for the system-log-daemon thing? I am quite swamped and travelling.
08:18:00 <spwhitton> then journald is always installed along with systemd cos it's not in that empty binary package.
08:18:12 <helmut> spwhitton: I think I answered your question in my first reply.
08:18:24 <Emperor> helmut's question is sound (and should maybe be asked of those not here); I feel it probably shouldn't be me, because I know Ian well, and would like to avoid any suggestion of a conflict of interest
08:19:04 <spwhitton> helmut: having the binary package be *empty* makes it compatible with what you said there, I thought
08:19:39 <spwhitton> the binary package indicates that we are in your second bullet point.
08:19:40 <helmut> spwhitton: oh. now I get it. that's a neat way of looking at it!
08:20:16 <Emperor> I think a similar idea was mooted in the d-devel thread and bluca was unhappy with it (but I think because he thought it was only something that would help devuan)
08:20:18 <helmut> spwhitton: can you write that up in slightly more detail to the bug? (I do consider it design work though)
08:20:52 <helmut> spwhitton: a downside would be that this empty package would be installed on the vast majority of systems
08:21:03 <spwhitton> I think that's an extremely minor downside
08:21:47 <spwhitton> anyway yes I will write to the bug, and we'll see if I've misunderstooda nything
08:22:09 <Emperor> #action spwhitton to add their suggestion to #1084924
08:22:33 <Emperor> #agreed we need someone to act as moderator for #1084924
08:22:48 <spwhitton> I'm also good friends with Ian.
08:22:52 <helmut> the other question is how we can get ian to talk to us. he privately reconfirmed that he would not like to participate  on the ctte bug, because we fail at moderating
08:23:05 <spwhitton> he's happy to discuss private though?
08:23:29 <helmut> given that we move into design work, how about we follow ian's suggestion and create a policy bug and move the discussion largely there?
08:23:34 <Emperor> I think if we have questions for him, someone (ideally whoever ends up being moderator for this bug) should email them to him directly; I think he's said he'll respond to such questions
08:24:16 <helmut> whatever comes out of this will very likely also result in a policy change (unless we end up doing spwhitton's empty package)
08:24:23 <spwhitton> helmut: I think we need to be clearer on how it's a policy issue.  do you mean the virtual package descriptions?  my idea doesn't require a policy change.
08:24:26 <spwhitton> right.
08:25:27 <helmut> but then we can still discuss it on the policy side, clarify the state of affairs and close the bug there with no code change
08:26:08 <Emperor> I _think_ let's see how spwhitton's suggestion goes over; but yes, we may end up saying it's a question of policy and the policy process should be followed.
08:26:11 <helmut> the advantage of doing that is that ian offered to interact directly there and we wouldn't have to proxy his messages
08:26:18 <spwhitton> yeah.
08:26:37 <helmut> spwhitton: would you Cc systemd maintainers on the empty package?
08:27:13 <spwhitton> sure.
08:27:19 <spwhitton> systemd@packages.debian.org ?
08:28:29 <Emperor> spwhitton: BTS thinks pkg-systemd-maintainers@lists.alioth.debian.org
08:28:33 <spwhitton> ty
08:29:05 <Emperor> #topic Recruitment
08:29:12 <Emperor> let's pop over to -private for this
08:36:26 <Emperor> #action helmut to talk about recruitment in Toulouse
08:36:45 <Emperor> #action spwhitton to ping the person who said they'd nominate themself
08:37:01 <Emperor> #topic AOB
08:37:29 <Emperor> Two quick things from me: I added some docs on how the BTS usercategory works (thanks to spwhitton for digging up ancient emails on this)
08:37:39 <spwhitton> thank you for finally documenting it, nice!!!
08:37:46 <roehling> \o/
08:38:22 <helmut> I'm unsure whether we agreed to move the system-log-daemon to policy now
08:38:27 <spwhitton> we didn't.
08:38:37 <helmut> ok
08:38:49 <Emperor> Second, does anyone have good free tooling for updating the .ics file? tumbleweed is currently doing it (thanks!)
08:39:10 <Emperor> it's fine if the answer is no...
08:39:19 <spwhitton> Emperor: emacs diary mode!
08:39:24 <spwhitton> no .ics support == no tool needed
08:39:34 <helmut> I happen to use two tools python3-vobject (for generating them from something else) and vim (for editing by hand)
08:39:37 <Emperor> 🤦
08:40:22 <Emperor> I looked at the .ics file in an editor, and the fragment that whenisgood had produced, and it didn't look like I would obviously combine them in a correct manner.
08:41:09 <Emperor> python3-vobject might be helpful, though, thanks.
08:41:22 <Emperor> Any other AOB?
08:41:29 <helmut> python3-vobject has a significant barrier to entrance. let me know if you need assistance
08:41:39 <Emperor> ack, ty
08:42:23 <Emperor> I'm not quite sure what went wrong with attendance today, maybe I should send a reminder 24h in advance or something?
08:42:40 <Emperor> I guess I'll ask the people who I was expecting to be here...
08:42:46 <spwhitton> bnoth sound like good ideas.
08:43:43 <Emperor> Last call for AOB
08:44:09 <Emperor> OK, thanks for your time folks.
08:44:11 <Emperor> #endmeeting