19:01:31 <h01ger> #startmeeting
19:01:31 <MeetBot> Meeting started Mon Dec 21 19:01:31 2009 UTC.  The chair is h01ger. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:31 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:02:12 <h01ger> #topic everybody says hi - h01ger suggests a basically free flowing meeting, where we can talk about remaining blockers and work on them :-)
19:02:20 * h01ger = Holger Levsen
19:02:21 * jever = Jürgen Leibner
19:02:26 * pere = Petter Reinholdtsen
19:02:39 <h01ger> http://tinyurl.com/edulenny-releaseview-1
19:02:43 * pere fail to see the point of a meeting if we are going to behave as it is a freeflowing irc chat.
19:02:54 <h01ger> is the topic i suggest
19:03:13 <h01ger> but i can turn this into a regular agenda, np
19:03:42 <debalance_> debalance = Philipp Huebner+
19:03:43 * h01ger edits http://wiki.debian.org/DebianEdu/Meeting - hold on please :)
19:03:50 * debalance_ = Philipp Huebner
19:04:02 * vagrantc = Vagrant Cascadian
19:04:08 * debalance = Philipp Huebner
19:04:11 <debalance> sorry for the noise
19:04:40 <f1ash> \me Andi Mundt
19:05:41 <h01ger> hi f1ash!
19:05:51 <f1ash> hi all!
19:05:56 <h01ger> f1ash, how's your involvement here? </curious>
19:06:05 <h01ger> http://wiki.debian.org/DebianEdu/Meeting has a agenda now
19:06:16 <h01ger> #topic who writes summary?
19:06:22 <h01ger> #topic 2. who writes summary?
19:06:23 <f1ash> going to start with more involvement...
19:07:44 <h01ger> summary-writer, anyone?
19:09:17 <vagrantc> i'll do it
19:09:21 <h01ger> cool
19:09:30 <h01ger> #info vagrantc will write summary \o/
19:09:52 <h01ger> #topic 3. lenny status: http://tinyurl.com/edulenny-releaseview-1
19:10:06 <h01ger> #topic 3.1 lenny status: #1376: Removable media (like usb sticks) inserted into ltsp server show up on ltsp clients
19:10:14 <h01ger> pere posted some info to the bug today..
19:10:41 * pere asked martin pitt for ideas, and he had some clues and was going to place his comment into bugzilla laster (he had to leave for dinner).
19:11:17 <pere> one thing to note is that the is_local flag in consolekit is correct for thin client users, and thus should not get the messages if it was only sent to local users.
19:11:37 <pere> ck-list-sessions lists consolekit status.
19:11:54 * h01ger notes that last meeting we agreed that documenting this issue is enough to make it p3 - and iirc i volunteered to do that. /me checks
19:12:47 <pere> yes.  just wanted to see if a little effort could fix it in time for the release.
19:13:01 * h01ger nods. fixing it would be great, for sure!
19:13:09 <h01ger> #topic 3.2 1383: usernames are caseinsensitive during login
19:13:26 <h01ger> #info still waiting for the maintainer upload scheduled for this weekend
19:13:31 <h01ger> aeh, wait
19:14:19 <pere> ?
19:14:24 <h01ger> its monday
19:15:05 <pere> so perhaps arthur did not make it this weekend, or perhaps it already happened...
19:15:30 <h01ger> http://qa.debian.org/developer.php?login=adejong@debian.org says its there \o/
19:16:03 <h01ger> http://release.debian.org/proposed-updates/stable_diffs/nss-ldapd_0.6.7.2.debdiff has the debdiff \o/
19:16:15 <pere> great.
19:16:26 <pere> any idea how long it will take before it is in lenny?
19:16:32 <h01ger> pere, can you take that debdiff and do an upload to lenny-test?
19:16:49 * h01ger doesnt know when the next lenny pointrelease is planned
19:16:56 <h01ger> so 1-28 days :-/
19:17:09 <pere> h01ger: I will see if I find time to do that.  had other things on my todo list.
19:17:12 <h01ger> so i would suggest to upload 0.6.7.2~edu1
19:17:20 <h01ger> anybody else?
19:17:36 <h01ger> its taking the diff, building on stable and upload :-P
19:17:45 <h01ger> (and writing debian/changelog :)
19:17:47 <vagrantc> i can do that
19:17:54 <vagrantc> or at least try
19:17:59 <h01ger> vagrantc, thanks
19:18:28 <h01ger> #info vagrantc will try to do an upload of nss-ldapd 0.6.7.2~edu1 to our archive
19:18:51 <h01ger> #topic 3.3 lenny status: #1398: DHCP server stops unexpectedly after less then 24 hours
19:19:04 <h01ger> pere?
19:19:14 * pere made a patch I hope will solve it, but lack the means to test it.
19:19:32 <pere> it protects the ldap search command with code to ignore SIGPIPE.
19:19:37 <h01ger> OleA, debalance: can you test this patch? pere provides .debs even :)
19:19:51 <pere> similar code was already in place for the ldap close command.
19:20:20 <pere> if the patch work, we should ask the maintainer to upload a fix in lenny and unstable.
19:20:33 * h01ger nods
19:20:36 <debalance> I need a amd64 package or the source package to build it myself
19:20:49 <pere> if the patch do not work, we should continue with the plan to restart dhcpd in static mode.
19:20:56 <pere> debalance: the source package is next to the deb.
19:21:07 <debalance> okay, i'll build and install it
19:21:17 <h01ger> #info debalance will try peres patch and report back
19:21:30 <h01ger> pere, thats also all in the debian bts already?
19:21:43 <pere> h01ger: yes.
19:21:57 <h01ger> \o/
19:22:04 <h01ger> #topic 3.4 lenny status: #1404: Gnash are filling up .xsession-errors
19:22:22 <pere> h01ger: you first?
19:22:29 <h01ger> #info debian bug has a patch which was approved by SRM. h01ger will upload to s-p-u
19:22:40 <h01ger> #info (with maintainer approval)
19:22:53 <debalance> pere: could you give me the link again? already deleted the mail
19:23:18 <h01ger> debalance, http://bugs.debian.org/559160
19:23:20 <pere> #link http://people.skolelinux.org/~pere/debian/packages/lenny/
19:23:27 <h01ger> right :)
19:23:46 <h01ger> pere, you can give links to MeetBot with or without #link :)
19:23:59 <pere> I've been in contact with gnash upstream (Rob Savoy), which seem to be interested in maintaining the latest upstream version of gnash in Debian Edu.
19:24:30 <pere> Given that the latest gnash is needed to get more sites working, I believe this is a good idea.
19:24:42 <h01ger> cheers! did you ask him whether it needs other backports?
19:24:43 <vagrantc> debian-edu-volatile?
19:24:55 <h01ger> debian-volatile?
19:24:58 <h01ger> :)
19:25:07 <pere> h01ger: nope, but he said they were already making lenny versions.
19:25:17 * h01ger thinks that newer gnash would be good for debian lenny too
19:25:20 <h01ger> nice
19:25:28 <pere> I'll keep debian-edu@ on CC for the conversation.
19:25:43 <h01ger> pere, thank you!
19:25:44 <h01ger> #topic 3.5 lenny status: #1370: sound should work on thin clients
19:25:46 <pere> suspect rob have unrealistic expectations on how much work is needed, but we will see.
19:25:47 * jever thinks he is called 'Rob Savoye'
19:25:56 <pere> jever: could be. :P)
19:26:01 * h01ger apologies for being so fast
19:26:21 <h01ger> #1370? :-D
19:26:36 <pere> I've read a bit on pulseaudio and sound systems, but is no-where near understanding of the issues.
19:27:03 <pere> need someone with test equipment to test whatever I come up with.
19:27:20 <h01ger> pere, you can use sound with virtualbox very nicely
19:27:42 <pere> itais told me that his home-made gnome ltsp installation uses pulseaudio without problems
19:27:52 * h01ger too - doing a full tjener with latest lenny-test dvd atm..
19:27:59 <pere> without a /etc/asound.conf file, which I suspected was needed to get alsa applications to use pulseaudio.
19:28:22 <pere> itais is not using the current debian-edu gnome installation, so we do not know if that is working or not.
19:28:22 <debalance> I have an older laptop I can use as a TC, sound works there when doing a pure lenny ltsp-build-client
19:28:53 <pere> debalance: great.  which applications?  audacity and the mplayer browser plugin are good test cases.
19:29:04 <pere> sound already work with KDE and gcompris.
19:29:09 <debalance> only checked webradio using iceweasel and xine so far
19:29:10 <vagrantc> applications which support pulseaudio directly (most of GNOME) will probably work without asound.conf
19:29:19 <pere> I am starting to suspect that KDE is supposed to use esd with pulseaudio.
19:29:20 <vagrantc> but other applications still need a compatibility layet
19:29:22 <vagrantc> layer
19:29:41 <vagrantc> i think alsa is going to be a better bet than esd
19:29:59 <pere> vagrantc: how is the ltsp clients getting the pulseaudio stream from the server?
19:30:14 <pere> how is it selected?  I only find the ESOUND environment varialbe pointing to the client.
19:30:21 * vagrantc looks
19:31:09 <vagrantc> PULSE_SERVER environment variable
19:31:10 <pere> we could add pulseaudio entries in /etc/asound.conf for ALSA, and then set a environment variable to use it when clients log in.
19:31:29 <vagrantc> ldm should set PULSE_SERVER
19:31:30 <pere> vagrantc: did not see it when I tested a ltsp login.
19:31:54 <vagrantc> is debian-edu tweaking lts.conf ?
19:32:04 <vagrantc> defaults are *definitely* to use pulseaudio
19:32:21 <pere> vagrantc: yes.
19:32:46 <pere> [Default]
19:32:46 <pere> NBD_SWAP=Y
19:32:46 <pere> SOUND=Y
19:32:46 <pere> LOCALDEV=Y
19:32:46 <pere> SCREEN_07=ldm
19:33:09 <pere> I suspect we could drop it, but have not tested it.
19:33:47 <pere> anyway, sound like debalance, vagrantc and me should continue looking into this.
19:34:03 <pere> I added some URLs to bugzilla.
19:34:58 <debalance> wow, dhcp3-server-ldap is definitely not lintian-clean ^^
19:36:09 <h01ger> debalance, just run lintian on the old package and compare with debdiff....
19:36:34 <h01ger> anything left to say to #1370 now?
19:36:39 <pere> vagrantc: do you know if these lts.conf entries are still needed?  The last one is inserted for diskless workstations, no idea why.
19:36:48 <pere> (do not remember why we added it)
19:37:01 <vagrantc> pere: only NBD_SWAP. other's are defaults.
19:37:13 <debalance> h01ger: http://lintian.debian.org/maintainer/apollock@debian.org.html#dhcp3 ;) the rest comes from pere's changes regarding the revision and such stuff
19:37:20 <pere> vagrantc: right.  debalance please test without these entries in /opt/ltsp/i386/etc/lts.conf
19:37:21 <vagrantc> pere: ah, SCREEN_07=ldm is also needed
19:37:23 * janr thinks lts.conf is needed to enable local swap on diskless workstations
19:37:42 <vagrantc> pere: if a display manager (kdm/gdm/xdm) is installed in the chroot
19:37:58 <pere> vagrantc: right.  kdm is installed.
19:38:17 <vagrantc> pere: but sound and localdev are the defaults, i believe.
19:38:26 <vagrantc> pere: a little hard to keep track of older LTSP versions in my head.
19:38:49 <pere> vagrantc: right.  if someone can confirm that sound and local devices still work without these, I want to remove them.
19:39:01 <h01ger> pere, for squeeze?
19:39:22 <pere> for lenny, to reduce the upgrade problems and limit how much we edit using cfengine.
19:39:28 <pere> if they are useless, we should remove them.
19:39:39 <debalance> pere, is it enough if I install the dhcp3-server-ldap package? or should I install -server and -common too?
19:39:43 <h01ger> ah, its a diverge from debian..
19:39:52 <pere> debalance: should be enough with the -ldap package.
19:40:25 <h01ger> anyway, as cross discussions start, i suggest to move on..
19:40:46 <h01ger> #info 1370 still needs attention
19:40:51 <pere> there are two cfengine rules to edit etc/resolv.conf and etc/ltsp/update-kernels.conf on thin clients.  I suspect both are obsolete now, but have not had time to test it.
19:41:06 <h01ger> #topic 3.6 lenny status: #1407: Package education-workstation not installed on workstation profile
19:41:18 * h01ger believes this is fixed and just said so in bugzilla
19:41:21 <pere> did anyone verify that report?
19:41:29 <h01ger> not yet
19:41:42 * h01ger will try to
19:42:13 <pere> I suspect it is fixed too, or based on some misunderstanding (we use tasksel tasks and not metapackages, but install the metapackage too I believe).
19:42:38 <h01ger> #topic 4. alpha2 news+issues
19:42:50 <h01ger> sep released it today \o/
19:43:12 <pere> great
19:43:32 <h01ger> did someone test it yet?
19:43:38 <pere> but I believe we should work more on the text when announcing new versions, explaining more on what was changed.
19:43:53 <pere> every change for the better give people motivation to test it. :)
19:44:15 <pere> I have not tested it yet.
19:44:37 * h01ger nods (write shiny announcements)
19:46:11 <pere> I believe we should wait at least one week for the next release, to give some time for testers to provide feedback.
19:46:44 * h01ger thinks a news years eve RC1 is a nice idea
19:47:05 <h01ger> maybe with zero p2 bugs! </daydream>
19:47:24 <pere> yeah, would be great.  but as usual, I suspect testing will expose some fatal bugs.
19:47:28 <h01ger> exceptfor 1370 we maybe have tackled them all \o/
19:47:55 <h01ger> #topic 5. rc1 for xmas or new years eve?
19:48:36 <vagrantc> i'd be inclined to the latter ... otherwise it makes the alpha2 kinda pointless
19:48:47 <h01ger> #info maybe for new years eve indeed: except for 1370 all p2 bugs are being well worked on. sometime between alpha2 and rc1 should be given, also to write a nice announcement, motivating testers
19:48:52 <pere> yes, and if new RC bugs show up, we might have to make alpha3.
19:49:15 <pere> but it look very good at the moment, I must admit. :)
19:50:11 * h01ger is happy with the progress too!
19:50:27 <h01ger> #topic 6. any other business?
19:51:14 <pere> is the translation status for the installation and documentation good?  when we are getting close to release, we should poke translators again and give them a deadline.
19:51:44 <h01ger> we are close to a release :) and at least the docs can be always updated easily
19:51:44 <pere> we should also make sure someone did a norwegian bokmål and nynorsk installation, as well as german, french and spanish.
19:52:06 <h01ger> #info <pere> is the translation status for the installation and documentation good?  when we are getting close to release, we should poke translators again and give them a deadline. we should also make sure someone did a norwegian bokmål and nynorsk installation, as well as german, french and spanish.
19:52:31 <pere> I do bokmål installs.  who are doing nynorsk, german, frensh and spanish?
19:52:39 * h01ger always tests in german unless to report bugs
19:52:48 <debalance> same with me
19:53:01 <pere> is the spell checker set to use german then?
19:53:12 * h01ger hasnt checked
19:54:28 <h01ger> while i think we should test this (and fix if needed), i also think this is not necessarily p2, unless in all languages ;) i'd like to aim at a point release 2month after the release
19:54:31 <pere> there used to be a bug there, I hope it was fixed.
19:54:44 <pere> yeah.
19:54:49 <h01ger> #topic 7. next meeting
19:55:13 <h01ger> next tuesday? (cause itais cant join on mondays..)
19:55:17 <pere> OOo get norwegian bokmål spell checking by default, at least. :)
19:55:37 <pere> I'm in transit next tuesday, might make it for the evening.
19:56:26 <pere> any protests for next tuesday?
19:56:37 <debalance> pere: needed to install all 3 dhcp packages due to exactly versioned depends
19:56:54 * debalance has installed the new dhcp packages on i386 ltspserver and amd64 tjener now
19:56:55 <h01ger> #agreed next meeting, tuesday 29th of decembre, 20 UTC / 19 CET
19:57:09 <debalance> the other way round, right?
19:57:17 <pere> yeah.
19:57:24 <pere> 19 UTC / 20 CET
19:57:32 * h01ger thanks everybody for particpating and getting a rockin' release out!
19:57:47 <h01ger> #agreed corrected: next meeting, tuesday 29th of decembre, 19 UTC / 20 CET
19:58:03 <pere> great.
19:58:10 * h01ger specially thanks vagrantc for writing the summary! :)
19:58:13 <pere> debalance: do you know how to test the new dhcpd server?
19:58:34 <debalance> pere: is there anything special?
19:58:45 <debalance> installed the new packages, changed setting back to dynamic and restarted dhcpd
19:58:47 * vagrantc hopes to do better than in the past
19:59:04 <pere> debalance: to trigger the bug, the server need to be unused for several hours, and then used by a client again.
19:59:30 <debalance> well, the installation had this problem in the past over night, so I expect it to happen again if the bug is not fixed
19:59:33 <pere> debalance: the LDAP connection need to time out / be disconnected by the server to trigger the bug.
19:59:44 <pere> debalance: unless there are more clients on the network now.
19:59:49 <debalance> not really
20:00:00 <h01ger> #endmeeting