20:02:32 <waldi> #startmeeting
20:02:32 <MeetBot> Meeting started Fri Mar 13 20:02:32 2020 UTC. The chair is waldi. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:32 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:02:38 <waldi> welcome, welcome
20:02:45 <ScottK> o/
20:02:48 <spwhitton> hello
20:02:50 <waldi> whos here?
20:03:11 <ta> i am here
20:04:15 <waldi> spwhitton: you said, you had something to discuss=
20:04:45 <spwhitton> #topic manpages.git
20:04:53 <waldi> #topic manpages.git
20:05:43 <spwhitton> Given that debadmin manpower is fairly low, I would like to suggest that we unprotect the master branch of manpages.git rather than requiring MRs for documentation. As currently master is unprotected for website.git and ftp assistants often push changes.
20:07:53 <ta> how is it protected?
20:08:10 <spwhitton> ta: atm only debadmin can push to the master branch.
20:08:18 <spwhitton> It's a GitLab feature.
20:08:22 <ansgar> Oh, a meeting.
20:08:22 <waldi> ta: go to project -> settings -> repository -> protected branches
20:09:14 <ta> ah, there ...
20:10:07 * ScottK thinks spwhitton's proposal is sensible.
20:10:11 <ta> ansgar: is there a reason why only maintainers are allowed to push as opposed to website.git where maintainers and developers are allowed?
20:10:32 <waldi> ta: because that's the default setting of our gitlab isntance
20:10:33 <ansgar> ta: I think it might be the default? Not sure, but writing manpages is fine.
20:12:03 <ta> ok, so spwhitton have fun
20:12:17 <waldi> okay, next point
20:12:24 <waldi> #topic trainee recruitment
20:12:27 <waldi> spwhitton: please
20:12:54 <spwhitton> We have basically a single active trainee, and not many processing NEW, so I would like to suggest we send out another call for volunteers.
20:13:26 <spwhitton> I don't mind being the one to copy-and-paste lamby's e-mail.
20:14:19 <ta> spwhitton: do you also want to train the trainees?
20:15:11 <spwhitton> ta: I mean, in so far as that's a matter of reviewing their notes, then I see that as just part of working NEW.
20:15:59 <spwhitton> did you have something else in mind?
20:16:02 <ScottK> I think having one person be the lead for supervising trainees makes sense.
20:16:14 <ScottK> It gives focus.
20:16:42 <ScottK> Also, as the most recent trainee, I think you're in the best position to help new trainees work through issues. You just did it recently.
20:17:04 <spwhitton> On the other hand I am also the least experienced NEW reviewer :)
20:17:19 <spwhitton> But if others agree with ScottK then I would be okay to take on that role.
20:17:20 <ScottK> Yes, but you know enough to know when to ask questions.
20:17:39 <dwfreed> ^ that's the most important part
20:17:48 <ScottK> Also, in the last round, there was definitely a problem where notes went unreviewed for a long time.
20:20:14 <ScottK> Any objection to spwhitton sending out a call for volunteers?
20:20:26 <ta> not from my side
20:20:40 <spwhitton> Then, what about the idea of me taking the lead on supervising them?
20:21:02 * ta likes that idea
20:21:18 * ScottK too.
20:21:47 <waldi> sounds good
20:24:50 <waldi> do we have more stuff we need to talk about?
20:24:59 <ansgar> We should look at the OpenSSL foo
20:25:08 <ansgar> #924937
20:25:20 <ansgar> The list of blocks and affects is getting longer ;-)
20:25:22 <waldi> #topic OpenSSL license
20:26:12 <ansgar> I think we had mostly an agreement to do what Fedora does and just need to write something?
20:26:22 <ansgar> (Also for GCC runtime libraries and cups, not just openssl.)
20:26:31 <waldi> i haven't hear anything different
20:26:33 <spwhitton> Fedora considers openssl to be a system library, you mean?
20:26:39 <ansgar> spwhitton: Yes.
20:26:55 <ansgar> I asked the FSF about this ~1 year ago, but never got a reply.
20:26:56 <waldi> #agreed do what Fedora does with OpenSSL
20:27:13 <ScottK> Historically, I
20:27:15 <ScottK> Meh.
20:27:30 <ScottK> Historically, I thought this was a bad idea, but I've come around and think it's OK now.
20:27:55 <waldi> okay. who wants to write that?
20:29:30 * ScottK was about to suggest noes goes [1], but that's against current corona virus best practices. [1] https://en.wikipedia.org/wiki/Nose_goes
20:29:44 <ScottK> For some better spelling of nose.
20:30:48 <ScottK> ansgar: If you have some notes about GCC and CUPS, I don't mind doing an initial draft (I don't think I understand those as well as I understand openssl.
20:31:50 <ansgar> ScottK: It's basically the same: cups moved to Apache-2. GCC runtime is GPL-3-with-runtime-exception. Both have the same problem with GPL-2 as OpenSSL (well, different terms, but the same problem in prnciple)
20:33:20 <ScottK> Right, but what's the rationale for them being system libraries?
20:33:36 <ScottK> GCC I can see.
20:34:00 <ScottK> Lots of systems don't have CUPS and that's perfectly fine, so why is it a system library?
20:34:29 <ansgar> Either fundamental functionality (GCC runtime, OpenSSL these days as everything wants cryptography), interacting with basic system services (printer subsystem)
20:35:03 <ScottK> OK, so printing is a basic system service.
20:35:08 * ScottK can deal with that.
20:35:34 <ScottK> Thanks.
20:40:01 <waldi> okay. next point?
20:41:21 <waldi> #agreed consider OpenSSL, cups and libgcc as system libraries (re GPL-2)
20:49:09 <waldi> #topic anything else?
20:49:19 <ScottK> Not from me.
20:49:46 <ta> me neither
20:49:52 <waldi> thank you for your time
20:49:55 <waldi> #endmeeting