12:00:41 <Zhenech> #startmeeting
12:00:42 <MeetBot> Meeting started Sat Apr 30 12:00:41 2011 UTC. The chair is Zhenech. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:42 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:02:11 <kgoetz> oh no, meeting time -.-
12:02:17 <hansg> Hi all
12:02:40 <shevek> Hi
12:02:44 <thekittster> Hi
12:02:48 <ansgar> Hi :)
12:03:14 <Zhenech> aindilis, amoe ansgar captnfab chipi christoph Clint debfx ettin Goneri harrytuttle helmut JanC jandd jkirk Jon jordanm josef|rumba kandie kandie Marcon nozzy pdewacht pixie RainCT Rhonda RichiH rmayorga rudi_s sam shevek Soliton softcoder stump stevecotton SynrG tarzeau thekittster the-me Tolimar ansgar wRAR |Brad|_
12:03:19 <Zhenech> wake up
12:03:32 <Marcon> hi
12:03:33 <Zhenech> (i could swear there was a pingall command)
12:03:35 <kandie> hello
12:04:44 <kgoetz> :)
12:04:56 <Zhenech> does anyone has any extra topics for the agenda? (http://wiki.debian.org/Games/Meetings/2011-04-30)
12:04:57 <Marcon> sorry guys, i little busy now. have little problems with webhosting on my work :(
12:05:52 <Zhenech> seems noone? :)
12:05:54 <Zhenech> good
12:06:11 <Zhenech> anyone wants to introduce himself (as this point sliped last time)?
12:06:21 <the-me> Zhenech: building all packages with hardening-wrapper enabled?
12:06:32 * the-me currently implements it for all his packages
12:06:41 <kgoetz> building all packages from vcs for lintian tesitng purposes
12:06:56 <kgoetz> and getting all packages uploaded if newer in vcs
12:07:13 <kgoetz> don't know if htey fit in existing agenda item
12:07:23 <Zhenech> noted, we'll see :)
12:07:36 <Goneri> hi
12:07:37 <the-me> Zhenech: which one?
12:07:58 <Zhenech> the-me, all of them :)
12:08:03 <the-me> ;)
12:08:40 <Zhenech> #topic games and cross-distro collaboration
12:08:59 <Zhenech> hansg, you're the only one non-debian person in here as I can see
12:09:28 <Zhenech> it might be an indicator for bad collab as noone else joined :)
12:10:23 <Zhenech> the games@l.fd.o is rather dead too :(
12:11:23 <hansg> Zhenech, yes it is a sad affair
12:12:09 <hansg> It makes sense though, Fedora and Debian seem to be the only 2 distro's who really care about the capital F in Free Software, esp. when it comes to games
12:13:00 <kgoetz> hansg: i have to say, fedora have done great work when it comes to keeping the freedom of their distribution
12:13:07 <kgoetz> hansg: so thanks :)
12:13:18 <thekittster> there's another aspect to collaboration, which is sharing patches to games which are dead upstream but still appreciated
12:13:32 <hansg> And the Fedora Games SIG is a bit in a slumber modes lately. It are mostly dinosaurs like me who have been doing Fedora Packaging for ages, and they have gotten a lot of other things on their plates as time progresses. One of these days I need to kickstart the Games SIG in Fedora and get it going again
12:14:10 * RichiH opens an eye, tentatively
12:14:34 <hansg> thekittster, I completely agree, but with both games and non games packages I've more or less the same experience working together with Debian packagers works well, other less community oriented distro-s most people tend to be too busy with their own thing
12:14:50 <Zhenech> hansg, should we reping other distros again as we did at the start of cross-games?
12:15:33 <hansg> Zhenech, I think first we need a *plan*, with some concrete things / milestones to work on, and then ping other distros
12:15:35 <Zhenech> thekittster, that's where dep5 could help -- we should setup a patches index as ubuntu has on patches.ubuntu.com
12:16:01 <ansgar> Zhenech: patch-tracker.debian.org?
12:16:08 <Zhenech> oh we have, right :>
12:16:16 * hansg believes that for games with a dead upstream the solution is to form a new upstream
12:16:27 <thekittster> hansg, that is the ideal solution
12:16:28 <hansg> See my Fosdem talk on distro collab.
12:16:35 <thekittster> but it requires some dedicated enough ;-)
12:16:36 <Zhenech> hansg, that is what pabs intended to do iirc
12:16:47 <thekittster> s/some/someone/
12:17:18 <thekittster> hansg, is there a patch tracker for Fedora?
12:17:27 <hansg> thekittster, I know Guus and I seriously underestimated the amount of time it would take to get blobwars "non free" - free
12:18:02 <hansg> thekittster, what does a patch tracker for a distro exactly do ?
12:18:14 <hansg> IOW what information are you looking for
12:18:32 <Zhenech> #link http://patch-tracker.debian.org/email/pkg-games-devel@lists.alioth.debian.org
12:18:54 <RichiH> i think any patch tracker would need to _not_ have any distro in it's FQDN -- if people see it's on debian infra, they might think it's debian-centric
12:18:57 <Zhenech> ansgar, am I wrong or does it not show dep5 headers in the overview?
12:19:28 <thekittster> basically a list of patches applied to a distro's package (wrt. upstream) so they can easily be downloaded
12:20:07 <hansg> thekittster, I see, well given that Fedora always uses pristine upstream sources + patches, yes we do, ie:
12:20:08 <Zhenech> RichiH, depends, we can have non-debian specific patches in there too, but people have to know that
12:20:21 <shevek> thekittster: RichiH: That contradicts: if it's about patches used for a distro, it SHOULD have the distro in the name.
12:20:25 <hansg> http://pkgs.fedoraproject.org/gitweb/?p=freecol.git;a=tree
12:20:34 <RichiH> Zhenech: thing is, they will assume it's debian-specific
12:21:00 <ansgar> Zhenech: No, it just shows the filename.
12:21:01 <thekittster> hansg, thanks
12:21:08 <Zhenech> #idea general games overview page with *all* distros and *all* patches listed
12:21:09 <RichiH> hansg: hmm, how to rpms get generated? is it similar to how a debian/ directory works for .deb?
12:21:40 <hansg> I still vote for just creating a new upstream where necessary, and then invite other distro-s to join the new upstream
12:21:44 <shevek> What patches is this about anyway? Distro-specific patches should be handled per distro, and other patches should be integrated upstream. Why do we need another patch tracker? For upstreams which don't agree with us?
12:21:45 <RichiH> Zhenech: good idea, but people would need to patch cleanly and transparently
12:21:59 <Zhenech> RichiH, we do in debian :)
12:22:01 <thekittster> shevek, there's that, and cases where upstream no longer exists
12:22:21 <Zhenech> hansg, that very page will become upstream for dead upstream with time
12:22:26 <Zhenech> imgo
12:22:28 <Zhenech> imho
12:22:33 <thekittster> but I agree with hansg that it's better to create a new upstream (or adopt it, see sf.net's takeover procedure)
12:22:59 <hansg> Zhenech, no it will just be a collection of random patches, with multiple patches fixing the same issues, but differently enough to conflict, etc...
12:23:10 <thekittster> Zhenech, yes, but it's not quite the same having somewhere to accumulate patches, it's another to have properly managed releases
12:23:40 <hansg> Zhenech, I've gone through the process of collecting patches for $random-dead-upstream project in merging them into one several times, and it is not nice
12:23:47 <kandie_> can I join in with my problem?
12:24:13 <Zhenech> hansg, ok, I didnt, so you win :)
12:24:15 <RichiH> this idea might be, well, shit, but _if_ upstream is replaced, would it be an option to have branches master with vanilla, branch debian with debian-specific stuff, branch fedora with fedora-specific stuff, etc?
12:24:53 <RichiH> that way people could cherry-pick patches they want/need for their own distros and it would be easy to pick patches into master when they are globally useful
12:25:16 <shevek> Is there actually a reason to have distro-specific patches? Or is this about patches containing the packaging?
12:25:21 <RichiH> of course, this would mean some sort of access control so some random dude who joined last week does not clobber the master branch with crap
12:25:28 <thekittster> RIchiH, if upstream is replaced, it becomes new upstream and distro-specific patches can stay in the distro
12:25:34 <Zhenech> RichiH, might be an idea, yes
12:25:37 <thekittster> same as all other packages
12:26:09 <hansg> The goal would be to get rid of distro specific patches entirely :)
12:26:13 <Zhenech> shevek, sometimes yes, like we have boost1.46 in debian and packageA needs a patch to build with it, but no other distro has boost1.46 yet and it would ftbfs with that patch tehere
12:26:24 <Zhenech> but the goal is as hans writes
12:26:27 <RichiH> shevek: sometimes, you might want to factor out some library that's available, but $foo might keep it in the main tree as it does not have its own package for it
12:26:28 <shevek> Ah right
12:26:49 <RichiH> otoh, new "upstream" could simply fix this for everyone
12:27:22 <RichiH> by simply requiring an external lib and throwing out anything that's in the package's source
12:27:26 <shevek> Well, taking over upstream for a dead game is one thing, but also taking over the missing (for one distro) lib is a lot more work.
12:27:48 <Zhenech> we need to get to the next points somehow :)
12:27:49 <RichiH> there's that
12:28:20 <RichiH> another thing that could be done is to try and have a training session at conferences
12:28:32 <Zhenech> #idea central place for dead-upstream games where we become new upstream (together with Fedora)
12:28:52 <RichiH> 'game packaging for fun and profit' with subtitle: debian & fedora do it together and so should you
12:29:02 <Zhenech> #info need a list of dead upstream games and some kind of meter whether it should be taken over
12:29:22 <RichiH> opensuse and ubuntu would get the packaging more or less for free anyway
12:29:26 <Zhenech> (i dont not want to maintain yet another tetris because it was written)
12:29:48 <hansg> RichiH, right bundled libs are evil, if we do a new upstream we would simply remove them
12:30:11 <hansg> kandie_, the meeting has not started yet AFAIK, so feel free to throw your problem into the group
12:30:23 <Zhenech> hansg, the meeting did start at 1400 :)
12:31:38 <hansg> Zhenech, did it? I don't see anyone chairing it ...
12:31:45 <Zhenech> <
12:31:50 <Zhenech> #chair hansg
12:31:50 <MeetBot> Current chairs: Zhenech hansg
12:31:52 <Zhenech> :)
12:32:03 <hansg> Oh, missed that bit
12:32:14 <kandie_> hansg: very well, i released an open-source game called Vertigo a few weeks ago, and I was intending to license it under the ordinary GPL. however, pabs pointed out that i'm using assets which licenses do not comply with the GPL, and also suggested to replace them / get rid of them. What I'm wondering is, where does the licensing of my game stand? I know it can't get into the official repos, but can it still be effectively GPL-ed?
12:33:23 * SynrG blinks
12:33:24 <kandie_> also, I would like to suggest for someone to write a noob-friendly guide for us programmers who have no clue about legalities or licensing to just know up front what it takes to get into the repositories, because if I had found such a resource, I would've paid special attention to everything I ended up usign
12:33:29 <Zhenech> do we agree that this topic also covers point 3 of the agenda? freedesktop.org/games group
12:33:42 <shevek> kandie_: Hm, we should postpone that until after the meeting. You may want to contact the legal people about that, anyway.
12:33:45 <hansg> Erm, first of all IANAL, but Fedora's stance on this is that as long as resources can be replaced without requiring recompilation or some such (ie it is a picture which could be replaced with another picture by simply replacing a file) they are not bound by the GPL
12:33:59 <hansg> They should still be licensed under a Free software license though
12:34:21 <Zhenech> #idea info page for upstreams how to be a good upstream (there was something like that already)
12:34:42 <hansg> Anyways as Zhenech said, for the order of the meeting (which has already started my bad) it is best to park this till later
12:34:54 <kandie_> okay, thank you :)
12:35:11 <Zhenech> kandie_, just for you: http://wiki.debian.org/UpstreamGuide
12:35:32 <Zhenech> more for collab/deadupstream/something?
12:35:41 <kandie_> Zhenech: thanks, checking it out now
12:36:06 <hansg> Zhenech, wrt the current discussion also covering point 3, I agree
12:36:28 <Zhenech> #agree we did cover point 3 of the agenda already
12:36:42 <Zhenech> #topic pending, removed, orphaned, wnpp & suggested games
12:37:21 <RichiH> #help
12:37:27 <hansg> Zhenech, who not so fast, wrt more for collab/deadupstream/something? I was wondering if anyone actually has some ideas how to move forward with this with some concrete plans / milestones ?
12:37:38 <hansg> s/who/ho/
12:38:10 <shevek> I think the first thing we need is a list of which games this is about.
12:38:24 <shevek> Which may actually fit our new topic. :-)
12:38:36 <Zhenech> hansg, see shevek :)
12:38:40 <RichiH> from http://wiki.debian.org/MeetBot : #help - Add a "Call for Help" to the minutes. Use this command when you need to recruit someone to do a task. (Counter-intuitively, this doesn't provide help on the bot)
12:39:01 <RichiH> just to protocol that i didn't request help as in "put that into minutes"
12:39:59 <Zhenech> ok
12:40:28 <Zhenech> we have that suggested page in the wiki
12:40:49 <Zhenech> we should create a similar with packages that need love (like dead upstream)
12:40:55 <hansg> Ok, so as most of you know Guus Sliepen and I have replaced all non free contents of blobwars (all the sound effects + music) and formed a new upstream (working together with the original, next on our hit list is blobandconquer the sequel to blobwars, which needs new textures, music and sfx
12:41:21 <hansg> Note while at it we ofcourse also integrated all distro patches from various sources (including debian and Fedora)
12:41:30 <hansg> And did an actual new tarbal release ...
12:42:14 <hansg> Anyways I (and I believe Guus too) would like to do the same for blobandconquer. But we are both a bit short on time ...
12:42:43 <hansg> I can coordinate an effort like this, if we can get some volunteers. Sorry guess I'm making a mess of the meeting schedule now...
12:43:02 <shevek> hansg: I might be able to help for blobwars. I've done quite some work on it in the past already. blobandconquer is harder, because I don't have working 3d accellaration.
12:43:35 <Zhenech> hansg, just a short idea: ask phoronix.com for some publicity for that kind of stuff?
12:44:19 <hansg> Anyways to get things on topic, +1 for a wiki page listing games which could benefit from a new "distro-spawned" upstream
12:45:12 <hansg> Zhenech, that is actually a good idea. I've been planning on organizing a local hackfest to get some work done on blobandconquer, other could join in through the internet, and then some publicity would be good
12:46:01 <Zhenech> #action Zhenech would volunteer to clean up existing ITPs by pkg-games and look into games-related RFPs that are not yet listed in the wiki
12:46:18 <Zhenech> #action hansg does a blobandconquer hackfest, everyone welcome
12:46:39 <hansg> WRT wiki page listing games which could benefit from a new "distro-spawned" upstream, these are not necessary games with a dead upstream, in the case of the blob* upstream is still alive, ok with us taking over, but not interested in cleaning up the non free resources themselves
12:46:54 <SynrG> i wonder if something beyond just a wiki page might be possible, along the lines of debianart.org, pulling together a community of contributors to participate in projects like this (though arguably, the commitment required to be part of a new upstream is much greater than doing individual art projects)
12:47:07 <hansg> hehe, guess that one is pinned on me now, it was just a pipedream, but it is good to actually realize it :)
12:47:14 <SynrG> so not sure if it would work out so well
12:47:42 <Zhenech> SynrG, can you put something like this up?
12:47:43 <Zhenech> :)
12:48:07 <hansg> SynrG, I've tried using the Fedora art team for some resource replacements, with little success. Doing games sprites is not the same as a single logo, it requires a more concentrated and sustained effort
12:48:10 <SynrG> not really. are there any existing projects of this kind that would benefit from our participation?
12:48:19 <shevek> SynrG: Having free resources is very useful, but I've found that they need work before they can be used in a game.
12:48:24 * SynrG nods
12:48:47 <shevek> SynrG: So it's useful to have the artists work this way, but it's not a replacement for taking over upstream.
12:48:58 <SynrG> shevek: i cited debianart.org as a model ... not as a resource
12:49:38 <SynrG> it's a model community of participants (artists) contributing in a broad way towards various development efforts
12:49:57 <hansg> Funny debianart.org is almost the same sort of service as the Fedora art team
12:50:04 <SynrG> just wondering if there's anything with that kind of breadth out there for contributing to reviving dead upstreams
12:50:13 <SynrG> for games
12:50:30 <Zhenech> afaik not (yet)
12:50:45 <hansg> SynrG, not that I know of. There is this site hosting code from dead opensource projects in general, but is more of an archive (and I can't remember the name/url)
12:51:22 <Zhenech> #action Zhenech will try to get some kind of ping-bot for not-uploaded vcs-changes
12:52:33 <ansgar> Zhenech: What sort of ping bot?
12:52:37 <SynrG> of course, "reviving dead upstreams" sounds a bit unglamorous/negative. "renewing the classics" or something is a more positive spin
12:53:14 <Zhenech> ansgar, "you have version 2.2.1-2 in svn since 2 weeks, why not upload it" :)
12:53:24 <Zhenech> ansgar, I find myself often in that situation of just forgetting
12:53:31 <ansgar> Zhenech: PET for IRC? :)
12:53:34 <Zhenech> and no looking on PET does not help
12:53:36 <shevek> SynrG: I personally don't think we should hide the fact that upstream is dead, but that may be just me. :-)
12:53:39 <Zhenech> pet for irc/mail
12:53:56 <hansg> the linux game tome did use to have this game of the month thingie, which actually has spawn some interesting projects like supertuxkart (iirc). It could be interesting to try and get some sort of linux gaming website set up, where we spotlight a game each X weeks and then try to get a group of people to contribute it to bang it into shape. The effort in doing a new upstream usually is a large effort in the beginning and then a
12:53:57 <hansg> much smaller sustained effort as long as it is kept alive
12:54:28 <SynrG> shevek: it's not a matter of hiding ... it's just a matter of how you would define the goals of such a hypothetical community in positive terms.
12:54:53 <Zhenech> hansg, go for it and cound on me for hosting/coding if needed :)
12:55:16 <shevek> SynrG: Yes, I agree with that in principle, but "renewing the classics" sounds like we're going to rewrite games which existed on vintage hardware, which is not what this is about.
12:55:18 <hansg> shevek, wrt hiding that upstream is dead. We've 2 choices then, maintain the game ourselves (since compile will break with new compilers, new compilers /environment will uncover hidden bugs, etc. Or we drop it from our repos
12:55:20 <Zhenech> may we stop the dead-upstream issue now? :)
12:55:27 <SynrG> i think it's more likely you'll find and be able to integrate the efforts of existing game developers centered around concepts such as "classic games" ...
12:55:30 <SynrG> than "dead upstreams"
12:55:35 <hansg> Once we choice to maintain it doing a new upstream makes more sense then every distro for itself
12:55:53 <SynrG> shevek: ah, good point
12:55:58 <SynrG> well, just brainstorming :)
12:56:31 <Zhenech> #info hansg and Zhenech plan some sort of colab page that should push reviving old games
12:56:45 <Zhenech> and now STOP :)
12:56:58 <hansg> ok
12:57:20 <Zhenech> now inter-Debian cleanup of packages :)
12:57:45 <Zhenech> anyone ideas besides cleaning up wiki(suggested), itp/rfps?
12:58:05 <Zhenech> oh and punishing people as pabs did
12:58:14 <ansgar> What did he so?
12:58:27 <Zhenech> #action pabs (as he is not here) continues pinging people about bugs etc on irc, did help a lot
12:58:51 <Zhenech> ansgar, he pinged a person on irc when he saw him/her online about a bug or upload he/she did not do yet
12:59:26 <thekittster> one things we mentioned last time wrt all this is that it would be nice to have a team policy
12:59:27 <Zhenech> ansgar, like reminding me of uploading pokerth to unstable after release
12:59:36 <thekittster> so people know it's OK to go in and fix other team-members' packages
12:59:41 <thekittster> eg for FTBFSs
12:59:42 <Zhenech> ok
12:59:56 <Zhenech> for me, a team is a team
13:00:12 <Zhenech> everyone is free to upload my packages if the package benefits from it
13:00:27 <ansgar> For me, anybody in the team can change/upload my packages.
13:00:43 <thekittster> yes, most of us here probably share this opinion
13:00:56 <Zhenech> i'd prefer to be pinged about new upstreams, but wont kill anyone if not :)
13:00:57 <thekittster> I'm talking about making it official
13:01:37 <thekittster> there have been some heated exchanges in the past about changes made or packages being removed from team maintainership
13:01:54 <thekittster> also defining what's OK for another team-member to change
13:02:01 <Zhenech> #agree Uploads by people not in Uploaders are encouraged (dch --team helps here)!
13:02:04 <thekittster> eg. maybe not switching from cdbs to dh7 ;-)
13:02:35 <Zhenech> #info But please not change build-system, patch-system etc
13:03:20 <Zhenech> #info neither move svn→git without "owners" permission
13:03:23 <ansgar> IIRC we agreed last time that dh5 → dh7 (with dh $@) is okay.
13:05:00 <Zhenech> ansgar, also for non-owner uploads?
13:06:08 <shevek> It sounds good to me. If you're using debhelper, going to dh7 is a big improvement. Does anyone only want older versions of it?
13:06:51 <Zhenech> shevek, i have one package which wont be fun with dh7, but thats a different matter
13:07:15 <shevek> Zhenech: It may be hard to go there, but if someone wants to do it, will you have a problem with it?
13:07:16 <Zhenech> I have no problem in going dh5→7
13:07:34 <ansgar> Zhenech: I did understand it that way.
13:08:35 <Zhenech> shevek, in that particular case yes as I wont understand how it is built anymore :)
13:08:38 <kgoetz> sorry all, i have to crash. hardly here anyway. gl with the meeting, i'll read up in the morning
13:08:38 <Zhenech> on most other cases not
13:08:48 <Zhenech> n8 kgoetz
13:09:15 <RichiH> sorry, got called away
13:09:16 <Zhenech> shevek, in that package I build two flavours (qt and gtk) and thats hard with dh7
13:09:43 <RichiH> Zhenech: asking phoronix for anything other than dying a long and extremely painful death seems weird
13:09:54 <Zhenech> i'd agree on "if simple 'dh $@' would do, feel free to switch"
13:09:56 <shevek> Zhenech: Ah, ok. Should such a situation be documented in debian/rules or so, to make sure nobody tries to do it anyway?
13:10:41 <Zhenech> shevek, maybe it should, yes
13:10:56 <Zhenech> RichiH, we may have a different opinion on things here :)
13:11:44 <Zhenech> noone against dh7 in easy cases, right?
13:11:56 <shevek> Then I'd go for "if not documented otherwise in debian/rules, upgrading dh version is fine" even
13:12:14 <shevek> But that may be to radical for some. :-)
13:12:15 <RichiH> fwiw, i very much agree that team == team and anyone can upload anything
13:12:29 <shevek> s/to/too/
13:13:00 <RichiH> using latest dh by default makes sense, imo
13:13:11 <RichiH> Zhenech: that's fine ::)
13:13:22 <RichiH> aaaand current once again
13:13:25 <shevek> Well, probably you shouldn't upgrade further than the version in stable, to support backports.
13:13:40 <RichiH> shevek: good point
13:13:55 <ansgar> shevek: debhelper is usually available in backports.
13:14:30 <Zhenech> #agree Upgrading dh version is fine if it's easy (think dh $@) and not forbidden in debian/rules by a comment
13:14:45 <shevek> ansgar: Yes, but it would be nice if people have at least some chance at building the source from unstable with a stable system.
13:15:24 <thekittster> stable has dh8
13:15:27 <shevek> Yes
13:15:56 <shevek> Which is great, because I want overrides. :-)
13:16:16 <Zhenech> while at policies, sponsoring policy? :)
13:16:23 <thekittster> well even oldstable has dh7 with overrides (7.0.15)
13:16:41 <ansgar> I would like packages to use UNRELEASED/unstable in d/changelog as used by PET.
13:17:27 <ansgar> ie. UNRELEASED == package not ready for upload; unstable (or experimental), not-tagged: asking for upload.
13:17:41 <Zhenech> ansgar, even if I dont do this myself yet, agreed
13:18:12 <ansgar> Optional comments regarding the current upload in d/changelog (ie. feedback from sponsors).
13:18:17 <Zhenech> #info packages should use UNRELEASED/unstable in d/changelog as used by PET (ie. UNRELEASED == package not ready for upload; unstable (or experimental), not-tagged: asking for upload.)
13:18:30 <shevek> Is there documentation on how to sponsor a package from the games team? I find myself not even starting because I don't feel like finding out how to do it.
13:18:53 <ansgar> That scheme works very well in pkg-perl, although packages there are easier to review (they are quite small, but we have lots of them).
13:19:28 <Zhenech> shevek, not really, no
13:20:24 <Zhenech> shevek, basically if its an existing package: builds fine, starts fine, one level plays fine, lintian does not cry: upload
13:20:39 <Zhenech> shevek, for new packages (and maybe even new upstreams) copyright check
13:20:52 <Zhenech> thats what I do (when I do sponsoring which is rare)
13:20:59 <shevek> Zhenech: Yes, that's normal for sponsoring. But I mean how to tag it in the repository and such things.
13:21:18 <Zhenech> ah
13:21:40 <thekittster> there are detailed pages on the wiki for svn and git
13:21:51 <thekittster> http://wiki.debian.org/Games/VCS/git
13:21:52 <thekittster> http://wiki.debian.org/Games/VCS/svn
13:21:59 <thekittster> with tagging instructions
13:22:13 <ansgar> Oh, and in case it is not known yet:
13:22:24 <ansgar> #link http://pet.43-1.org/pkg-games/pet.cgi
13:22:43 <ansgar> Should be mostly up-to-date (new packages w/o commit hooks might be missing).
13:23:11 <Zhenech> ansgar, diff to http://pkg-games.alioth.debian.org/cgi-bin/PET/qareport.cgi?
13:23:27 <ansgar> Zhenech: It has Git. But misses some information for the templates.
13:23:36 <Zhenech> ah ok
13:23:55 <Zhenech> #link http://wiki.debian.org/Games/VCS/git
13:23:56 <Zhenech> #link http://wiki.debian.org/Games/VCS/svn
13:24:16 <Zhenech> shevek, do these help?
13:25:19 <shevek> Partly. They don't say what is the task of the sponsor. Does the sponsor tag, or is that up to the person creating the package?
13:25:49 <Zhenech> imho the one who does the upload, so the sponsor
13:25:58 <Zhenech> but we can agree on anything :)
13:26:27 <Zhenech> as the sponsor might change some minor glitch without poking the maintainer
13:26:59 <shevek> True. But if someone from outside the team sponsors, then obviously the maintainer tags.
13:27:36 <Zhenech> actually every dd has write access to every repo on alioth…
13:27:51 <Zhenech> but yes
13:28:14 <Zhenech> outside-sponsors will build from tarball, not from vcs in most cases anyway
13:28:59 <shevek> Right.
13:30:17 <Zhenech> #agree Sponsor tags upload in VCS (if he is part of pkg-games)
13:30:53 <Zhenech> #action Zhenech polishes the wiki with Team- and Sponsor-Policy as decided in the meeting
13:30:56 <ansgar> We should also try to get the current sponsoring queue empty. There are still some quite old uploads.
13:32:31 <Zhenech> right, maybe shevek wants to try? :)
13:33:15 <shevek> Sounds good. :-)
13:33:48 <Zhenech> #action shevek starts sponsoring
13:34:03 <Zhenech> (we wanted to end 35min ago XD)
13:35:02 <Zhenech> may I do "agreed we handled point 4 without setting #topic"
13:35:24 <ansgar> Sure :)
13:35:31 <Zhenech> #agreed we handled point 4 without setting #topic
13:35:55 <Zhenech> then there is that cleaning users/admins thingy on the agenda
13:36:17 <Zhenech> #topic cleaning old, adding new admins/users
13:36:35 <Zhenech> #info Tolimar wanted to step back as an admin
13:36:40 <Zhenech> anyone wants his place? :)
13:36:43 <ansgar> I noticed some people asked to join the group on LP.
13:36:59 <Zhenech> ew, that lp group, forgot about it :>
13:37:04 <ansgar> I suggest to reject them, referring them to the group on Alioth.
13:37:05 <Zhenech> shame on me
13:37:16 <ansgar> (when they are not members of pkg-games there)
13:38:07 <Zhenech> #action Zhenech cleans https://launchpad.net/~pkg-games/+members#proposed
13:38:10 <Zhenech> will do so
13:38:22 <ansgar> I can do so as well.
13:38:35 <Zhenech> #action ansgar will help
13:38:37 <Zhenech> :)
13:40:22 <Zhenech> #info Zhenech sent a ping to people who did not commit to svn/git since a longer time, no replies :(
13:40:57 <Zhenech> should we actively kick people out?
13:40:58 <shevek> I didn't see a ping
13:41:14 <shevek> And I definitely didn't do anything lately...
13:41:28 <Zhenech> shevek, should have gone to wijnen@alioth.debian.org
13:41:41 <Zhenech> 13.04.2011
13:41:47 <shevek> Hmm
13:43:38 <Zhenech> I will repeat it anways, so you have a chance :)
13:44:46 <shevek> We just decided I should start sponsoring so I will commit the tags. ;-)
13:45:20 <thekittster> I've got to go, see you another time
13:45:32 <Zhenech> shevek, :)
13:46:37 <Zhenech> as I see noone want to have Tolimars place?
13:48:05 <christoph> how many admins are still left then?
13:48:35 <Zhenech> Project Admins
13:48:36 <Zhenech> Alexander Reichle-Schmehl
13:48:36 <Zhenech> Barry deFreese
13:48:36 <Zhenech> Eddy Petrisor
13:48:36 <Zhenech> Evgeni Golov
13:48:38 <Zhenech> Evgeny Dolgikh
13:48:41 <Zhenech> Gerfried Fuchs
13:48:44 <Zhenech> Miriam Ruiz
13:48:45 <Zhenech> Paul Wise
13:48:48 <Zhenech> Samuel Hocevar
13:48:50 <Zhenech> Siegfried-Angel Gevatter Pujals
13:48:53 <Zhenech> enough
13:48:59 <christoph> jep that was the idea
13:50:30 <Zhenech> ok, Tolimar you are free then :)
13:51:15 <Marcon> They say "Freedom!!!"? :)
13:51:39 <Zhenech> moving to debconf?
13:53:13 <Zhenech> #topic debconf
13:53:32 <Zhenech> #idea meeting at debconf would be great
13:53:35 <ansgar> Who will be there?
13:53:37 <Zhenech> who will be there?
13:53:38 <Zhenech> <
13:53:51 <Fuddl> ← not sure ATM
13:54:02 <ansgar> I am almost convinced to go.
13:54:21 <shevek> I most likely will not.
13:54:48 * christoph probably
13:55:07 * Marcon cannot go to other country at this moment :(
13:56:12 <SynrG> not me. sorry
13:57:13 <Zhenech> i wonder if we should combine that with hansg idea about a talk on that matter
13:59:58 <hansg> Note I won't be present to give such a talk :)
14:01:00 <Zhenech> why not? :)
14:06:19 <hansg> Because I'm already travelling abroad 4-5 times this year for FOSS stuff, and my wife thinks that is enough. Now if you move debconf to the Netherlands, I'll happily attend :)
14:07:13 <Zhenech> bosnia isnt that far :)
14:09:10 <Zhenech> ok
14:09:47 <Zhenech> shall we note we want a meeting, and have yet to decide exacttly what and how?
14:11:01 <shevek> Sounds good to me.
14:11:25 <Zhenech> #info we want a meeting, and have yet to decide exacttly what and how
14:11:33 <Zhenech> i'd end this meeting here then?
14:11:38 <Zhenech> 2h11 is enough :)
14:14:00 <shevek> Indeed :-)
14:14:05 <Zhenech> #endmeeting