09:59:05 <arand> #startmeeting
09:59:05 <MeetBot> Meeting started Sat Nov 26 09:59:05 2011 UTC. The chair is arand. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:59:05 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
09:59:17 <sam> pabs: ah, thanks a lot
09:59:40 <arand> First off: Introductions
10:00:01 <benonsoftware> Hello all
10:00:08 <arand> #topic Introductions
10:00:32 <luk> hi everyone
10:00:40 <mase> hey
10:00:52 <BigMc> ho
10:01:06 <luk> I'm interested in QA and space issues of games
10:01:10 <pabs> I'm Paul Wise, in the team I mainly work on warzone2100 and some art games and reviving the team a bit
10:01:32 <arand> Hi all! My name is Martin Werner, I currently maintain AssaultCube and Lugaru, and I'll be the chair for this meeting.
10:01:48 <benonsoftware> Hi all, I'm Ben Donald-Wilson
10:02:22 <sam> I'm Sam Hocevar, and I wish I'd spend more time working on the team packages
10:02:24 * luk is Luk Claes btw
10:02:29 <mase> Hello! My name's Thomas Maass. I care about wiithon and speed-dreams.
10:02:31 <BigMc> I'm Tobias Hansen and I maintain sludge and bsnes
10:03:02 <rey_> I'm Peter De Wachter, and I maintain a bunch of shmups
10:03:15 <helmut> i'm Helmut Grohne only maintaining jugglemaster in here (which is not exactly a game imho)
10:03:43 <Marcon> Hi. My name is Yevgeniy Dolgikh. I'm not so long in team and now planing fix some lintian warnings in few poackages
10:04:01 <pabs> :D
10:04:08 <sam> I mostly maintain Abuse
10:05:02 <arand> Welcome everyone. :)
10:05:37 <luk> ansgar: are you not around?
10:06:21 <benonsoftware> I have to go now, (Long story)
10:06:28 <benonsoftware> I'll read the logs
10:06:48 <benonsoftware> email me at benny@touchlay.com if there is anything I can do
10:07:49 <arand> #topic Action items from last meeting
10:08:06 <arand> #info http://meetbot.debian.net/debian-games/2011/debian-games.2011-08-07-11.59.html
10:08:56 <arand> for #1 Rhonda does not seem to be around, so possibly defer this one?
10:09:13 <pabs> yeah
10:09:22 <arand> (Or maybe drop it completely, since it's been inactive a while)
10:09:39 <pabs> #info FHS/LSB infrastructure has been down due to the kernel.org intrusion, so pabs did not investigate lintian warnings about /usr/games
10:10:36 <arand> It's been started up now, but last time I checked there was just "Is this list still alive?" emails...
10:10:37 <luk> is this about writing a new lintian warning or what is this about?
10:11:27 <arand> pabs: Are the decision of deprecation given at this point?
10:11:50 <pabs> luk: #642767
10:12:14 <pabs> I don't think there has been any final decision yet
10:12:39 <arand> #info item #2, this is regarding the usegae of "games" in paths, for example /usr/lib/games instead of /usr/lib
10:13:26 <arand> #info the decision on depracation is not final
10:13:30 <pabs> SynrG: are you here?
10:13:43 <helmut> what would /usr/lib/games look like in the presence of multi-arch? would it be /usr/lib/$arch/games or /usr/lib/games/$arch?
10:15:05 <mase> yes, we should care about multiarch, since armel is coming up more and more.
10:16:08 <arand> I'm hesitant to delve too deep into this since it's not completely on the agenda.
10:16:36 <pabs> no games ship public libraries in /usr/lib/games so multi-arch is irrelevant there
10:16:52 * pabs votes for moving on
10:17:05 <helmut> pabs: thanks for the explanation. agreed.
10:17:19 <arand> Yes, since we have little info since last meeting anyways.
10:17:43 <BigMc> pabs +1
10:18:14 <arand> #info #3 commit acces to all DDs, alioth issues?
10:18:14 <Marcon> agreed with pabs
10:18:30 <arand> "nobody present can tell anything about the issue, apart from Clint who said that "there's also a group limit on alioth and not having to join another one helps not max that out", but SynrG's point to which I agree: "does anyone know if any DD has not contributed merely because they didn't have access by default?"
10:18:52 <arand> Do we know anything more on this one as of now?
10:19:08 <ol> fwiw, I would have committed a change yesterday
10:19:14 <ol> but pabs did it for me
10:19:31 <pabs> I guess we need to assign this task to someone, otherwise we will never know if there are any issues or not
10:19:42 <sam> what would be a reason not to allow it?
10:19:56 <ol> (I'm Olly Betts, and I maintain a discreet silence most of the time...)
10:20:19 <arand> I don
10:20:42 <arand> I don't see any particular cons with it.
10:21:08 <arand> I could take that on, if no one else wants?
10:21:23 <pabs> if there are any cons, I think we can deal with them when they happen
10:21:32 <pabs> sounds good
10:21:52 <arand> #action arand to contact alioth about giving all DDs commit acces.
10:22:19 <arand> for #4 is SynrG around, or anyone else know anything more about it?
10:22:42 <arand> #info #4 SynrG to talk to debian-women who have recently had a series of successful meetings to expand membership. looks like the meeting would be mostly social/indoctrination, not technical
10:23:17 <pabs> #link http://wiki.debian.org/IRC/debian-meeting
10:24:54 <arand> Anyone would want to take this on instead? Defer it?
10:25:11 <pabs> I don't see anything scheduled so I guess SynrG did not work on it
10:25:32 <pabs> I guess I could do it
10:25:44 <arand> Cool :)
10:26:12 <pabs> #action pabs to organise a games team public meeting with http://wiki.debian.org/IRC/debian-meeting
10:26:51 <arand> #info #5 next debian games meeting organizer should try to appoint a meeting with Pleft and let everyone choose time in there. on the next meeting we will all share our experience and decide if we are ready to move, or it's too early, or everybody hates Pleft
10:27:08 <pabs> :)
10:27:49 <arand> #info arand forgot to use pleft this time around, should be attempted next meeting
10:27:59 <luk> lol
10:28:03 <arand> #action next debian games meeting organizer should try to appoint a meeting with Pleft and let everyone choose time in there. on the next meeting we will all share our experience and decide if we are ready to move, or it's too early, or everybody hates Pleft
10:28:29 <arand> (Most emabarrasingly, I brought pleft up in the first place :/ )
10:29:06 <arand> #info #6 How to package a game if it depends on unstable/unreleased versions of non-standard libraries?
10:29:20 <arand> #info one should contact dependency devs and talk to them
10:29:54 <arand> Mayb I guess that no one was "one" for this? :D
10:30:14 <sam> this is a problem we'll run into more and more
10:30:15 <sam> it
10:30:27 <mase> that is no easy action some times. some devs are hard to contact.
10:30:38 <sam> it's not uncommon to fork game engines for a few features that render them binary incompatible
10:30:42 <luk> someone into packaging a CVS snapshot of fgfs-atlas to work with recent simgear-dev, btw?
10:30:43 <BigMc> I had this problem. i waited half a year or so for the next upstream release of the dependency, then pushed everything tinto Debian
10:31:20 <mase> atlas is broken with recent simgear.
10:31:24 <arand> So it's definitely something in need of attention, any takers for this?
10:31:34 <BigMc> Ah, you mean forked libraries? Never mind.
10:31:42 <luk> mase: yes, but not the one in upstream's vcs
10:31:57 <sam> (I work in the industry, and I don't think there's a single third-party framework that we haven't forked locally in a backward incompatible way)
10:32:51 <mase> luk: i use the upstream vcs, it does not build.
10:33:11 <pabs> what to do is different on a case-by-case basis, but poke upstream to make a release, switch Debian entirely to the snapshot or package the snapshot in a separate package
10:33:54 <helmut> I think the problem is more often than not rooted in the library upstreams. for instance i recently experienced that a stable release of pysnmp fails at the most simple example.
10:33:55 <luk> mase: pm please
10:34:03 <mase> what do you think about the development version of sdl-1.3? it seems to support opengles, which is important for the arm architecture?
10:34:22 <pabs> sam is working on sdl1.3 :D
10:34:26 <sam> mase: it can (and will) be installed side-by-side
10:34:28 <arand> I would be up for taking this one, (contancting devs and see what they think)
10:34:40 <pabs> sdl1.3 is also important for newer input devices, like touchscreens
10:34:42 <sam> mase: only the -dev cannot
10:35:08 <arand> #action arand to should contact dependency devs and talk to them about games depending on unstable/unreleased versions of non-standard libraries
10:35:21 <sam> but it will also mean duplicating all dependent libraries, eg. there'll be a sdl-image1.2 _and_ a sdl-image1.3
10:35:22 <pabs> arand: which devs?
10:35:45 <arand> I guess the action is partly to figure that out.
10:36:08 * pabs wonders what this action was about
10:36:29 <helmut> maybe someone with more insight could answer: do different games usually apply the same modifications to forked libraries?
10:36:56 <pabs> hi Fuddl
10:37:08 <Fuddl> hi pabs
10:37:14 <sam> helmut: not according to my personal observation
10:37:32 <arand> Fuddl: We're in the action items currently.
10:37:44 <sam> which admittedly is not very meaningful...
10:38:31 <arand> #7 seems to be done, and #8 got picked up by me.
10:38:46 <helmut> for instance the industrial linux forks seem to have duplicated their work in many places. so i was expecting something similar with library forks in games.
10:38:50 <sam> #8 is the same as #6, right?
10:39:29 <arand> sam: I think the debian live and non-standard libs, are supposed to be two topics, but got mangled up
10:39:33 <pabs> sam: you're looking at the summary rather than the action items, scroll down
10:39:41 <sam> oh okay
10:40:02 <arand> Anyhow, moving ont the next topic?
10:40:21 <sam> helmut: also, a problem is that more and more games and frameworks use C++ instead of C; in C it's easy to add a function without breaking anythin; in C++ you can't usually add a method to a class without breaking it
10:40:42 <arand> #topic
10:40:50 <arand> #topic New members, recruiting, advertising, experiences?
10:40:56 <arand> whoops :)
10:41:07 <helmut> sam: unless it is virtual, you can afaik.
10:41:37 <sam> helmut: the thing is, they're almost always virtual
10:41:43 <luk> not sure I would/should become a new member, though I would certainly commit to the vcs if DDs would have access :-)
10:42:19 <pabs> :D
10:42:35 <sam> that's definitely a vote in favour
10:42:40 <arand> Are there any new members atound?
10:43:05 <arand> Or looking-to-become?
10:43:11 <pabs> some ideas on this topic from one of our earlier meetings: http://meetbot.debian.net/debian-games/2011/debian-games.2011-03-18-21.09.html
10:43:36 <arand> #link http://meetbot.debian.net/debian-games/2011/debian-games.2011-03-18-21.09.html
10:43:59 <arand> (item #3)
10:44:23 <pabs> #info pabs and others did some watching various lists and handholding folks into the team. it worked well but required a lot of effort
10:45:09 <pabs> #info eventually I stopped doing it due to there being so many games RFS mails
10:45:45 <pabs> #info Zhenech did ping all inactive members of pkg-games but got no replies at all (IIRC)
10:45:48 <helmut> I tried to encourage Andrei Karas (manaplus).
10:47:02 <pabs> I would like to suggest that we swap the next meeting for one of these: wiki.debian.org/Games/Parties
10:47:11 <luk> +1
10:47:12 <mase> and how can i get rid of the -quest in my account? is there a pending time or something?
10:47:49 <arand> pabs: That sounds like an excellent idea!
10:48:17 <helmut> pabs++
10:48:25 <luk> mase: not sure, best ask the alioth admins. I myself had to join all the teams with my new login and afterwards request removal of the old one
10:48:38 <arand> #idea swap the next meeting for one of these: wiki.debian.org/Games/Parties
10:48:58 <pabs> anyone willing to organise a party instead of a meeting?
10:49:12 <arand> mase: http://wiki.debian.org/Alioth/FAQ#Why_do_I_have_a_.22-guest.22_suffix_on_my_account_.3F
10:49:39 <mase> thx for the info.
10:50:42 <helmut> should we decide on a party topic during this meeting already?
10:50:42 <luk> so when one gets a Debian login one has 2 logins... I thought you were talking about that aspect
10:52:18 <arand> I think it would be good to give some ideas for topics
10:52:55 <pabs> there are lots on the wiki page, but I would suggest screenshots as a first one
10:53:27 <arand> #idea Games Party topic: screenshots of games
10:53:41 <mase> i have a question about my maintained packages for speed-dreams. i will ask it later.
10:53:54 <luk> I hope noone minds if I focus on QA anyway regardless the official topic :-)
10:54:20 <arand> mase: There should be time for non-agenda after the meeting hopefully :)
10:54:42 <mase> pabs: i agree, screenshots are important for games.
10:55:26 <arand> U guess the general idea is to have a "theme" as just a source of inspiration :)
10:55:32 <arand> *I
10:55:51 <arand> So do we all seem to agree on screenshots?
10:56:02 <luk> right, I like the screenshots theme
10:56:09 <arand> And more importantly, any takers for organisig it?
10:58:13 * pabs notices the wind whistling through tumbleweed
10:58:24 <arand> Indeed :)
10:58:27 <sam> oh I thought I was just lagging
10:58:35 <mase> i suggest, the maintainers should take the screenshots of their packages.
10:59:14 <arand> Maybe we'll have to see if people who are not currently present would be interested.
10:59:27 <arand> Since we can't pin this one down right now.
10:59:45 <pabs> mase: parties aren't necessarily about getting things done, but about getting more folks involved
11:00:00 <pabs> take a closer look at the wiki page
11:00:32 <arand> #action ask around if anyone wants t organise a Debian Games Team screenshotting party.
11:01:04 * pabs nominates arand to organise it :)
11:02:17 <arand> I could always try, I guess
11:02:31 <pabs> :D
11:02:40 <arand> #action aand to organise a Debian Games Team screenshotting party.
11:02:52 * arand is easily persuaded
11:03:08 * pabs cackles evilly
11:03:25 <arand> Uhm, I wonder if it's possible to remove misspelled items...
11:03:40 * pabs doubts
11:03:55 <arand> Well, doesn't matter greatly though, anyhow.
11:04:15 <arand> Anything else in the recruiting, advertising area?
11:04:57 <arand> I was planning on trying to get some new-ish members input on how we're doing in those areas...
11:05:27 * luk thinks we should organise something on DebConf
11:05:58 <luk> and maybe also LCA or other conferences?
11:06:07 <sam> fosdem maybe?
11:06:39 <pabs> indeed
11:06:53 <arand> Who will be going to these? whence are they?
11:06:58 <pabs> I'm going to DebConf12 but not the others
11:07:14 <pabs> Kamping_Kaiser might be going to LCA, he lives not too far away
11:07:58 <luk> LCA is 16-21 January
11:07:59 <pabs> DebConf12 is in Nicaragua, LCA in Victoria, Australia, FOSDEM in Belgium IIRC
11:08:17 <luk> Fosdem is 5-6 February
11:09:21 <helmut> on the party: I would like to see forwarding (and reporting) bugs, because those little annoyances can remove all the fun from games.
11:11:03 <arand> luk: Do you have any suggestions for what should be organized at the confs?
11:12:03 <luk> talk/BOF/workshop/party are all fine, but I think we need to show people how fun Debian (games) can be ;-)
11:13:09 <arand> So organinsing a session of _playing_ games :) ?
11:13:24 <sam> there was a time when tetrinet was the #1 occupation of #debian-devel, maybe there are other games that could be hosted on debian.net where people could gather to have fun
11:15:01 <luk> there is a 'Open Source Game Development' developer room at Fosdem
11:15:07 <arand> #idea organise something for upcoming conferences talk/BOF/workshop/party, focus on games being FUN :)
11:15:13 <helmut> especially with multiplayer some games are forked or developed further in a way that using upstream version or even debian packages poses a severe disadvantage during gameplay.
11:16:14 <sam> manaplus? :)
11:16:15 <luk> https://lists.fosdem.org/pipermail/fosdem/2011-November/001345.html
11:16:30 <helmut> sam: that's not the only one.
11:16:41 <mase> helmut: you mean games, where the latest version is required to work properly in mp mode?
11:16:48 <luk> #link https://lists.fosdem.org/pipermail/fosdem/2011-November/001345.html
11:16:52 <pabs> #info there is a 'Open Source Game Development' developer room at Fosdem
11:17:04 <sam> some manaworld guilds even have their own fork :(
11:17:09 <helmut> mase: it is not technically required. older versions work, but they lack essential features.
11:17:30 <mase> for example pokerth?
11:17:47 <helmut> probably. I would expect some shooters, too.
11:18:00 <mase> i absolutely agree.
11:18:19 <arand> I'm tempted to move on..
11:18:33 <helmut> so if we want to concentrate on making playing fun, we need to target this aspect in some way.
11:18:48 <helmut> arand: ok
11:19:06 <arand> Seems like we've covered this topic to the extent of our ideas
11:19:23 <arand> (The conferences that is)
11:19:36 <arand> Unless someone else has more ideas?
11:20:18 <arand> #topic Wheezy Roadmap
11:20:30 <arand> #link ttp://meetbot.debian.net/debian-games/2011/debian-games.2011-03-18-21.09.html
11:20:40 <arand> #link http://meetbot.debian.net/debian-games/2011/debian-games.2011-03-18-21.09.html
11:20:55 <arand> (item #2)
11:21:27 <arand> Are therer any key things we would like to put as a DGT goal for wheezy?
11:21:43 <luk> DGT?
11:21:50 <luk> ah, team
11:22:09 <mase> we should make use of opengles for wheezy. otherwise debian could have a big disadvantage.
11:22:30 <luk> xz compression for data packages?
11:22:44 <arand> #idea Use opengles
11:22:48 <mase> sdl 1.3 is a important step for this. but the release will be in june afaik.
11:22:55 <arand> #idea xz compression
11:23:10 <pabs> mase: are there any open source games using opengl es? we already have OpenGL ES libs in Debian
11:23:39 <rey_> the new gdc compiler implements the D2 language rather than D1, so our D games will need porting
11:23:41 <mase> i know mame as the first one.
11:23:50 * luk has to go now, will be back later (probaby after the meeting)
11:24:01 <arand> luk: see you.
11:24:07 <sam> WebGL uses OpenGL ES
11:24:20 <mase> pabs: the libs are there, but nearly nothing makes use of them.
11:25:14 <helmut> [xz] is there any easily accesible or nicely compiled data on the disk usage or benefits already?
11:25:51 <ansgar> helmut: It shrink amd64+all from 27 GB to 21 GB (for squeeze)
11:26:10 <pabs> mase: the wheezy freeze is around June, so sdl1.3 might be too late
11:26:39 <pabs> rey_: any idea if the upstreams will be porting them, or is that completely up to us? how different are D1/D2?
11:26:52 <helmut> ansgar: thanks
11:27:08 <rey_> upstream hasn't touched the games in years, so I think we'll have to do it
11:27:08 <arand> #info SDL 1.3 around June may be too late for Wheezy
11:27:14 <rey_> but it's mostly keyword changes
11:27:28 <mase> pabs: that would be a big step behind other distros.
11:28:01 <sam> well we'll have an SDL 1.3 snapshot for sure
11:28:04 <pabs> are they already shipping sdl 1.3?
11:28:22 <rey_> can somebody point me to a sdl1.3 summary? I haven't heard of it before
11:28:41 <mase> not yet, but they surely will.
11:29:05 <mase> we should take the development snapshots, as they can coexist with 1.2.
11:29:23 <sam> sdl 1.3 is a cleaned up sdl 1.2, almost perfectly source-compatible, and with focus on newer OpenGL versions (GL 3.x, 4.x, OpenGL ES)
11:29:29 <mase> otherwise we will be about 2 years behind.
11:30:04 <sam> I'll probably upload it to experimental tonight :)
11:30:47 <pabs> maybe we can get upstream to release it before the freeze, anyone want to contact them?
11:31:08 <pabs> it would suck to ship an incompatible beta snapshot
11:31:09 <arand> Do we think we should be pushing for an unreleased SDL 1.3 as default in wheezy, or is the coexistence more appropriate?
11:31:11 <sam> SDL development activity has always be linked to Sam Lantinga's employment
11:31:29 <sam> he's currently got a job, so SDL is progressing slowly
11:31:34 <mase> i own a maemo phone and an arm netbook. there is NO point, where I can use gles. for example I have to use mame with software rendering, which makes is unusable.
11:32:10 <pabs> mase: you cannot use OpenGL ES on non-x86-based systems, there are no free drivers at all
11:32:28 <arand> So I'm guessing the June release date of 1.3 is quite flexible anyways? :)
11:32:37 <pabs> arand: IIRC 1.3 is mostly compatible with 1.2 so we could possibly switch entirely
11:32:51 <sam> arand: I honestly don't give that date much attention
11:32:56 <mase> pabs: as good as no free drivers.
11:33:03 <helmut> given what others said sticking with 1.2 sounds like the worst option.
11:33:20 <arand> pabs: Yes, I've gotten that impression as well.
11:33:46 <pabs> mase: unless you can hack into the systems of embedded GPU manufacturers and steal their documentation, that probably is not going to change in time for wheezy either
11:34:25 <arand> So 1.3 default for wheezy, even if that means using an unrelesed version, is this what we want?
11:34:27 <pabs> in any case, driver stuff is not games team responsibility, so I will be quiet now
11:34:39 <mase> I am watching projects, that want to port debian to mobile devices, mostly the arm architecture.
11:34:49 <arand> 1.3
11:35:05 <arand> ... has quite a lot with multitouch as well afaik
11:35:13 <sam> arand: I would find that acceptable, yes
11:35:13 <helmut> just for the numbers: sdl has 418 (binary) rdepends if i can count.
11:35:14 <mase> yes, the driver stuff is not the problem of debian-games.
11:35:18 * pabs points mase in the direction of #debian-mobile/#debian-arm
11:35:35 <SynrG> morning
11:35:38 <arand> Any objections otherwsie?
11:35:39 <sam> helmut: 1.3 won't replace 1.2, they'll coexist for at least one release
11:35:44 <SynrG> sorry, this is rather late for me ...
11:35:46 <arand> SynrG: Hia :)
11:36:04 <SynrG> er, i mean early
11:36:09 <SynrG> (and i'm late as a result)
11:36:20 <arand> SynrG: We're on the wheezy section atm.
11:36:38 <helmut> sam: even more reason to push
11:36:47 <sam> yes
11:37:28 <arand> sam: This would mean 1.3 as "default", and 1.2 coexisting
11:37:40 <pabs> so SDL 1.2, D 2, OpenGL ES driver stuff, anything else we want to complete before wheezy? maybe fixing our RC bugs ;)
11:37:52 <arand> :D
11:38:36 <arand> #agreed SDL 1.3 as default for Wheezy
11:38:47 <mase> also agree.
11:39:33 <BigMc> What about merging the SDL team into the games team? SDL isn't even out responsibility
11:39:38 <BigMc> right now ;)
11:39:56 <arand> That is true...
11:40:19 <pabs> BigMc: we missed our chance at that
11:40:33 <pabs> BigMc: see the recent thread
11:40:42 <arand> I think that's another topic, also ;)
11:40:42 <sam> I'd agree with that, but also there're new people on the SDL team now
11:41:07 <BigMc> Is someone from the SDL team here?
11:41:10 * sam
11:41:14 <BigMc> ok
11:42:03 <arand> pabs: I'm not sure if there's much more to say about RC bugs than "FIXEM!" ;)
11:42:09 <pabs> :)
11:42:21 <helmut> next weekend :-)
11:42:22 <sam> does anyone else hate their desktop's games menu?
11:42:34 <arand> Oh, yes.
11:42:47 <rey_> gnome 3 doesn't have menus :)
11:42:48 <pabs> sam: GNOME 3 one is nice, but the icons are ugly due to scaling
11:42:50 <sam> it's several screens high, and I can't find anything in there
11:42:58 <helmut> what is a menu? *g*
11:42:59 <sam> I use GNOME3 compat
11:44:02 <arand> #idea use gnome games menu sections
11:44:09 <Fuddl> it's even worse in gnome-shell - the users' don't get tooltips. so the only thing they see is the name of the game and no further information
11:44:37 <pabs> Fuddl: I guess that needs someone to file a bug upstream
11:45:01 <mase> yes, that is a gnome3 issue.
11:45:29 <Fuddl> I'd wait until I can see if gnome-shell 3.2 has some fixes. ATM we only have 3.0.something in sid
11:45:33 <pabs> sam: in fallback mode I see submenus, do you have none?
11:45:47 <sam> nope
11:46:25 <sam> what are those submenus? do they go by topic?
11:46:33 <pabs> IIRC they plan to delete fallback mode so not sure if its worth a bug for that
11:46:39 <rey_> are you talking about the debian menus or the xdg menus?
11:46:39 <pabs> yeah, same as GNOME 2
11:46:51 * pabs xdg
11:47:03 <sam> if they delete fallback mode I swear there's going to be some kind of bloodshed
11:47:14 <mase> IIRC they want to keep fallback mode for all gnome3 releases.
11:47:22 <rey_> because I believe the debian menu has an option to disable submenus
11:47:30 <arand> For the scaling in g-shell, I guess we need to supply appropriate icons, and bug upstream accordingly?
11:47:36 <sam> it's the xdg menu
11:48:11 <pabs> sam: https://lwn.net/Articles/465728/
11:48:20 <sam> the Debian menu has proper submenus for games, but in there most of the games don't have their proper icon
11:48:55 <pabs> sam: more specifically, https://lwn.net/Articles/465760/
11:49:05 <arand> Is this a result of an incorrect .desktop file?
11:49:19 <pabs> arand: indeed re icons
11:49:24 <sam> pabs: yes, I've read that, but I also read the rage in the comments
11:49:53 <RainCT> The xdg (gnome 2) menu shows subcategories (eg "Strategy" and stuff) when there's a lot of games in then.
11:50:00 <RainCT> *them (hi, btw :))
11:50:02 <pabs> sam: theres yr bloodshed :)
11:50:22 <arand> RainCT: Hello :)
11:51:22 <mase> gnome3 doesn't show submenus, neither normal nor fallback mode?
11:51:55 <pabs> #info GNOME 3 shell menu icons are ugly due to scaling, we need to create SVG or large PNG icons
11:51:56 <sam> my heart surgeon recommended I don't try normal GNOME 3
11:52:14 <RainCT> Normal doesn't, and even its (main) categories display sucks :P
11:52:36 <pabs> mase: gnome shell does not have menus, just a list of all apps, that can be filtered by search or by some top-level categories
11:53:29 <mase> I saw this on 3.0.2. that was the last version I tested.
11:53:49 <arand> #idea start a wiki page with the Wheezy roadmap
11:54:12 <arand> I'd be up for creating one with the items dicussed here.
11:54:36 * pabs notes the meeting is almost 3 hours long so far
11:54:39 <SynrG> can we return to #4 now that i'm here?
11:54:47 <sam> pabs: only 2!
11:55:05 <arand> #action arand to create a wiki page Games/Wheezy
11:55:53 <arand> SynrG: We are at #3 currently.
11:56:00 <SynrG> oh :)
11:56:01 <pabs> SynrG: I sent a mail about it just now: lists.debian.org/1322305038.11073.57.camel@chianamo
11:56:13 <SynrG> well, see http://paste.debian.net/147067/
11:56:22 <SynrG> i did take action. just didn't follow up :p
11:56:43 <pabs> ah :)
11:57:02 <pabs> would you volunteer to be a speaker in such a session?
11:57:03 <SynrG> and then we didn't have meetings in, like ... forever. and i totally forgot :/
11:57:24 <SynrG> i'll think about it
11:57:45 <arand> So, onto #4.
11:58:28 <arand> #topic Sponsorship
11:58:48 <arand> #idea Better integration debexpo <-> sponsors/queue (use reviews; make/request a "games" filter on debexpo?)
11:58:56 <arand> #idea Replace Games/Sponsor/Queue with PET?
11:59:49 <pabs> re debexpo, there was recently a call for contributions: http://lists.debian.org/4ECD5330.40104@toell.net
12:00:00 <arand> I was thinking that currently, a lot of what is done on the sponsors wiki page could probably be done via a search filter on debexpo ("mentors")
12:00:12 <pabs> so we would need someone with web development experience to help out on that
12:01:25 <arand> Or do we want to move away from that and only use PET?
12:02:30 <BigMc> Is pet supposed to be ready now? It shows wrong information on all my packages.
12:02:54 <pabs> it should be
12:03:32 <BigMc> ansgar: Did you see my mail? http://lists.alioth.debian.org/pipermail/pet-devel/2011-November/000136.html
12:04:31 <pabs> if they are in git, the hook might be missing or broken?
12:05:02 <BigMc> I doubt that being in the "ready to upload" section of pet will result in enough pressure for sponsors to upload.
12:05:20 <BigMc> That's how it is now.
12:05:47 <BigMc> We don't need to discuss the bug here further.
12:06:45 <arand> I would assume that if we only use pet, we'd need something else in conjunction, be it RFS or similar..
12:07:31 <arand> Since in my experience being passive whilst seeking sponsorship does not work very well.
12:07:49 <BigMc> Then we can as well keep the queue or why not?
12:08:57 <BigMc> That worked well for me, although it takes some time, because it seems goneri is the only one uploading packages from there regularly.
12:09:06 <arand> Yes, the queue seems to be working at least resonably.
12:10:24 <arand> If there's no strong opinions on this I'm tempted to race on?
12:10:44 <helmut> arand++
12:11:03 <arand> #info queue seems to work ok, no strong opinions on either idea
12:11:31 <arand> #topic PlayDeb
12:11:50 <arand> #idea Push new packages and package updates there?
12:11:57 <arand> #idea Integration of playdeb packages into Debian?
12:12:03 <arand> #idea Integration of playdeb people into DGT?
12:12:24 <pabs> #info pabs had success pushing one warzone2100 version into playdeb, but they still forked the package in unnecessary ways
12:13:09 <pabs> #info playdeb has some games that are not in Debian
12:13:17 <ansgar> What does playdeb give over official repositories?
12:14:13 <pabs> apart from the web interface, it builds each game for all (ubuntu) releases rather than just the in-development one
12:14:19 <arand> The main intent of PlayDeb i think is partly quick updates to new versions, and packaging of things with copyright which would not get into Debian/ubuntu
12:15:00 <pabs> sort of like backports.debian.org but automatic
12:15:23 <helmut> so, new versions could go to experimental, right? and things with copyright are for non-free. do i miss anything?
12:15:25 <ansgar> Ubuntu does have backports as well (similar to backports.d.o I think).
12:15:30 <arand> I'm not sure PlayDeb does automatic backporting.
12:15:56 <pabs> helmut: s/experimental/unstable/
12:16:30 * rey_ is afk
12:17:28 <arand> One thing I have noticed is that our versioning compared to PlayDeb is often a bit incompatible.
12:17:45 <pabs> one minor thing we could do is contact playdeb to ask them to provide packages built against Debian too
12:18:00 <pabs> would that be a good idea?
12:18:48 <arand> I have personally not had a package fail on that basis (though I've only tried a few installs PD->Debian)
12:20:28 <mase> pabs: do you think, they will make the effort?
12:20:53 <pabs> I have no idea, but no harm done if not
12:21:36 <mase> playdeb should be called playubu or something :)
12:22:13 * helmut still fails to understand what task {play,get}deb aim to solve.
12:22:34 <pabs> http://www.playdeb.net/about/
12:22:56 <pabs> #link http://www.playdeb.net/about/
12:23:58 <arand> helmut: afaik backports, quick updates, and packages that *works*, but may not be suited for deb/ubu for copyright/quality reasons.
12:24:18 <helmut> seriously sounds like duplicate effort to me. every single part of that agenda has a more general solution. but maybe that's just me.
12:24:59 <ansgar> No, I don't quite see the point as well. Most packages could probably be handled via backports.
12:25:38 <helmut> arand: so you suggest that we package low quality versions as well to upload them to playdeb?
12:25:46 <arand> I think a lot of it may be also not needing to wait for sponsorship..
12:25:58 <arand> helmut: I do not.
12:27:27 * helmut suggests to move on as there seems to be no consensus or obvious benefit on playdeb.
12:27:36 <arand> helmut: I'm just saying that that is the case, many of the PlayDeb packages could need a bit more work in order to conform to Debia Policy, afaik.
12:28:25 <pabs> playdeb is the last topic on the agenda unless someone has something else
12:29:20 <mase> only the replacement of torcs by speed-dreams, and the usage of qmc2 as a mame / mess frontend.
12:30:09 <arand> I think we might take that in post-meeting? Is that ok?
12:30:14 <mase> yes
12:30:35 <arand> #topic Next Meeting
12:30:57 <arand> With the planned party, do we also want a meeting?
12:31:32 <mase> i think yes.
12:32:27 <arand> i would agree, keeping go-throughs of action items etc. separate from a publicity event.
12:33:56 <arand> Meeting would thus need an organiser, prefereably someone who hasn't done a meeting in a while :)
12:36:13 * pabs notices tumbleweed again
12:37:06 <pabs> I guess we delay the next meeting again until someone steps up to organise it?
12:37:58 <SynrG> seems to be a pattern :/ sorry, i could barely make this one, so i'm reluctant to commit
12:38:09 <arand> I guess so,
12:38:52 <arand> please do mention it in order that people know we are looking. (Maybe add to channel topic or so?)
12:39:12 <pabs> sounds good
12:39:27 <pabs> we probably need an #info or #action in the meeting summary
12:39:40 <arand> #info no takers for organising the next meeting, keep a look out for anyone interested
12:40:13 <arand> So, if that is all?
12:40:13 <SynrG> oops, should i have had MeetBot change that?
12:40:29 <pabs> I guess we can close the meeting now
12:40:36 <arand> SynrG: Proably after MeetBot hacnges the topic back ;)
12:40:40 <SynrG> yes
12:40:44 <arand> #endmeeting