#debian-kernel Meeting

Meeting started by rperier at 18:33:28 UTC (full logs).

Meeting summary

    1. meeting agenda at https://salsa.debian.org/kernel-team/kernel-team/wikis/meetings (ana, 18:35:28)
    2. meeting agenda at https://salsa.debian.org/kernel-team/kernel-team/wikis/meetings (bwh, 18:37:44)

  1. Feedback from DebConf 18 (bwh, 18:37:52)
    1. ACTION: bwh to send list of interesting DebConf talks (bwh, 18:43:59)

  2. What is the focus for buster? what is the targeted version and features? (bwh, 18:44:40)
    1. AGREED: We will use Linux 4.19.y in buster (bwh, 18:48:58)
    2. ACTION: Corsac will review kconfig options for hardening (bwh, 18:52:34)
    3. ACTION: bwh to review kconfig options in general (bwh, 18:54:57)

  3. What is the state of the next (pending) stretch 9.6? Do we bump firmware-nonfree? (bwh, 18:58:33)
    1. ACTION: bwh to review MR for 4.9.130 in stretch (bwh, 19:00:07)
    2. https://www.openwall.com/lists/oss-security/2018/10/02/2 should probably first released as well as DSA, then mergend (carnil, 19:00:10)
    3. ACTION: bwh/carnil to upload linux to stretch (bwh, 19:00:29)
    4. ACTION: bwh to apply relevant security fixes to firmware-nonfree/stretch and upload (bwh, 19:04:35)
    5. https://security-tracker.debian.org/tracker/source-package/firmware-nonfree issues look bad indeed (Corsac, 19:04:56)

  4. Management of stretch-security and stretch-pu updates (timing, ABI bumps, changelogs...) (bwh, 19:11:34)
    1. ACTION: Team should rebase and upload to stable-pu at least once a month (bwh, 19:23:43)

  5. Can we improve handling of embargoed updates? (bwh, 19:34:53)
    1. https://oss-security.openwall.org/wiki/mailing-lists/distros#handling-of-embargoed-information (jcristau, 19:42:02)
    2. https://oss-security.openwall.org/wiki/mailing-lists/distros#handling-of-embargoed-information (Corsac, 19:42:11)
    3. ACTION: bwh to create Salsa group for embargoed updates (bwh, 19:46:43)

  6. Do we close old bugs for kernel < a specific version ? (for very old kernels) (bwh, 19:50:01)
    1. ACTION: rperier will triage older bugs (bwh, 19:54:43)

  7. Potential use of dgit & git-debrebase (bwh, 20:01:17)
    1. https://debconf18.debconf.org/talks/60-git-debrebase-new-tool-for-managing-debian-packaging-in-git/ (bwh, 20:06:03)
    2. https://salsa.debian.org/benh/linux/tree/use-dgit (bwh, 20:07:44)
    3. ACTION: bwh to create linux-with-dgit repo under kernel-team for team to experiment with (bwh, 20:16:14)
    4. ACTION: bwh to send mail to debian-kernel explaining workfow changes for linux-with-dgit repo (bwh, 20:16:30)

  8. Create a shared roadmap for the current development release that contains all the expected technical goals or actions to complete until the next release (in addition to existing opened bugs) (bwh, 20:17:34)
    1. ACTION: Corsac and waldi to create issues/milestones on Salsa for planned work (bwh, 20:27:23)


Meeting ended at 20:32:52 UTC (full logs).

Action items

  1. bwh to send list of interesting DebConf talks
  2. Corsac will review kconfig options for hardening
  3. bwh to review kconfig options in general
  4. bwh to review MR for 4.9.130 in stretch
  5. bwh/carnil to upload linux to stretch
  6. bwh to apply relevant security fixes to firmware-nonfree/stretch and upload
  7. Team should rebase and upload to stable-pu at least once a month
  8. bwh to create Salsa group for embargoed updates
  9. rperier will triage older bugs
  10. bwh to create linux-with-dgit repo under kernel-team for team to experiment with
  11. bwh to send mail to debian-kernel explaining workfow changes for linux-with-dgit repo
  12. Corsac and waldi to create issues/milestones on Salsa for planned work


Action items, by person

  1. bwh
    1. bwh to send list of interesting DebConf talks
    2. bwh to review kconfig options in general
    3. bwh to review MR for 4.9.130 in stretch
    4. bwh/carnil to upload linux to stretch
    5. bwh to apply relevant security fixes to firmware-nonfree/stretch and upload
    6. bwh to create Salsa group for embargoed updates
    7. bwh to create linux-with-dgit repo under kernel-team for team to experiment with
    8. bwh to send mail to debian-kernel explaining workfow changes for linux-with-dgit repo
  2. carnil
    1. bwh/carnil to upload linux to stretch
  3. Corsac
    1. Corsac will review kconfig options for hardening
    2. Corsac and waldi to create issues/milestones on Salsa for planned work
  4. rperier
    1. rperier will triage older bugs
  5. waldi
    1. Corsac and waldi to create issues/milestones on Salsa for planned work


People present (lines said)

  1. bwh (134)
  2. Corsac (70)
  3. waldi (38)
  4. rperier (34)
  5. carnil (21)
  6. jcristau (11)
  7. ukleinek (6)
  8. vagrantc (6)
  9. MeetBot (3)
  10. Mithrandir (2)
  11. ana (2)
  12. Cryptobytes (1)


Generated by MeetBot 0.1.4.