#debian-kernel Meeting

Meeting started by carnil at 19:00:16 UTC (full logs).

Meeting summary

  1. can we agree on trying to schedule regular team meetings every week (carnil, 19:03:16)
    1. My proposal here would be that we hold those meetings on every wednesday, 21:00 CEST/19:00 UTC trying to keep them focused on the most important bits and do not make them overlong (carnil, 19:04:13)
    2. AGREED: hold kernel-team meetings every week on wednesday 21:00 CEST/19:00 UTC (carnil, 19:06:51)

  2. recent open bugs / recently updated bugs (carnil, 19:07:39)
    1. ACTION: bwh will reply to #1071378 on the reporter performing the needed tests and eventually mark it moreinfo and unreproducible for now (carnil, 19:09:56)
    2. reproducer from the reporter is in message #40, did anyone tried to reproduce it with it? (carnil, 19:12:23)
    3. With respect to #1039883 the reporter provided a reproducer script in message https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1039883#40 where it is unclear is someone tried to reproduce it on their own as well (carnil, 19:15:46)
    4. ACTION: ema will try to reproduce #1039883 (ema, 19:16:08)
    5. ACTION: carnil will tag #1071378 moreinfo as we asked the reporter to bisect the issue and report upstream (carnil, 19:18:53)
    6. #1057282 is affecting ci.debian.net infrastructure, once updating the kernel on arm64 hosts. Ben asked Paul if more recent kernels fix the issue (carnil, 19:19:36)
    7. Paul Gevers has though a question back to us before trying that on ci.debian.net in https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1057282#42 (carnil, 19:20:10)
    8. summarizing question is if ith is worth knowing and put workload on the ci.debian.net maintainers (carnil, 19:20:42)
    9. ACTION: bwh to follow up to #1057282 (bwh, 19:25:52)
    10. #1072004 is actually affecting task for QA for the release, breaking autopkgtest for qemu jobs . We lowered the severity for now, but bluca is asking to make it actually RC to not let the version of linux migrate to testing (carnil, 19:27:34)
    11. if our understanding is correct the reproducing #1072004 is a matter of installing the kernel in a VM and use such a VM in autopkgtest with qemu backend with first verifying it is reproducible with a 6.8.y kernel (carnil, 19:43:43)
    12. ACTION: ema might have time to give it a try to reproduce the issue in the next few days (carnil, 19:44:10)
    13. ACTION: ema to try reproduce #1072004 with 6.8 and 6.9 as guest kernel in autopkgtest-virt-qemu (ema, 19:45:31)

  3. firmware-nonfree lacking behind upstream versions (carnil, 19:46:39)
    1. situation is rather unforunate for firmware-nofree . We lack behind several upstream version containing both security fixes and updates which have real impact for users with recent HW (carnil, 19:47:12)
    2. diederik did a lot of work rebasing the versions but the main problem is reviewing those MR and lacking of automatism (carnil, 19:47:32)
    3. bwh hopes to work on it "soon" but there cannot be a promise for it (carnil, 19:47:48)
    4. limiting factor for firmware-nonfree is right now rather reviewing the MRs by kernel-team maintainers (carnil, 19:56:05)
    5. some ifnormation we put in the package is quite useless (descriptions for firmware) as we do have automation for finding firmware packages relevant to present hardware (carnil, 19:56:39)
    6. ACTION: bwh to overhaul firmware logging patches (bwh, 20:00:50)
    7. next meeting will be On Wed. 5th June 21:00 CEST (carnil, 20:04:43)


Meeting ended at 20:05:06 UTC (full logs).

Action items

  1. bwh will reply to #1071378 on the reporter performing the needed tests and eventually mark it moreinfo and unreproducible for now
  2. ema will try to reproduce #1039883
  3. carnil will tag #1071378 moreinfo as we asked the reporter to bisect the issue and report upstream
  4. bwh to follow up to #1057282
  5. ema might have time to give it a try to reproduce the issue in the next few days
  6. ema to try reproduce #1072004 with 6.8 and 6.9 as guest kernel in autopkgtest-virt-qemu
  7. bwh to overhaul firmware logging patches


Action items, by person

  1. bwh
    1. bwh will reply to #1071378 on the reporter performing the needed tests and eventually mark it moreinfo and unreproducible for now
    2. bwh to follow up to #1057282
    3. bwh to overhaul firmware logging patches
  2. carnil
    1. carnil will tag #1071378 moreinfo as we asked the reporter to bisect the issue and report upstream
  3. ema
    1. ema will try to reproduce #1039883
    2. ema might have time to give it a try to reproduce the issue in the next few days
    3. ema to try reproduce #1072004 with 6.8 and 6.9 as guest kernel in autopkgtest-virt-qemu


People present (lines said)

  1. carnil (64)
  2. bwh (35)
  3. diederik (33)
  4. ema (13)
  5. waldi (8)
  6. MeetBot (2)
  7. bluca (2)
  8. daissi (2)


Generated by MeetBot 0.1.4.