#debian-kernel Meeting

Meeting started by carnil at 19:01:15 UTC (full logs).

Meeting summary

  1. Userspace use of linux-headers-* for bpftool export header (carnil, 19:03:46)
    1. AGREED: split out installing vmlinux.h header into a separate linux-bpf-dev package to address the problems from https://lists.debian.org/debian-kernel/2024/06/msg00228.html and #1064976 (carnil, 19:16:56)
    2. ACTION: bluca will create a MR implementing the discussed approach to split out the header into a new binary package linux-bpf-dev for review (carnil, 19:17:38)

  2. linux: ext4 corruption with symlinks (#1039883) (carnil, 19:19:13)
    1. ACTION: bwh to follow up patch for #1039883 upstream (bwh, 19:22:59)

  3. fat-modules: SD corruption upon opening file on Linux desktop (#1063754) (carnil, 19:24:13)
    1. ACTION: carnil will have another look through the bug log of #1063754, doublechecking with reporte that the reporte is not taking any action before/card removal before a sync happening (carnil, 19:36:08)

  4. linux-image-6.5.0-0.deb12.1-arm64: arm64 kernel upgrade makes systems unresponsive (#1057282) (carnil, 19:38:24)
    1. ACTION: ping Paul Gevers on the the question to perform again testing with recent unstable or backports kernel (carnil, 19:39:40)
    2. ACTION: carnil will ping Paul Gevers on the the question to perform again testing with recent unstable or backports kernel (carnil, 19:40:30)

  5. linux: D-I's X fails to start under kvm -vga qxl (#1075713) (carnil, 19:40:59)
    1. ACTION: bwh to investigate #1075713 (bwh, 19:42:45)

  6. Packaging: rebase master branch for 6.10-rcX (carnil, 19:43:13)


Meeting ended at 19:50:37 UTC (full logs).

Action items

  1. bluca will create a MR implementing the discussed approach to split out the header into a new binary package linux-bpf-dev for review
  2. bwh to follow up patch for #1039883 upstream
  3. carnil will have another look through the bug log of #1063754, doublechecking with reporte that the reporte is not taking any action before/card removal before a sync happening
  4. ping Paul Gevers on the the question to perform again testing with recent unstable or backports kernel
  5. carnil will ping Paul Gevers on the the question to perform again testing with recent unstable or backports kernel
  6. bwh to investigate #1075713


Action items, by person

  1. bluca
    1. bluca will create a MR implementing the discussed approach to split out the header into a new binary package linux-bpf-dev for review
  2. bwh
    1. bwh to follow up patch for #1039883 upstream
    2. bwh to investigate #1075713
  3. carnil
    1. carnil will have another look through the bug log of #1063754, doublechecking with reporte that the reporte is not taking any action before/card removal before a sync happening
    2. carnil will ping Paul Gevers on the the question to perform again testing with recent unstable or backports kernel


People present (lines said)

  1. carnil (60)
  2. bluca (26)
  3. bwh (25)
  4. waldi (9)
  5. iam_tj[m]1 (9)
  6. MeetBot (3)
  7. ukleinek (1)


Generated by MeetBot 0.1.4.