19:01:43 <carnil> #startmeeting
19:01:43 <MeetBot> Meeting started Wed Sep 25 19:01:43 2024 UTC.  The chair is carnil. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:43 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:02:05 <carnil> hello all, welcome to todays meeting
19:02:18 <bwh> Hello
19:02:22 <carnil> #chair bwh
19:02:22 <MeetBot> Current chairs: bwh carnil
19:03:04 <carnil> the plan for today is not very sofisticated, I was partially sick this week, and have not done much work on the claimed actions, but let's just start in the above section with the current list of bugs
19:03:28 <carnil> #topic #1063754 - fat-modules: SD corruption upon opening file on Linux desktop
19:03:47 <bwh> I am running a test for this, but I don't expect to replicate it
19:04:01 <carnil> bwh: IIRC, you had already started to draft a reply to the reporter correct?
19:04:14 <bwh> I don't think so
19:05:09 <bwh> So I will complete the test and then reply. A next step might be to ask for a disk image
19:05:19 <carnil> if you can run your test and not replicate it, I'm wondering how we could proceed.
19:05:25 <carnil> ok that is a way forward
19:05:58 <carnil> #action bwh will complete the test for the issue and reply to the reporter.
19:06:07 <carnil> okay with that?
19:06:42 <bwh> OK
19:07:05 <carnil> #topic #1076372 - Corruption of Longsys/Lexar NM790 NVMe drive with Linux 6.5+
19:07:27 <carnil> last meeting we decided to retitle the bug to match it more specifically to the drive, which bwh has done (thanks)
19:07:41 <carnil> just before the meeting I have replied again to Stefan to ask if he was able to do further tests
19:07:48 <bwh> So I see
19:08:05 <carnil> so we have so far no further actions here unless we can get this more input on the issue
19:08:08 <bwh> right
19:09:11 <carnil> so no action for this, but wait for the reply, I hope we get something back until the next meeting
19:09:30 <carnil> #topic #1082647 - copy_exec: [regression] ignores trailing slash, installs file as directory name
19:09:40 <carnil> this is already handled by you Ben
19:10:04 <carnil> would you mind summarizing: is the plan to restore the behaviour completely, that is as well for trixie?
19:10:31 <carnil> or "just" for stable, handling it as regression?
19:10:48 <bwh> I intend to restore and document the old behaviour, i.e. if the target argument ends with a slash then the source basename is appended to the target
19:11:13 <bwh> (and directories are created if necessary)
19:11:35 <carnil> #action bwh intends to restore and document the old behaviour for copy_exec (see bug log for details)
19:11:54 <carnil> bwh: so would you be fine if we update the metadata to reflect that the issue is as well present in the unstable version?
19:12:04 <bwh> yes
19:12:37 <carnil> #action Update bug metadata to reflect the issue is going to be handled as well in trixie/unstable
19:12:52 <carnil> thank you!
19:13:19 <carnil> #topic #1076483, #1081705 - Warning "scheduling while atomic" in intel_thermal driver with Linux 6.9+ and RT
19:13:39 <carnil> I hoped to have ukleinek here on board today as he submitted a patch relateting to the issue
19:14:17 <carnil> but that said, the reporter seems to have tested the patch (cf. #https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1076483#30) and still seems to be unhappy
19:15:01 <carnil> so maybe ukleinek has an idea how to further handle this specifically
19:16:07 <carnil> so maybe as action, ping ukleinek separately to check if he has time to further look into it
19:16:09 <bwh> Or one of the RT maintainers will reply
19:17:11 <carnil> so for the moment we let it go trough another round and re-check it at the next meeting latest
19:17:15 <bwh> OK
19:17:57 <carnil> #action carnil pings ukleinek to check with him on possible further investigation of the #1076483 bug. Otherwise wait for the RT maintainers to reply on the upstream thread
19:18:12 <carnil> #topic #1082081 - Performance issues on VM (virtio)
19:19:32 <carnil> This was on me as action as it affects the stable update. David (taffit) was able to do some further tests and we conclude for the moment that there is actually at least for their case at work not a performance regression. See message from today: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1082081#79
19:20:02 <carnil> but we are still waiting from the other reporters claiming there is a regression to test now as well the additional patch.
19:20:04 <bwh> And is that with the currently released kernel or with a pending patch?
19:20:32 <carnil> bwh: the other reporters running vm on a Nutanix hypervisor claim it is with the 6.1.106-3 update
19:21:10 <bwh> Sorry, my question was whether taffit's result is with the released kernel or with a pending patch
19:21:32 <bwh> It looks like he tested with a patch, but the other reporters have not tested that, right?
19:21:44 <carnil> ah sorry.
19:21:58 <carnil> yes the other reporters have not yet tested the additional patch and am waiting for feedback from them
19:22:25 <carnil> I have as well searched around in the regressions and stable list upstream, but have not found something related.
19:23:30 <bwh> I think your MR !1181 would include that patch, right?
19:24:13 <carnil> What I'm aiming to is to release 6.1.111-1 via bookworm-security, there were other virtio related changes in.
19:24:21 <carnil> bwh: yes that would be included
19:24:50 <bwh> OK, so I think there's no additional action needed for this bug, right?
19:25:11 <carnil> correct, sorry it was maybe a bit verbose but wanted to give a status update
19:25:17 <carnil> let's move on then
19:25:38 <carnil> #topic #1041484 - kernel: hpet_acpi_add: no address or irqs in _CRS
19:26:12 <carnil> AFAIU, with you bringing it as question to upstream, we are on hold?
19:26:16 <bwh> yes
19:26:28 <carnil> ok so no action, and wait
19:26:47 <carnil> #topic #1082001 - linux-image-6.1.0-25-amd64: TOMOYO LSM rejects execveat(AT_EMPTY_PATH) inside chroot
19:27:13 <carnil> samewise here, you investigated the issue, reporter should bring it to upstream
19:27:50 <carnil> I wonder if in this case if nothing happends for say 2 weeks, to close the bug. OTOH if the bug gets reported upstream then we can keep it with marking it forwrded upstream open
19:28:11 <carnil> the former is to not have lingering such bugs for too long in our BTS without actions
19:28:15 <bwh> I don't know
19:28:44 <carnil> but one action we can take here is to update the metadata as well as it affects as well trixie/unstable's kernel version
19:28:56 <bwh> yes
19:29:28 <carnil> #action update version metadata to reflect not only 6.1.y is affected, wait for repoter to make an upstream report
19:29:50 <carnil> #topic #1081833 - linux-image-6.1.0-25-amd64: regression on linux-image-6.1.0-25.amd64 regular cracks in HDMI sound during playback - 6.1.0-23 works.
19:30:03 <carnil> this was a sucessful bisect by the reporter
19:30:16 <carnil> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1081833#42
19:30:34 <bwh> Right
19:30:43 <carnil> claims to have bisected the change and isolated 478689b5990d ("ALSA: hda: Conditionally use snooping for AMD HDMI") as the culprit, which is HDMI related
19:31:01 <bwh> Are you OK to continue handling this bug?
19:31:12 <carnil> what is surprising is that the commit did fix
19:31:18 <carnil> Quote: the recent regression report revealed that the use of WC pages for AMD HDMI device together with AMD IOMMU leads to unexpected truncation or noises.
19:31:57 <carnil> bwh: yes I'm ok to handle it further but wanted to ask here in the meeting first if that might ring some bell to you
19:32:22 <carnil> otherwise I will just further handle it from here now and contact upstream including the people having touched the code in that commit
19:32:24 <bwh> From the commit message, this seems like phenomenology rather than anyone actually understanding the problem
19:32:57 <bwh> So, it wouldn't be that surprising that a "fix" for some cases breaks it in others
19:33:34 <carnil> Ok I will bring the issue upstream
19:33:56 <carnil> #action carnil brings #1081833 regression to upstream's attention
19:34:17 <carnil> #topic #1082611 - linux-headers-amd64-6.10 and linux-image-amd64-6.10 ?
19:34:46 <carnil> this is more a wishlist and tbh I would tend to say that we even could mark it wontfix
19:34:57 <bwh> I feel like we've seen a similar request before. I can look for that and merge it it's still open.
19:35:08 <bwh> I agree that it's wishlist and wontfix
19:35:29 <carnil> bwh: if you can take care of that and search for the other bug and merge them that would be great
19:35:40 <bwh> OK
19:35:53 <carnil> #action bwh looks for similar report to merge with #1082611
19:36:11 <carnil> there should be an agreed tag as well for meetbot to record that we think it's wontfix, right?
19:36:27 <bwh> yes
19:36:55 <carnil> #agreed #1082611 issue is wishlist and we tend to mark it wontfix (no change planned for implementing requested support)
19:37:33 <carnil> #topic #1081826 - linux-libc-dev ships header files not needed for 99% of it's users
19:37:48 <carnil> all actions are already taken, I think we have right now nothing to do further here
19:37:53 <bwh> right
19:38:02 <carnil> #topic #1082296 - linux [amd64]: Enable CONFIG_ADDRESS_MASKING
19:38:31 <bwh> There's an MR for this but CI failed, so I am ignoring it for now
19:38:33 <carnil> there is an existing merge request to handle #1082296, which we simply might need to act on for having it for trixie, so merged in at least maaster
19:39:04 <carnil> ah right, so Jair should first address that.
19:39:51 <carnil> but it is strange, looks the build job just either got stuck or runned into timeout, as there was no failure in the end of the log
19:40:10 <bwh> Yes I think it is just flakiness, not real breakage
19:40:19 <carnil> ok lets wait as you said
19:40:36 <carnil> #topic #1081836 -  linux-image-6.10.9-1-arm64: Please enable drivers for am64 hummingboard-t
19:40:40 <carnil> merge request exists for this one
19:41:12 <bwh> Yes, and needs rebasing as it cnflicts with my udeb changes
19:41:22 <carnil> (and can be handled while we review things for the next upload to experimental I guess, as there will be another one likely before we move 6.11.y to unstable)
19:41:44 <bwh> right
19:41:56 <carnil> #topic #894906 - linux-cpupower: provide a systemd service and a default config file
19:43:01 <carnil> waldi did respond to the bug (thanks!) but now federico still disagrees. I suggesst we leave it and see if Bastian has still energy to followup. If not in the end we are deciding if it is worth or not having those files in.
19:43:07 <carnil> i.e. no action for now
19:43:14 <bwh> I agree
19:43:40 <carnil> As we are already out of time soon, before coming to AOB a question
19:43:53 <carnil> #topic Move 6.11.y to unstable?
19:44:28 <carnil> we have suceeding builds for all release architectures: https://buildd.debian.org/status/package.php?p=linux&suite=experimental
19:44:42 <carnil> usually we wait a bit for uploading to unstable before moving a new version to it
19:44:54 <bwh> I think we should have at least one more upload to experimental
19:45:08 <carnil> bug our aim is (I hope we agree) to get 6.12. ready for trixie
19:45:15 <carnil> ok this answers I guess my question
19:45:40 <carnil> then we do at least one other update to experimental and make the way free for 6.12-rcX only afterwards in experimnental
19:45:59 <bwh> Right
19:46:24 <carnil> #topic AOB?
19:46:48 <carnil> Any other things to discuss today?
19:47:01 <bwh> Nothing from me
19:47:06 <carnil> ok :)
19:47:32 <carnil> then who is chair'ing the next meeting. Are you taking it as we do not know if Bastian is available?
19:47:56 <bwh> I should be available next week, so yes
19:48:25 <carnil> Thank you!
19:48:44 <carnil> Then I guess we are done for today, thanks Ben for all the input and updates!
19:48:54 <bwh> Thank you for chairing
19:49:01 <carnil> #endmeeting