19:01:09 <waldi> #startmeeting
19:01:09 <MeetBot> Meeting started Wed Oct  9 19:01:09 2024 UTC.  The chair is waldi. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:09 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:01:24 <bwh> Hi
19:01:32 <waldi> #chair bwh carnil
19:01:32 <MeetBot> Current chairs: bwh carnil waldi
19:02:40 <waldi> i think carnil said he is absent
19:02:53 <bwh> Right
19:04:20 <waldi> and i don't have much time today. what are the most pressing matters?
19:05:10 <bwh> firmware-realtek file conflict (#1084791)
19:05:22 <waldi> #topic #1084820, #1084791
19:05:49 <bwh> I wasn't aware of this other package (obviously)
19:05:57 <waldi> right. this file was recently added to firmware-realtek and previously shipped by something else
19:06:49 <bwh> I'm thinking the other package should go away *if* all its firmware is in linux-firmware.git
19:07:00 <waldi> yes
19:07:26 <bwh> otherwise, we need to figure out who ships what
19:07:33 <waldi> it oly contains those two mentioned files
19:07:51 <bwh> OK, I hadn't got as far as the file list
19:08:24 <bwh> #action bwh will propose removal of firmware-realtek-rtl8723cs-bt and add necessary conflicts/replaces in firmware-realtek
19:08:34 <waldi> thx
19:08:42 <waldi> #topic #1064795 - iproute2: installs same filename to both bin and sbin
19:09:09 <waldi> bluca again. in debian no merge of bin and sbin is planned, so this is no problem
19:09:20 <bwh> Yes, I don't see why this is 'important'
19:10:06 <bwh> For now, ip needs to be in both places to avoid breakage
19:11:12 <bwh> I would also like to discuss #1084232 briefly
19:11:42 <waldi> any action? close the bug report, because it is bogus at the given state?
19:13:09 <waldi> okay, no right now
19:13:16 <waldi> #topic #1084232
19:13:17 <bwh> Well there is a general problem that we are failing to manage space in /boot in a sensible way
19:13:30 <waldi> yes
19:14:03 <bwh> So I think in the longer term we need to have a discussion involving kernel, boot loader, and initramfs-builder maintainers about how to do that better
19:14:40 <waldi> i have something for that, but don't manage to write it down for discussion
19:14:50 <bwh> This just got worse due to GPU firmware getting larger and larger (for both amdgpu and nouveau/nvidia)
19:15:28 <bwh> but I wonder if there's anything we can do in the short term to make this less of a pain point for trixie
19:16:16 <bwh> Any ideas?
19:16:28 <waldi> low space mode where such firmware must not be included
19:17:03 <bwh> Then we run the risk of those drivers going into a broken state
19:17:25 <waldi> we can boot until after the initramfs with the efi console
19:18:18 <bwh> Maybe? But that may not work well with multi-head
19:18:44 <waldi> it is a fallback scenario
19:18:46 <bwh> But we could maybe talk to the plymouth maintainers about changing what drivers it includes
19:20:19 <bwh> #action bwh will start discussion with plymouth maintainers about conditional inclusion of graphics drivers in initramfs
19:21:54 <bwh> OK. then there's !1159
19:22:38 <waldi> #topic !1159
19:23:36 <bwh> There is some discussion of templating there which I hoped you would comment on. And then later I realised it probably would make sense to use Jinja2 here rather than extending our own template system.
19:25:51 <waldi> this is not backward compatible, aka we need to raise the interface version (an interface that is not versioned at all right now)
19:27:41 <bwh> Do you mean that packages installing hooks wouldn't be able to rely on this?
19:28:16 <bwh> If we implement this before trixie then other packages could rely on it post-trixie
19:31:04 <waldi> and "make deb-pkg" also relies on it
19:31:43 <bwh> Yeah...
19:32:54 <bwh> OK, so this MR has a number of problems :-)
19:32:59 <bwh> Please do comment on it
19:33:13 <waldi> #action waldi to comment on !1159
19:33:39 <waldi> #topic AOB
19:33:48 <waldi> anything else?
19:33:57 <bwh> There is the uggrade to 6.12 (!1232)
19:34:09 <bwh> Do you want to look at that or shall I go ahead and merge it?
19:35:04 <waldi> done
19:35:07 <KGB> 03linux 05master 06Bastian Blank * [merge] merge request !1232: Update to 6.12-rc2 * 14https://salsa.debian.org/kernel-team/linux/-/merge_requests/1232
19:35:08 <KGB> 03linux 05master 78c8af8 06Ben Hutchings 10debian/ 10(12 files in 7 dirs) * Update to 6.12-rc2 * 14https://salsa.debian.org/kernel-team/linux/-/commit/78c8af8
19:35:08 <KGB> 03linux 05master ded5a7a 06Ben Hutchings 10debian/ 10(106 files in 2 dirs) * [rt] Update to 6.12-rc1-rt2 * 14https://salsa.debian.org/kernel-team/linux/-/commit/ded5a7a
19:35:08 <KGB> 03linux 05master 3a17dcb 06Ben Hutchings 10debian/ 10changelog 10rules.d/certs/Makefile * d/rules.d/certs: Add newly required include directory to CPPFLAGS * 14https://salsa.debian.org/kernel-team/linux/-/commit/3a17dcb
19:35:13 <KGB> 03linux 05master e696894 06Ben Hutchings 10debian/ 10changelog 10libcpupower1.symbols * libcpupower: Update symbols file for change in 6.12 * 14https://salsa.debian.org/kernel-team/linux/-/commit/e696894
19:35:17 <KGB> 03linux 05master 367fda9 06Ben Hutchings 10debian/ 10(7 files in 6 dirs) * d/config: Update with the help of kconfigeditor2 * 14https://salsa.debian.org/kernel-team/linux/-/commit/367fda9
19:35:20 <KGB> 03linux 05master c0069ea 06Bastian Blank 10debian/ 10(125 files in 14 dirs) * Merge branch 'update-6.12' into 'master' * 14https://salsa.debian.org/kernel-team/linux/-/commit/c0069ea
19:35:44 <waldi> i did not manage to announce the branch stuff yet, i hope to get this done until the weekend
19:35:45 <bwh> :-)
19:35:50 <bwh> Thanks
19:35:55 <waldi> will you chair next weeks meeting?
19:36:03 <bwh> OK
19:36:06 <waldi> thx
19:36:23 <waldi> sorry for cutting this short
19:36:26 <waldi> #endmeeting