#debian-kernel Meeting

Meeting started by carnil at 19:00:36 UTC (full logs).

Meeting summary

  1. kconfigeditor2: Incorrectly places CONFIG_PREEMPT_RT=y outside "choice: Preemption Model" (carnil, 19:02:03)
    1. https://salsa.debian.org/kernel-team/kernel-team/-/issues/6 (carnil, 19:02:29)
    2. ACTION: ukleinek looks into https://salsa.debian.org/kernel-team/kernel-team/-/issues/6 (ukleinek, 19:08:41)

  2. #1063754 fat-modules: SD corruption upon opening file on Linux desktop (carnil, 19:08:47)
  3. #1076372 Corruption of Longsys/Lexar NM790 NVMe drive with Linux 6.5+ (carnil, 19:12:04)
    1. ACTION: carnil closes the bug #1076372 with explanations that is seems quite likely to be firmware/hardware bug and that it can be reopened later in case of further information from reporter (carnil, 19:14:09)

  4. #1085425 linux-image-6.10.12-riscv64: dwmmc_starfive causes filesystem corruption on emmc (carnil, 19:14:29)
    1. ACTION: aurel32 prepares revert of offending commit introducing #1085425 to be included in next unstable upload (carnil, 19:22:58)

  5. #1084791, #1084820 firmware-realtek has an undeclared file conflict (carnil, 19:23:45)
    1. ACTION: bwh will upload firmware-nonfree to fix file conflicts (bwh, 19:24:41)

  6. #1085387 iwlwifi: wifi does not work at startup, starts working after 2-3 reboots and then works fine (carnil, 19:25:23)
    1. ACTION: ukleinek will ask for more details for #1085387 and tag + moreinfo the bug (carnil, 19:27:56)

  7. #1033058 Booting mini.iso : kernel hangs on ppc64el (carnil, 19:28:19)
    1. ACTION: bwh will move new problem reported on #1033058 to a new bug report (bwh, 19:31:59)

  8. #1084180 linux-image-6.1.0-26-amd64: Fails to boot. Kernel panic. (carnil, 19:32:53)
    1. ACTION: carnil follows up on replies in #1084180 (carnil, 19:33:23)

  9. #1085177 linux-image-6.11.2-amd64: kworker/0:0+events spin causes high (>1) cpu load due to qxl_fence_wait (carnil, 19:33:52)
  10. #1085762 linux-image-6.1.0-26-amd64: Random crashes during pbuilder compile runs (carnil, 19:40:36)
    1. ACTION: bwh will ask for more info (affected arch, kernel log, etc.) on #1085762 (bwh, 19:47:31)

  11. #1085160 linux-sysctl-defaults: apply setting after installation (carnil, 19:47:48)
  12. https://salsa.debian.org/kernel-team/linux/-/merge_requests/1242 config: Enable LAZY_RCU (carnil, 19:48:51)
  13. https://salsa.debian.org/kernel-team/linux/-/merge_requests/1233 d/config: enable IPE LSM (carnil, 19:54:51)
    1. ACTION: ukleinek can have deeper ook at MR!1234 and either approve or directly merge (carnil, 19:55:58)

  14. AoB (carnil, 19:56:07)
    1. ACTION: waldi takes care of chair'ing the next team meeting (carnil, 20:02:47)


Meeting ended at 20:03:11 UTC (full logs).

Action items

  1. ukleinek looks into https://salsa.debian.org/kernel-team/kernel-team/-/issues/6
  2. carnil closes the bug #1076372 with explanations that is seems quite likely to be firmware/hardware bug and that it can be reopened later in case of further information from reporter
  3. aurel32 prepares revert of offending commit introducing #1085425 to be included in next unstable upload
  4. bwh will upload firmware-nonfree to fix file conflicts
  5. ukleinek will ask for more details for #1085387 and tag + moreinfo the bug
  6. bwh will move new problem reported on #1033058 to a new bug report
  7. carnil follows up on replies in #1084180
  8. bwh will ask for more info (affected arch, kernel log, etc.) on #1085762
  9. ukleinek can have deeper ook at MR!1234 and either approve or directly merge
  10. waldi takes care of chair'ing the next team meeting


Action items, by person

  1. aurel32
    1. aurel32 prepares revert of offending commit introducing #1085425 to be included in next unstable upload
  2. bwh
    1. bwh will upload firmware-nonfree to fix file conflicts
    2. bwh will move new problem reported on #1033058 to a new bug report
    3. bwh will ask for more info (affected arch, kernel log, etc.) on #1085762
  3. carnil
    1. carnil closes the bug #1076372 with explanations that is seems quite likely to be firmware/hardware bug and that it can be reopened later in case of further information from reporter
    2. carnil follows up on replies in #1084180
  4. ukleinek
    1. ukleinek looks into https://salsa.debian.org/kernel-team/kernel-team/-/issues/6
    2. ukleinek will ask for more details for #1085387 and tag + moreinfo the bug
    3. ukleinek can have deeper ook at MR!1234 and either approve or directly merge
  5. waldi
    1. waldi takes care of chair'ing the next team meeting


People present (lines said)

  1. carnil (75)
  2. bwh (45)
  3. ukleinek (20)
  4. waldi (15)
  5. aurel32 (11)
  6. ema (4)
  7. MeetBot (3)
  8. iam_tj[m]1 (2)


Generated by MeetBot 0.1.4.