#debian-kernel Meeting

Meeting started by bwh at 19:00:28 UTC (full logs).

Meeting summary

  1. Bug #1118100: linux: FTBFS on 'all' buildd: Could not import extension kernel_include (exception: No module named 'docutils.utils.error_reporting') (bwh, 19:02:52)
    1. AGREED: carnil will upload 6.16.12-2 to unstable once we are confident that there isn't further breakage from the temporary linux-libc-dev removal (bwh, 19:07:47)

  2. #1112627: linux-image-6.16.3+deb14-amd64: Intel audio no longer works: DMAR: [DMA Write NO_PASID] Request device [00:1b.0] ... non-zero reserved fields in PTE (bwh, 19:10:28)
    1. ACTION: carnil will ask to test #1112627 on the upstream kernel with IOMMU explicitly enabled (bwh, 19:15:26)

  3. #1114557: linux-image-6.12.43+deb13-amd64: Jieli touchscreen and stylus no longer supported (bwh, 19:15:45)
  4. #1114884: linux-image-6.1.0-39-amd64: AMD Ryzen 9 7950X, linux-image-6.1.0-39-amd64 hangs on boot while 6.1.0-37-amd64 works fine (bwh, 19:18:18)
  5. #1117672: Debian trixie 13.1: Orangepi5b plus] linux-image-6.12.48+deb13-arm64: NVMe and PCIe issues (bwh, 19:19:09)
    1. ACTION: waldi to take at the device tree and kernel config in #1117672 (waldi, 19:25:31)
    2. ACTION: waldi will investigate broken DT seen in #1117672 (bwh, 19:25:31)

  6. #1111011: RTL8125D - link drops (bwh, 19:25:53)
    1. ACTION: bwh will ask reporter of #1111011 to check EEE status in the broken and working configs (bwh, 19:28:52)

  7. #1116067: linux-image-6.1.0-32-amd64: btrfs compression quietly stopped around 60TB in (bwh, 19:29:08)
  8. #1116358: linux-image-6.12.48+deb13-amd64: LVM snapshots causing I/O errors in KVM guest with aio=io_uring set (bwh, 19:31:17)
    1. ACTION: carnil will ask reporter to test the patch for #1116358 (bwh, 19:33:45)

  9. #1117002: linux-image-6.12.48+deb13-amd64: warning in arch/x86/kernel/cpu/cpuid-deps.c:117 do_clear_cpu_cap on Intel Atom N450 (bwh, 19:33:58)
    1. ACTION: carnil forwards #1117002 report to upstream (carnil, 19:36:43)

  10. #1117256: linux-image-6.12.48+deb13-amd64: Kernel can no longer activate ethernet on Dell WD19S docking station (bwh, 19:36:59)
  11. #1117567: Held Package Still Updating (bwh, 19:37:58)
  12. #1117599: linux-image-6.16.9+deb14-amd64: GPU hangs three times after starting chromium (bwh, 19:40:57)
  13. #1117848: linux-image-6.12.48+deb13-amd64: After a few hours of desktop operation under kde the amdgpu driver crashes (bwh, 19:52:55)
    1. ACTION: bwh will follow up #1117848, ask for more info about suggested workaround, and forward (bwh, 20:00:39)

  14. #1117959: ipv6_route flags RTF_ADDRCONF and RTF_PREFIX_RT are not cleared when static on-link routes are added during IPv6 address configuration (bwh, 20:00:59)
  15. #1118025: USB mouse stops working after suspend on Debian 13 (usbhid error -71) (bwh, 20:01:51)
    1. ACTION: waldi will follow up #1118025 (bwh, 20:07:17)

  16. #1117674: Please enable udebs for the 6.1 backport (bwh, 20:07:25)
  17. #1111052: Please increase default UDP receive buffer size (rmem_max) (bwh, 20:10:00)
  18. Migration excuses (bwh, 20:12:59)
  19. New upstream versions (bwh, 20:14:09)
    1. ACTION: kathara will update firmware-nonfree to upstream 20251011 (bwh, 20:16:01)
    2. ACTION: kathara will update ktls-utils to 1.3.0-rc1 (bwh, 20:17:27)
    3. ACTION: bwh will update wireless-regdb to 2025.10.07 (bwh, 20:17:41)

  20. Merge requests (bwh, 20:17:57)
  21. AOB (bwh, 20:20:27)


Meeting ended at 20:23:57 UTC (full logs).

Action items

  1. carnil will ask to test #1112627 on the upstream kernel with IOMMU explicitly enabled
  2. waldi to take at the device tree and kernel config in #1117672
  3. waldi will investigate broken DT seen in #1117672
  4. bwh will ask reporter of #1111011 to check EEE status in the broken and working configs
  5. carnil will ask reporter to test the patch for #1116358
  6. carnil forwards #1117002 report to upstream
  7. bwh will follow up #1117848, ask for more info about suggested workaround, and forward
  8. waldi will follow up #1118025
  9. kathara will update firmware-nonfree to upstream 20251011
  10. kathara will update ktls-utils to 1.3.0-rc1
  11. bwh will update wireless-regdb to 2025.10.07


Action items, by person

  1. bwh
    1. bwh will ask reporter of #1111011 to check EEE status in the broken and working configs
    2. bwh will follow up #1117848, ask for more info about suggested workaround, and forward
    3. bwh will update wireless-regdb to 2025.10.07
  2. carnil
    1. carnil will ask to test #1112627 on the upstream kernel with IOMMU explicitly enabled
    2. carnil will ask reporter to test the patch for #1116358
    3. carnil forwards #1117002 report to upstream
  3. kathara
    1. kathara will update firmware-nonfree to upstream 20251011
    2. kathara will update ktls-utils to 1.3.0-rc1
  4. waldi
    1. waldi to take at the device tree and kernel config in #1117672
    2. waldi will investigate broken DT seen in #1117672
    3. waldi will follow up #1118025


People present (lines said)

  1. bwh (104)
  2. carnil (39)
  3. waldi (31)
  4. kathara (4)
  5. MeetBot (2)


Generated by MeetBot 0.1.4.