20:00:04 <ukleinek> #startmeeting
20:00:04 <MeetBot> Meeting started Wed Nov 12 20:00:04 2025 UTC.  The chair is ukleinek. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:04 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:00:17 <carnil> hi
20:00:18 <ukleinek> #chair carnil ukleinek
20:00:18 <MeetBot> Current chairs: carnil ukleinek
20:00:52 <ukleinek> ok, anthing before tackling the bug list?
20:00:58 <carnil> no
20:01:03 <ukleinek> #topic #1120534
20:01:34 <ukleinek> tagged moreinfo, waiting
20:01:38 <carnil> thanks for adding more questions!
20:01:46 <ukleinek> #topic #1112627
20:02:19 <ukleinek> IMHO disabling the iommu is a good enough work around.
20:03:07 <carnil> I would like to hear from the reporter if he has usecases to use IOMMU, but given he asked when to enable VT-d I guess there are none with the current setup. So as you say, just let him use the workaround
20:03:07 <ukleinek> I don't remember the exact details, but I think it's not feasible to make the kernel autodetect something here and disable the iommu without a kernel parameter
20:03:55 * ukleinek had to disable the iommu on his last laptop, too.
20:03:56 <carnil> I can take an action to ask back on the qemu question, and then propose to use the workaround (IOMMU disabled either via intel_iommu=off or disable VT-d in BIOS)
20:04:34 <ukleinek> #action carnil proposes to keep iommu disabled without further action for #1112627
20:04:40 <ukleinek> #topic #1114884
20:05:33 <ukleinek> #action ukleinek retitles #1114884 to make the subject match the problem
20:06:23 <ukleinek> Otherwise I'm out of ideas. Failing modeswitch probably?
20:07:01 <carnil> the last followup mail from today indicates there is a behaviour change from 6.1.0-37-amd64 -> 6.1.0-39-amd64 would it be worth asking for bisecting to isolate the commit which causes the behaviour change to better undertand what the problem could be?
20:07:16 <ukleinek> the reporter could try to unbind+bind the graphics driver
20:08:45 <ukleinek> There are two graphics cards, one amdgpu and one ast
20:09:17 <ukleinek> #action ukleinek follows up on #1114884, asks for a bisect and explains how to reload the drivers
20:09:25 <ukleinek> #topic #1118437
20:09:48 <carnil> wait here
20:09:53 * ukleinek nods
20:09:57 <ukleinek> #topic #1118762
20:10:44 <ukleinek> It's on us to review the logs that the reporter sent, right?
20:11:23 <carnil> yes
20:11:58 <ukleinek> and also waiting on upstream to reply carnil's mail?
20:13:30 <ukleinek> carnil: do you continue working on that bug?
20:14:22 <ukleinek> ah it was bwh who provided the patch and thus is probably more into that bug
20:15:02 <carnil> I will go through the logs and see if i get an idea
20:15:06 <carnil> are we talking about the same?
20:15:44 <ukleinek> oh no, we don't. off-by-one in my browser tabs
20:16:17 <ukleinek> #action carnil looks into the logs provided in #1118762
20:16:22 <ukleinek> #topic #1120554
20:17:13 <ukleinek> timeout on probe of the sound driver. I suggest letting the reporter try the sid kernel and depending on the outcome take it upstream
20:17:18 <carnil> ukleinek: wondering, is the needed firmware installed?
20:17:37 <carnil> I guess it is firmware-sof-signed?
20:18:35 <ukleinek> "- firmware-sof-signed package: (check version with: dpkg -l | grep firmware-sof)"
20:19:12 <carnil> yes was asking because of that line, which is not clear
20:19:44 <ukleinek> #action ukleinek contacts reporter of #1120554, asks if firmware is installed and a newer kernel can be tested
20:19:53 <ukleinek> #topic #1116251
20:20:17 <ukleinek> bdrung didn't reply to my feedback, so wait
20:20:24 <carnil> ok
20:20:29 <ukleinek> #topic #1117959
20:20:57 <carnil> there was finaly a reply from upstream on netdev, confirming it is a bug.
20:21:04 <ukleinek> ack for waiting until the dust settles upstream
20:21:11 <carnil> as described Fernando Fernandez Mancera working on a fix upstream, so wait this to land
20:21:23 <ukleinek> #topic #1118349
20:22:30 <carnil> ah there are new replies, from Christian König asking for bisecting
20:22:48 <ukleinek> the reporter is a bit confused, not sure if he is capable to do a git bisect
20:23:10 <ukleinek> #action ukleinek follows up on #1118349
20:23:11 <carnil> right the last mail does not really answer Christian's question
20:23:16 <carnil> thanks
20:23:27 <ukleinek> #topic #1119093
20:23:43 <ukleinek> wait
20:23:49 <carnil> yes
20:23:53 <ukleinek> #topic #1120058
20:24:09 <ukleinek> also wait (kernel log, test on 6.17)
20:24:19 <ukleinek> #topic #1120277
20:24:23 <carnil> same, no reply from reporter for more information
20:24:37 <ukleinek> #topic #1120280
20:25:32 <ukleinek> I think "stack guard page was hit" (in the absence of an attack) means deep function nesting?!
20:26:15 <ukleinek> I asked in #linux-rt (where many x86 maintainers hang around)
20:26:38 <ukleinek> 1762947048       bpetkov: see the big comment around arch/x86/kernel/traps.c:573
20:26:56 <ukleinek> I read that once, but failed to understand it
20:28:42 <ukleinek> Does early_xen_iret_patch appearing in the call trace mean that xen is in use?
20:29:17 <ukleinek> we need someone who understands more about x86 than /me
20:30:01 <ukleinek> mXodprobe.blacklist=amdgpu memmap=524288K!8388608K on the command line looks strange?!
20:30:41 <ukleinek> module list includes `vhba(OE)`
20:30:55 <carnil> would it be worth forward this to upstream mailinglist to see if that rings a bell?
20:31:10 <carnil> what is that?
20:31:47 <carnil> vhba-dkms - VHBA virtual host bus adapter module
20:32:10 <ukleinek> This is VHBA (Virtual SCSI Host Bus adapter), a Linux kernel module which acts as a low-level SCSI driver and which provides the SCSI layer with a virtual SCSI adapter which can have multiple virtual devices. It is part of the userspace-cdemu suite, a free GPL CD/DVD-ROM device emulator for linux.This is VHBA (Virtual SCSI Host Bus adapter), a Linux kernel module which acts as a low-level SCSI
20:32:16 <ukleinek> driver and which provides the SCSI layer with a virtual SCSI adapter which can have multiple virtual devices. It is part of the userspace-cdemu suite, a free GPL CD/DVD-ROM device emulator for linux.
20:33:18 <ukleinek> Ok, before taking this upstream, ask the reporter about their usage of virtualisation and if this reproduces without vhba
20:33:53 <carnil> ukleinek: that soulds good
20:34:23 <ukleinek> ✂️
20:35:18 <ukleinek> #action ukleinek asks reporter of #1120280 if the problem is reproducible without xen(?) and/or vhba
20:35:25 <ukleinek> #topic #1120479
20:36:08 <ukleinek> carnil: thanks for the hint about the overlap with #1115613
20:36:39 <carnil> I thnk with the minimal confing change confirmed we can prepare a MR for debian/latest
20:37:04 <ukleinek> Or amend it into !1650
20:37:14 <carnil> and then ask as well Dennis van Dok if that might as well in that case
20:37:29 <carnil> I can take an action to expand the required config change and ask for testing to both again
20:37:57 <carnil> ok for me on ammending it into !1650
20:38:17 <ukleinek> #action carnil works on #1120479 (in combination to #1115613 and !1650)
20:38:23 <ukleinek> #topic #1115613
20:38:59 <ukleinek> oh, my script to prepare the #topic commands was tricked
20:39:02 <ukleinek> #topic #1119957
20:39:57 <ukleinek> maybe another duplicate of #1115613?
20:40:17 <carnil> IIRC, was that this one where Ben wanted to ask upstream for firmware inclusion?
20:40:24 <ukleinek> oh, wrong tab again
20:40:50 <ukleinek> ah, that makes sense, yes
20:41:01 <carnil> we had last time in the minutes:
20:41:03 <carnil> @benh will try to find the firmware (commit author, maintainer)
20:41:20 <carnil> I would say (and guess bwh will agree) that we can keep the assignment for the action
20:41:37 <ukleinek> #topic #1120421
20:42:09 <carnil> bwh wanted to ask waldi if the change was intended, and if yes, then adapt wireless-regdb accordingly
20:42:25 <ukleinek> elbrus claims (and I didn't check) that this blocks linux migration, so this is kinda urgent?!
20:44:00 <ukleinek> ok, let's hope waldi is well again soon
20:44:02 <carnil> yes our 6.17.y cannot migrate to testing right now and superseed the 6.16.y one, but we can live as well little bit longer yet with the situation if we prefer to leave it to ben for looking into wireless-regdb
20:44:16 <carnil> I would say to wait a few days
20:44:24 <ukleinek> #AoB
20:44:35 <ukleinek> #topic AoB
20:44:49 <carnil> it would be actually nice to migrate before uploading 6.17.8 (which is a big one) but it is okayish
20:44:54 <carnil> ok changed topic :)
20:45:31 * ukleinek looks into the wide audience for volunteers for chairing next week.
20:46:20 <carnil> no nothing else from me, about chairing the meeting I would prefer to not prepare the next one (not because of jitsi, but because I do not yet know how my wednesday will look like from workplace toward afternoon)
20:46:44 <carnil> but as we are only we to, I guess I have to bite the bullet if we want to alternate
20:46:50 <ukleinek> It would be waldi's turn. I'll do the fallback
20:46:58 <carnil> ok
20:47:12 <ukleinek> #endmeeting