#debian-kernel Meeting

Meeting started by carnil at 20:00:01 UTC (full logs).

Meeting summary

  1. Removal of iptables-legacy (carnil, 20:02:52)
    1. https://lists.debian.org/debian-devel/2025/11/msg00303.html (carnil, 20:07:44)
    2. ACTION: waldi rechecks all candidates and then fills bugs for the iptables-legacy removal (carnil, 20:09:56)

  2. #1105211: mt7921e: stuck at low transmit power (carnil, 20:11:46)
  3. #1106558: linux-image-6.12.22+bpo-amd64: Wifi module fails to load (carnil, 20:12:55)
  4. #1116554: linux-image-6.12.43+deb12-amd64: hard freeze during normal operation with stacktraces in the syslog (carnil, 20:13:24)
  5. #1116643: UBSAN: shift-out-of-bounds in .../drivers/gpu/drm/display/drm_dp_mst_topology.c (shift exponent -1) (carnil, 20:14:21)
    1. ACTION: ukleinek looks at #1116643 (ukleinek, 20:15:46)

  6. #1118437: linux-image-6.17.2-amd64: kernel crash in interrupt after receiving an ip packet on veth from xsk from user space (carnil, 20:16:06)
  7. #1120554: linux-image-6.12.48+deb13-amd64: SOF driver fails on Intel Comet Lake - CSE_IPC_RESET_PHASE_1 timeout (carnil, 20:17:09)
    1. ACTION: bwh will add firmware-sof-signed and other firmware packages to Package-Status field of the reportbug control file (bwh, 20:19:17)

  8. #1120598: nfs: ls input/output error ("NFS: readdir(/) returns -5") on krb5 NFSv4 client using SHA2 (carnil, 20:23:29)
  9. #1120602: hyper-v: BUG: kernel NULL pointer dereference, address: 00000000000000a0 (carnil, 20:24:57)
  10. #1120718: linux-image-6.12.43+deb13-amd64: hung tasks on mutex acquisition during rtnetlink ops (carnil, 20:27:27)
  11. #1121006: linux: reported optimal_io_size from mpt3sas devices results in 4GB raid10 optimal_io_size (carnil, 20:31:38)
  12. #1121227: linux-image-6.12.48+deb13-amd64: Black screen with Nouveau TRAP_PROP [RT-FAULT] on NVIDIA GT 230M (GT216M) (carnil, 20:35:39)
    1. ACTION: ukleinek tries to handhold for #1121227 (ukleinek, 20:39:40)

  13. #1100105: linux-image-amd64: Issues with Framework audio module (carnil, 20:40:18)
    1. ACTION: bwh will forward #1100105 upstream (bwh, 20:44:53)

  14. #1116251: linux-image-6.12.48+deb13-rpi: Raspberry Pi Zero W does not boot (carnil, 20:45:21)
    1. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1116251#42 (carnil, 20:46:02)

  15. #1117959: ipv6_route flags RTF_ADDRCONF and RTF_PREFIX_RT are not cleared when static on-link routes are added during IPv6 address configuration (carnil, 20:49:17)
  16. #1118349: Hanging the radeon video on AMD APU, reopening #879992 (carnil, 20:49:57)
  17. #1119093: linux-image-6.16.3+deb13-amd64: UBSAN array-index-out-of-bounds in ath5k driver (carnil, 20:50:43)
  18. #1120280: linux-image-6.12.57+deb13-amd64-unsigned: BUG: ENTRY_TRAMPOLINE stack guard page was hit at (maybe related with usage of make --load-average) (carnil, 20:51:25)
  19. #1120854: linux-image-arm64: Enable dma engine for Renesas RZ platform (carnil, 20:51:54)
    1. https://salsa.debian.org/kernel-team/linux/-/merge_requests/1720 (carnil, 20:52:11)
    2. ACTION: bwh reviews MR (!1720) for #1120854 (carnil, 20:53:00)

  20. #1121032: thunderbolt_net: missing ndo_set_mac_address prevents bonding mode 802.3ad (carnil, 20:53:23)
  21. #1121211: UBSAN: array-index-out-of-bounds in /build/reproducible-path/linux-6.17.8/drivers/clk/samsung/clk-exynos-clkout.c:178:18 (carnil, 20:54:49)
  22. Migration excuses (carnil, 20:56:16)
  23. New upstream versions (carnil, 20:56:42)
  24. Merge requests (carnil, 20:59:18)
  25. AoB (carnil, 21:05:32)


Meeting ended at 21:07:13 UTC (full logs).

Action items

  1. waldi rechecks all candidates and then fills bugs for the iptables-legacy removal
  2. ukleinek looks at #1116643
  3. bwh will add firmware-sof-signed and other firmware packages to Package-Status field of the reportbug control file
  4. ukleinek tries to handhold for #1121227
  5. bwh will forward #1100105 upstream
  6. bwh reviews MR (!1720) for #1120854


Action items, by person

  1. bwh
    1. bwh will add firmware-sof-signed and other firmware packages to Package-Status field of the reportbug control file
    2. bwh will forward #1100105 upstream
    3. bwh reviews MR (!1720) for #1120854
  2. ukleinek
    1. ukleinek looks at #1116643
    2. ukleinek tries to handhold for #1121227
  3. waldi
    1. waldi rechecks all candidates and then fills bugs for the iptables-legacy removal


People present (lines said)

  1. carnil (118)
  2. bwh (48)
  3. ukleinek (47)
  4. waldi (12)
  5. MeetBot (3)
  6. KGB (1)


Generated by MeetBot 0.1.4.