20:00:02 <carnil> #startmeeting
20:00:03 <MeetBot> Meeting started Wed Jan 14 20:00:02 2026 UTC.  The chair is carnil. Information about MeetBot at https://wiki.debian.org/MeetBot.
20:00:03 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:00:22 <carnil> #chair bwh ukleinek waldi
20:00:22 <MeetBot> Current chairs: bwh carnil ukleinek waldi
20:00:43 <bwh> Hi
20:00:46 <carnil> hi all.
20:00:46 <ukleinek> nothing special on my agenda today
20:01:42 <carnil> nothing special, I noticed that we had not yet maintainer set to the kernel team address for dracut, filled https://salsa.debian.org/kernel-team/dracut/-/merge_requests/39 for bdrung and MrFai for review
20:01:56 <carnil> then we start with the buglist unless you have something to discuss beforehand?
20:02:15 <waldi> i have
20:02:25 <carnil> waldi: ok
20:02:26 <waldi> does anyone have problems if we absorb kernel-wedge?
20:02:27 <ukleinek> ..ooOO(headache)
20:02:33 <waldi> ukleinek: yeah
20:02:49 <ukleinek> absorb as in put into linux.git?
20:02:52 <waldi> we are the only user and it's just a pain. yes
20:03:01 <bwh> kernel-wedge was also used for kFreeBSD, but I suppose that's over now
20:03:56 <ukleinek> no objection, I don't feel a big pain about it being external, but I also already wondered why we have it at all.
20:03:58 <waldi> my plan is to replace it later, as i want to have more modules debs as well, but in the first step
20:04:00 <bwh> so as long as the installer team is happy with that I don't mind
20:04:23 <ukleinek> how does the installer team come into play here?
20:04:35 <bwh> current maintainer of kernel-wedge
20:04:54 <waldi> and the work is done by some of us, mostly
20:05:00 <bwh> mostly, yes
20:05:09 <waldi> good. nothing else from me
20:05:29 <carnil> I have no objections as well, but think we agree on it with installer team
20:05:32 <carnil> ok
20:05:37 * ukleinek nods
20:05:54 <carnil> waldi: I guess before you leave (if), you agree that you contact the installe team about the plan?
20:06:05 <carnil> s/installe/installer/
20:06:21 <waldi> yes
20:06:53 <carnil> #action waldi contacts d-i team about absorbing kernel-wedge into kernel-team linux.git (as only user)
20:07:12 <carnil> okay so let's move to the bug list, bit ad-hoc
20:07:15 <ukleinek> #1051844 just popped up because of new spam in the bug log. Might still be relevant though.
20:07:22 <carnil> #topic
20:07:22 <carnil> #1072063: (i, u) [drm/i915] one of the external monitors randomly blank for 2-3 seconds with 6.8+ Linux kernels (regression)
20:07:35 <carnil> opnly opped up because of last message was spam, spam reported
20:07:51 <carnil> #topic
20:07:51 <carnil> #1111095: (i, ) firmware-amd-graphics: Radeon HD 8280 : gpu lock, black screen and crash.
20:08:04 <waldi> carnil: no newline…
20:08:35 <carnil> #topic #1111095: (i, ) firmware-amd-graphics: Radeon HD 8280 : gpu lock, black screen and crash
20:08:51 <bwh> The latest message seems to come from someone else with a different problem
20:09:23 <bwh> So, they should be directed to open a separate bug report (unless one already exists, which is quite possible)
20:10:20 <carnil> I think it's bit cryptic becuase the later reporte talks like having the same bug
20:10:46 <bwh> The first reporter's issue depends on kernel version, but theirs apparently depends on firmware version
20:11:18 <carnil> bwh: can you ask the second reporte to double-check open bugs and in case fill a new one?
20:11:23 <bwh> OK
20:11:32 <ukleinek> sounds reasonable
20:12:14 <carnil> #action bwh will ask the second reporter of #1111095 to check for open bugs or otherwise fill a separate bug, since problems seems unrelated
20:12:40 <carnil> #topic #1115613: (i, +M) linux: Please enable CONFIG_SOUNDWIRE_AMD=m
20:12:57 <ukleinek> action seems to be at the reporter
20:13:02 <bwh> There's now a tested set of config changes
20:13:04 <carnil> that is still on me (pending MR to be rebased and completed) as there are now a set of people with suggested minimal config actions
20:13:11 <bwh> right
20:13:21 <carnil> so I should complete taht and prepare to have it merged on debian/latest
20:13:47 <ukleinek> ah, again >1 person involved
20:13:56 <carnil> #action carnil completes https://salsa.debian.org/kernel-team/linux/-/merge_requests/1650 with the minimal set of needed options to resolve #1115613
20:13:57 <bwh> but they do have the same hardware, apparently
20:14:18 <carnil> #topic #1116251: (i, u) linux-image-6.12.48+deb13-rpi: Raspberry Pi Zero W does not boot
20:14:28 <KGB> 03dracut 05debian/unstable 06Thomas Lange * [approved] merge request !39: debian/control: Set Debian Kernel Team address as maintainer * 14https://salsa.debian.org/kernel-team/dracut/-/merge_requests/39
20:14:50 <bwh> I think that only has a tag change from me
20:15:04 <carnil> and the upstream discussion is still ongoing I guess?
20:15:18 <bwh> I don't know
20:15:20 <carnil> but last message on the thread is from 2nd January
20:15:21 <ukleinek> no fixing commit in next
20:15:39 <carnil> looks is bit stalling
20:15:51 <carnil> wait?
20:16:07 <bwh> yes
20:16:20 <carnil> #topic #1116643: (i, Mu) UBSAN: shift-out-of-bounds in .../drivers/gpu/drm/display/drm_dp_mst_topology.c (shift exponent -1)
20:16:36 <carnil> waiting for reporter to test patch
20:16:39 <bwh> right
20:16:47 <ukleinek> /nod
20:16:57 <carnil> #topic #1123591: (i, u) reportbug: Kernel 6.17.11 "ixgbe"-driver broken (OEM Intel X540-AT2 card)
20:17:36 <carnil> so was tested without propietary drivers
20:17:57 <bwh> I think we need a new kernel log to see if the PCI resource allocation changed at all
20:18:25 <ukleinek> given "it's been working for several years without issues." ask for tests with older kernels and then a bisection?
20:18:54 <ukleinek> "results attached, as requested" is a lie
20:19:27 <bwh> Bisection might be sensible, yes
20:19:46 <bwh> Or we can ask to test with 6.18.5 and then forward upstream if it's not fixed
20:19:48 <ukleinek> #action ukleinek will reply to #1123591 asking for tests with older kernels and a recent kernel log
20:19:57 <carnil> thanks ukleinek
20:20:10 <ukleinek> for an upstream report a test with older kernels would be nice
20:20:23 <carnil> #topic #1123750: (i, +u) linux: regression: virtual consoles 2-12 unusable (merged with #1124288, #1124340)
20:20:35 <carnil> all patches queued up for next 5.10.y version
20:20:39 <bwh> right
20:20:48 <carnil> -> wait for that and then in bwh's hand
20:21:16 <carnil> #topic #1125001: (i, ) linux-image-loong64: Backlight and touchpad doesn't work on laptop.
20:21:33 <carnil> missing patches upstream, said we won't pick them if they are not upstreamed
20:22:13 <bwh> right, so I suppose we wait for the vendor now
20:22:15 <carnil> Binbin Zhou as upstream(?) was CC'ed in last message, so I think we can simply wait to see progress here
20:22:38 <carnil> #topic #1038945: (n, ) linux: kernel null pointer dereference loading an invalid AppArmor profile, regression since 6.1
20:22:54 <carnil> spam in last message
20:23:05 <carnil> (reported)
20:23:21 <bwh> I suppose we should retest this though
20:23:22 <carnil> #topic #1081195: (n, ) devscripts: test-patches KeyError: 'pae'
20:23:42 <ukleinek> bwh: check if we can get the 1.850.000,00 USD? :-)
20:23:57 <carnil> bwh: right, looking at https://gitlab.com/apparmor/apparmor/-/issues/346 it is still open
20:24:10 <ukleinek> should be easily bisectable
20:24:35 <bwh> carnil: Oh right, I missed that it was forwarded
20:24:59 <bwh> This one was also hit by spam
20:25:36 <carnil> okay so reported spam, and move to next
20:25:50 <carnil> #topic #1120831: (n, u) linux: failed command: READ FPDMA QUEUED after boot
20:26:26 <carnil> finally bisected, forwarded upstream, Niklas and reporer are trying to find the required limit for a quirk
20:27:00 <ukleinek> Niklas = upstream I guess?
20:27:05 <carnil> the results from reporter are yet not fully clear, but believe it is now in good (upstream) hands and we can wait
20:27:08 <carnil> ukleinek: yes
20:27:14 <carnil> Niklas Cassel <cassel@kernel.org>
20:27:47 <ukleinek> ack
20:27:48 <carnil> so watch the discussion, help reporter in case needed, but otherwise wait until fix lands
20:28:00 <carnil> #topic #1121535: (n, +uM) linux-image-6.17.8+deb14-amd64: array-index-out-of-bounds trace during boot (...ctamixer.c:347:48)
20:28:00 <ukleinek> ack++
20:28:16 <ukleinek> action is on reporter side, so wait
20:28:18 <carnil> wait
20:28:20 <carnil> ack
20:28:27 <bwh> OK
20:28:56 <carnil> #topic #1122035: (n, +) linux-image-amd64: Enable SimpleDRM to save laptops for GNOME 49 please! (merged with #993640, #1125148)
20:29:09 <carnil> another report about SimpleDRM
20:29:33 <bwh> I will try to figure out what is going on with GRUB
20:29:35 <ukleinek> what is the stopper there, ISTR something about grub
20:30:00 <ukleinek> 👍
20:30:23 <bwh> and then work out if/how we can handle the edge cases where GRUB is still configured to break efifb
20:32:33 <carnil> IIRC, you were planning to look at this closer, and we can leave it assigned to you right?
20:32:38 <carnil> you = bwh
20:32:44 <bwh> yes
20:32:49 <carnil> ok
20:33:28 <carnil> #action bwh looks for #1122035 and friends what the status around grub is, and how the edge cases where GRUB is still configured to break efifb can be handled
20:33:48 <carnil> #topic #1122106: (n, Uu+) linux-image-amd64: UBSAN create a systematic trace in DRM driver (merged with #1122154)
20:33:57 <carnil> this is fixed upstream and landed in mainline in 6.19-rc5
20:34:07 <carnil> so can be fixed with the next experimental upload rebasing to 6.19-rc5
20:34:17 <bwh> excellent
20:34:44 <carnil> #topic #1123648: (n, +) udeb: Add USB TYPE-C and mux modules in usb-modules for booting Debian installers
20:35:05 <carnil> has a MR which needs to be reviewed i guess
20:35:10 <bwh> Only change is I tagged and marked forwarded
20:36:20 <carnil> anyone with spare cycles to check that MR?
20:36:37 <ukleinek> on a quick glance the MR looks reasonable
20:36:56 <bwh> I think we discussed this last week and someone alreayd took an aciton?
20:37:08 <bwh> yes I did
20:37:23 * carnil looks up last meeting minutes
20:37:39 <carnil> ah yes so we can keep assigned to you if you are fine with it
20:37:42 <ukleinek> bwh: "@bwh"
20:37:58 <ukleinek> s/wh"/enh"/
20:39:08 <carnil> #action bwh reviews MR to address #1123648
20:39:14 <carnil> hope this is fine :)
20:39:18 <ukleinek> I have a genio board on my work desk, I think it's not a 700 though and never had debian running on it
20:39:33 <bwh> yes
20:39:37 <carnil> #topic #1124756: (n, ) linux-image-6.12.41+deb13-amd64: sporadic freezes
20:40:15 <carnil> new report
20:40:37 <bwh> Looks like we'll need a bisection for this
20:40:40 <carnil> apparently a regression from Debian bookworm -> trixie (6.1.y -> 6.12.y)
20:41:12 <carnil> the problem here might be that it takes some time to eproduce (1 to 2 times a day)
20:41:15 <ukleinek> maybe forward to tuxedo?
20:41:35 <bwh> carnil: Oh, right. Then it's not really bisectable.
20:41:58 * ukleinek still has a contact to the main developer (from some GPL discussion). I can make him aware.
20:42:57 <ukleinek> #action ukleinek forwards #1124756 to vendor
20:43:01 <carnil> and bisect might still be an option even in longer terms to tests, user might first do a manual bisect against packaged major versions releaed in Debian
20:43:08 <carnil> thanks ukleinek
20:43:12 <bwh> Both the bookworm and trixie kernel versions are old. I wonder if it's worth suggesting to test the latest version
20:43:41 <bwh> but probably not
20:43:43 <carnil> bwh: My first attempt was to install newer kernels from experimental. This did not solve the problems.
20:44:15 <carnil> so guess we should gather which one was tested so we can update metadata as well
20:44:27 <bwh> right, fair enough
20:44:47 <ukleinek> I'll also suggest a bisect between packaged versions. I doubt "Version: all kernel versions higher 6.1
20:44:51 <ukleinek> " is accurate
20:45:15 <ukleinek> (and if it is, the bts doesn't understand it)
20:45:35 <ukleinek> ah, but carnil and the reporter already worked on that.
20:46:02 <carnil> ukleinek: yes I updated the metadata according the available information from the report, but nothing more
20:46:23 <carnil> so thanks for handling it, ukleinek
20:46:29 <carnil> #topic #1124836: (n, ) linux-image-amd64: linux-image-6.18.3+deb14-amd64 introduced an ACPI warning
20:46:35 <bwh> Already closed
20:46:38 <carnil> ah sorry this is already closed
20:46:54 <carnil> #topic #1124839: (n, ) linux-image-6.17 -- wireless does not wake up after standby
20:47:11 <ukleinek> ask for a bisection
20:47:14 <bwh> I already have an action to request running reportbug properly
20:47:39 <carnil> tag moreinfo and wait?
20:47:44 <bwh> I will do that
20:48:01 <carnil> OTOH there is information that it looks like regressing from 6.16 to 6.17
20:48:35 <carnil> so we might ask a couple of questions along, like either test 6.18.y as ell from unstable in newest version or if feasible do the bisect work between 6.16 and 6.17
20:50:12 <carnil> okay but let's wait for reporter to provide first set of useful information
20:50:26 <ukleinek> (once bwh came around to ask for it)
20:50:42 <carnil> #topic #1125155: (n, ) /usr/share/bug/linux-image-6.12.57+deb13-amd64/include-pci: amdgpu flip timeout, system freezes
20:51:02 <bwh> I'll report spam on this
20:51:27 <carnil> new report otherwise without action from us so far
20:51:32 <carnil> unfortunately amdgpu related
20:51:54 <ukleinek> not sure, while the link in #10 is Russian(?) it seems related
20:52:41 <ukleinek> (but then probably only someone asking an LLM what to do)
20:52:45 <bwh> precisely
20:53:16 <carnil> I have seen I think two bugs this week on our bugs with such followups :(
20:53:59 <carnil> maybe I'm not seeing it right
20:54:08 <carnil> but I do not see the flip timeout messages
20:54:20 <carnil> should we ask to provide full log or directly report to amdgpu upstream?
20:54:29 <ukleinek> I think it's not sensible to try to understand the link content
20:55:31 <bwh> We should probably try to see if it matches any of the other many amdgpu bugs
20:55:50 <bwh> but that's easier said than done
20:55:57 <carnil> so for that we need a complete log with the actual amdgpu related errors at least
20:56:01 <bwh> I think so
20:56:03 <carnil> I can ask the reporter to provide a full log
20:56:22 <carnil> #topic carnil ask reporter of #1125155 to provide full logs including the amdgpu problems
20:56:23 <ukleinek> carnil: thx
20:56:33 <carnil> #action carnil ask reporter of #1125155 to provide full logs including the amdgpu problems
20:56:36 <carnil> ups :(
20:56:40 <carnil> sorry
20:56:52 <carnil> we have 4 minutes left, do you still have some energy?
20:56:57 <ukleinek> some
20:57:10 <bwh> some
20:57:10 <carnil> let's look at one more bug and then move to the rest
20:57:37 <ukleinek> the dracut one?
20:57:45 <carnil> (or two, the rest are minor and wishlist)
20:57:49 <carnil> ok two then :)
20:57:58 <carnil> #topic #1125287: (n, ) linux-image-6.12.63+deb13-amd64: Misleading error message "x2apic: IRQ remapping doesn't support X2APIC mode"
20:58:57 <bwh> The real problem here is a misconfiguration in the BIOS. The error message could maybe be improved but I think that's minor
20:59:08 <carnil> BTH, I'm bit confused here, it is just that reporter has not enabled IOMMU and then the kernel bails out with that message. it is not that we have not enabled some options, the last comment about CONFIG_HYPERVISOR_GUEST looks wrong as we have correctly CONFIG_IRQ_REMAP=y
20:59:53 <bwh> I think I understand this well enough to suggest alternate wording
20:59:58 <ukleinek> The bug gives way to interpretation as the reporter didn't specify their expectations
21:00:10 <bwh> #action bwh will propose a patch for #1125287
21:00:16 <carnil> bwh: thanks!
21:00:20 <ukleinek> (though they probably don't expect us to fix the bios :-)
21:00:49 <carnil> #topic #1125375: (n, ) linux-image-6.12.63+deb13-amd64: PCIe AER error storm on Intel Raptor Lake PCIe 5.0 root port with RTX 3070 Ti
21:01:00 <carnil> already replied, but forgot the moreinfo tag, just added
21:01:03 <ukleinek> that rings a bell somehow. Is that a duplicate to a former bug?
21:01:11 <carnil> #topic #1114857: (w, ) Switch default initramfs builder to dracut
21:01:16 <carnil> bwh: ^^ this one
21:02:06 <bwh> Well we did it, so this just needs to be closed with the right version
21:02:36 <ukleinek> the switch to make dracut the default also needs installer work, right?
21:02:44 <carnil> so we have already added dracut first in Depends now, but AFAIU we have open the d-i part and a list of affected packages in Debian specifically
21:03:21 <bwh> But tht would imply a bug against general rather than src:linux
21:03:31 <ukleinek> reassign to the installer?
21:04:14 <ukleinek> the need to adapt further packages are then more blocking bugs?
21:05:04 <bwh> Some of them would not be blocking, but wishlist "please integrate with dracut too"
21:05:17 * ukleinek nods
21:05:41 <carnil> I think we need to have something to track this project
21:05:56 <ukleinek> ack, so let's not close the bug
21:05:57 <carnil> and a driver :)
21:06:20 * ukleinek just recently renewed his driver license
21:06:21 <bwh> I think all we need to take responsibility for is that the installer can install with dracut and produce a bootable system for the storage configurations that partman handles
21:06:41 <carnil> ack
21:06:47 <bwh> or at least not regress w.r.t. initramfs-tools :-)
21:07:18 <bwh> Anyway I already have an action to work on this
21:07:35 <ukleinek> maybe there isn't much to be done. if we're lucky the installer already pulls in dracut due to the dependency.
21:08:16 <bwh> I'm pretty sure there is some i-t-specific logic there though, like for setting MODULES=dep vs MODULES=most
21:08:31 <bwh> and RESUME=(wherever)
21:08:38 <ukleinek> ah right
21:09:09 <carnil> so d-i part in good hands, and we do not have to discuss any further specifics today, right?
21:09:18 * ukleinek nods
21:09:23 <bwh> OK
21:09:40 <carnil> okay to skip the other bugs? or do you want to pick any specific?
21:09:55 <ukleinek> okay to skip
21:10:03 <carnil> #topic Migration excuses
21:10:19 <carnil> linux currently blocked from migrating, would hopefuly do with the next pending upload
21:10:42 <carnil> I was merely waiting on a decision for https://salsa.debian.org/kernel-team/linux/-/merge_requests/1784
21:10:50 <carnil> but that should be fine?
21:11:38 <bwh> Don't we want a ~ on the end of those versions?
21:12:11 <bwh> otherwise backports will be uninstallable
21:12:13 <ukleinek> is a break a good idea? Doesn't that just result in flash-kernel and reform-tools to be uninstalled?
21:12:44 <bwh> If it's versioned, no I don't think it does
21:13:03 <waldi> apt may do that. but as this only affects backports, well
21:13:53 <waldi> it may be useful to mark those packages as Important: yes
21:14:59 * ukleinek doesn't know the exact semantic, but those packages are not important for all machines
21:15:21 <ukleinek> s/semantic/& of Important: yes/
21:15:39 <waldi> if the package is installed, it is handled like essential. if it is not installed, nothing
21:15:59 <waldi> aka it makes deinstallation harder
21:16:10 <ukleinek> sounds good then
21:16:40 * ukleinek adds this to his flash-kernel list
21:17:15 <bwh> I added a comment
21:17:23 <carnil> ok thanks
21:18:14 <carnil> #topic New upstream versions
21:18:42 <bwh> I still have an action to unblock the update of firmware-nonfree
21:19:13 <carnil> firmware-nonfree should have a MR, but pending, so all good, but there are two concurrent/interleaving MRs for 20251125
21:19:25 <carnil> right
21:19:45 <carnil> #topic AoB
21:19:52 <ukleinek> I can chair next week
21:19:57 <ukleinek> I already asked a few weeks back about FOSDEM, but don't remember the exact outcome. I'm going to FOSDEM, IIRC bwh also said he'd come and waldi intended to. What about carnil? If we are all there, we could take dinner together? On Friday?
21:20:10 <carnil> I cannot come
21:20:18 <ukleinek> :'-(
21:20:23 <bwh> Friday would be hard due to train strikes
21:20:39 <ukleinek> ooh, do I need to check my connection?
21:21:14 <carnil> yeah it's not realistic for me for fosdem due to $reasons not logged here, but I plan and intend to go to MiniDebconf hamburg
21:21:40 <carnil> but enjoy in this case the kernel team gathering :)
21:22:29 <bwh> ukleinek: You probably should, yes
21:22:34 <carnil> ukleinek: thanks for chairing next week
21:22:45 <bwh> carnil: Thanks for chairing this week
21:22:56 <carnil> so done for today I would say
21:23:00 * ukleinek has a German train, so *maybe* he is fine
21:23:23 * ukleinek heads directly to bed
21:23:27 <carnil> #endmeeting