#debian-kernel Meeting

Meeting started by bwh at 20:00:20 UTC (full logs).

Meeting summary

    1. ACTION: carnil disables the build-arm64 job to work around ci failures (ukleinek, 20:09:49)
    2. AGREED: unstable will get at least one more 6.18.y upload (bwh, 20:15:19)
    3. AGREED: 6.19 should go into unstable starting with 6.19.5 (bwh, 20:15:35)

  1. #1127635: (i, M) linux-image-6.18.9+deb14-powerpc64: fails to boot on IBM 8204-E8A (POWER6 p550) LPAR, NULL deref in PCI MSI setup (bwh, 20:15:58)
  2. #1128396: (i, uM) linux-image-6.12.69+deb13-amd64: Black screen on boot with Intel Meteor Lake xe driver (PCI ID 7d55) (bwh, 20:16:40)
    1. ACTION: carnil ask again for bisection for #1128396 issue (carnil, 20:18:19)

  3. #1128632: (i, ) linux-image-6.12.73+deb13-amd64: boot failures, ACPI errors, and sleep issues on ASUS Sabertooth Z77 (i7-3770K) (bwh, 20:18:35)
    1. ACTION: bwh will ask for kernel boot logs for #1128632 (bwh, 20:22:08)

  4. #1121192: (n, M) kworker: Events_unbound, kworker processes, continually using CPU. (bwh, 20:22:29)
    1. ACTION: bwh will fix firmware-nvidia-graphics to trigger update-initramfs (bwh, 20:31:33)
    2. ACTION: bwh will ask reporter of #1121192 to test with nouveau *and* firmware installed, on newer kernel versions (bwh, 20:32:16)

  5. #1126957: (n, u) kernel panic when repeatedly trying to mount an nfsv4 share with mtls and failing (bwh, 20:32:34)
  6. #1127612: (n, u+) linux-image-6.12.69+deb13-amd64: hp_bioscfg mm/page_alloc.c:4802 warning (bwh, 20:34:30)
    1. ACTION: bwh will reply to patch for #1127612 (bwh, 20:38:44)

  7. #1127688: (n, M) linux-image-6.18.9+deb14-amd64: Crash to black screen with QR code to log (bwh, 20:39:21)
  8. #1128397: (n, Mu) linux-image-6.18.10+deb14-amd64: open(/proc/$pid/maps) is empty after $pid exec()s, unless you read a partial line from the fd before, in which case it has the rest of the line only (bwh, 20:40:36)
  9. #1128626: (n, u) btusb: add 2c4e:0115 (Mercusys MA530, RTL8761BU) (bwh, 20:41:58)
  10. #1128834: (n, u) linux-image-6.1.0-43-amd64: NFS client regression in 6.1.162: large rsize/wsize (1MB) causes EIO (bwh, 20:43:20)
    1. ACTION: carnil follows up for #1128834 with linux-nfs to see if a workaround needs/should be implemented on kernel side (carnil, 20:46:38)

  11. #1128861: (n, ) linux: when serving NFS, client attempts to lock served files fail with "No locks available" (bwh, 20:46:50)
  12. #1126710: (w, ) linux-image-6.18.5+deb14-amd64: unable to mount existing XFS V4 filesystem because kernel CONFIG_XFS_SUPPORT_V4 is not set (merged with #1128422) (bwh, 20:48:37)
    1. ACTION: bwh will reenable CONFIG_XFS_SUPPORT_V4 for trixie-backports (bwh, 20:50:00)

  13. #1124400: (n, u) update-initramfs no longer includes /lib/modules/<kver>/updates directory (bwh, 20:50:47)
    1. ACTION: bwh will discuss #1124400 with bdrung etc. (bwh, 20:53:35)

  14. #1128969: (n, +) dracut: autopkgtests fail on arm64 (bwh, 20:53:58)
  15. #1128598: (n, Uu) rtl8852bu: bluetooth audio suttering at random (bwh, 20:56:21)
    1. ACTION: bwh will update firmware-nonfree in trixie-backports (bwh, 20:57:06)

  16. #1064620: (w, +) firmware-nonfree: suggestions for the packaging, gencontrol.py and debian/rules (bwh, 20:57:48)
    1. ACTION: bwh will review #1064620 and possibly ask to create an MR (bwh, 20:59:07)

  17. #1128562: (m, ) /usr/bin/linux-check-removal: Use of uninitialized value $_[2] in join or string at /usr/share/perl5/Debconf/Client/ConfModule.pm line 122. (bwh, 20:59:18)
    1. ACTION: bwh will investigate #1128562 (bwh, 21:05:35)

  18. Migration excuses (bwh, 21:05:50)
  19. New upstream versions (bwh, 21:08:06)
  20. Merge requests (bwh, 21:10:36)
  21. AOB (bwh, 21:11:52)
    1. ACTION: ukleinek will chair next week (ukleinek, 21:15:12)


Meeting ended at 21:15:59 UTC (full logs).

Action items

  1. carnil disables the build-arm64 job to work around ci failures
  2. carnil ask again for bisection for #1128396 issue
  3. bwh will ask for kernel boot logs for #1128632
  4. bwh will fix firmware-nvidia-graphics to trigger update-initramfs
  5. bwh will ask reporter of #1121192 to test with nouveau *and* firmware installed, on newer kernel versions
  6. bwh will reply to patch for #1127612
  7. carnil follows up for #1128834 with linux-nfs to see if a workaround needs/should be implemented on kernel side
  8. bwh will reenable CONFIG_XFS_SUPPORT_V4 for trixie-backports
  9. bwh will discuss #1124400 with bdrung etc.
  10. bwh will update firmware-nonfree in trixie-backports
  11. bwh will review #1064620 and possibly ask to create an MR
  12. bwh will investigate #1128562
  13. ukleinek will chair next week


Action items, by person

  1. bwh
    1. bwh will ask for kernel boot logs for #1128632
    2. bwh will fix firmware-nvidia-graphics to trigger update-initramfs
    3. bwh will ask reporter of #1121192 to test with nouveau *and* firmware installed, on newer kernel versions
    4. bwh will reply to patch for #1127612
    5. bwh will reenable CONFIG_XFS_SUPPORT_V4 for trixie-backports
    6. bwh will discuss #1124400 with bdrung etc.
    7. bwh will update firmware-nonfree in trixie-backports
    8. bwh will review #1064620 and possibly ask to create an MR
    9. bwh will investigate #1128562
  2. carnil
    1. carnil disables the build-arm64 job to work around ci failures
    2. carnil ask again for bisection for #1128396 issue
    3. carnil follows up for #1128834 with linux-nfs to see if a workaround needs/should be implemented on kernel side
  3. ukleinek
    1. ukleinek will chair next week


People present (lines said)

  1. bwh (104)
  2. carnil (51)
  3. ukleinek (39)
  4. waldi (29)
  5. MeetBot (2)
  6. carnil_ (2)


Generated by MeetBot 0.1.4.