20:00:02 <carnil> #startmeeting
20:00:02 <MeetBot> Meeting started Wed Mar 25 20:00:02 2026 UTC.  The chair is carnil. Information about MeetBot at https://wiki.debian.org/MeetBot.
20:00:02 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:00:07 <carnil> hello
20:00:17 <waldi> hi
20:00:42 <carnil> I'm sorry I'm not very well prepared, but already feeling better, got a cold but I have ammended all the bugs, so excuse if I'm oot up to date with every bug
20:01:14 <carnil> so I think ukleinek said to not be around IIRC, is bwh around?
20:01:27 <carnil> #chair bwh carnil waldi
20:01:27 <MeetBot> Current chairs: bwh carnil waldi
20:02:09 <carnil> Is there anything someone wants to discuss before we go to the bug list? :)
20:02:22 <waldi> not from my side
20:02:53 <carnil> ok
20:03:08 <carnil> so I guess we are two today, let's start
20:03:17 <carnil> #topic #1126671: (S, ) linux-image-6.17.13+deb13-amd64: Disconect root (path=/) during heavy load on NvME, partial corruption on NTFS.crash soon but not yet
20:03:40 <waldi> this is still mine, as i'm now back i should manage to do that
20:03:43 <carnil> waldi: if I did recall correctly you said, *if* you find time you might have a second look at that bug and then reply to thr reporter
20:03:52 <bwh> Hi, sorry I'm late
20:04:10 <carnil> #action waldi take a look at #1126671 for further debugging and reply to reporter
20:04:14 <carnil> bwh: np!
20:04:16 <carnil> hi
20:04:29 <carnil> #topic #1113728: (i, ) linux: new ABI versioning prevents linux-version and other tools from correctly sorting Debian revisions (merged with #1130656, #1131008, #1131108)
20:04:55 <carnil> this one has a MR from Ben, https://salsa.debian.org/kernel-team/linux/-/merge_requests/1854
20:05:05 <bwh> I (or someone else) just needs to merge that
20:05:14 <carnil> IMHO looks good to merge and has an proval from waldi as well
20:05:32 <carnil> ok let's merge, I can take care of it and pick it as well for the other brnaches
20:05:41 <bwh> Thanks
20:05:55 <carnil> the piuparts failure is "just" because we lack behind on debian/latest AFAICT
20:06:16 <bwh> right
20:06:39 <carnil> #action carnil take care of merging https://salsa.debian.org/kernel-team/linux/-/merge_requests/1854 and pick changes to other branches as labeled
20:06:49 <carnil> #topic #1130605: (i, M) linux-image-6.19.6+deb14-amd64: hangs with kernel call trace when trying to sleep
20:07:11 <carnil> so far no reply from reporter on the questions, so I think we are fine to wait
20:07:21 <bwh> OK
20:07:43 <carnil> #topic #1130775: (i, u) Regression: MDRAID 1.2 superblock created in Kernel 6.19 is rejected by older kernels (-EINVAL) (merged with #1130781)
20:08:20 <waldi> why would this count as regression?
20:08:32 <carnil> nothing we can act right now on Debian's side, we have an action to get in touch with upstream to discuss the 'regression' part, and see what can be done wrt either reverting or fixing
20:09:30 <bwh> waldi: I agree that it is not a regression, but it is unexpected that a backwards-incompatible change is made in what is nominally the same md-raid version
20:09:36 <carnil> waldi: if you create a raid with a newer kernel, you cannot assemble it with an older kernel, assume someone encounters as well an issue where bisecion would be needed you have at least a problem when bisecting before the commit introducing the behaviour change
20:09:57 <waldi> bwh: this would mean any incompatible change would need a new version
20:10:06 <bwh> yes
20:10:07 <carnil> maybe we can retitle to make the  backwards-incompatible clearer and not count it as regression
20:10:20 <waldi> yes
20:10:32 <bwh> I'll do that now
20:10:37 <waldi> bwh: but we have the same behaviour in all filesystems as well
20:10:49 <waldi> ext4 got so many incompaible flags
20:11:16 <waldi> so what is different with md, except that you don't have control what flags will be set?
20:11:21 <bwh> Sure, but you always have the option to not enable those (or explicitly disable them)
20:11:37 <bwh> For md the kernel is turning on the new feature with apparently no way to opt out
20:12:04 <waldi> okay, no idea
20:12:50 <carnil> bwh: but the idea is still to query upstream?
20:13:20 <bwh> yes
20:13:25 <KGB> 03linux 05debian/latest 06Salvatore Bonaccorso * [approved] merge request !1854: Fix ordering of kernel version strings for multiple Debian revisions * 14https://salsa.debian.org/kernel-team/linux/-/merge_requests/1854
20:13:31 <bwh> I will keep that action from last week
20:13:35 <carnil> thanks
20:14:05 <carnil> #action bwh queries upstream about #1130775 (backwards-incompatible change)
20:14:17 <carnil> #topic #1131158: (i, uM) linux: regression on ThinkPad T14s Gen 4 AMD: 6.18.15 backports fails to reach S0i3 on s2idle, 6.12.74 works
20:14:51 <carnil> we still are waiting for the original reporter to respond. just last week a new reporter claimed to encounter the same bug
20:15:20 <carnil> (and say that nwer kernel based on 6.19.6 do not expose the problem)
20:15:36 <carnil> but I have no idea if it *is* the same issue
20:15:53 <bwh> Certainly seems likely, but indeed let's wait for the original reporter
20:16:06 <carnil> so nothing to act on, wait for the reporte
20:16:19 <carnil> #topic #1111011: (n, M) RTL8125D - link drops
20:16:36 <carnil> this got just an update saying that an update to newer version still has the problem
20:17:01 <carnil> we were out of ideas IIRC
20:17:26 <waldi> did the op ever answer the question got gbit?
20:17:46 <waldi> ah, did actually
20:18:01 <bwh> Some of the Realtek PHYs need firmware patches for link stability and I wonder if the r8125-dkms driver has a newer version of the firmware for this chip
20:18:56 <bwh> I suppose I could look at that
20:19:21 <carnil> bwh: if you feel you have capacity for that, I think that would be great
20:19:32 <bwh> #action bwh will check whether newer PHY firmware is available for #1111011
20:19:52 <carnil> #1112238: (n, u) linux-image-6.12.41+deb13-amd64: Second Intel P4510 NVME SSD no longer detected after Upgrade to 6.12 kernel series (Debian Trixie)
20:19:56 <carnil> #topic #1112238: (n, u) linux-image-6.12.41+deb13-amd64: Second Intel P4510 NVME SSD no longer detected after Upgrade to 6.12 kernel series (Debian Trixie)
20:20:04 <carnil> (sorry, misstyped)
20:20:25 <carnil> still no action needed from our side, needs to get an action upstream, reporter is in the loop, might need to ping again after a while
20:20:27 <bwh> That didn't change since last week
20:20:40 <carnil> #topic #1113996: (n, uM) linux-image-amd64: self-tests for sha256 using sha256-padlock-nano failed
20:21:00 <carnil> this has been fixed/addressed/workarounded upstream and the fix is in mainline
20:21:23 <carnil> if we want, we can pick the fix ahread, created a MR https://salsa.debian.org/kernel-team/linux/-/merge_requests/1857 but not sure it is worth doing or just wait
20:21:30 <carnil> user might be happy if we do
20:22:24 <bwh> Let's do it
20:22:36 <carnil> prefrences? Closing a bug would be motivating
20:22:44 <carnil> ok
20:23:15 <carnil> #action carnil will merge https://salsa.debian.org/kernel-team/linux/-/merge_requests/1857
20:23:33 <carnil> #topic #1127588: (n, ) linux-image-6.18.9+deb14-amd64: Cannot hibernate after some time of work
20:24:19 <bwh> Right, I still have an action to ask some questions about this
20:24:26 <carnil> thanks!
20:24:59 <carnil> btw, I wonder how/if we can easily track actions across meeting, maybe something for next agenda or AoB
20:25:18 <carnil> I struggle almost all the time
20:25:27 <carnil> #topic
20:25:27 <carnil> #1128861: (n, u) linux: when serving NFS, client attempts to lock served files fail with "No locks available"
20:25:40 <carnil> some progress upstream I think, but no fix applied, correct?
20:25:46 <waldi> #topic #1128861
20:26:25 <bwh> Also the upstream discussion is talking about only fixing 6.18 and 6.19, whereas the breakage is also in 6.12
20:27:29 <bwh> I can reply to remind them of that
20:27:41 <carnil> though the fixes tag is 6.13-rc1 but as well backported to 6.12.54, so I gues sthe machinery for backports would pick that as well for 6.12.y in the end
20:28:04 <carnil> bwh: right, that would be good
20:28:39 <carnil> #topic #1130114: (n, ) Please enable usbio module in linux kernel >= 6.18
20:29:24 <carnil> my understanding is, enabling the modules will not make the camera still fully functional and might need more changes (in userland?), but still seems sensible to make a MR enabling the option(s)?
20:29:32 <bwh> yes
20:30:25 <carnil> if nobody voluneers I can propose the MR for a review/merge in debian/latest
20:31:14 <carnil> #action carnil prepares MR enabling options as mentioned in #1130114 to enable usbio module for next experimental upload
20:31:30 <carnil> #topic #1130336: (n, u) linux-image-6.12.73+deb13-amd64: Network failure beyond first connection
20:32:05 <carnil> while the iptables rules triggering the regression does not make much sense, upstream still plans to unbreak the regression, so simply wait until the fix land in mainline
20:32:20 <carnil> #topic #1130930: (n, u) linux-image-6.12.74+deb13+1-amd64: Kernel-6.12.74+deb 13+1-amd64 fail/stuck to Unload AMD driver for single gpu passthrough (merged with #1131626)
20:33:10 <carnil> this is pending for the next trixie upload already, was fixed in 6.12.77 upstream
20:33:23 <carnil> #topic #1131025: (n, u) linux-image-6.12.73+deb13-amd64: echo vfio-pci >driver_override does not work for DVB Adapter
20:34:28 <carnil> The issue was bisected, and reporter confirmed as well reverting commit fixes the issue on top of 6.12.73, so plan to make a report upstream; it is as well a 6.12.y regression aapprently, it works with 6.19.y
20:34:44 <carnil> #action carnil forwards issue upstream as regression report for 6.12.y
20:34:59 <carnil> #topic #1131431: (n, u) linux: loong64 KVM warnings (memcpy + UBSAN out-of-bounds)
20:35:35 <carnil> This is a new reporter, aurel32 reported, while DSA did reinstall a machine
20:37:13 <carnil> maybe this can just go upstream as reporter, or should we leave it to the debian-loongarch people?
20:37:16 <bwh> I suppose I can have a look at this. Is aurel32 not a loong64 porter?
20:38:21 <bwh> #action bwh will look at #1131431 and forward upstream
20:38:22 <carnil> Hmm not sure
20:38:30 <carnil> btw, we might need to update our MAINTAINERS.Debian
20:38:58 <bwh> yes
20:39:38 <waldi> boah, who reviewed this code?
20:41:14 <carnil> from the comment I suspect waldi has identified other issues ;-)
20:41:39 <carnil> anyway, thanks bwh for taking it
20:41:45 <carnil> #topic #1131546: (n, ) linux: debian/b/test-patches does not produce easy to test (unsigned) image package
20:41:59 <carnil> bwh: this is just a tracking bug for the issue with test-patches we discussed last week
20:42:13 <bwh> right
20:42:13 <carnil> hope I summarized it correctly
20:42:16 <bwh> yes
20:43:11 <carnil> we can keep the action to you I hope
20:43:14 <carnil> #topic #1131789: (n, ) linux-image-6.19.6: GPF in ucsi_handle_connector_change on USB disconnect
20:43:18 <carnil> this a new reporter
20:43:23 <carnil> s/reporter/report/
20:46:24 <bwh> Love how the slop explanation has an entirely different value for the register
20:46:39 <bwh> and doesn't cite a source for "known race"
20:47:45 <bwh> I suppose it's worth having a quick look for other reports upstream, otherwise this can be fowarded as a new bug
20:49:22 <carnil> not finding simlar reports upstream so far, but closest maybe with similar trace https://retrace.fedoraproject.org/faf/problems/778867/
20:50:08 <carnil> or https://lore.kernel.org/all/e17329a8-eb65-4dbe-ae8f-3b68efcf11f5@secunet.com/
20:51:10 <bwh> Those are certainly quite similar but it's not clear to me that they're the same
20:51:52 <waldi> all are wrong pointer inside the same module
20:51:57 <bwh> #action bwh will forward #1131789 upstream, noting similar earlier report found by carnil
20:51:57 <waldi> oh, dm_crypt_sina…
20:52:12 <waldi> this is weird stuff
20:52:49 <carnil> thanks bwh
20:53:01 <carnil> #topic #1131166: (w, +) enable uniwill platform driver
20:53:20 <carnil> have done a MR, with similar arguments as with the other MR above, I will just merge it for debian/latest
20:53:29 <waldi> yeah
20:53:32 <carnil> (unless I hear objections)
20:53:42 <KGB> 03linux 05debian/latest 27a2387 06Salvatore Bonaccorso (via 06Ben Hutchings) 10debian/ 10changelog 10config/amd64/config * [amd64] drivers/platform/x86/uniwill: Enable X86_PLATFORM_DRIVERS_UNIWILL * 14https://salsa.debian.org/kernel-team/linux/-/commit/27a2387
20:53:42 <KGB> 03linux 05debian/latest 070b29b 06Salvatore Bonaccorso (via 06Ben Hutchings) 10debian/ 10changelog 10config/amd64/config * [amd64] drivers/platform/x86/uniwill: Enable UNIWILL_LAPTOP as module * 14https://salsa.debian.org/kernel-team/linux/-/commit/070b29b
20:53:42 <KGB> 03linux 05debian/latest d9ce169 06Ben Hutchings 10debian/ 10changelog 10config/amd64/config * Merge branch 'enable-uniwill-driver' into 'debian/latest' * 14https://salsa.debian.org/kernel-team/linux/-/commit/d9ce169
20:53:42 <carnil> #topic #1131772: (w, ) Please enable support for Radxa Orion O6
20:53:46 <KGB> 03linux 05debian/latest 06Ben Hutchings * [merge] merge request !1853: [amd64] drivers/platform/x86/uniwill: Enable UNIWILL_LAPTOP as module * 14https://salsa.debian.org/kernel-team/linux/-/merge_requests/1853
20:53:53 <carnil> ah even better :)
20:54:15 <carnil> #1131772 has a MR
20:54:23 <carnil> but it went back to draft
20:54:28 <carnil> so we can wait until this is ready
20:54:30 <waldi> this needs more stuff enabled
20:55:02 <waldi> a complete separate pcie controller implementation
20:55:41 <waldi> ah, already in there. okay
20:55:46 <carnil> waldi: are you aiming to monitor that MR?
20:56:03 <waldi> yeah, i take that
20:56:12 <carnil> thanks!
20:56:17 <carnil> so done iwth the src:linux bugs
20:56:29 <carnil> #topic
20:56:29 <carnil> #1131751: (i, Uu) ABI break in amdxdna npu firmware
20:56:40 <KGB> 03linux 05debian/latest 06Bastian Blank * [update] merge request !1858: Draft: [arm64] Enable CIX Radxa Orion O6 platforms * 14https://salsa.debian.org/kernel-team/linux/-/merge_requests/1858
20:56:44 <bwh> This is fixed in the latest upstream version; I just need to upload that
20:56:53 <carnil> helmut identified it is fixed upstream
20:56:57 <carnil> ack
20:57:18 <carnil> #topic migration excuses
20:57:42 <carnil> dracut, just too young yet, should go in in one day
20:57:55 <carnil> #topic New upstream versions
20:58:00 <KGB> 03firmware-nonfree 05debian/latest 06Ben Hutchings * [update] merge request !140: Update to 20260309 * 14https://salsa.debian.org/kernel-team/firmware-nonfree/-/merge_requests/140
20:58:01 <carnil> the usual candidates :)
20:58:20 <carnil> 6.19.10 go t released today, already started on preparing that for upload
20:58:48 <carnil> we have 7.0-rc5 as well which at some point we should have in debian/latest, but I have no capacity for that
20:58:54 <KGB> 03linux 05debian/latest 06Bastian Blank * [close] merge request !1846: [armhf] drivers/gpu/drm/v3d: Enable DRM_V3D as module * 14https://salsa.debian.org/kernel-team/linux/-/merge_requests/1846
20:59:17 <waldi> carnil: i should have capacity in the next days
20:59:34 <carnil> \o/
20:59:48 <carnil> waldi: would be great, thank you
20:59:57 <carnil> #topic merge requests
21:00:02 <carnil> any to discuss in particular?
21:01:18 <carnil> silence means no :)
21:01:22 <waldi> nope
21:01:22 <carnil> #topic AoB
21:01:39 <carnil> ukleinek: said he will chair next meeting
21:02:07 <carnil> so other than that I think we are done for tonight
21:02:34 <bwh> Yes, thank you
21:02:41 <carnil> waldi, bwh thanks a lot for attending, giving input taking actions!
21:02:45 <carnil> #endmeeting