19:00:40 <bwh> #startmeeting
19:00:40 <MeetBot> Meeting started Wed Apr  8 19:00:40 2026 UTC.  The chair is bwh. Information about MeetBot at https://wiki.debian.org/MeetBot.
19:00:40 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:00:48 <carnil> hi
19:01:39 <bwh> Anyone else?
19:01:59 <tarzeau> i'm also here, but first time...
19:02:08 <carnil> welome tarzeau
19:02:37 <bwh> Hi tarzeau
19:02:49 <bwh> Any urgent items before we start on the bug list?
19:03:14 <carnil> nothing from me
19:03:31 <bwh> #topic #1126671: (S, ) linux-image-6.17.13+deb13-amd64: Disconect root (path=/) during heavy load on NvME, partial corruption on NTFS.crash soon but not yet
19:03:58 <bwh> No progress here but as an RC bug it stays on the list
19:04:08 <carnil> ack
19:04:31 <bwh> Who had an action for this?
19:04:46 <carnil> it was waldi (time permitting)
19:04:55 <bwh> right
19:04:58 <carnil> but was low prio/low on the list
19:05:28 <carnil> we either can keep it this way, given I think we have not much ideas or someone else tries to respawn some energy for it
19:05:32 <bwh> Maybe I should take an action to look at it too, because it should be high priority
19:06:16 <bwh> #action bwh will look at #1126671 to work out what to do or ask next
19:06:36 <bwh> #topic #1131558: (i, ) grub2-common: zz-update-grub should run update-grub after linux-binary removal, too
19:06:40 <carnil> I still did not understood when/if the rporter can reliably reproduce or just still have a corrupted one. But if you take an action things should be cleaer afterwards
19:07:37 <bwh> I think waldi and I are roughly in agreement about how to solve this
19:07:52 <carnil> On IRC waldi expressed the idea how we wants to fix that, by moving the image into /lib and install it into /boot
19:07:56 <carnil> ok
19:08:00 <bwh> right
19:08:47 <bwh> so either he or I can implement that
19:09:14 <carnil> ok sounds good
19:09:20 <bwh> Shall I record that as #agreed?
19:09:43 <carnil> (sorry not really a productive comment)
19:09:59 <carnil> bwh: ok yes, and then discuss off-meeting who/when some of you take care of it
19:10:15 <bwh> #agreed fix for #1131558 will be that linux-binary(-unsigned) will install under /usr/lib and linux-image will copy to /boot
19:10:37 <bwh> #topic #1132130: (i, M) BUG: kernel NULL pointer dereference
19:11:11 <bwh> No reply since I added the summary, so we are still waiting
19:11:36 * carnil nods
19:11:43 <bwh> #topic #1132814: (i, ) linux-source-6.19: please enable CONFIG_VIDEO_INTEL_IPU7
19:12:13 <carnil> as this was tested, I think it would be fine to enable it?
19:12:47 <carnil> I can take an action to make a MR for debian/latest if we agree. I'm not sure about the general states aobut these drivers, but if it helps already some people it might be worth of
19:13:23 <bwh> It's staging but I suppose if it works for the reporter then it's OK
19:14:04 <carnil> ok let's do it then
19:14:54 <carnil> #action carnil opens a MR enabling CONFIG_VIDEO_INTEL_IPU7 (to close #1132814)
19:15:02 <bwh> #topic #1130926: (n, ) systemd powering hard disks down before reboot
19:15:39 <bwh> We discussed this last week and the only change is I added the commit that probably changed this
19:15:52 <carnil> I think you found the commit which causes this behaviour and it is intentional, I guess the reporter will disagree, but shall we close it accordingly?
19:16:28 <bwh> yes OK
19:16:50 <bwh> #action bwh will close #1130926 with explanation of the intended change
19:16:59 <carnil> +1 thanks!
19:17:00 <bwh> #topic #1131025: (n, u+) linux-image-6.12.73+deb13-amd64: echo vfio-pci >driver_override does not work for DVB Adapter
19:18:13 <carnil> Now that it is clear hwich commits are missing I was waiting that they appear on the stable series
19:18:34 <carnil> given upstream is in the loop I was expecting that this happens :)
19:19:26 <bwh> At least some of the messages went to stable@
19:19:32 <carnil> so far there is nothing on the stable list to post those request, but I can monitor it and ping in a few days if nothing happens
19:19:54 <bwh> OK, sounds good
19:20:36 <carnil> #action carnil keeps an eye on #1131025 (make sure missing commits will be picked for 6.12.y stable series)
19:20:44 <bwh> #topic #1132305: (n, +) hyperv-daemons is missing the fcopy daemon
19:20:48 <carnil> unfortunately it won't be in 6.12.81 as the review of that just started
19:21:59 <bwh> I spent... a while... getting Windows and Hyper-V running and figuring out how to enable the host side of this, and I now have an MR that makes the daemon work
19:22:37 <bwh> I think I should give waldi a chance to re-review though
19:22:45 <carnil> yes sounds good
19:23:07 <bwh> #topic #1132343: (n, ) linux: broken wifi (with ath11k) after resuming from suspend
19:24:58 <bwh> The reporter said rebinding the driver works, which suggests that this is a driver bug (it is possible to reinit the hw) rather than a firmware issue where the hw is in an unrecoverable state
19:25:43 <bwh> So, I think this can be forwarded to the ath11k maintainers
19:26:13 <carnil> yes I think this could help alredy even we have no
19:26:24 <carnil> easy to reproduce way from santiago
19:27:23 <carnil> do we want to ask santiago himself to forward the report (helping him to make sure the right people is contacted via get_maintainers? I'm fine either way
19:27:33 <bwh> #action bwh will forward #1132343 to ath11k maintainers
19:28:03 <bwh> It's email so we can do it
19:28:30 <bwh> #topic #1132796: (n, +) linux-kbuild is missing scripts/gen-btf.sh
19:29:22 <bwh> Oh, waldi already merged this
19:29:28 <carnil> waldi: did merge the MR from the reporter
19:29:35 <carnil> so should land in the next experimental upload
19:30:01 <bwh> I'll just do a tagpending...
19:30:47 <bwh> #topic #1132816: (n, u) linux-image-rt-amd64: missing ip_tables.ko in linux-image-rt-amd64
19:31:59 <bwh> This is a repeat of a bug report that I reassigned to libvirt. Since I don't expect it to be fixed there in the short term and we've now had 2 reports, I think it may be sensible to keep a wontfix report open on src:linux
19:32:56 <carnil> side question on this: When is it the right moment to close wontfix bugs in general? While they can be filtered, too many bugs open just do not help to remain motivated and keep the overview :) and unfortunately we are back at same level as last year in may (cf. https://qa.debian.org/data/bts/graphs/l/linux.png)
19:33:17 <bwh> I wish I knew
19:34:43 <carnil> I guess when I have some dedicated time for Debian tasks alone I would love to do another housekeeping round. Okay but sorry for distracting gfrom the mentioned bug. Yes it's okay let's keep it open + wontfix for a while
19:35:19 <bwh> but bugs tagged wontfix are separated out so I would hope they aren't too much of a burden...?
19:36:16 * carnil nods, yes it is fine it is really just a motivational thing when the curve is increasing
19:36:48 <bwh> I never remember about that graph so I live in blissful ignorance
19:37:29 <bwh> #topic #1131809: (S, ) dracut: ppc64el autopkgtest are flaky and take 7 hours per run
19:38:07 <bwh> Nothing changed but it's RC
19:38:50 <bwh> I have an open action to discuss the failures with bdrung
19:39:26 <carnil> thank ou for that
19:40:08 <bwh> #topic #1132794: (n, ) dracut 110-8 breaks autopkgtest EFI boot images
19:40:53 <bwh> This is not yet solved but bdrung seems to be quite active on it, so I think we can leave it with him
19:41:19 * carnil nods
19:41:24 <bwh> #topic #1132448: (i, u) firmware-mediatek: Wifi perf degraded a lot after upgrade firmware-mediatek from 20250410-2 to 20260221-1~bpo13+1 and 20260309-1
19:41:47 <bwh> I just replied to this to say this should go upstream
19:42:08 <carnil> ack
19:42:29 <bwh> *However*, Hotmail bounced it and the bounce says it won't accept mail from debian.org
19:43:12 <carnil> hmm :(
19:43:55 <carnil> sill if the reporter follows the bug should see your reply and act, if nothing happens we migh provide some help and forward it, but then we do not have the exact HW details to provide
19:44:26 <bwh> I can try sending through kernel.org; I'm not sure if that implements all the anti-spam protocols expected by MS
19:44:37 <bwh> right
19:45:36 <bwh> #action bwh will try a different sending address to contact the reporter of #1132448
19:45:49 <carnil> thanks!
19:45:52 <bwh> #topic Migration excuses
19:46:56 <carnil> for linux at least it is yet just too young, and need waiting
19:46:58 <bwh> dracut is listed as having autopkgtest failures but I think the latest version fixed those
19:48:12 <bwh> initramfs-tools triggered an autopkgtest failure for miniramfs, but that's a bug in the latter (it uses cpio but doesn't Depend on it, and now initramfs-tools-bin Depends on 3cpio | cpio)
19:48:46 <bwh> which is #1132532
19:49:39 <bwh> OK, so I think we don't have anything to do here
19:49:44 <bwh> #topic New upstream versions
19:49:45 <carnil> ok
19:50:23 <bwh> We really should get 7.0 uploaded to experimental
19:50:36 <carnil> I was going to say the same
19:51:02 <carnil> is it in an uploadable shape? If so would be nice to have the ball rolling for 7.0
19:51:04 <bwh> I can probably do that some time this week
19:51:24 <carnil> would be nice thank you bwh
19:51:36 <carnil> if you do not mind I will take care of nfs-utils new usptream version
19:52:23 <bwh> It is certainly uploadable but I would expect some build failures. Better to find those sooner than later
19:52:42 <bwh> I am very happy with you taking care of nfs-utils
19:52:49 <bwh> #topic Merge requests
19:53:51 <bwh> Do we need to discuss any of these?
19:54:29 <carnil> nothing from me, I think to remember that ukleinek said to have  a look at the arm64 specific ones
19:54:38 <carnil> so should be all more or less in hands
19:54:55 <bwh> right
19:55:12 <bwh> #topic Any other business
19:55:29 <bwh> tarzeau: Did you have something to discuss?
19:57:30 <bwh> Then, who will chair next week? Not me
19:58:16 <carnil> I guess given we are only two now it is my turn *but* I have a known longer day on next wednesday and busy on the two days before, things might become a bit tight
19:58:39 <carnil> but it's fair so I take it and if I see to struggle I will ask ukleinek or waldi
19:59:28 <bwh> I can do it again
19:59:42 <carnil> bwh: you just said "not me" ;-)
19:59:54 <bwh> I know you don't like chairing on Jitsi and you are a lot busier than me
20:00:39 <carnil> ok given the cirumstances for next wednesday I'm glad if you can take it again
20:00:48 <bwh> #action bwh will chair next week
20:00:51 <bwh> #endmeeting