19:00:01 <carnil> #startmeeting
19:00:01 <MeetBot> Meeting started Wed May  6 19:00:01 2026 UTC.  The chair is carnil. Information about MeetBot at https://wiki.debian.org/MeetBot.
19:00:01 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:00:10 <waldi> hi
19:00:12 <ukleinek> bwh: o/
19:00:13 <carnil> #chair bwh ukleinek waldi
19:00:13 <MeetBot> Current chairs: bwh carnil ukleinek waldi
19:00:18 <carnil> hello!
19:00:18 <ukleinek> s/bwh: //
19:00:27 <bwh> Hi
19:00:50 <carnil> welcome to todays meeting, partially from Hamburg :)
19:01:13 <carnil> I got nothing to put in fron of the bug list, anyone wants to discuss something/needs discussing?
19:01:15 <yunseongkim[m]> Hello!
19:01:31 <ukleinek> also partially from Freiburg! :-D
19:02:00 * ukleinek doesn't have anything to discuss upfront
19:02:10 <bwh> Not from me
19:02:24 <carnil> okay then let's move to the (long) buglist
19:03:17 <carnil> one comment, as jochensp just joined as well the channel: he approached Ben and me today about questions on reproducing the kernel. But summarizing the two main "issues" should be shinx and documentation build, and signing of the modules
19:03:29 <ukleinek> ..ooOO(uuh, mixed dos and unix newlines in the meeting file)
19:04:16 <carnil> #topic #1126671: (S, ) linux-image-6.17.13+deb13-amd64: Disconect root (path=/) during heavy load on NvME, partial corruption on NTFS.crash soon but not yet
19:04:41 <carnil> So far no progress on this one. We have an action for bwh from last week, and I assume it is okay to leave it :)
19:04:43 * ukleinek recently worked on something somewhat related. Resulted in patches like 3096d3e9f44afe011d2017ddade416924e1c99d5 (in next)
19:04:55 <bwh> I meant to look at this today, but then I was asked to review a standards document urgently. So maybe tomorrow
19:05:06 <ukleinek> (related to reproducible builds)
19:05:19 <carnil> sounds good, then let's keep the action to you
19:05:42 <carnil> #action bwh intents to debug the issue in #1126671 and keeps the action on it
19:06:00 <carnil> #topic #949020: (i, ) linux-image-5.5.0-rc5-amd64: Poweroff/suspend doesn't work in 5.5.0-rc5 (forwarded: r)
19:06:12 <ukleinek> 5.5!
19:06:32 <carnil> New reporter responding to an old bug. IMHO unlikely that it is the same issue. Asked to test if this is the known regression from #1135599 and if it is still reproducible to open a new bug
19:06:40 <carnil> so no action, respeticvely wait for a reply
19:06:53 <ukleinek> ack
19:07:03 <carnil> #topic #1106668: (i, M) Waking up from suspend to RAM reproducibly leads to a hard freeze
19:07:03 <bwh> #action bwh will fix "forwarded: r" for https://lore.kernel.org/r/...
19:07:15 <carnil> bwh: good idea :)
19:07:30 <carnil> Waiting for feedback from reporter. -> no action
19:07:47 <carnil> #topic #1108860: (i, u) linux-image-6.1.0-34-amd64: Wireguard fragmentation fails with VXLAN since kernel 6.1.0-34, causing network timeouts (forwarded: regressions)
19:07:52 <carnil> this one got a followup.
19:08:16 <carnil> But basically reporter say it is still reproducible with 6.1.164-1 and he has a mitigation/workaround for the problem
19:08:25 <carnil> Reporter can mitigate the issue by addin TCP MSS clamping on the forwarding path of router.
19:08:32 <ukleinek> and upstream is in the loop, so nothing for us, right?
19:08:35 <carnil> but I think here without reply/action from upstream we are a bit lost
19:08:46 <carnil> so we have to wait for upstream
19:08:50 <carnil> ukleinek: yes
19:08:54 * ukleinek nods
19:08:59 <bwh> I see some upstream developers but no mailing list in cc
19:09:24 <carnil> bwh: would you suggest to expand the recipients to netdev mailinglist?
19:09:49 <bwh> I think that increases the likelihood of getting it fixed, yes
19:09:50 <ukleinek> wireguard@lists.zx2c4.com?
19:10:01 <carnil> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1108860#90 hat actually
19:10:14 <carnil> but apparently the last reply got dropped recipients
19:10:15 <bwh> Well there are multiple layers involved so netdev might make more sense
19:10:27 <bwh> or both
19:10:32 <ukleinek> +1 for both
19:11:05 <carnil> I take an action to followup on the last message from reporter and add back again the other recipients
19:11:10 <bwh> Thanks
19:11:34 <carnil> #action carnil followsup on #1108860 and includes again the required recipients + wireguard@lists.zx2c4.com and netdev list
19:11:51 <carnil> let's move to the most intersting bug :)
19:11:56 <carnil> #topic #1124075: (i, Ru) linux-image-6.17.12+deb14-amd64: Kernel Oops (GPF) in idempotent_init_module when loading lp module (merged with #1124463, #1126128, #1130365, #1133414, #1134565, #1134723, #1135533) (forwarded: lore.kernel.org)
19:12:05 <carnil> bwh: the stage for sumarizing is yours :)
19:12:35 <bwh> It's reproducible and has a patch now waiting for a response from upstream
19:12:40 <bwh> Next bug?
19:12:53 <carnil> #topic #1134599: (i, M) linux-image-6.19.11+deb13-amd64: kernel panic
19:13:04 <carnil> ukleinek asked some questions back. Wait for reporter.
19:13:08 <bwh> OK
19:13:22 <carnil> #topic 1135235: (i, ) linux-image-6.19.13+deb14-amd64: Reoccuring host crash "Invalid SPTE change" with gaming win kvm/qemu guest and device passthrough
19:14:00 <carnil> samewise: followup to ask if recent regression and if bisect is an option to do for the reporter. And asked to test the most current version in unstable as well as 6.19.y is EOL anyway
19:14:04 <carnil> -> wait
19:14:09 <carnil> again a lot of waits
19:14:16 <bwh> Do we know what looking-glass is?
19:14:55 <ukleinek> "Looking Glass is an open source application that allows the use of a KVM (Kernel-based Virtual Machine) configured for VGA PCI Pass-through without an attached physical monitor, keyboard or mouse."
19:14:58 <carnil> looking-glass: https://looking-glass.io/docs/B6/module/ I mentioed it because it would as well ship a dkms module
19:15:10 <carnil> but it is not loaded in the case of the reporter afaics
19:15:56 <bwh> OK so it 's a wrapper for KVM
19:16:01 <bwh> got it
19:16:40 <carnil> this could be a potential source for the problem, at least we had in past a couple of months ago as well a reporter (but that one with the repsetive module used)
19:16:59 <carnil> should we simply wait for reply or do you have an idea what to do else here?
19:17:09 <bwh> No I don't have any other suggestions
19:17:17 <ukleinek> wait is fine
19:17:25 <carnil> #topic #1135359: (i, ) linux-image-6.19.14+deb14-amd64: CONFIG_SND_SOC_SDCA_CLASS needs to be enabled for audio to work on 2026 Pantherlake platforms
19:17:57 <carnil> ah there is now as well a MR for this:
19:17:59 <carnil> https://salsa.debian.org/kernel-team/linux/-/merge_requests/1906
19:18:33 <carnil> I'm adding a patch tag and forwarded to the MR
19:18:33 <ukleinek> yunseongkim[m]: care to mark the bug forwarded?
19:18:54 <bwh> but CI failed because there is an error in the config changes
19:19:11 <carnil> RuntimeError: Can't recognize SND_SST_ATOM_HIFI2_PLATFORM=m
19:19:12 <yunseongkim[m]> Yes, I will check it! Thanks.
19:19:32 <carnil> #action yunseongkim[m] will update the MR
19:19:40 <carnil> #action yunseongkim[m] will update the MR for #1135359
19:19:42 <carnil> sorry
19:19:59 <carnil> #topic 1135527: (i, u) linux-image-6.1.0-45-amd64: probable borked netfilter patch / log spamming in bookworm release 6.1.170-1 (merged with #1135514) (forwarded: regressions)
19:20:39 <carnil> Regression in last update in 6.1.y, root cause is a missing patch to be backported as well, tested it and patch author sent patches for 6.1.y and 6.6.y
19:21:06 <carnil> This ideally can be included with other regression fixes before the weekend so that we can ship a fixed version in the upcoming point release
19:21:16 <carnil> will take care of it
19:21:26 <carnil> #topic #1135599: (i, u) linux-image-6.1.0-45-amd64:suspend to disk causes lockup on laptop (merged with #1135637)
19:21:28 <ukleinek> sounds great
19:21:40 <carnil> samewise a regression with the 6.1.170-1 update last week
19:21:48 <ukleinek> same reporter
19:22:08 <carnil> there is a revert queued already to fix it, so same procedure as above
19:22:26 <carnil> #topic #1119093: (n, +u) linux-image-6.16.3+deb13-amd64: UBSAN array-index-out-of-bounds in ath5k driver
19:22:39 <carnil> this got active again because upstream replied that they will apply the patch
19:23:11 <ukleinek> tag fixed-upstream?
19:23:15 <carnil> so at some point we get the fixes in debian/latest and forky
19:23:33 <carnil> ukleinek: it was not yet merged when I last checked, so have not done that, but yes maybe
19:23:46 <carnil> please do
19:24:09 <KGB> 03linux 05debian/latest 06Yunseong Kim * [update] merge request !1906: Enable SDCA, SoundWire and regmap modules for Panther Lake audio support * 14https://salsa.debian.org/kernel-team/linux/-/merge_requests/1906
19:24:12 <ukleinek> will check after the meeting where it was merged
19:24:18 <carnil> #topic #1130114: (n, u+) Please enable usbio module in linux kernel >= 6.18 (merged with #1135682)
19:24:33 <bwh> already pending
19:24:37 <carnil> MR existed, merge in debian/latest and will be included in next update
19:25:00 <carnil> #topic #1131025: (n, u+) linux-image-6.12.73+deb13-amd64: echo vfio-pci >driver_override does not work for DVB Adapter
19:25:10 <carnil> patch exists, needs to land yet but is on its way
19:25:16 <carnil> -> wait so far
19:25:37 <carnil> #topic #1132343: (n, u+) linux: broken wifi (with ath11k) after resuming from suspend (forwarded: ath11k)
19:25:48 <carnil> Update to metadata on affected versions. Patch upstream from Santiago under discussion.
19:26:19 <carnil> so i exepct if we miss it, then santiago will let us know
19:26:37 <carnil> #topic #1134242: (n, ) “nouveau: kernel rejected pushbuf: No such device” and “gsp: mmu fault queued” with NVIDIA PΛLiΤ GeForce GTX 1660 and xorg
19:26:54 <carnil> status: ukleinek: asked to forward upstream, so far this has not yet happened right by the reporter?
19:27:27 <carnil> should we until then mark it moreinfo?
19:28:10 <ukleinek> https://lore.kernel.org/all/?q=a:%22Md%20Ayquassar%22 doesn't find anything, so I guess it's accurate that no upstream reporting happend so far.
19:28:38 <santiago> for once, I am in front of my keyboard Wednesday at this time. yes, I'll keep the ath11k-related bug above updated about any news
19:28:56 <ukleinek> moreinfo isn't entirely accurate, but it matches our usage
19:29:15 <carnil> ok
19:29:17 <ukleinek> santiago: thanks
19:29:22 <carnil> #topic #1135204: (n, ) linux-image-6.12.74 (bookworm-backports): cgroup2 corruption causes systemd failure (status=219/CGROUP)
19:29:28 <carnil> this is a new report
19:30:26 <carnil> to me it is not clear what the reporter does to trigger the problem
19:30:31 <bwh> Yeah
19:30:47 <ukleinek> is there a limit for the number of cgroups and systemd somehow fails to free these?
19:31:27 <bwh> I don't think there's any hard limit, certainly not for a process running with full capabilities
19:31:40 <ukleinek> what is 219?
19:31:57 <waldi> internal systemd error
19:32:15 <carnil> │ 219       │ EXIT_CGROUP                  │ Setting  up  the service con‐ │
19:32:18 <carnil> │           │                              │ trol group failed.
19:32:40 <carnil> I assume that's what is reporting, from systemd.exec(5)
19:33:00 <bwh> At a minimum we'll need logging from kernel and systemd for that boot
19:33:26 <carnil> so let's tart with that
19:33:36 <bwh> #action bwh will ask for logs for #1135204
19:33:40 <carnil> ask for a log from kernel and system up to first tiggering the problem
19:33:43 <carnil> thanks bwh
19:33:46 <ukleinek> checking the systemd code to see which syscall actually failed probably also helps to understand the issue
19:33:54 <carnil> I was to say the same, it's fine if you take it
19:34:07 <carnil> #topic #1135248: (n, ) kernel configuration: request to enable support for Intel BE200 Wi-Fi 7 chip
19:34:31 <carnil> as well a new report, but it s confusing. The required module is already enabled
19:34:51 <carnil> asked back on log and to know which firmware versions are installed
19:34:59 <ukleinek> the required kernel is enabled in 6.18+ only?
19:35:19 <waldi> Best regards,
19:35:20 <waldi> <Your Name/Username>
19:35:20 <carnil> there are two modules afaiu
19:35:20 <ukleinek> the reporter failed to replace the placeholders in the AI text :-D
19:35:55 <ukleinek> Also <insert the exact Debian 13 kernel package version, e.g., 6.12.74-1>
19:36:06 <carnil> iwlmvm, when using firmware older up to .96.ucode and the iwlmld module with newer firmware, but this exists only in later 6.15-rc1 onwards
19:36:31 <bwh> That PCI device ID is also present in the driver in 6.12, so ???
19:36:44 <bwh> So let's wait
19:37:21 <carnil> ok
19:37:42 <carnil> #topic #1135354: (n, u) linux-image-7.0.3+deb14-amd64: Conexant SN6140: UCM returns EBUSY at cold boot, audio falls back to dummy output
19:37:54 <carnil> New report. Might already have enough information to forward upstream with information what reporter has at hand to workaround the issue (delay wireplumper start or restart wireplumper service)
19:38:09 <bwh> Yes I agree this can go straight upstream
19:38:12 <ukleinek> ack
19:38:27 <carnil> something more we would like to ask, otherwise I can take care of forwarding the report straight to usptream
19:38:45 <carnil> #action forwards the report from #1135354 to upstream
19:39:18 <carnil> #topic #1135574: (n, ) linux-image-6.12.85+deb13-amd64: builtin webcam broken on Dell Precision 5690 MTL (IPU6/IVSC, OVTI02E1; libcamera no sensor; VIDIOC_STREAMON link severed)
19:39:27 <carnil> this is a new reports and needs yet a reply at all
19:40:59 <ukleinek> Tainted: POE
19:41:11 <waldi> nvidia
19:41:12 <carnil> afaiu it is *not* a regression at least
19:41:46 <ukleinek> Ubuntu's 6.8 almost worked :'-)
19:42:28 <bwh> We are missng CONFIG_VIDEO_OV02E10
19:42:46 <waldi> thats an easy fix
19:42:49 <bwh> The IPU6 driver is logigng "Found supported sensor OVTI02E1:00" but there is no sensor driver
19:43:25 <bwh> Unfortunately I don't see it in 6.12
19:43:30 <carnil> but it's not in 6.12.y
19:43:57 <carnil> Ubuntu might have backported support to thei 6.8 kernel then
19:44:07 <ukleinek> still enabling it and when it hits backports ask for a test sounds right
19:44:09 <carnil> suggest to the reporter to move to the backports kernel for this device?
19:44:21 <bwh> It's not enabled even in unstable yet
19:44:47 <carnil> I have  /boot/config-7.0.3+deb14-amd64:CONFIG_VIDEO_OV02E10=m
19:45:10 <bwh> Oh sorry, I was looking at a 6.19 config
19:45:31 <carnil> so riht backports is not even an option yet until we have 7.0.y in backports
19:45:56 <bwh> #action bwh will ask to test whether backport of 7.0.y fixes #1135574 when available
19:46:04 <carnil> thanks bwh
19:46:17 <carnil> #topic #1135729: (n, ) Consider disabling CONFIG_CRYPTO_USER_API_*
19:46:20 <ukleinek> or ask to test the unstable kernel if the reporter isn't patient
19:46:37 <carnil> I'm not sure yet we can do this, AFAIU from
19:46:45 <carnil> https://www.openwall.com/lists/oss-security/2026/05/06/5
19:46:50 <carnil> iwd might need first adaptions
19:46:56 <bwh> No we can't
19:47:07 <bwh> Next bug
19:47:15 <carnil> ok :) clear word from ben
19:47:21 * ukleinek thought LUKS needs these
19:47:26 <carnil> should we close the bug with a reasoning?
19:47:42 <bwh> I can mark it wontfix for now
19:47:46 <carnil> ok
19:47:53 <carnil> thanks
19:47:56 <carnil> #topic #1135748: (n, M) linux-image-6.12.85+deb13-amd64: suspend to disk crashes after resume
19:48:05 <bwh> #action bwh will mark #1135729 wontfix with explanation
19:48:33 <carnil> this is a new report. After updating to the trixie kernel, the laptop after suspend crashes just after resume
19:49:15 <ukleinek> no_console_suspend might help
19:49:18 <carnil> I had not a chance to read the followups from Bill
19:49:49 <yunseongkim[m]> Can I check it with Bill?
19:50:44 <carnil> yes, sure yunseongkim[m]
19:50:53 <yunseongkim[m]> Ok!
19:51:16 <yunseongkim[m]> #action yunseong to take a look at #1135748
19:51:38 <carnil> #topic #1135313: (m, uM) Logspam: "AMD-Vi: Completion-Wait loop timed out"
19:51:46 <ukleinek> ..ooOO(Does #action work without being a chair?)
19:52:20 <carnil> missing backport to the 6.12.y stable series, submitted to the stable maintainers
19:52:33 <carnil> #topic #1131898: (w, ) linux-base-6.19.8+deb14-amd64: Please set CONFIG_ASUS_ARMOURY=m
19:52:43 <ukleinek> Logspam?
19:52:58 <carnil> ukleinek: frequently logged warning might explain better
19:53:41 <carnil> For #1131898 already pending
19:53:51 <carnil> so we are done with the Linux bugs
19:54:04 <carnil> #topic #1131809: (S, ) dracut: ppc64el autopkgtest are flaky and take 7 hours per run
19:54:32 <carnil> bdrung: is at minidebconf, maybe we can join forces to at least tackle the kernel related issues from it?
19:54:46 <bwh> Yes please
19:54:57 <carnil> let's approach bdrung tomorrow then :)
19:55:17 <carnil> #topic #1135267: (S, ) fails to build from source due to pack_cis not in path
19:55:37 <carnil> New report. Patch from Daniel.
19:55:44 <carnil> bwh: I think it is best in your hands :)
19:56:01 <bwh> Right
19:56:26 <bwh> I should move the tools to /usr/bin. I think I just copied the previous installation locations from pcmcia-cs
19:56:36 * ukleinek wonders how this worked before, but not enough to want to take a look
19:56:52 <bwh> but also this worked on the buildds so I think the bug can be downgraded
19:57:03 <bwh> #action bwh will respond to #1135267
19:57:18 <ukleinek> Was the package built with /usr/sbin in PATH?
19:57:25 <bwh> must have been
19:58:34 <ukleinek> ok, next bug
19:58:59 <carnil> I do not remember correctly, but was'nt there as well restrictions on buildd chroots during the usr-merge phase, but it does not really matter now I guess
19:59:15 <carnil> I skip the next wo bugs because I just have seen the corresponding MRs are already merged
19:59:29 <ukleinek> tag + pending?
19:59:34 <carnil> #topic #1135141: (n, M) please be more careful with available disk space on /boot
19:59:49 <carnil> still waiting for the reporter to answer bwh's questions -> wait
19:59:55 <bwh> yes
19:59:58 <carnil> #topic Migration excuses
20:00:53 <carnil> ethtool should in meanwhile only be too young yet
20:01:40 <bwh> initramfs-tools (actually miniramfs) is in progress
20:02:07 <carnil> linux has autopkgtest regressions, and at least there is glibc marked as well. I have not those yet TBH
20:03:27 <bwh> Seems like there is a new warning printed by resolve_btfids to stderr
20:03:46 <bwh> which breaks the headers-kbuild test cases
20:04:02 <bwh> Not sure why that didn't happen on Salsa...
20:05:38 <carnil> okay that's something we need to investigate
20:06:06 <waldi> bwh: "FAIL stderr: + trap cleanup EXIT". somewhere a set -x
20:06:17 <bwh> oh OK
20:07:20 <waldi> case "${KBUILD_VERBOSE}" in
20:07:20 <waldi> *1*)
20:07:21 <waldi> set -x
20:07:21 <waldi> ;;
20:07:45 <bwh> So do you want to take this one?
20:07:59 <waldi> i do
20:08:07 <carnil> thanks waldi
20:08:28 <carnil> I thin kthen we can move to the new upstream versions and MRs
20:08:33 <carnil> #topic New upstream versions
20:08:57 <carnil> ktls-utils has now a new upstream version which we might update, the rc one was already prepared by bwh
20:09:05 <bwh> #action bwh will update ktls-utils to 1.4.0
20:09:38 <carnil> linux: I expect 7.0.4 tomorrow(?) can do that import for unstable, how we move 7.1-rc2 to experimental? Something pending or should we go ahead with that as well?
20:09:56 <carnil> (apart the ready MRs)
20:10:20 <carnil> Othewise I would find it great if we move it to experimental to give a little bit of exposure already
20:10:55 <carnil> waldi: you did the hard part of the work, you call :)
20:11:07 <bwh> I can but would rather not run kernel builds on my laptop, so I will pass on that
20:11:54 <carnil> okay I can likely can do a full build on a remote machine which is more powerful and if it works upload to experimental
20:12:05 <ukleinek> \o/
20:12:08 <carnil> wireless-regdb?
20:12:37 <carnil> (I'm sorry that we are running late already)
20:12:50 <bwh> I guess I will do that as usual
20:12:55 <carnil> thanks :)
20:12:57 <bwh> #action bwh will update wireless-regdb
20:13:00 <carnil> #topic Merge requests
20:13:11 <carnil> anything specific to be discussed?
20:13:59 <aurel32> would it be possible to get the trixie branch of initramfs in the next point release?
20:14:19 <ukleinek> !1902 looks fine to merge
20:14:22 <bwh> aurel32: yes, thanks for the reminder
20:15:12 <ukleinek> aurel32: I'll give !1902 another look and then likely merge
20:15:15 <carnil> ukleinek: on that MR waldi commented that something is missing, is this indeptently?
20:15:46 <ukleinek> carnil: aurel32 pushed more changes since then that I think address the concerns.
20:15:50 <aurel32> bwh: thanks
20:15:52 <carnil> ok
20:16:07 <carnil> (the open thread then can be resolved I guess)
20:16:25 <aurel32> carnil: yes, the first commit was enough to get it build on riscv64, but the second was necessary for amd64
20:16:31 <carnil> thanks for taking care of it
20:16:37 <KGB> 03linux 05debian/latest 06Salvatore Bonaccorso * [update] merge request !1902: udeb: update crypto-modules and pcmcia-modules to fix FTBFS * 14https://salsa.debian.org/kernel-team/linux/-/merge_requests/1902
20:17:06 <carnil> I have one which is not anymore on the list if you still have energy
20:17:22 <carnil> if not then we skip it
20:17:32 <ukleinek> 😴
20:17:59 <carnil> ok we skip it
20:18:05 <carnil> #topic AoB?
20:18:14 <carnil> who takes care of peparing the next meeting?
20:18:23 <carnil> it is in Jitsi, I guess ukleinek is super happy
20:18:40 <cacin> Can I ask a question outside scheduled questions for the meeting? In 3 days, it will be 15 years of bug #626217 could there be any activity to finish it?
20:19:14 <bwh> I think it's my turn next week
20:19:16 <waldi> cacin: "nothing needs those links now" is wrong, at least zipl needs them
20:19:57 <carnil> #action bwh will chair next meeting on 2026-05-13
20:20:01 <carnil> thanks bwh
20:20:16 <carnil> I close then this meeting
20:20:24 <cacin> waldi: zipl did not exist 15 years ago, so the topic of the bug report is out of date.
20:20:39 <ukleinek> carnil: Thanks for your preparations and guiding through the meeting
20:20:44 <carnil> #endmeeting