19:00:04 <carnil> #startmeeting
19:00:04 <MeetBot> Meeting started Wed Jun  3 19:00:04 2026 UTC.  The chair is carnil. Information about MeetBot at https://wiki.debian.org/MeetBot.
19:00:04 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:00:08 <carnil> hi
19:00:15 <bwh> Hi
19:00:19 <carnil> #chair bwh
19:00:19 <MeetBot> Current chairs: bwh carnil
19:00:44 <carnil> bwh: IIRC waldi and ukleinek cannot attend today
19:01:04 <carnil> So let'start into meeting, maybe shorter today
19:01:12 <carnil> is there anything you want to pick up before the buglist?
19:01:42 <bwh> We should maybe talk about bookworm going over to LTS
19:02:50 <carnil> The plan is to handover regular security support to LTS after 3 years, so the current discussion onging between the various teams is on 12th june LTS team takes over security support for bookworm, while still making sure that until the last point release
19:02:57 <bwh> right
19:03:11 <carnil> updates do not interfere with finalizing work on bookworm's last point release and bookworm-pu requests
19:03:37 <carnil> so specific for src:linux I guess you are happy to continue with the 6.1.y imports?
19:04:01 <bwh> Just let me know when you are ready for me to take over, I suppose
19:04:27 <carnil> ok, I'm not sure what we should do with 6.1.175
19:05:07 <carnil> if there were not so many flux of incoming issues given the size of it i would have said we make that for the last point release in one months time, but that does not look realisitc
19:05:32 <bwh> I am still only just over half-way through reviewing 5.10.258. I expect there to be some other regressions there that also apply to 6.1.175
19:06:13 <carnil> if you want I can just stop here and leave it in yours hand starting today (and if you appreciate a helping hand I can still contribute for a while for 6.1.y as well, but making sure I do not get into your way for your LTS contribution)
19:06:29 <carnil> bwh: yes you are much better in tracking all those regressions, thanks for that a lot!
19:06:49 <bwh> I think I am better at finding them, not so much keeping track of everything
19:07:24 <carnil> bwh: do we want to discuss those details outside the meeting? But baseline 12th june is the formal date of ending regular security support, start of LTS team for bookworm
19:07:50 <bwh> I think we don't need to go into more detail right now
19:07:58 <carnil> ok
19:08:24 <carnil> next small topic would be the pipeline jobs failing, in particular piuparts
19:09:02 <carnil> it fails all down as well for trixie: https://salsa.debian.org/carnil/linux/-/jobs/9711799 so at first glance it does not look it is "our fault", but it is blocking right now on automatic merges for our MRs
19:09:46 <carnil> I have not tried to understand it yet, as only this evening I came to the point to have the build job actually running properly (after clearing runner caches and restarting again)
19:09:59 <carnil> but something broke
19:10:15 <bwh> Well this smells like a general bug in the pipeline
19:11:20 <bwh> https://salsa.debian.org/salsa-ci-team/pipeline/-/work_items/574
19:12:11 <bwh> So, unless one of us is going to work on that we should probably just wait
19:12:33 <carnil> ok, so good let's move on to the bugs then
19:13:03 <carnil> #topic #1126671: (S, ) linux-image-6\.17\.13+deb13-amd64: Disconnect root (path=/) during heavy load on NvME, partial corruption on NTFS.crash soon but not yet
19:13:12 <carnil> I have recorded:
19:13:17 <carnil> Waiting for timeslot from @benh and/or @waldi.
19:13:26 <bwh> No, almost all my time has been spent on reviewing 5.10.258
19:14:07 <bwh> "but I'm sure things will calm down next week"
19:14:15 <carnil> so no timeslot available so far, can I leave this still to you and waldi ok?
19:14:19 <bwh> yes
19:14:48 <carnil> #action when timeslot available, either bwh or waldi will look into debugging #1126671
19:14:57 <carnil> #topic #1138242: (S, ) linux-image-6.12.90+deb13.1-riscv64-dbg and linux-image-6.12.90+deb13.1-s390x-dbg have an undeclared file conflict
19:15:18 <carnil> helmut filled this new one with a file conflict
19:16:02 <carnil> is it actually possible here to have proper conflict relation between packages without having us to explode the relationsships?
19:16:08 <bwh> No we can't do that
19:16:34 <bwh> We have to make sure that all files include the ABI string somewhere
19:17:08 <bwh> #action bwh will investigate #1138242 to find which files don't depend on the ABI string
19:17:19 <carnil> thanks Ben
19:17:33 <carnil> #topic #1130845: (i, uM) linux-image-6.18.12+deb13-amd64: kernel panic after plugging a 5 Bay USB Docking Station (DS-5R15) with BTRFS disks
19:17:46 <carnil> 1. Still unclear if this was a regression. Asked for logs get through netconsole.
19:17:58 <carnil> 2. I think we should wait here for the reporter following up to the questions
19:18:17 <carnil> #topic #1135235: (i, M) linux-image-6.19.13+deb14-amd64: Reoccuring host crash "Invalid SPTE change" with gaming win kvm/qemu guest and device passthrough (forwarded: lore.kernel.org)
19:18:45 <carnil> The reporter followed upstream's instruction to build kernel with CONFIG_VMAP_STACK=y and CONFIG_KASAN=y
19:19:01 <carnil> and we are now waiting for the test results/reproducing steps
19:19:12 <carnil> so IMHO nothing to do for us at the moment
19:19:18 <bwh> They did ask a question in the last message
19:19:47 <carnil> ah good point
19:19:50 <bwh> How to check whether KASAN is active. Which I think it always is with CONFIG_KASAN=y?
19:21:42 <carnil> https://docs.kernel.org/dev-tools/kasan.html suggests that, and there are other boot parametesrs to influence the panic control and reporting
19:21:47 <bwh> yeah
19:22:04 <carnil> let me take an action to at least respond to this question from the reporter before we go into wait mode again
19:22:26 <carnil> #action carnil will followup on the KASAN question from the reporter in #1135235
19:22:53 <carnil> #topic #1137107: (i, Mu) netfs local_bh_enable in hard IRQ via cachefiles read completion (merged with #1137105, #1137106)
19:23:09 <carnil> ukleinek: said last time: We'd need a way to reproduce. Wait for David Howells to maybe reply.
19:23:37 <carnil> the reporter seems not in position though to test as well other kernels other than in the repository?
19:24:04 <carnil> so wait on getting some input from upstream is fine
19:24:08 <bwh> Well, tough luck I suppose
19:24:28 <carnil> but we need to convince the reporter to be ble to test other kernels
19:24:39 <carnil> otherwise I do not see how we can move forward
19:24:55 <bwh> I'll also tag it unreproducible and we can close it later if nothing happens
19:24:58 <carnil> should we tag this unreproducible ?
19:25:10 <carnil> he same thinking, good please go ahead with that
19:25:15 <bwh> done
19:25:27 <carnil> #topic #1137142: (i, u) linux-image-amd64: Screen goes black dozen of seconds after resume from suspend state on ThinkPad T16 2023
19:25:57 <carnil> Do you want to keep an action for this searching the ML for similar reports?
19:26:19 <bwh> OK
19:26:41 <carnil> #action bwh ill search ML for similar reports to #1137142
19:26:54 <carnil> #topic #1137272: (i, M) linux-image-amd64: Missing sound on Lenovo x9-15 (and possibly other Lunar Lake laptops)
19:27:23 <carnil> no feedback from reporter, but I took the liberty to merge the bugreport with #1136179 as we were pretty confident already that it's the same
19:27:43 <carnil> #topic #1138755: (i, ) Subject: amdgpu: RX 640 hangs right after VCE initialization on kernel 6.12 (i5-11400F, no iGPU)
19:27:47 <carnil> new report
19:27:57 <KGB> 03linux 05debian/latest 06Ben Hutchings * [update] merge request !1942: [amd64] Enable CONFIG_PINCTRL_CS42L43 and CONFIG_SPI_CS42L43 explicitly * 14https://salsa.debian.org/kernel-team/linux/-/merge_requests/1942
19:28:16 <carnil> as reporter can easily reproduce the issue I asked if reporter is willing to bisect and gave instructions
19:28:35 <bwh> re #1137272, I just tagged the MR for backport since ukleinek said 6.12 and 7.0 were affected
19:28:49 <carnil> wait I would say, unless you have some ideas what to propose as well
19:28:56 <bwh> Let me catch up...
19:29:02 <carnil> bwh: ack re #1137272 makes sense
19:29:39 <bwh> OK, I will just tag this moreinfo
19:29:55 <carnil> good, and then let's wait
19:30:08 <carnil> #topic #1127588: (n, M) linux-image-6.18.9+deb14-amd64: Cannot hibernate after some time of work
19:31:02 <carnil> waldi: asked for /proc/{mem,slab}info which got provided by reporter, so as for last time needs now us again to followup. I *think* waldi would still try to have a look
19:31:26 <bwh> Can we assign that action in absentia?
19:31:40 <carnil> not really it is unfair
19:32:05 <bwh> #action bwh will follow up to #1127588 if waldi does not
19:32:10 <carnil> I can try to have a look in between if I can make something out of it
19:32:14 <carnil> ok fine as well :)
19:32:26 <carnil> #topic #1135748: (n, ) linux-image-6.12.85+deb13-amd64: suspend to disk crashes after resume
19:32:38 <yunseongkim[m]> Thanks to TJ, I still look up PM related way.
19:32:40 <carnil> Tj gave instructions to use the Debugging hibernation and suspend instructions and report back anything significant from logs.
19:32:48 <carnil> hi yunseongkim[m], welcome
19:32:58 <carnil> I tagged it moreinfo and suggest we wait for replies
19:33:36 <carnil> #topic #1136792: (n, M) linux-image-7.0.4+deb13-amd64: ipv6 temp addresses renew prematurely when removing interface (merged with #1136793)
19:33:48 <carnil> no followup yet to the questions/answer from waldi -> wait
19:34:10 <carnil> #topic #1137275: (n, ) linux-image-7.0.7+deb13-amd64: No sound after update kernel to 7.0.7 (stable-backports) from 6.12.86, missed firmware-realtek
19:34:39 <carnil> ukleinek asked for a bisection, now need to wait for the results
19:34:52 <bwh> right
19:35:17 <carnil> #topic #1137548: (n, MRu) linux-image-6.12.90+deb13-amd64: kernel NULL deref in cap_capable() during /proc/<pid>/stat read causes system hang via orphaned spinlock
19:35:45 <carnil> I guess we can wait as noted as there was no followup to your questions yet
19:36:05 <carnil> I'm still not really awaere of reported regressions for the ptrace fix
19:36:26 <carnil> (but there is so much on the regressions and stable lists which I might have missed a report)
19:36:59 <carnil> if you neither are aware of reports, let's just wait
19:37:30 <carnil> ok
19:37:32 <bwh> I think it was just a coincidence that the ptrace fix and this weird crash happened around the same time
19:37:34 <carnil> #topic #1138033: (n, ) linux-image-7.1-loong64 dmesg has Call Trace Workqueue: events drm_fb_helper_damage_work [drm_kms_helper]
19:38:23 <carnil> ukleinek: looked at it, there seems to be an upstream report/suggested patch as well upstream, related to https://lore.kernel.org/dri-devel/20260519092420.1124348-1-zhengxingda@iscas.ac.cn/ . ukleinek asked to add a Closes references to our bug so it will fall on the radar when it lands and we can add a bug closer
19:38:32 <carnil> other than that I think nothing remains on our end to do
19:38:35 <bwh> great
19:38:44 <carnil> that were the src:linux bugs
19:39:00 <carnil> #topic #1011089: (n, M) nfs-utils: old configs /etc/default/nfs-* should have warnings
19:39:17 <bwh> (and the stable-update script really should look for Closes: https://bugs.debian.org/... automatically)
19:39:21 <carnil> this just got on the list again becuase a user said to please consider non-systemd users
19:39:38 <carnil> bwh: that is a nice idea!
19:40:37 <bwh> I don't agree with the bug report and I think we should close it
19:41:00 <carnil> let's close it
19:41:15 <bwh> The initial report says "In other words, they are ignored when systemd is used, and the configuration should be done in /etc/nfs.conf in that case."
19:41:47 <bwh> which might have been true at the time but now there is nothing that overrides nfs.conf
19:42:38 <bwh> as of 1:2.6.3-1
19:43:05 <bwh> Will you close it or shall I?
19:43:22 <bwh> Oh I replied first so I'll close it
19:43:33 <carnil> thanks :)
19:44:16 <carnil> should we go into the dracut bugs or skip them? I guess they will primarly be handled by Benjamin and Thomas
19:44:42 <bwh> We can go through them
19:44:52 <carnil> #topic #1131809: (S, ) dracut: ppc64el autopkgtest are flaky and take 7 hours per run
19:45:07 <carnil> you keep an action?
19:45:21 <bwh> yes
19:45:46 <carnil> #action bwh will look into #1131809
19:46:00 <carnil> sorry i feel you take all the work and am no of much help :-/
19:46:06 <carnil> #topic #1095646: (i, ) dracut-core: Shipping /usr/lib/kernel/install.d/50-dracut.install causes two initrds to be installed on kernel postinst
19:46:20 <carnil> nothing new here, just followup from a user proposing a workaround
19:46:27 <bwh> I think this is simple. The hook should be moved from dracut-core to dracut
19:46:47 <bwh> #action bwh will follow up #1095646
19:47:40 <carnil> #topic #1100919: (n, ) Missing sysuser from 91tpm2-tss
19:47:52 <carnil> samewise nothing new, but a user asked if the bug is going to be fixed
19:48:38 <bwh> It seems like this should be fixed in another package. I'm not taking any action on this
19:49:07 <carnil> me neither for the moment
19:49:19 <carnil> #topic #1138644: (n, ) dracut: Move postinst.d and postrm.d into /usr/lib
19:49:22 <KGB> 03firmware-nonfree 05debian/latest b902dd4 06Ben Hutchings 10debian/ 10bin/gencontrol.py 10changelog 10lib/python/debian_firmware/config.py 10templates/binary.control.in * Add support for per-package Suggests control field * 14https://salsa.debian.org/kernel-team/firmware-nonfree/-/commit/b902dd4
19:49:22 <KGB> 03firmware-nonfree 05debian/latest b70913d 06Ben Hutchings 10debian/ 10changelog 10config/defines.toml * misc-nonfree: Move all packages from Recommends to Suggests * 14https://salsa.debian.org/kernel-team/firmware-nonfree/-/commit/b70913d
19:49:22 <KGB> 03firmware-nonfree 05debian/latest 5760fca 06Ben Hutchings 10debian/ 10changelog 10config/defines.toml * libertas: Remove firmware-marvell-prestera from Recommends * 14https://salsa.debian.org/kernel-team/firmware-nonfree/-/commit/5760fca
19:49:26 <KGB> 03firmware-nonfree 05debian/latest 3a2ea4a 06Ben Hutchings 10debian/ 10changelog 10config/defines.toml 10templates/extra.control.in * Remove remains of the firmware-qcom-media to firmware-qcom-soc transition * 14https://salsa.debian.org/kernel-team/firmware-nonfree/-/commit/3a2ea4a
19:49:31 <KGB> 03firmware-nonfree 05debian/latest 8abd14c 06Ben Hutchings 10debian/ 10changelog 10config/defines.toml * libertas: Remove Replaces/Provides relations to libertas-firmware * 14https://salsa.debian.org/kernel-team/firmware-nonfree/-/commit/8abd14c
19:49:35 <KGB> 03firmware-nonfree 05debian/latest 16014e0 06Ben Hutchings 10debian/ 10changelog 10config/defines.toml * misc-nonfree: Remove Provides relation to firmware-{adi,ralink} * 14https://salsa.debian.org/kernel-team/firmware-nonfree/-/commit/16014e0
19:49:39 <KGB> 03firmware-nonfree 05debian/latest 78415b2 06Ben Hutchings 10debian/ 10(6 files in 5 dirs) * Merge branch 'update-package-rels' into 'debian/latest' * 14https://salsa.debian.org/kernel-team/firmware-nonfree/-/commit/78415b2
19:49:42 <carnil> this is a new report
19:49:44 <KGB> 03firmware-nonfree 05debian/latest 06Ben Hutchings * [merge] merge request !150: Update and remove obsolete package relations * 14https://salsa.debian.org/kernel-team/firmware-nonfree/-/merge_requests/150
19:49:48 <KGB> 03firmware-nonfree 05pipeline 06Ben Hutchings 1100899 * pending (build: created; orig: pending; build source: created; lintian: created)
19:49:51 <KGB> 03firmware-nonfree 05pipeline 06Ben Hutchings 1100899 * running (build: created; build source: created; lintian: created; orig: running)
19:50:18 <bwh> Seems like a feature request
19:50:31 <bwh> I won't take an action for this
19:50:48 <carnil> #topic Migration excuses
19:50:53 <carnil> no, nothing, really ...
19:51:20 <carnil> (7.0.10-1 was hinted by Paul yesterday to make way for 7.0.11-1 to unstable)
19:51:28 <carnil> #topic New upstream versions
19:51:50 <bwh> I have firmware-nonfree and wireless-regdb in progress
19:51:58 <carnil> for linux I made a MR, but as discussed on beginning of the meeting the salsa runner issues blocked me
19:52:08 <bwh> Should be able to upload those within the week
19:52:26 <carnil> and not on the list I have as well done 7.0.11 import and 6.12.92, where at least 7.0.11 I would like to upload "soonish"
19:52:46 <carnil> bwh: thanks for doing that work!
19:52:59 <carnil> #topic Merge requests
19:53:06 <carnil> any specific MR you would like to discuss?
19:53:14 <bwh> I should really implement a comparison of the stable branch versions and include that in the "New upstream versions" table
19:54:01 <bwh> Yes, linux!1936
19:54:26 <bwh> Am I being unreasonable in asking to test removing the special-casing for sparc64?
19:55:12 <carnil> give me some seconds to read the discussion
19:56:55 <carnil> I think it's fair to ask this
19:57:13 <bwh> Good
19:57:26 <carnil> OTOH if I see it correctly we have special casing as well for other ports and we would need to ask the same for those, correct?
19:58:33 <bwh> I would love to get rid of more special cases but I don't have a specific person to ask
19:59:49 <carnil> let's see how the MR submitter responds to your query, I see some frustration
20:00:17 <carnil> ok for you getting backed with this "yes it is reasonable"?
20:00:25 <bwh> yes
20:00:29 <bwh> thanks
20:00:46 <carnil> then, almost in time
20:00:50 <carnil> #topic AoB
20:00:59 <carnil> chair for next week I think :)
20:01:07 <bwh> ...
20:01:11 <carnil> worst case I can do it if you are short on time
20:01:23 <carnil> i say the same as you said
20:01:26 <bwh> No I will do it
20:01:32 <carnil> the next week should hopefully be calm(er) again
20:01:36 <carnil> thanks!
20:01:45 <carnil> #action bwh will chair next weeks meeting
20:01:49 <carnil> then we are done :)
20:01:59 <yunseongkim[m]> Thanks carnil and bwh. :)
20:01:59 <bwh> Thank you for chairing
20:02:03 <carnil> #endmeeting