14:58:49 <h01ger> #startmeeting
14:58:49 <MeetBot> Meeting started Thu May 28 14:58:49 2020 UTC.  The chair is h01ger. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:58:49 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:58:52 <lamby> TZ=UTC; good afternoon all
14:59:15 <el_cubano> Agenda link?
14:59:18 <h01ger> #topic say hi or otherwise indicate your presence. also you might introduce yourself if you are new..
14:59:26 <h01ger> the agenda is at https://pad.riseup.net/p/7yvWKum_5a3KeIvO4uZy
14:59:32 * sunweaver is attending the meeting
14:59:34 <utkarsh2102> hi!
14:59:35 <buxy> hi
14:59:38 * el_cubano is present
14:59:40 <bhe[m]> hi
14:59:41 <el_cubano> h01ger: Thanks!
14:59:42 <lamby> hello humans
14:59:54 <apo> hello
14:59:57 <buxy> hello MeetBot
15:00:05 <h01ger> for those lurking around: we, the lts contributors have started to hold bi-monthly public meeting here on #debian-lts
15:00:12 <bwh> hi
15:00:19 <Beuc> hey
15:00:34 <h01ger> hi bwh, you only missed the agenda link so far: https://pad.riseup.net/p/7yvWKum_5a3KeIvO4uZy
15:00:46 <bunk> hi
15:00:48 <h01ger> so i guess we can start now..
15:01:08 <h01ger> if you have stuff to add to the agenda, please add it to the pad *and* message me...
15:01:21 <h01ger> #topic future irc meetings
15:01:47 <h01ger> so the question is, shall we stick to this date (last thursday of the month, 15 utc), or dudle every 2 month?
15:01:57 * sunweaver ducks...
15:02:05 <h01ger> brian cannot make this time, thus he is not here and cannot comment
15:02:08 <sunweaver> I have miscalculated UTC (+/-2)
15:02:17 <sunweaver> so, earlier would be good (e.g. by 2 hours)
15:02:38 <sunweaver> I could arrange with the family today, but it's a difficult (dinner preparation) time.
15:02:52 <buxy> h01ger: did you discuss with him whether he felt bad from not being able to participate?
15:03:09 <lamby> Mild preference for not dudling again because it's effort, but that's extremely minor.
15:03:14 <h01ger> buxy: i only commented on the list but didnt communicated with him directly
15:03:23 <h01ger> lamby: yeah
15:03:26 <buxy> if he feels bad, then we can alternate early in the day in Europe or late in the day in Europe
15:03:53 <Beuc> dudling - next time is july/summer/etc., possibly different schedule
15:04:04 <h01ger> buxy: that will make the time impossible for others, i believe
15:04:50 <buxy> h01ger: that's not a big deal, if we want everybody to be able to participate we must accept lower attendance at times
15:05:01 <h01ger> so considering what Beuc said (and lamby) i think i'll go for another dudle, and again, until we have a slot which fits us. and i'll mail brian explicitly in parallel and ask him
15:05:19 <h01ger> does that sound sound?
15:05:20 <sunweaver> having a fixed date long time in advance makes the meeting well plannable, so this I prefer over re-dudling.
15:05:29 <buxy> me too
15:05:36 <h01ger> sure. me also
15:05:48 <sunweaver> so, then one more dudling, it possibly is...
15:06:03 <bwh> Is Brian *never* able to make this time?
15:06:07 <el_cubano> I also prefer having a set date/time well in advance
15:06:30 <bwh> Or, just on this occasion?
15:06:33 <h01ger> bwh: this time is in the middle of his impossible hours which i guess means he is sleeping
15:06:35 <buxy> people will be in vacation at various times, trying to optimize the rate of participation by requiring everybody to spend 10 minutes every month does not seem worth it
15:06:40 <bwh> h01ger: OK then
15:07:01 <buxy> sunweaver: I was agreeing with you actually
15:07:02 <h01ger> ok then. the final dudle
15:07:39 <buxy> h01ger: doing the final dudle based on summer agenda might not be the best idea, I think the timing we have now is fine
15:07:45 <sunweaver> buxy: yeah, I got that.
15:08:26 <h01ger> i'm fine either way. so we just stick to this time and i'mm mail brian and if he's really unhappy we dudl again
15:08:35 <sunweaver> I can well to arrange this time of day once a month permanently with the family, so ignore my UTC-miscalc above.
15:08:38 <h01ger> s#i'mm#i'll#
15:08:41 <bunk> bwh: 1 am there
15:09:10 <el_cubano> Is that .au?
15:09:10 <buxy> h01ger: if he's unhappy, we keed the same day but schedule it at 7:00am UTC
15:09:32 <h01ger> el_cubano: yes
15:09:38 <h01ger> but .au has 3 timezones as well
15:09:45 <h01ger> anyway, next topic?
15:09:56 * el_cubano nods
15:10:08 <h01ger> #agreed we just stick to this timeslot and i'll mail brian
15:10:25 <h01ger> #topic revisit concurrent package claims
15:10:45 <h01ger> this topic has been resolved on the list and thus is just to give you the summary
15:11:51 <h01ger> basically we agreed that concurrent package claims are not a big problem, because i unclaim packages after 2 weeks of inactivity already and because it doesnt happen so often. thus i will include a warning in my semi automatic weekly mails if someone has claimed 4 or more packages, but besides the warning i wont do anything
15:12:07 <h01ger> next topic from my side, unless you have comments, questions, etc
15:13:19 <lamby> Sounds good.
15:13:36 <el_cubano> Sounds good to me also.
15:13:42 <sunweaver> yep, fine.
15:13:46 <h01ger> #info basically we agreed that concurrent package claims are not a big problem, because i unclaim packages after 2 weeks of inactivity already and because it doesnt happen so often. thus i will include a warning in my semi automatic weekly mails if someone has claimed 4 or more packages, but besides the warning i wont do anything
15:14:04 <h01ger> #topic check README updated with FD discussion
15:14:37 <h01ger> i think this topic has been resolved (in git) and thus this topic is just ment as check that we agree that is the case
15:15:03 <h01ger> have people doing frontdesk noticed the changes?
15:15:04 <el_cubano> I've followed the updates as they have been comitted/pushed.  I agree that it is resolved.
15:15:47 <Beuc> #link https://wiki.debian.org/LTS/Development?action=diff&rev2=230&rev1=222
15:16:31 <sunweaver> Beuc: the diff is the change we are discussing here? (sorry, I seem to have missed it so far).
15:16:34 <h01ger> #save
15:16:57 <Beuc> This is basically what was added, removed and redefined from README
15:17:03 <sunweaver> ok
15:17:34 <h01ger> so next topic?
15:18:10 <sunweaver> yep, thanks for the clear write-up in the wiki.
15:18:12 <utkarsh2102> yep!
15:18:25 <h01ger> #topic Funding of large project
15:18:42 <h01ger> (this is not about wiki/LTS/TODO but the new project on salsa
15:18:44 <h01ger> )
15:19:12 <h01ger> #link https://salsa.debian.org/freexian-team/project-funding
15:19:38 <h01ger> and quoting from our agenda:
15:19:46 <h01ger> We assume that anybody could submit project ideas to be funded. Open questions are:
15:19:46 <h01ger> - who decides whether a project is worth to be funded? what would the process look like? For LTS funded projects, we could have a condorcet vote every half year between paid LTS contributors to rank the various proposals.
15:19:47 <h01ger> - assuming that anyone can make a bid for a project, who selects the winning bid? what criteria do we use? what's the process?
15:19:47 <h01ger> - who reviews the work and gives the OK for the payment to happen?
15:20:17 <h01ger> buxy: whats your idea to answer/unstuck these questions?
15:20:36 <buxy> This is about how we are going to spend the money that we put aside for what we called "large projects" or "infrastructure projects".
15:21:15 <buxy> There are tons of models we can imagine.
15:21:18 <h01ger> like setting up buildds for elts? or is this limited to lts?
15:21:43 <h01ger> do we have someone who is interested to drive / maintain this for the next, say, half year?
15:21:54 <buxy> It's up to us really.
15:22:06 <h01ger> k
15:22:23 <buxy> I expect that we want to select projects that contribute to LTS in some way, possibly in relation with other Debian teams that we are interacting with.
15:22:52 <buxy> I'm willing to drive this project.
15:23:01 <h01ger> cool
15:23:18 <buxy> But I want to know how I should handle it.
15:23:33 <sunweaver> do we mean "funding" as in funded by Freexian from LTS customers?
15:23:41 <h01ger> #info buxy will drive this project but wants our input how
15:23:42 <sunweaver> or funded by 3rd party sponsors?
15:24:05 <buxy> While discussion with el_cubano, he said that as Freexian owner, I could just decide on the projects to fund and be done with it. But I'm not sure that everybody would agree with him.
15:24:23 <sunweaver> I agree with him.
15:24:31 <buxy> sunweaver: yes, money from LTS sponsors that we put aside in the monthly dispatch
15:24:32 <Beuc> I like the condorcet idea to select a project.
15:24:42 <h01ger> buxy: because the money was given for LTS 'patches'?
15:25:03 * h01ger is a bit afraid that condorcet is a bit overkill
15:25:21 <buxy> h01ger: I don't get your question?
15:25:56 <Beuc> Let me rephrase: I appreciated the idea of involving LTS contributors in the decision making.
15:25:59 <h01ger> buxy: why do you think people would disagree with el_cubano here?
15:26:31 <bunk> sunweaver: point 8 from http://meetbot.debian.net/debian-lts/2020/debian-lts.2020-04-29-13.59.html
15:26:39 <buxy> h01ger: because LTS hours that we all agreed to put aside are hours shared by all of us in some way
15:26:49 <buxy> and maybe people would want to have a say on how this money is spent
15:27:10 <sunweaver> bunk: thx
15:27:16 <h01ger> buxy: ic
15:27:45 <el_cubano> buxy: But it is only the case that the hours are handled in the current fashion because you have decided to allocate all available funding to contributor hours (less overhead, I presume).
15:27:53 * h01ger also appreciates if more people decide and think about these questions but also see the overhead. i'm fine either way and happy that buxy wants collaboration
15:28:07 <el_cubano> You could just as easily reserve additional funding for overhead and then it never enters the contributor hours pool.
15:28:34 <el_cubano> The projects you have mentioned definitely seem like they fall into the category of overhead.
15:28:45 <sunweaver> hmmm... so, we try to address situations where there are more ideas than money available.
15:29:04 <sunweaver> either buxy decides top-down or we find consensus here
15:29:04 <bwh> I appreciate that buxy wants to give us a say, rather than being "the boss"
15:29:16 <sunweaver> about the order and the if-at-all
15:29:27 <el_cubano> sunweaver: I think it is more about what ideas are "good" to attempt as part of this effort.
15:29:27 <lamby> bwh: same :)
15:29:45 <el_cubano> Ideas that are likely to not go anywhere, or to just become a big time suck are not good uses of limited funding.
15:30:04 <sunweaver> buxy: is it more like you need 1-2 of us recommending project ideas? Or a democratic decision reaching?
15:30:05 <buxy> sunweaver: which is quite likely if we publicize this possibility a little bit
15:30:18 <h01ger> are we good with this topic or what do we have left to discuss/docuemnt? it seems we agree we are happy that buxy is driving this and now we are waiting for this to happen eventually
15:30:19 <h01ger> or?
15:31:18 <buxy> OTOH, I'm a bit biased too because one of the reasons why I'm pushin in this direction is because I'd like to fund developement on debusine because I need it for distro-tracker and it could benefit multiple places in Debian
15:31:53 <bwh> Remind us what that is?
15:32:05 * h01ger likes these debusine related development plans (and thus might be biased as well)
15:32:06 <sunweaver> if we don't have other enthusiastic ideas in the pipeline, this sounds like a valid and biased approach, to me...
15:32:26 <buxy> so what about some intermediary setup? we have a poll and in the end I take the decision taking into account your votes and comments?
15:32:44 <buxy> bwh: https://salsa.debian.org/hertzog/debusine (mostly a concept currently)
15:32:53 <sunweaver> buxy: yep.
15:33:07 <h01ger> buxy: i like the intermediary setup. perfect is the enemy of good..
15:33:10 <el_cubano> buxy: I like that.
15:33:15 <sunweaver> or if you feel unsure about $something, bring up the topic in a meeting your if urgend via mail
15:33:26 <sunweaver> 80% is perfection
15:33:32 <sunweaver> sometimes, even 60%
15:33:57 <sunweaver> s/your if urgend/or if urgent/
15:34:03 <Beuc> consultative vote is quite vague though, as a decision-making process
15:34:04 <buxy> what about the selection of how implements the project?
15:34:10 <bwh> buxy: Thanks
15:34:25 <el_cubano> buxy: Do you mean "who implements"?
15:34:32 <sunweaver> buxy: ?
15:34:41 <buxy> yes "who implements" sorry
15:35:26 <sunweaver> I guess, it will be more difficult to find people with matching skills and free schedule slots
15:35:43 <el_cubano> I think we accept proposals (we can even make a public call for additional proposals), then evaluate each on its merits.  We as active contributors can provide input (via MR comments) and you (buxy) takes the final decision.
15:35:45 <buxy> Beuc: at least if I don't follow the result of the vote, I have to come up with a pretty solid justification
15:36:36 <sunweaver> buxy: with the example of debusine, you as the driver of that project should pick the best person for the jobs needed.
15:36:51 <sunweaver> (and available)...
15:37:04 <sunweaver> even if it means, finding someone outside of the current team
15:38:11 <Beuc> If somebody other than buxy is driving a project, I guess their opinion would matter more -- not sure whether we find a driver before or after a contractor though
15:38:16 <buxy> that's among the questions... do we want to define some preference towards team members? I'm tempted to say yes, but what about if the team member's offer is twice the amount of someone else with similar skills in other parts of the world?
15:38:21 <sunweaver> Beuc: yes.
15:38:47 <h01ger> buxy: prefer team members if reasonable?
15:38:54 <el_cubano> buxy: That is handled by the proposal evaluation process (cost and technical competence being among the criteria)
15:39:31 <sunweaver> buxy: are you talking of different hourly rates depending on the tasks to ba accomplished?
15:40:02 <h01ger> sunweaver: no different costs because competent people are faster and thus cheaper (for the same hourly rate)
15:40:18 <el_cubano> sunweaver: Based on some other discussions, buxy prefers clearly defined projects with fixed cost for a given task/milestone.
15:40:30 <buxy> sunweaver: I think most projects would be billed as fixed amount offer, not billed by the hour.
15:40:33 <sunweaver> of course, the choice of workers must follow principles of effectiveness.
15:40:34 <h01ger> we still have 3 more topics and 19 minutes left...
15:40:49 <sunweaver> the faster someone is on a job the better choice he*she is.
15:40:54 <bwh> h01ger: But at the same time, competent people are more likely to take the time to do a proper job and not an unmaintainable hack...
15:41:04 <h01ger> i suspect we keep this topic on the agenda for the next meeting?
15:41:10 * bhe[m] requests to move this discusion to ML. one line comments are hard to follow :)
15:41:21 <h01ger> bwh: sure sure. thus i would go with 'prefer team members if reasonable'
15:41:35 <h01ger> we are also running out of time...
15:41:39 <bwh> h01ger: I agree with that
15:41:44 <h01ger> so, time for some closing comments and next topic
15:41:50 <sunweaver> ok
15:41:57 <h01ger> #save
15:42:22 <h01ger> #agreed we'll come back to this topic at the next meeting
15:42:52 <h01ger> #topic LTS survey by Utkarsh and h01ger: https://surveys.debian.net/index.php?r=survey/index&sid=856794&lang=en is it ready? shall we announce it? where/how?
15:43:06 <Beuc> probably better to discuss before net meeting though - this is a complex topic that needs reflexion
15:43:15 <Beuc> *next meeting
15:43:20 <buxy> yes
15:43:33 <h01ger> we can always discuss on the list
15:43:38 <h01ger> about the survey
15:43:48 <h01ger> i've just clicked through the survey again and it looks good to me
15:44:01 <h01ger> do you agree?
15:44:20 <h01ger> if so, we should decide for how long we want to run the survey and then announce it
15:44:48 <lamby> I have not yet had a proper look I'm afraid. Will followup to the list if I have comments.
15:45:34 <el_cubano> I briefly looked it over and it looks good; the feedback and suggestions have resulted in a clean and effective survey.
15:45:44 <sunweaver> h01ger: I wonder if there should be some enterprise related question in it.
15:45:45 <utkarsh2102> \o/
15:45:56 * h01ger thinks we should let the survey run for 2 weeks at least and probably rather 4
15:46:14 <utkarsh2102> I'd say 3
15:46:15 <h01ger> sunweaver: thats a very late and unactionable comment
15:46:15 <Beuc> 1 month with a mid-reminder sounds good
15:46:25 <sunweaver> so, basically I'd be interested if big / medium sized companies have switched over to Debian (e.g. from Ubuntu) since Debian LTS appeared.
15:46:43 <sunweaver> sorry, for not having contributed to the survey discussion earlier.
15:46:55 <h01ger> sunweaver: we are ready to release the survey and yes, that ;)
15:46:57 <sunweaver> 4 weeks...
15:48:04 <h01ger> buxy: will you publish something on your/freexians blog?
15:48:09 * sunweaver sunweaver is currently talking a very big customer into using and contributing to Debian, and his main leverage is the existence of LTS/ELTS...
15:48:17 <utkarsh2102> h01ger: for LTS users/sponsors to take that survey, where would you be planning to announce this?
15:48:18 <buxy> h01ger: yes, please send me a draft?
15:48:21 <lamby> sunweaver: :)
15:48:22 <h01ger> and then i think we should announce the survey on debian-lts@l.d.o but not on d-d-a
15:48:37 <sunweaver> debian-users?
15:49:08 <el_cubano> Perhaps the publicity team could publish a news item (or micro news, or whatever) about it?
15:49:08 <h01ger> buxy: can do, though next week only. busy with my maybe-accepted talk for the minidebconf until the end of this week
15:49:29 <h01ger> or maybe i can squeeze it in sooner.. will try
15:49:44 <h01ger> el_cubano: micro news is also a good idea
15:49:49 <utkarsh2102> el_cubano: about that. I had a word about that already. we'll do that once the survey is live
15:49:53 <buxy> el_cubano: ack, letting publicity team relay where appropriate is good
15:49:54 <h01ger> not sure about debian-user
15:50:12 <h01ger> and i think we'll let the survey run until the end of june then
15:50:40 <Beuc> planet.debian.org through the blog post sounds good, btw
15:50:45 <h01ger> #agreed a post on raphaels blog. a mail to -lts@l.d.o and involving the publicity team for micrones etc
15:51:01 <h01ger> #info h01ger will take of the above
15:51:16 <h01ger> #agreed the survey will run til the end of june
15:51:19 <h01ger> next topic?
15:51:36 <utkarsh2102> I think so..
15:52:11 <h01ger> #topic feedback from informal h01ger/carnil meeting
15:52:27 <h01ger> for one, this survey is a result of that meeting
15:53:20 <h01ger> and then i have a bunch of notes from carnil and jmm which i'm not sure i can share widely, though i have shared them with buxy. i'll ask carnil & jmm whether i can share them internally with the lts folks (but not the public lts list)
15:54:16 <h01ger> AIUI they are afraid of exposing themselves as they are only 2 people and thus easy to identify and they dont want to be perceived as complaining. *AIUI* thats why the notes are not public
15:54:43 <Beuc> without expressing who said what, give a high-level summary of pros/cons that were evoked, suggestions of ameliorations?
15:55:21 <h01ger> i'll rather ask them if its ok to just share the notes
15:55:26 <Beuc> just to have a shorter feedback loop, basically
15:55:36 <h01ger> the notes are high level summary arguments already, hard to condense further
15:56:09 * h01ger moves on the last topic (and will keep this topic for next time so it doesnt get lost)
15:56:12 <buxy> I don't remember them on the top of my head
15:56:21 <h01ger> #topic any other business
15:56:22 <Beuc> Are there action points that can be considered already?
15:56:31 <sunweaver> h01ger, then we should stop here, get an ACK from them to share the notes internally in the team...
15:56:34 <h01ger> there are hardly new aspects left
15:56:49 <h01ger> yes, the topic is now any other business :)
15:57:26 <h01ger> anything we need to prepare for when stretch becomes lts?
15:57:43 <h01ger> will that happen end of june 'automatically' or might the date still change?
15:58:02 <apo> https://wiki.debian.org/LTS/Development#Switching_to_the_next_LTS_release
15:58:05 <h01ger> probably a good topic for in a month :)
15:58:26 <bwh> Should we consider working on issues in stretch already?
15:58:36 <h01ger> #info we might want to discuss stretch becoming lts at the next meeting..
15:58:39 <utkarsh2102> should xen be dropped from dla-needed yet?
15:58:39 <sunweaver> buxy: h01ger: as jessie ELTS is going to be bigger than wheezy ELTS, are more team members needed?
15:59:08 <h01ger> utkarsh2102: please move this to the public list, so this is documented
15:59:10 <buxy> bwh: we did that last time, we can do it already I guess
15:59:20 <bwh> buxy: thanks
15:59:31 <buxy> just making sure to cooperate nicely with security team...
15:59:34 <el_cubano> utkarsh2102: There has not yet been another stretch point release to pick up and update of debian-security-support
16:00:00 <utkarsh2102> ah, okay!
16:00:01 <h01ger> afaik there is one last point release for stretch planned
16:00:17 <h01ger> (well not planned yet, but will happen)
16:00:29 <buxy> sunweaver: it doesn't hurt to add new members I guess
16:00:44 <h01ger> regarding debian-security-support, i have plans to discuss updates like we have for tzdata or clamav for the d-s-s package in future...
16:00:58 <sunweaver> buxy: ack.
16:01:08 <h01ger> are we done?
16:01:09 <el_cubano> One other item that I want bring up: based on my RFC to the list, next week I will start migrating content from LTS/TODO in the wiki to GitLab.
16:01:32 <el_cubano> Are we going to bulk add all active LTS contributors to the new lts-team/lts-extra-tasks project?
16:01:40 <el_cubano> (The project is yet to be created.)
16:01:50 <h01ger> el_cubano: why not? (so yes i would say)
16:02:00 <el_cubano> OK.  Sounds good.
16:02:21 <h01ger> coolio
16:02:23 <el_cubano> I presume that if I create the Salsa project, I will be owner then I can perform the bulk add operation myself.
16:02:28 * h01ger nods
16:02:48 <buxy> el_cubano: we should add them at the group level
16:02:59 <h01ger> so thank you all for attending and *see* you next month in our (private) video call meeting!
16:03:07 * h01ger waves
16:03:13 <sunweaver> _o/
16:03:15 <el_cubano> buxy: Ah, yes of course.
16:03:35 <el_cubano> I'll check if I have enough rights to do that.
16:03:43 * el_cubano waves
16:03:48 <Beuc> bye!
16:03:56 <utkarsh2102> keep well, ciao o/
16:03:57 <bhe[m]> later all !
16:04:04 <h01ger> #endmeeting